Cocoonフォーラム

書き込みの前に以下の3点をご確認ください。
  1. 1つのトピックにつき1つの質問を書き込んでください
  2. 不具合・カスタマイズ対象ページのURLを提示高速化を無効にしてください
  3. 該当部分のキャプチャ・環境情報とともに書き込んでいただけると助かります

何を書き込んだら良いか分からない場合は、以下のテンプレートをコピペしてご利用ください。

不具合・カスタマイズ対象ページのURL:

相談内容:

不具合の発生手順:

解決のために試したこと:

※文字だけでは正しく伝わらない可能性があるため、スクショ画像の添付もお願いします。
※高速化設定をしている場合は無効にしてください。
環境情報:

※↑こちらに「Cocoon設定 → テーマ情報」にある「環境情報」を貼り付けてください。

環境情報の取得方法はこちら。
https://wp-cocoon.com/theme-report/
高速化設定を無効にするにはこちら。
https://wp-cocoon.com/theme-trouble/

フォーラム利用ガイドリンク

  1. フォーラムガイドライン
  2. よくある質問と答え(FAQ)
  3. サポート対象外のケース
  4. 原因不明の不具合用トラブルシューティング
  5. トピックにHTMLを貼り付ける方法(推奨ツール:notepad.pw
  6. 真っ白画面でのエラーメッセージの確認方法
  7. ブラウザ環境チェックツール

フォーラム質問後、問題等が解決した場合は結果を書き込んでいただけると幸いです。同様の問題で調べている方には、結果が一番気になる部分となります。

テーマを更新することができない
 
共有:
通知
すべてクリア

[解決済] テーマを更新することができない

33投稿
5ユーザー
17Likes
6,067表示
rinrin
(@rinrin)
Active Member Registered
結合: 4年前
投稿: 17
rinrin - Twitter
Topic starter  

いつもお世話になっております。

既に作成されているものであったら申し訳ありません。

 

ver.1.1.6の時から起こっていたのですが、テーマを更新しようとすると

 

Cocoon の更新中にエラーが発生しました: パッケージをインストールできませんでした。 PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature

 

というエラー? が表示されてテーマを更新することができません。

ver.1.1.6の時には、親テーマをダウンロードしアップロードしましたが毎度アップロードするのも手間なので…なんとか改善できたら良いなと思っております。

 

Cocoonを2つのブログで使用させていただいておりますが、2つのブログ両方でエラーが起きており更新することができません。

何か設定の問題なのでしょうか?

改善に向け、何か教えていただけますでしょうか…。

よろしくお願いいたします。


   
rinrin
(@rinrin)
Active Member Registered
結合: 4年前
投稿: 17
rinrin - Twitter
Topic starter  

確認が足りず申し訳ありません。

環境情報を追記いたします。

 

----------------------------------------------
サイト名:アニメの世界に行きたい りんりんの感想
サイトURL: https://anime-rinrin.xyz
ホームURL: https://anime-rinrin.xyz
コンテンツURL:/wp-content
インクルードURL:/wp-includes/
テンプレートURL:/wp-content/themes/cocoon-master
スタイルシートURL:/wp-content/themes/cocoon-child-master
Wordpressバージョン:4.9.8
PHPバージョン:5.6.36
ブラウザ:Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0
サーバーソフト:LiteSpeed
サーバープロトコル:HTTP/1.1
エンコーディング:gzip, deflate, br
言語:ja,en-US;q=0.7,en;q=0.3
----------------------------------------------
テーマ名:Cocoon
バージョン:1.1.6.1
カテゴリ数:57
タグ数:142
ユーザー数:1
----------------------------------------------
子テーマ名:Cocoon Child
バージョン:0.0.3
----------------------------------------------
利用中のプラグイン:
AdSense Manager 4.0.3
Advanced Code Editor 2.2.7
Akismet Anti-Spam 4.0.8
BackWPup 3.6.0
Better Delete Revision 1.6.1
Edit Author Slug 1.5.2
EWWW Image Optimizer 4.3.2
Google XML Sitemaps 4.0.9
Jetpack by WordPress.com 6.4.2
LiteSpeed Cache 2.4.4
Search Regex 1.4.16
Shortcodes Ultimate 5.0.4
SiteGuard WP Plugin 1.4.3
Table of Contents Plus 1601
TinyMCE Advanced 4.8.0
WP Multibyte Patch 2.8.1
WP to Twitter 3.3.7
----------------------------------------------


   
かうたっく
(@kautakku)
Famed Member Moderator
結合: 5年前
投稿: 4764
かうたっく - Facebook
 

Cocoonを2つのブログで使用させていただいておりますが、2つのブログ両方でエラーが起きており更新することができません。

どちらもmixhostですよね?

エックスサーバーではテスト環境・本番環境でも正常でした。

https://ja.wordpress.org/plugins/litespeed-cache/

プラグインが昨日バージョンアップがあったようですが、一応プラグインのキャッシュを削除して再度、管理画面『外観』『テーマ』からアップロードしたらどうなりますか?

WordPressでLiteSpeed Cacheを使用して高速化する方法MixHost

ちなみに『パージ』の一番上(辺りの設定あいまい)はOFFですよね。

検索されたと思いますが、検索で書いてなさそうな所だとコレ辺りかと思いまして。


   
わいひら reacted
rinrin
(@rinrin)
Active Member Registered
結合: 4年前
投稿: 17
rinrin - Twitter
Topic starter  

かうたっくさん、返信ありがとうございます…!そしてすみません…。

 

サーバーが影響しているんでしょうか。テーマがアップデートできないのは今回が初めてでした。

「すべてをパージする」の後に、

外観→テーマ にて「更新する」を実行しましたが、やはり同じエラー名が表示されました。

 

LiteSpeed Cacheプラグインの

設定→[3]パージ の一番上「アップグレード時にすべてをパージする」

はオンになっていたのでオフにしてみましたが、やはり更新はできませんでした…。

一度Mixhostに現状を伝えるなど問い合わせた方が良いのでしょうか?

 


   
かうたっく
(@kautakku)
Famed Member Moderator
結合: 5年前
投稿: 4764
かうたっく - Facebook
 

でしたらそこの設定ではなかったかもです?そこはデフォルトのままが良いかと思います。

キャッシュかな?と思ったんですが、プラグインのキャッシュを削除など確認されましたか?

 

サーバーに聞くにしてもまず原因の範囲を特定する為にする事として、プラグインの停止や、関係なさそうですがCocoon設定のキャッシュ削除も試しみるなどですかね。

---------追記

※あとサーバー的に知りたいのは、デフォルトテーマの更新は通常通り管理画面からできるかなど…かと思われます。

----------ここまで

その上でわいひらさんの心当たりを探ってもらって、それからサーバーの心当たりを探すのも良さそうかもです。

どうも無理であればFTPソフトと言う手段が残ってしまっているので…。うぅ~ん、、この段階で解決すれば良いですよね。。

This post was modified 4年前 by かうたっく

   
わいひら reacted
rinrin
(@rinrin)
Active Member Registered
結合: 4年前
投稿: 17
rinrin - Twitter
Topic starter  

かうたっくさん、返信ありがとうございます…!

恐らくデフォルトのままなのでLiteSpeed Cacheの設定は元に戻しました。
ありがとうございます。

1.プラグインを全て停止
2.Cocoon設定でのキャッシュ削除「全てのキャッシュを削除」

の後にテーマ更新をかけてみましたが、やはり同じエラーが出てきてできませんでした。
デフォルトテーマ「Twenty Seventeen」は入れていますが、今まで更新の際に何か困ったことはありませんでした。毎回とりあえず更新していて、現在ver.1.7で最新だと思われます。

FTPソフトで更新だと…今まであまりやったことが無いので不安が残りますが…毎回直入れしか無いのでしょうか…。

現状ふわふわしたままですが、勢いでMixhostに問い合わせてみました。


   
かうたっく
(@kautakku)
Famed Member Moderator
結合: 5年前
投稿: 4764
かうたっく - Facebook
 

Twenty Seventeenバージョン: 1.7かと思います。

あとはわいひらさんの回答をまって、ひっそりチェックさせていただきますね。

****

もしよければサーバーサイドの返信を書いていただけたら、個人的にも嬉しいです。どのようなご対応されるか、他serverさんのご回答が気になってる状況です。

他の検索者さん的にも有益であるかもしれませんし、サーバーサイドへの対応の参考になるかもしれません。※ちょっと強引ですが…^^; その辺が気になってます❦

(迅速な行動は気持ちいいですね)

密かに見守ってます!

****


   
わいひら reacted
rinrin
(@rinrin)
Active Member Registered
結合: 4年前
投稿: 17
rinrin - Twitter
Topic starter  

かうたっくさん、本当にありがとうございます…!!

実は…デフォルトテーマの更新について触れる前に既に問い合わせしてしまっていて…先ほど追記として新たに連絡したところです。

今日はMixhostはお休みなので、明日以降に返事があると思います。
返事が何かしらありましたらこちらで共有させていただきます。
皆さんの参考になるようでしたら、私も嬉しいです!

色々本当にありがとうございます…!


   
rinrin
(@rinrin)
Active Member Registered
結合: 4年前
投稿: 17
rinrin - Twitter
Topic starter  

お疲れさまです。

本日(2018年9月5日(水))、プラグイン(Jetpack by WordPress.com)の更新が来ていたので更新をした後…

テーマの更新が残っているので、試しに更新してみたら‥‥。

 

なんか更新できました!!!

ど、どうしてなんでしょう…。

前にかうたっくさんに教えてもらって以来、プラグインやったりはしましたが私は何もしておらず…。

寝かせていたらいつの間にか更新ができるようになりました…。

何でなのか全くわからないですが、か、解決しました!w

 

Mixhostには問い合わせ中で「確認次第連絡します」のまま、待機中の状態です。

何か連絡あるかもしれないので、Mixhostから返信があるまでクローズせずこのままにしておきます。

 

あ、ありがとうございました…!!w


   
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 13830
わいひら - Facebookわいひら - Twitter
 

エラーメッセージで検索すると、以下のページが出てきます。
https://smashballoon.com/uploading-plugin-pclzip_err_bad_format-10-unable-find-end-central-dir-record-signature/
原因としては以下の2点が挙げられています。

1.ZIPファイルに不備がある
2.WordPressに使用するメモリが足りていない

この原因が確かなのかわからないです。
ただ、サーバに負荷がかかっていて、メモリ量が足りていないとかであれば、そういったこともありえるのかもしれません。


   
rinrin
(@rinrin)
Active Member Registered
結合: 4年前
投稿: 17
rinrin - Twitter
Topic starter  

わいひらさん、ありがとうございます。

教えていただいたページ…英語が読めないのでさっぱりでした…!中身を教えていただいてありがとうございます。

 

サーバーに負荷がかかっていた可能性が高い…と思います。

一時的に?メモリ量が足りなくなっていたのかもしれません。

 

しかし未だにサーバー側から連絡がありません…。また連絡がありましたら、ここに追記させていただきます!

 


   
わいひら reacted
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 13830
わいひら - Facebookわいひら - Twitter
 

承知しました!


   
rinrin
(@rinrin)
Active Member Registered
結合: 4年前
投稿: 17
rinrin - Twitter
Topic starter  

その後…1か月ほど経過しましたが、何故か未だにサーバーから返答がありません…。

1度は「確認します」と返答があったのですが、その後催促の連絡をしても何も返信が来ませんでした。

 

わいひらさんの言うようにサーバーに負荷がかかっていた可能性が高いです。

2度ほど更新できなかったことがあったのですが、しばらく時間を置いたらいつも通り更新できるようになりました。

今では特に更新で手間取りません。

なので、もやっと解決して申し訳ないですが…これで解決ということにします。

色々ありがとうございました!とっても助かりました!


   
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 13830
わいひら - Facebookわいひら - Twitter
 

ご連絡ありがとうございます。
現在問題ないのであれば、やはりサーバーの状態が影響していた可能性は高そうですね。
現在、MixHostコントロールパネルのphp.iniのmemory_limitは幾つになっていましたか?
もし、同様の状態になれば、メモリ量を増やすことで対応できるかもしれません。


   
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 13830
わいひら - Facebookわいひら - Twitter
 

現在のメモリ設定量を見るには、MixHostコントロールパネルの「MultiPHP INI Editor」を開いて、


   
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 13830
わいひら - Facebookわいひら - Twitter
 

memory_limit 部分を見ます。


   
rinrin
(@rinrin)
Active Member Registered
結合: 4年前
投稿: 17
rinrin - Twitter
Topic starter  

わいひらさん、確認が遅くなってしまってすみません…!

MultiPHP INI Editor が無かったので

php.iniの編集方法

https://help.mixhost.jp/hc/ja/articles/115003736411-php-ini%E3%81%AE%E7%B7%A8%E9%9B%86%E6%96%B9%E6%B3%95

を参考にして「memory_limit」を確認してきました。

memory_limitは128Mに設定されておりました。

 

何故だかまたテーマが更新ができなくなってしまったので、一時寝かせ中です…。


   
Akira
(@akira)
Noble Member Registered
結合: 5年前
投稿: 1115
Akira - FacebookAkira - Twitter
 

PHP のバージョンが 5.6.36 と古いのが、原因かもしれません。

7.1 以上にバージョンアップされると、テーマを更新できないでしょうか。


   
わいひら reacted
rinrin
(@rinrin)
Active Member Registered
結合: 4年前
投稿: 17
rinrin - Twitter
Topic starter  

Akiraさん、コメントありがとうございます!

PHPのバージョンについて全く気にしたことがありませんでした。

確かに5.6と書いてありました!!

何故だか先ほど更新してみたら、テーマの更新に成功しました。

PHPの更新、チャレンジしてみます!ありがとうございます!


   
わいひら reacted
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 13830
わいひら - Facebookわいひら - Twitter
 

MixHostであれば、memory_limitは256Mにしても大丈夫だと思います。
たとえ、制限を超えたとしても、MixHostの場合、制限以上のメモリは使えない仕様になっているので。

PHPのバージョン変更処理は、Simplicity1、2で使っていたものと変わりないので、5.6でも大丈夫のようには思いますが、出来れば7.2以上にしておくことに越したことはないと思います。


   
rinrin
(@rinrin)
Active Member Registered
結合: 4年前
投稿: 17
rinrin - Twitter
Topic starter  

わいひらさん、ありがとうございます。

memory_limitを256Mにしてみました。

そしてPHPを、7.2に変更してみました。変更してすぐにサイトをさらっと見ましたが特に変化はありませんでした。

PHPのバージョンについて全く考えたことが無かったので良かったです。

わいひらさん、Akiraさんありがとうございます!


   
わいひら reacted
kazusun
(@kazusun)
Eminent Member Registered
結合: 4年前
投稿: 47
 

お世話になります。
rinrinさんと同じような現象かもしれないので、こちらに書き込ませて頂きます。

現在Cocoonのバージョンは1.6.5なのでバージョンアップをしようとしました。
ですが、エラーとなります。
PHPは7.2.13です。
memory_limitは22800000000Mです。(←管理画面にはこのように表示されています)

ちなみに「Twenty Seventeen」など、ほかのテーマは更新が出来ました。

Cocoon使い始めて間もないので、もしかすると初歩的問題なのかもしれませんが、なにか分かればご助言頂けると幸いです。

 


   
かうたっく
(@kautakku)
Famed Member Moderator
結合: 5年前
投稿: 4764
かうたっく - Facebook

   
kazusun reacted
kazusun
(@kazusun)
Eminent Member Registered
結合: 4年前
投稿: 47
 

かうたっくさん、ありがとうございます。

今回はFTPの手動でバージョンアップ完了しました。
一応、サーバーに問い合わせてみたら、テーマ側でナンチャラかんちゃらがバグっているんだろうって言われましたが、素人なので何言っているか分かりませんでした。
肝心なところなのに<(_ _)>


   
かうたっく
(@kautakku)
Famed Member Moderator
結合: 5年前
投稿: 4764
かうたっく - Facebook
 

テーマ側でナンチャラかんちゃらがバグっているんだろうっ

その内容ってメールであれば、コピペしていただけますか。


   
わいひら reacted
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 13830
わいひら - Facebookわいひら - Twitter
 

確かに、その内容をあっていただければ、ある程度はわかるかもしれません。
※伏字にすべきところは伏字にしていただければと思います。


   
kazusun
(@kazusun)
Eminent Member Registered
結合: 4年前
投稿: 47
 

わいひらさん、かうたっくさん

すみません、電話で問い合わせしたんですよ。

でも重要な内容だと思うので、数日中にもう一回電話して聞いてみます。
分かったらお知らせしますね。


   
kazusun
(@kazusun)
Eminent Member Registered
結合: 4年前
投稿: 47
 

サーバー側にメールで問い合わせたところ次のような回答が来ました。


平素は、ありがとうございます。
バグフィックスについては、他のテーマは問題なくアップデート可能なご様子の様でしたので、あくまで推察となり、大変恐縮ですが、具体的な箇所等については、こちらはサーバーご提供の立場になります為、ご案内がしづらい立場となります。

何卒、ご理解頂けましたら幸いです。

電話で問い合わせたときに詳しく聞いておくべきでした。
役立たずですみません<(_ _)>


   
わいひら reacted
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 13830
わいひら - Facebookわいひら - Twitter
 

エラーメッセージの「cURL error 35: SSL connect error」で検索してみると、サーバーのSSL関係の設定の可能性もなくはないと思うのですが、サーバーが言うのであればそうなのかもしれません。ちょっと、サーバーが対応していないとも思えないので。
僕も確かめようがないので、ちょっと何とも言えないかも。

ちなみに、利用されているサーバーはどこでしょう?
電話でということはエックスサーバーとかでしょうか?


   
kazusun
(@kazusun)
Eminent Member Registered
結合: 4年前
投稿: 47
 

サーバーはロリポップとアナハイムを利用しているのですが、今回バージョンアップが出来なかったのはアナハイムの方です。

先に書きましたように、アナハイムでもTwenty系のテーマは問題なく更新できました。
ご参考までに。


   
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 13830
わいひら - Facebookわいひら - Twitter
 

アナハイムというサーバーは、今回初めて知りました。
https://www.anaheim-e.biz/

ロリポップでは大丈夫だったということは、もしかしたらアナハイムのSSL設定と、当サイト(MixHost)のSSL関係で何か問題があるのかもしれませんね。
MixHostはかなりセキュリティーに厳しくなっているので。


   
kazusun reacted
kazusun
(@kazusun)
Eminent Member Registered
結合: 4年前
投稿: 47
 

なるほどですね。
とりあえずFTPで解決できたので良かったです。

今後も色々とあると思いますが、わいひらさんも体に無理が無いようにお願いします。


   
わいひら reacted
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 13830
わいひら - Facebookわいひら - Twitter
 

体調が悪いときは、遠慮なく休ませていただいて体調に気をつけたいと思います。


   
kazusun reacted
共有:

問題の解決に至った場合には、トピック冒頭の「解決済み」リンクをクリックしていただけますと幸いです。

wpForoの解決済みリンク

また、有用な返信があった場合は「いいね!」リンクもご活用ください。返信者の励みになります。

wpForoのいいねリンク

「いいね!」機能はフォーラム登録者のみが利用できる機能です。

CC BY-ND 2.1)準じていれば(リンクを貼っていただければ)転載も自由です。カスタマイズ記事を書く際にコード等をコピペ利用していただいて構いません。

フォーラムの使い方がよくわからない場合は、テストトピックで自由にテストしていただいて構いません。

最近の書き込みはこちら。

詳細なカスタマイズ依頼をするならこちら。