「メイド・イン・ヘブン」スキン適用中

Cocoonフォーラム

サイト内検索
書き込みの前に以下の3点をご確認ください。
  1. 1つのトピックにつき1つの質問を書き込んでください
  2. 不具合・カスタマイズ対象ページのURLを提示高速化を無効にしてください
  3. 該当部分のキャプチャ・環境情報とともに書き込んでいただけると助かります

何を書き込んだら良いか分からない場合は、以下のテンプレートをコピペしてご利用ください。

不具合・カスタマイズ対象ページのURL:

相談内容:

不具合の発生手順:

解決のために試したこと:

※文字だけでは正しく伝わらない可能性があるため、スクショ画像の添付もお願いします。
※高速化設定をしている場合は無効にしてください。
環境情報:

※↑こちらに「Cocoon設定 → テーマ情報」にある「環境情報」を貼り付けてください。

環境情報の取得方法はこちら。
https://wp-cocoon.com/theme-report/
高速化設定を無効にするにはこちら。
https://wp-cocoon.com/theme-trouble/

フォーラム利用ガイドリンク

  1. フォーラムガイドライン
  2. よくある質問と答え(FAQ)
  3. サポート対象外のケース
  4. 原因不明の不具合用トラブルシューティング
  5. トピックにHTMLを貼り付ける方法(推奨ツール:notepad.pw
  6. 真っ白画面でのエラーメッセージの確認方法
  7. ブラウザ環境チェックツール
  8. Cocoonカスタマイズ依頼

フォーラム質問後、問題等が解決した場合は結果を書き込んでいただけると幸いです。同様の問題で調べている方には、結果が一番気になる部分となります。

wpForo ページのタイトル表示不具...
 
共有:
通知
すべてクリア

[解決済] wpForo ページのタイトル表示不具合

14 投稿
3 ユーザー
5 Likes
483 表示
(@konpeitoro)
Trusted Member Registered
結合: 1年前
投稿: 48
Topic starter  

お世話になっております。
Cocoon を愛用させていただいておりますが、wpForo 使用時に不具合が発生したようなので投稿させていただきます。
サイトを管理していると、wpForo ページのタイトル表示が(フォーラムのホームの場合)「テストサイト フォーラム | テストサイト」のようにブラウザーのタブに表示されているのと同じものになってしまいました。
デフォルトテーマ(Twenty Twenty-Three)に一時的に変更してみると、テストサイトの場合「Forum」と表示になっていますが、Cocoon に戻すと「テストサイト フォーラム | テストサイト」表示に戻ってしまいました。
本番サイトでは管理画面で[wpForo]>[Boards]で掲示板の名前を「談話室」に変更しているのですが、ほぼ初期設定のままのテストサイトでもこの現象が発生します。
「Forum」や「談話室」などと表示させたいです。

ご教示いただければ幸いです。
よろしくお願いいたします。

テストサイトのフォーラム

システム情報

私は完全招待制のクローズドな Web サイトを WordPress と Cocoon で運営しています。
そのため質問時なども当該サイトのURLは記載できないことが多いです。


   
わいひら
(@yhira)
Illustrious Member Admin
結合: 6年前
投稿: 16441
 

テストサイトでいうところの矢印部分のことでしょうか?


   
わいひら
(@yhira)
Illustrious Member Admin
結合: 6年前
投稿: 16441
 

だとしたらその部分はフォーラムを設置した固定ページのタイトル部分で設定するものではないでしょうか。

ちなみに当サイトのタイトル表示はこちら。
https://wp-cocoon.com/community/

This post was modified 10か月前 by わいひら

   
(@konpeitoro)
Trusted Member Registered
結合: 1年前
投稿: 48
Topic starter  

@yhira さん

ご確認いただきありがとうございます。

テストサイトでいうところの矢印部分のことでしょうか?

矢印部分のことで合っています。

テストサイトでは固定ページのタイトル設定は、Forum となっていますが、実際の wpForo ページのタイトル表示は「テストサイト フォーラム | テストサイト」」とサイト名付きになってしまいます。

本番サイトにて「談話室」という名前を使用していますが、一時的に固定ページのタイトルを Forum に変更しても変わりませんでした。

https://gyazo.com/8bdc1c82963017513709eb8d15f988a5

よろしくお願いします。

私は完全招待制のクローズドな Web サイトを WordPress と Cocoon で運営しています。
そのため質問時なども当該サイトのURLは記載できないことが多いです。


   
(@akira)
Famed Member Registered
結合: 6年前
投稿: 1657
 

@konpeitoro さん

wpForo のページの場合は、wp_get_document_title() での表示になっています。

https://github.com/xserver-inc/cocoon/blob/master/tmp/content.php#L37-L43

おそらく、Change Forum Page の画像に見える wpForo のメニュー「Boards」の「Board Title」に書いたものがタイトルとして表示されている気がします。「Board Title」はどうなっているでしょうか?

また、「| テストサイト」とサイト名が付くのは、Cocoon 設定 > タイトルの「投稿・固定ページタイトル」で「ページタイトル | サイト名」にチェックが入っているからだと思います。wpForo のページだけサイト名を付けたくない場合は、フィルターフック title_parts_custom で変更できるはずです。ただ、変更した場合、<title> タグや og:title なども変わるため注意が必要です。

This post was modified 10か月前 3回 by Akira

   
(@konpeitoro)
Trusted Member Registered
結合: 1年前
投稿: 48
Topic starter  

@akira さん

ご回答いただきありがとうございます。

Cocoon 設定 > タイトルの「投稿・固定ページタイトル」を「ページタイトル」にしてみましたが、タイトル表示は変わりませんでした。

title_parts_custom フックの使い方とサンプルを教えていただけますか?

なお、wpForo の Board title は「談話室」としていますが、サイト名も wpForo 固定ページに表示されてしまいます。

本番サイトの wpForo 掲示板タイトル設定

This post was modified 10か月前 by KonpeitoRO

私は完全招待制のクローズドな Web サイトを WordPress と Cocoon で運営しています。
そのため質問時なども当該サイトのURLは記載できないことが多いです。


   
(@akira)
Famed Member Registered
結合: 6年前
投稿: 1657
 

@konpeitoro さん

テスト環境でちょっと試してみました。

申し訳ありません。Cocoon 設定は関係ありませんでした。

wpForo メニュー > 設定 > wpForo SEO の「Enable Meta Titles」を「いいえ」にすれば、固定ページに書いたタイトルで表示されました。

参考:wpForo SEO


   
(@konpeitoro)
Trusted Member Registered
結合: 1年前
投稿: 48
Topic starter  

@akira さんがご教示くださったように、wpForo の設定が原因のようです。

wpForo メニュー > 設定 > wpForo SEO の「Enable Meta Titles」を「いいえ」にすれば、固定ページに書いたタイトルで表示されました。

テストサイトで wpForo 設定の「Enable Meta Titles」チェックを外してみると固定ページのタイトルが反映されましたが、本番サイトでは同じ設定をしても解決できませんでした。

ですが、まだそこまで会話をしていなかったので本番サイトでは wpForo をプラグイン一覧からアンインストール操作を選び、再度有効化して解決しました(データは削除されます)。

親切にサポートいただきありがとうございました。

私は完全招待制のクローズドな Web サイトを WordPress と Cocoon で運営しています。
そのため質問時なども当該サイトのURLは記載できないことが多いです。


   
わいひら reacted
わいひら
(@yhira)
Illustrious Member Admin
結合: 6年前
投稿: 16441
 

僕も試してみたんですがwpForo SEO の「Enable Meta Titles」を「いいえ」を設定した場合は個別トピックページのタイトルも変わってしまうかもしれません。

改めてCocoonを確認してみたところ細かな説明は省きますが改善できたと思うので以下のファイルで試してみていただけると幸いです。
------------------------------------------------
https://github.com/xserver-inc/cocoon
開発中の最新ファイルをダウンロードする場合は、上記ページのダウンロードボタンからzipファイルをダウンロードしてください。

WordPressでの手動アップデート方法はこちら
https://wp-cocoon.com/manual-update-of-cocoon-theme/
------------------------------------------------


   
(@konpeitoro)
Trusted Member Registered
結合: 1年前
投稿: 48
Topic starter  

@yhira さん

Cocoon を管理画面から 2.6.1.6 に更新してみました。

テストサイトではアップデート前から[Enable Meta Titles]をオンにすれば解決しましたが、本番サイトではアップデート後も解決しませんでした。

wpForo を一度アンインストールして有効化してみると、テストサイト、本番サイト両方で以下の重大なエラーが表示されます(フォルダー名は一部変更したうえで記載しています)。

Fatal error: Uncaught TypeError: call_user_func_array(): Argument #1 ($callback) must be a valid callback, first array member is not a valid class name or object in /home/users/2/example.com/web/wp-content/plugins/wpforo/includes/functions.php:2832 Stack trace: #0 /home/users/2/example.com/web/wp-content/plugins/wpforo/includes/functions.php(560): wpforo_ram_get('_is_wpforo_page', '') #1 /home/users/2/example.com/web/wp-content/themes/cocoon-master/lib/utils.php(1501): is_wpforo_page('') #2 /home/users/2/example.com/web/wp-content/themes/cocoon-master/lib/ogp.php(11): is_wpforo_plugin_page() #3 /home/users/2/example.com/web/wp-content/themes/cocoon-master/lib/_imports.php(101): require_once('/home/users/2/c...') #4 /home/users/2/example.com/web/wp-content/themes/cocoon-master/lib/_defins.php(343): require_once('/home/users/2/c...') #5 /home/users/2/example.com/web/wp-content/themes/cocoon-master/functions.php(15): require_once('/home/users/2/c...') #6 /home/users/2/example.com/web/wp-settings.php(591): include('/home/users/2/c...') #7 /home/users/2/example.com/web/wp-config.php(91): require_once('/home/users/2/c...') #8 /home/users/2/example.com/web/wp-load.php(50): require_once('/home/users/2/c...') #9 /home/users/2/example.com/web/wp-blog-header.php(13): require_once('/home/users/2/c...') #10 /home/users/2/example.com/web/index.php(17): require('/home/users/2/c...') #11 {main} thrown in /home/users/2/example.com/web/wp-content/plugins/wpforo/includes/functions.php on line 2832

なお、wpForo ではエラーや不具合が発生するなどがあるため、bbPress も検討しています。

私は完全招待制のクローズドな Web サイトを WordPress と Cocoon で運営しています。
そのため質問時なども当該サイトのURLは記載できないことが多いです。


   
わいひら
(@yhira)
Illustrious Member Admin
結合: 6年前
投稿: 16441
 

エラーが出ているページはどんなページですか?
サイト全体とか、wpForoページ全体とか、wpForoトピックページのみとか。
僕の環境だとどのページでもエラーが出ていないようです。
エラーメッセージはwpForoの添付画像の部分で出ています。
wpForoをFTPでアップデートしてもダメですか。


   
わいひら
(@yhira)
Illustrious Member Admin
結合: 6年前
投稿: 16441
 

テストサイトはサイト全体から出ていますね。
もし管理画面に入れるならCocoonのバージョンを旧バージョンに戻すと改善しますでしょうか。
https://wp-cocoon.com/manual-downgrade-of-cocoon-theme/


   
(@konpeitoro)
Trusted Member Registered
結合: 1年前
投稿: 48
Topic starter  

wpForo のエラーは一度デフォルトテーマに変更してから、プラグインを有効化し、Cocoon に切り替えると問題ありませんでした。
また、子テーマに tmp/content.php をカスタマイズしていたので、アップデートしても反映されていませんでした。
こちら側のミスで不具合が発生したので申し訳ありませんでした。
@yhira さん、@akira さん、丁寧にサポートいただきありがとうがとうございました。
本件はこれで解決しました。

私は完全招待制のクローズドな Web サイトを WordPress と Cocoon で運営しています。
そのため質問時なども当該サイトのURLは記載できないことが多いです。


   
わいひら reacted
わいひら
(@yhira)
Illustrious Member Admin
結合: 6年前
投稿: 16441
 

無効化→有効化する時に出るエラーなのかな?と僕の開発環境でも試してみましたが再現されませんでした。

投稿者:: @konpeitoro

また、子テーマに tmp/content.php をカスタマイズしていたので、アップデートしても反映されていませんでした。

古いwpForoを使用していたのだとしたら前述のエラーが出る可能性もあるかもしれません。
いずれにせよとりあえずエラーが解消したようで良かったです!

ご報告ありがとうございます。

 


   
KonpeitoRO reacted
共有:

問題の解決に至った場合には、トピック冒頭の「解決済み」をクリックしていただけますと幸いです。

また、有用な回答があった場合は返信右下にある「いいね!」もご活用ください。回答者の励みになります。

「いいね!」機能はフォーラム登録者のみが利用できる機能です。

CC BY-ND 2.1)準じていれば(リンクを貼っていただければ)転載も自由です。カスタマイズ記事を書く際にコード等をコピペ利用していただいて構いません。

フォーラムの使い方がよくわからない場合は、テストトピックで自由にテストしていただいて構いません。

最近の書き込みはこちら。

詳細なカスタマイズ依頼をするならこちら。

タイトルとURLをコピーしました