「メイド・イン・ヘブン」スキン適用中

Cocoonフォーラム

サイト内検索
書き込みの前に以下の3点をご確認ください。
  1. 1つのトピックにつき1つの質問を書き込んでください
  2. 不具合・カスタマイズ対象ページのURLを提示高速化を無効にしてください
  3. 該当部分のキャプチャ・環境情報とともに書き込んでいただけると助かります

何を書き込んだら良いか分からない場合は、以下のテンプレートをコピペしてご利用ください。

不具合・カスタマイズ対象ページのURL:

相談内容:

不具合の発生手順:

解決のために試したこと:

※文字だけでは正しく伝わらない可能性があるため、スクショ画像の添付もお願いします。
※高速化設定をしている場合は無効にしてください。
環境情報:

※↑こちらに「Cocoon設定 → テーマ情報」にある「環境情報」を貼り付けてください。

環境情報の取得方法はこちら。
https://wp-cocoon.com/theme-report/
高速化設定を無効にするにはこちら。
https://wp-cocoon.com/theme-trouble/

フォーラム利用ガイドリンク

  1. フォーラムガイドライン
  2. よくある質問と答え(FAQ)
  3. サポート対象外のケース
  4. 原因不明の不具合用トラブルシューティング
  5. トピックにHTMLを貼り付ける方法(推奨ツール:notepad.pw
  6. 真っ白画面でのエラーメッセージの確認方法
  7. ブラウザ環境チェックツール
  8. Cocoonカスタマイズ依頼

フォーラム質問後、問題等が解決した場合は結果を書き込んでいただけると幸いです。同様の問題で調べている方には、結果が一番気になる部分となります。

Cocoonテーマを有効化すると重大な...
 
共有:
通知
すべてクリア

Cocoonテーマを有効化すると重大なエラーが出る

15 投稿
6 ユーザー
8 Reactions
2,092 表示
(@agns0131)
New Member Registered
結合: 3年前
投稿: 2
Topic starter  

 

【不具合・カスタマイズ対象ページのURL】

http://192.168.100.206/wordpress/wp-admin/themes.php?activated=true

 

【相談内容】

WordPressでCocoonテーマを使おうと思い、親テーマ(低サイズ版)と子テーマをインストールし、アップロードをしました。(低サイズ版ではない親テーマは有効化したら期限切れと表示されたので、低サイズ版にしました)

その後、子テーマを有効化(もしくはライブプレビュー)したら画像・下記のような画面になりました。

 

このサイトで重大なエラーが発生しました。対応手順については、サイト管理者のメール受信ボックスを確認してください。

WordPress のトラブルシューティングについてはこちらをご覧ください。

 

ちなみにサイト管理者のメール受信ボックスには、メールは届いておりません。

WordPress初心者(phpがよくわからない)です。

Cocoonが適用できるよう、ご教授お願い致します。

 

【解決のために試したこと】

プラグインはすべて無効化しました。

【環境情報】

WordPress 5.8.2


   
引用
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 3年前
投稿: 7225
 

agns0131さん

低サイズ版は、アップロード容量の少ないサーバーの為にあります。

中身はかなり古いバージョンで、今のバージョンのWordPressでの稼動は難しいと思います。

必ずダッシュボードから、最新バージョンにアップデートして、ご利用ください。


   
わいひら reacted
返信引用
(@agns0131)
New Member Registered
結合: 3年前
投稿: 2
Topic starter  

@mk2_mk2 さん

ご覧いただきありがとうございます。

 

補足いたします。

cocoonを有効化すると重大なエラーが出て、他の画面に切り替えたりなにをしてもずっとエラーの画面のままになってしまいます。

つまりcocoonを有効化した状態ですと、更新をしたくてもダッシュボードにもアクセスができない状態です。

 

ちなみにこのように重大なエラーが出たので、

戻るボタンをおして→テーマ選択画面→cocoonではない別テーマを選択・有効化

…をして、エラー画面を回避しました。

(ただまたcocoonを有効化すると重大なエラーの画面になって何もできなくなってしまいます)

 

添付ファイルは、上記の方法で別テーマを有効化した状態のダッシュボード>更新の画面です。

テーマの更新が見当たらないのですが、別のテーマを有効化したままcocoonのテーマって更新できるのでしょうか。


   
返信引用
はる
(@haruinoue)
Noble Member Moderator
結合: 4年前
投稿: 1070
 

http://192.168.100.206/wordpress/wp-admin/themes.php?activated=true

これはローカル環境でしょうか?

エラーになるのはテーマのアップロードが上手くいっていなくてテーマが壊れている状態なのではないかと思いました。

ダッシュボードからのアップロードは諦め、WordPressのフォルダに直接Cocoonをコピーするのを試してみて良いと思います。

「wordpress/wp-content/themes」フォルダの中に、解凍したテーマのフォルダをコピーするとテーマをインストールした状態になります。

投稿者:: @agns0131

テーマの更新が見当たらないのですが、別のテーマを有効化したままcocoonのテーマって更新できるのでしょうか。

別のテーマを有効にしたままでも他テーマの更新はできるはずです。


   
わいひら reacted
返信引用
(@kedaruma2)
New Member Registered
結合: 1年前
投稿: 3
 

おせわになります。kedarumaです。

自分も全く同じ症状で困ってます。

 

動作環境

WordPress 6.2

PHP 7.4.33

 

再現手順

以下zipをアップロードでインストール後、インストールした何れかを有効にすると「このサイトで重大なエラーが発生しました。対応手順については、サイト管理者のメール受信ボックスを確認してください」と表示され一切のページへの遷移が出来なくなります、つまり一切の操作ができなくなります!

cocoon-child-master.zip (2023-05-10ダウンロード)

cocoon-master.zip (2023-05-10ダウンロード)

復旧にはftpでインストールしたテーマを削除する事で復旧し操作可能な状態にもどります。

 

やった事

ダンロードしたファイルを予めローカルPCで解答しftpでテーマをアップロードしてみる → 同じ症状で変化無し

 

注意喚起が必要ではないでしょうか、知識がなければ復旧できないので、初心者はサイトが破壊されたと認識するでしょうから。

 

以上です、取り急ぎお知らせしました。

 

 

 


   
返信引用
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 3年前
投稿: 7225
 

kedaruma2さん

確認ですが、kedaruma2さんは、低サイズ版をインストールなさったということでしょうか。

【追記】

今、スマホですが、低サイズ版をダウンロードしようとすると、ファイル名は「cocoon-master-low.zip」でした。


   
わいひら reacted
返信引用
(@kedaruma2)
New Member Registered
結合: 1年前
投稿: 3
 

mk2 さん

> 確認ですが、kedaruma2さんは、低サイズ版をインストールなさったということでしょうか。

いえ、自分は通常版です。

なので、通常版でも軽量版でもこのトラブルは発生するようです。

 


   
返信引用
(@kedaruma2)
New Member Registered
結合: 1年前
投稿: 3
 

とりあえず、WordPressを6.0.3にダウングレードする事で解決しました。

取り急ぎご報告まで。

 


   
返信引用
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 3年前
投稿: 7225
 

kedaruma2さん

エラーログなどをご確認いただけないでしょうか。(メッセージが分かれば良いです)

何が原因かも分からずでは、難しいと思います。

投稿者:: @kedaruma2

いえ、自分は通常版です。

なので、通常版でも軽量版でもこのトラブルは発生するようです。

普通の親テーマで起きるのであれば、他の環境でも起こるのではないかと思います。新規環境に関わらず。

私の本番環境では、親テーマは2.5.9で特に何も起きていません。

現在、私の手元にはスマホしかないため、確認はできませんので、夜以降になるかもしれませんが、確認してみます。(午前中に確認の時間がとれれば、確認しますが、難しい可能性が高いです)

 

もし、Cocoonの不具合であれば、修正すべきで注意換気ではないと思います。

 

ちなみに、現在のkedaruma2さんの環境情報を貼り付けていただけますでしょうか。

URL部分は消していただいて良いです。

 

申し訳ないですが、私は一旦フォーラムから離脱させていただきます。


   
わいひら reacted
返信引用
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 3年前
投稿: 7225
 

結論から言えば、特に問題はなさそうです。

ローカル環境で、以下の環境を2つ作りました。

  • WordPress 6.2
  • PHP 8.1.9

 
それぞれに、Cocoon公式サイトからダウンロードした、Cocoonをインストールし、有効化してみました。


環境Aは、以下の手順

  1. Cocoon親テーマ(Ver.2.5.9)をインストール
  2. 親テーマ有効化
  3. Cocoon子テーマ(Ver.1.1.3)をインストール
  4. 子テーマ有効化

 
上記環境で、特に問題は起きていません。


環境Bは、以下の手順

  1. Cocoon親テーマ・低サイズ版(Ver.1.6.1.2)をインストール
  2. 親テーマ有効化
  3. Cocoon子テーマ(Ver.1.1.3)をインストール
  4. 子テーマ有効化
  5. Cocoon親テーマ、ダッシュボードから最新バージョン(Ver.2.5.9)へ更新

 
上記も特に問題は発生していないようです。

低サイズ版の環境は、画像も添付しておきます。

 

親テーマ・低サイズ版をインストール・有効化

 
子テーマをインストール・有効化
 
親テーマを最新版にアップデート
 

これらのことから、基本的には問題ないと思います。

kedaruma2さんの環境だけで起きている可能性があると思います。


   
わいひら reacted
返信引用
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 3年前
投稿: 7225
 

kedaruma2さんの環境は、PHP7.4系みたいですので、念の為、以下の環境を作り、上の返信と同様の手順で確認を行いました。

  • WordPress 6.2
  • PHP 7.4.30

 
上記で、親テーマ(通常版)、親テーマ(低サイズ版)をインストール・有効化。
更に、それぞれ子テーマをインストール・有効化。

どちらも問題なかったです。


   
わいひら reacted
返信引用
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 3年前
投稿: 7225
 

このトピックは、元々 

kedaruma2さんの環境で起きていることが、このトピックのものと同じかどうかは、分からないですね。
(表面的なメッセージが同じでも、実際の原因が同じとは限らない。そもそもこのトピック主さんから返信もないので、益々分からない)

本来は、新規トピックを作成していただくべきだと思います。

 

とりあえず、あれから時が経っていますから、低サイズ版は少し心配しましたが、特に問題はないように思います。

所用がありますので、フォーラムからはしばらく離脱します。


   
わいひら reacted
返信引用
わいひら
(@yhira)
Illustrious Memberサイト Admin
結合: 6年前
投稿: 16663
 

https://wp-cocoon.com/community/postid/70411/
こちらに書かれている記述だけではちょっと何とも言えません。

以下の取得方法で環境情報を頂いてよろしいでしょうか。
https://wp-cocoon.com/theme-report/
サイトを公開したくない場合は、サイト情報がわかる部分を削除して頂いて構いません。

あとできればエラーメッセージがわかれば欲しいです。
エラーメッセージがわかれば原因を特定できる可能性が高くなります。


   
返信引用
(@saotome)
New Member Registered
結合: 1年前
投稿: 1
 

すいません横から失礼します。

私も同じ状況だったんですが、親テーマのほうを3年前くらいのバージョン使ってみたら上手くいきました。

お急ぎの方は試してみてください!


   
返信引用
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 3年前
投稿: 7225
 

投稿者:: @saotome

親テーマのほうを3年前くらいのバージョン使ってみたら上手くいきました。

このようなことは、なさらないでください。

(少なくとも、人に勧めるようなことではありません。)

最新のWordPressをご利用であれば、確実に不具合がおきます。(特にGutenberg上で)

最新のWordPressをご利用でない場合は、セキュリティ的に問題があると思います。


   
わいひら reacted
返信引用
共有:

問題の解決に至った場合には、トピック冒頭の「解決済み」をクリックしていただけますと幸いです。

また、有用な回答があった場合は返信右下にある「いいね!」もご活用ください。回答者の励みになります。

「いいね!」機能はフォーラム登録者のみが利用できる機能です。

CC BY-ND 2.1)準じていれば(リンクを貼っていただければ)転載も自由です。カスタマイズ記事を書く際にコード等をコピペ利用していただいて構いません。

フォーラムの使い方がよくわからない場合は、テストトピックで自由にテストしていただいて構いません。

最近の書き込みはこちら。

詳細なカスタマイズ依頼をするならこちら。

タイトルとURLをコピーしました