Cocoonフォーラム

書き込みの前に以下の3点をご確認ください。
  1. 1つのトピックにつき1つの質問を書き込んでください
  2. 不具合・カスタマイズ対象ページのURLを提示高速化を無効にしてください
  3. 該当部分のキャプチャ・環境情報とともに書き込んでいただけると助かります

何を書き込んだら良いか分からない場合は、以下のテンプレートをコピペしてご利用ください。

不具合・カスタマイズ対象ページのURL:

相談内容:

不具合の発生手順:

解決のために試したこと:

※文字だけでは正しく伝わらない可能性があるため、スクショ画像の添付もお願いします。
※高速化設定をしている場合は無効にしてください。
環境情報:

※↑こちらに「Cocoon設定 → テーマ情報」にある「環境情報」を貼り付けてください。

環境情報の取得方法はこちら。
https://wp-cocoon.com/theme-report/
高速化設定を無効にするにはこちら。
https://wp-cocoon.com/theme-trouble/

フォーラム利用ガイドリンク

  1. フォーラムガイドライン
  2. よくある質問と答え(FAQ)
  3. サポート対象外のケース
  4. 原因不明の不具合用トラブルシューティング
  5. トピックにHTMLを貼り付ける方法(推奨ツール:notepad.pw
  6. 真っ白画面でのエラーメッセージの確認方法
  7. ブラウザ環境チェックツール
  8. Cocoonカスタマイズ依頼

フォーラム質問後、問題等が解決した場合は結果を書き込んでいただけると幸いです。同様の問題で調べている方には、結果が一番気になる部分となります。

テーマのインストール後エラーが表示され...
 
共有:
通知
すべてクリア

[解決済] テーマのインストール後エラーが表示される

22 投稿
5 ユーザー
15 Likes
208 表示
as_y
 as_y
(@as_y)
Active Member Registered
結合: 3か月前
投稿: 5
Topic starter  

https://syounenyakyu.jp/

テーマを親、子とダウンロードして有効化すると以下の画面が表示されてしまいます。

https://gyazo.com/692d50cf582e12a4fcd382e879444ab1&source=gmail&ust=1661587781106000&usg=AOvVaw3BhY9IkKOTuxlk75uxs1I W"> https://gyazo.com/692d50cf582e12a4fcd382e879444ab1

サイトに載っていたエラー対処方法でダウンロードしても変わりません

私は何を間違えているのでしょうか、考えられることを教えていただけますか?


   
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 14137
 

見やすいように画像をアップしておきます。


   
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 14137
 

いくつか質問してよいでしょうか。
インストール後、WordPressの管理画面には入れますか?
管理画面に入れた場合、高速化設定をすべて無効にするとどうなりますか?
あと、WordpressとPHPのバージョンは幾つでしょうか。

不具合は再現できませんでしたが「fatal error: cannot use isset on the result of an expression」というエラーメッセージで推測して修正してみました。
以下のファイルで上書きアップデートしてみるとどうなりますでしょうか。
------------------------------------------------
https://github.com/yhira/cocoon
開発中の最新ファイルをダウンロードする場合は、上記ページのダウンロードボタンからzipファイルをダウンロードしてください。

WordPressでの手動アップデート方法はこちら
https://wp-cocoon.com/manual-update-of-cocoon-theme/
------------------------------------------------


   
as_y
 as_y
(@as_y)
Active Member Registered
結合: 3か月前
投稿: 5
Topic starter  

早速の返信ありがとうございます

管理画面には戻れます。

高速化の無効の方法が分かりません

WordPressは6.0.1でした

PHPのバージョンはどこで確認すればいいでしょうか?

また、新しいファイルをダウンロードしてみましたが、変わりませんでした、すいません


   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4413
 

as_yさん

投稿者:: @as_y

PHPのバージョンはどこで確認すればいいでしょうか?

これは、サーバー側の設定だと思いますので、サーバーの管理画面で確認できるものと思います。


   
わいひら reacted
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4413
 

as_yさん

投稿者:: @as_y

新しいファイルをダウンロードしてみましたが、変わりませんでした

上記のように仰っていますが、実際にインストールなさっているCocoonのバージョンは「2.4.7」に見えます。

 
 
わいひらさんのご案内したものをインストールできていれば、「2.4.8.3」のはずです。
(インストール後、戻したのであれば、すみません)

   
わいひら reacted
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4413
 

こういう状態のもの初めて拝見したので、理解が追いつかないのですが・・・。

「https」でアクセスすると、以下のような感じなのですが。

 
 
「http」でアクセスすると、転送されることなく、別なものが表示されます。
 
 
「http」でアクセスすると、Cocoonも見当たりません。
 
 
「https」と「http」のサイトが別扱いなのは理解しますが、ここまで完全に違うのは、どういうことなのか理解が追いつかず・・・。
 
今回のことと、関係あるのかどうかも良く分からないのですけれど。
詳しい方を待つしかないかもしれないです。

   
わいひら reacted
chu-ya
(@chu-ya)
Noble Member Registered
結合: 7か月前
投稿: 623
 

@mk2_mk2 さん
httpにWordPressでなく、HTMLを書いて作ったサイトが残っているだけかと。


   
わいひら reacted
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4413
 

chu-yaさん

何となく、サーバーの初期設定のページが残っているような気はします。
(index.htmlが表示されている?)

ただ、その場合でもCocoonのテーマディレクトリって、見れないのでしょうか。
(404になってしまうのでしょうか)


   
わいひら reacted
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4413
 

既に手元にはスマホしかありませんので、深追いはしません。

「http」のサイトについては、以下のような感じみたいです。

https://www.j-navi.com/main/wordpress.html

通常 URL は http://example.com/wordpress/ またはメインのトップページ( http://example.com )となります。 さらに virtual_html ディレクトリ( http:// )または secure_html ディレクトリ( https:// )にインストールすることもできます。 secure_html ディレクトリへのインストールは、無料のSSL証明書 がインストールされると(弊社にてご対応)すぐに実行できます。

「https」と「http」のサイトでは、まったく別の場所にインストールすることができるみたいです。

上記のような状態だとすると、こちらは関係なさそうですね。(おそらく)

エラーの画面のパスに「secure_html」が含まれていましたし。

もしかすると・・・。

URLの構造と実際のディレクトリの構造(階層?)の違いが関係している?

分かりませんので、詳しい方をお待ちします。


   
わいひら reacted
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4413
 

as_yさん

いろいろ書いてしまって、すみません。

まずは、わいひらさんがご対応くださったもので、ご確認ください。

もし、バージョンを戻していないのであれば、対応後のバージョンのインストールはできていないと思います。

 

バージョンアップ後に元に戻したのであれば、ご放念ください。


   
わいひら reacted
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4413
 

as_yさん

何度も申し訳ないです。

PHPのバージョンについては、WordPressの管理画面からも確認できるようです。

「ツール」-「サイトヘルス」-「情報」-「サーバー」に表示されていると思います。


   
わいひら reacted
as_y
 as_y
(@as_y)
Active Member Registered
結合: 3か月前
投稿: 5
Topic starter  

申し訳ありません
投稿後、急に体調を崩し作業・返信ができませんでした
改めてもう一度初めからやり直してみました

サイトからテーマをダウンロードし、手作業で教えていただいた手順でアップロードしました

結果エラー画面が当初と内容が変化したので写真を添付します

またPHPのバージョンは7.5だと思います

https://gyazo.com/ae788e79cb671ee48f04a9453ad355c3


   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4413
 

多くの方にご覧いただけますよう、画像を貼り付けます。

 
 
投稿者:: @as_y

またPHPのバージョンは7.5だと思います

7.5というバージョンはないと思うのですが・・・・。
(7.4系の次は、8.0系だったかと)

今主流なのは、7.4系、8.0系、8.1系だと思います。
(WordPressの要件が、7.4系以上だったと思います)


   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4413
 

as_yさん

もしかして、PHP5系をご利用ではありませんでしょうか。

以下のサイトで、エラーの発生した箇所のコードのチェックを行ったところ、同じ場所で同様のエラーとなりました。

PHP構文チェッカー
https://rakko.tools/tools/31/

 
PHP5系のバージョンは、すべてエラー。
PHP7系のバージョンは、すべて問題なしでした。
 
先にも書きました通り、現在のWordPressの要件は、7.4以上です。
 
WordPress について
要件
 
ご利用サーバーのPHPを、7.4系以降に切り替えるとどうなるかお試しください。
(PHP5系をご利用であれば)
 
どちらのサーバーをご利用なのか、ハッキリ分かりませんでしたが・・・。
J-NAVIだとすると、以下のようなバージョンが選択できるようです。
(他のサーバーでも、概ね同様だと思います)
(上記はJ-NAVI公式サイトのトップページのものです)

   
わいひら reacted
Akira
(@akira)
Noble Member Registered
結合: 5年前
投稿: 1179
 

PHP 8.0.0 で非推奨となったことを理由に、私が修正案を出した部分ですね。

Deprecated: uasort() の修正

宇宙船演算子 <=> は PHP 7.0.0 で追加されたたため、PHP 5 系ではエラーが出ます。

PHP 5 系でもエラーが出ないように、こうすべきだったかな。

function skin_files_comp($a, $b) {
  $f1 = (float)isset($a['priority']) ? $a['priority'] : 99999999999;
  $f2 = (float)isset($b['priority']) ? $b['priority'] : 99999999999;
  //優先度(priority)で比較する
  if ($f1 == $f2) {
      $n1 = (float)isset($a['skin_name']) ? $a['skin_name'] : 99999999999;
      $n2 = (float)isset($b['skin_name']) ? $b['skin_name'] : 99999999999;
      // return $n1 <=> $n2;
      return $n1 < $n2 ? -1 : 1;
  }
  return ($f1 < $f2) ? -1 : 1;
}

あるいは、こう。

function skin_files_comp($a, $b) {
  $f1 = (float)isset($a['priority']) ? $a['priority'] : 99999999999;
  $f2 = (float)isset($b['priority']) ? $b['priority'] : 99999999999;
  //優先度(priority)で比較する
  if ($f1 == $f2) {
      $f1 = (float)isset($a['skin_name']) ? $a['skin_name'] : 99999999999;
      $f2 = (float)isset($b['skin_name']) ? $b['skin_name'] : 99999999999;
      // return $n1 <=> $n2;
  }
  return ($f1 < $f2) ? -1 : 1;
}
This post was modified 2か月前 by Akira

   
わいひら reacted
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 14137
 

<=>はPHP5.6で対応してなかったんですね。
Akiraさんの修正案後者で修正させていただきました。
------------------------------------------------
https://github.com/xserver-inc/cocoon
開発中の最新ファイルをダウンロードする場合は、上記ページのダウンロードボタンからzipファイルをダウンロードしてください。

WordPressでの手動アップデート方法はこちら
https://wp-cocoon.com/manual-update-of-cocoon-theme/
------------------------------------------------


   
Akira reacted
Akira
(@akira)
Noble Member Registered
結合: 5年前
投稿: 1179
 

申し訳ありません。お手数をおかけしました。


   
わいひら reacted
as_y
 as_y
(@as_y)
Active Member Registered
結合: 3か月前
投稿: 5
Topic starter  

ありがとうございます!
修正版をダウンロードして置き替えたら、正常のに表示されました!
このまま親テーマだけでブログを作っていったほうがいいでしょうか?
それともやはり子テーマもダウンロードして子テーマで作業していくべきなんでしょうか?
お忙しい時にすいませんが教えてください


   
chu-ya
(@chu-ya)
Noble Member Registered
結合: 7か月前
投稿: 623
 

@as_y さん

投稿者:: @as_y

それともやはり子テーマもダウンロードして子テーマで作業していくべきなんでしょうか?

親テーマを変更している場合、親テーマがバージョンアップされると、上書きされ、以前の情報が消えてしまいます。
この為、子テーマがあり、CSSなどを変更・追加する場合、子テーマに記述します。
もしCSSなど変更する予定があるなら、子テーマを使う事をお勧めします。


   
わいひら reacted
Akira
(@akira)
Noble Member Registered
結合: 5年前
投稿: 1179
 

@as_y さん

修正版をダウンロードして置き替えたら、正常のに表示されました!

エラーが出なくなったとしても必ず PHP のバージョンを上げてください。

PHP 5 系は、すでにセキュリティサポートが切れています。また、PHP 7.4 も今年の 11 月 28 日にセキュリティサポートが切れます。

PHP 8.0 以上にされることを強くおすすめします。

参考:Supported Versions

このまま親テーマだけでブログを作っていったほうがいいでしょうか?
それともやはり子テーマもダウンロードして子テーマで作業していくべきなんでしょうか?

子テーマをご使用になるべきです。

何かしらのカスタマイズをする場合は、子テーマが必須です。カスタマイズをするご予定がなくとも子テーマのご使用をおすすめします。


   
わいひら reacted
as_y
 as_y
(@as_y)
Active Member Registered
結合: 3か月前
投稿: 5
Topic starter  

わかりました子テーマをダウンロードして使用します

またPHPも8.0にするようにサーバー会社に連絡します
ありがとうございました


   
わいひら reacted
共有:

問題の解決に至った場合には、トピック冒頭の「解決済み」をクリックしていただけますと幸いです。

wpForoの解決済みリンク

また、有用な回答があった場合は「いいね!」もご活用ください。回答者の励みになります。

wpForoのいいねリンク

「いいね!」機能はフォーラム登録者のみが利用できる機能です。

CC BY-ND 2.1)準じていれば(リンクを貼っていただければ)転載も自由です。カスタマイズ記事を書く際にコード等をコピペ利用していただいて構いません。

フォーラムの使い方がよくわからない場合は、テストトピックで自由にテストしていただいて構いません。

最近の書き込みはこちら。

詳細なカスタマイズ依頼をするならこちら。

タイトルとURLをコピーしました