「メイド・イン・ヘブン」スキン適用中

Cocoonフォーラム

サイト内検索
書き込みの前に以下の3点をご確認ください。
  1. 1つのトピックにつき1つの質問を書き込んでください
  2. 不具合・カスタマイズ対象ページのURLを提示高速化を無効にしてください
  3. 該当部分のキャプチャ・環境情報とともに書き込んでいただけると助かります

何を書き込んだら良いか分からない場合は、以下のテンプレートをコピペしてご利用ください。

不具合・カスタマイズ対象ページのURL:

相談内容:

不具合の発生手順:

解決のために試したこと:

※文字だけでは正しく伝わらない可能性があるため、スクショ画像の添付もお願いします。
※高速化設定をしている場合は無効にしてください。
環境情報:

※↑こちらに「Cocoon設定 → テーマ情報」にある「環境情報」を貼り付けてください。

環境情報の取得方法はこちら。
https://wp-cocoon.com/theme-report/
高速化設定を無効にするにはこちら。
https://wp-cocoon.com/theme-trouble/

フォーラム利用ガイドリンク

  1. フォーラムガイドライン
  2. よくある質問と答え(FAQ)
  3. サポート対象外のケース
  4. 原因不明の不具合用トラブルシューティング
  5. トピックにHTMLを貼り付ける方法(推奨ツール:notepad.pw
  6. 真っ白画面でのエラーメッセージの確認方法
  7. ブラウザ環境チェックツール
  8. Cocoonカスタマイズ依頼

フォーラム質問後、問題等が解決した場合は結果を書き込んでいただけると幸いです。同様の問題で調べている方には、結果が一番気になる部分となります。

最新版にアップデートするとCocoon...
 
共有:
通知
すべてクリア

[解決済] 最新版にアップデートするとCocoon設定が変更できなくなる

6 投稿
3 ユーザー
4 Likes
1,290 表示
(@simpfan)
New Member Registered
結合: 2年前
投稿: 3
Topic starter  

こんにちは。

いつもお世話になっています。

さっそくですが、今回公開された最新版(2.3.8)にアップデートしてから、Cocoonの設定が変更できなくなってしまいました。

設定画面自体は表示されるのですが、そこにあるどの設定タブをクリックしてもなんの応答もないので、それ以上どうにもできません。

一方、これはあくまでCocoonの設定ページだけに起きているエラーのようで、今のところサイト自体の表示などには異常は見受けられません。

このような事情のため、詳細な環境情報を貼り付けることもできないのですが、これについてはWordPress側からも次のようなメールが来たので、参考のためそのまま引用します。

どうぞよろしくお願いします。

こんにちは。

WordPress 5.2から、サイトでプラグインやテーマが致命的なエラーを発生させた場合にそれを検知してこの自動メールでお知らせする機能が追加されました。

今回の場合、WordPress がテーマ Cocoon でエラーを捉えました。

この問題を解決しようとする際、以下の情報を聞かれるかもしれません。
WordPress バーション5.8.2
現在のテーマ: Cocoon Child (バージョン 1.1.2)
現在のプラグイン:  (バージョン )
PHP バージョン8.0.12

エラー詳細
===============

エラーメッセージ: Uncaught ValueError: DOMDocument::loadHTML(): Argument #1 ($source) must not be empty in /public_html/wp-content/themes/cocoon-master/lib/open-graph.php:120

Stack trace:
#0 //public_html/wp-content/themes/cocoon-master/lib/open-graph.php(120): 
DOMDocument->loadHTML('')

#1 /public_html/wp-content/themes/cocoon-master/lib/open-graph.php(95): OpenGraphGetter::_parse(false, 'https://wp-simp...')

#2 /public_html/wp-content/themes/cocoon-master/lib/blogcard-out.php(175): OpenGraphGetter::fetch('https://wp-simp...')

#3 /public_html/wp-content/themes/cocoon-master/lib/page-settings/blogcard-out-forms.php(32): url_to_external_ogp_blogcard_tag('https://wp-simp...')

#4 /public_html/wp-content/themes/cocoon-master/lib/page-settings/_top-page.php(294): require_once

#5 /public_html/wp-content/themes/cocoon-master/lib/original-menu.php(62): require_once

#6 /public_html/wp-includes/class-wp-hook.php(303): add_theme_settings_page('')

#7 /public_html/wp-includes/class-wp-hook.php(327): WP_Hook->apply_filters('', Array)

#8 /public_html/wp-includes/plugin.php(470): WP_Hook->do_action(Array)

#9 /public_html/wp-admin/admin.php(259): do_action('toplevel_page_t...')

#10 {main}
  thrown

   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 3年前
投稿: 6887
 

simpfanさん

スマホからですので、簡単に。

ちなみにですが、PHP 7.4系にすると、状況は変わりますでしょうか。


   
わいひら reacted
(@simpfan)
New Member Registered
結合: 2年前
投稿: 3
Topic starter  

mk2さん、ありがとうございます。

PHP 7.4系にすると、状況は変わりますでしょうか。

今さっそく試してみたところ、おっしゃるとおりPHP7.4系にダウングレードすればエラーは出なくなる(正常に設定を変更できる)ようです。

とりあえずのご報告ですが、よろしくお願いします。

 


   
わいひら
(@yhira)
Illustrious Member Admin
結合: 6年前
投稿: 16441
 

僕のPHP8環境ではエラーは起きなかったのですが、以下のファイルでアップデートしてPHP8環境でテストすると動作しますでしょうか。

------------------------------------------------
https://github.com/yhira/cocoon
開発中の最新ファイルをダウンロードする場合は、上記ページのダウンロードボタンからzipファイルをダウンロードしてください。

WordPressでの手動アップデート方法はこちら
https://wp-cocoon.com/manual-update-of-cocoon-theme/
------------------------------------------------


   
simpfan reacted
(@simpfan)
New Member Registered
結合: 2年前
投稿: 3
Topic starter  

わいひらさん、ありがとうございます。

さっそくインストールしてみたところ、少なくとも僕の確認した範囲では、完全に解決したようです。

迅速なご対応、ありがとうございました!


   
わいひら
(@yhira)
Illustrious Member Admin
結合: 6年前
投稿: 16441
 

ご確認いただきありがとうございます!


   
共有:

問題の解決に至った場合には、トピック冒頭の「解決済み」をクリックしていただけますと幸いです。

また、有用な回答があった場合は返信右下にある「いいね!」もご活用ください。回答者の励みになります。

「いいね!」機能はフォーラム登録者のみが利用できる機能です。

CC BY-ND 2.1)準じていれば(リンクを貼っていただければ)転載も自由です。カスタマイズ記事を書く際にコード等をコピペ利用していただいて構いません。

フォーラムの使い方がよくわからない場合は、テストトピックで自由にテストしていただいて構いません。

最近の書き込みはこちら。

詳細なカスタマイズ依頼をするならこちら。

タイトルとURLをコピーしました