「メイド・イン・ヘブン」スキン適用中

Cocoonフォーラム

サイト内検索
書き込みの前に以下の3点をご確認ください。
  1. 1つのトピックにつき1つの質問を書き込んでください
  2. 不具合・カスタマイズ対象ページのURLを提示高速化を無効にしてください
  3. 該当部分のキャプチャ・環境情報とともに書き込んでいただけると助かります

何を書き込んだら良いか分からない場合は、以下のテンプレートをコピペしてご利用ください。

不具合・カスタマイズ対象ページのURL:

相談内容:

不具合の発生手順:

解決のために試したこと:

※文字だけでは正しく伝わらない可能性があるため、スクショ画像の添付もお願いします。
※高速化設定をしている場合は無効にしてください。
環境情報:

※↑こちらに「Cocoon設定 → テーマ情報」にある「環境情報」を貼り付けてください。

環境情報の取得方法はこちら。
https://wp-cocoon.com/theme-report/
高速化設定を無効にするにはこちら。
https://wp-cocoon.com/theme-trouble/

フォーラム利用ガイドリンク

  1. フォーラムガイドライン
  2. よくある質問と答え(FAQ)
  3. サポート対象外のケース
  4. 原因不明の不具合用トラブルシューティング
  5. トピックにHTMLを貼り付ける方法(推奨ツール:notepad.pw
  6. 真っ白画面でのエラーメッセージの確認方法
  7. ブラウザ環境チェックツール
  8. Cocoonカスタマイズ依頼

フォーラム質問後、問題等が解決した場合は結果を書き込んでいただけると幸いです。同様の問題で調べている方には、結果が一番気になる部分となります。

FAQブロックのトグル(アコーディオン...
 
共有:
通知
すべてクリア

[解決済] FAQブロックのトグル(アコーディオン)機能について

6 投稿
4 ユーザー
3 Reactions
112 表示
 zuss
(@zuss)
Eminent Member Registered
結合: 1年前
投稿: 20
Topic starter  

相談内容:

FAQブロックのトグル(アコーディオン)機能は廃止されてしまいましたか?

過去に同機能を使った記事ではそのまま使えており、そのブロックをコピーすれば使えるのですが、新規にFAQブロックを作っても右のブロックメニューにスタイルの選択肢が表示されません。

自分にだけ発生している不具合などであれば後ほど環境情報を記載します。よろしくお願いします。


   
引用
わいひら
(@yhira)
Illustrious Memberサイト Admin
結合: 6年前
投稿: 16743
 

廃止はしていません。僕の環境では表示されています。


   
返信引用
 zuss
(@zuss)
Eminent Member Registered
結合: 1年前
投稿: 20
Topic starter  

@yhira

なんと・・・それでは解決に向けてご助力いただけると幸いです。

 

自分で思いつく事として、以下のプラグインを一時停止してみましたが解決できませんでした。

・Limit Login Attempts Reloaded
・LiteSpeed Cache
・TablePress
・XO Security

そのほかのプラグインについては停止させるのが怖くて試せていません。

 

また、テーマファイルエディターの「style.css」と「functions.php」で自分が書き加えているものを一時的に削除してみましたが、解決できませんでした。

そのほか、LitesSpeed Cacheのパージ、Cocoon設定の全てのキャッシュの削除も試してみましたが進展はありませんでした。

 

このほかに何か試した方が良い事や原因に心当たりがあれば教えて下さい。よろしくお願いします。

 

----------------------------------------------
サイト名:ツースのゲーム攻略簿
サイトURL: https://zussgame.com
ホームURL: https://zussgame.com
コンテンツURL:/wp-content
インクルードURL:/wp-includes/
テンプレートURL:/wp-content/themes/cocoon-master
スタイルシートURL:/wp-content/themes/cocoon-child-master
親テーマスタイル:/wp-content/themes/cocoon-master/style.css
子テーマスタイル:/wp-content/themes/cocoon-child-master/style.css
WordPressバージョン:6.5.4
PHPバージョン:8.1.28
ブラウザ:Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/125.0.0.0 Safari/537.36
サーバーソフト:LiteSpeed
サーバープロトコル:HTTP/1.1
エンコーディング:gzip, deflate, br, zstd
言語:ja,en-US;q=0.9,en;q=0.8
----------------------------------------------
テーマ名:Cocoon
バージョン:2.7.4.3
カテゴリー数:7
タグ数:0
ユーザー数:1
----------------------------------------------
子テーマ名:Cocoon Child
バージョン:1.1.3
style.cssサイズ:984 バイト
functions.phpサイズ:1489 バイト
----------------------------------------------
Gutenberg:1
Font Awesome:4
Auto Post Thumbnail:0
Retina:1
ホームイメージ:/wp-content/uploads/2022/01/1-e1641091551949.png
----------------------------------------------
ブラウザキャッシュ有効化:0
HTML縮小化:0
CSS縮小化:0
JavaScript縮小化:0
Lazy Load:0
----------------------------------------------
利用中のプラグイン:
Limit Login Attempts Reloaded 2.26.9
LiteSpeed Cache 6.2.0.1
Really Simple SSL 8.1.4
TablePress 2.3.2
XML Sitemap & Google News 5.4.9
XO Security 3.10.3
----------------------------------------------

一応、過去にFAQブロックを使用していた記事のURLも貼っておきます。

https://zussgame.com/minecraft-sky-experience-trap/#toc21

 

This post was modified 4週間前 3回 by zuss

   
返信引用
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 3年前
投稿: 7301
 

zussさん

私の環境も、問題なく表示されていました。

とりあえず、この事象だからという訳ではなく、トラブルシューティングの基本として、以下のようなことを試してみると良いと思います。

 

親テーマを手動アップデート

Cocoonテーマファイルを手動でアップデートする方法
https://wp-cocoon.com/manual-update-of-cocoon-theme/

更新前後に、同じバージョンが表示されても、進めてください。

 

全プラグイン無効化&親テーマ有効化

以下のプラグインを使えば、閲覧者に影響はないです。
(ログインユーザーのみが、全プラグイン無効化&親テーマ有効化される)

WordPressのトラブルシューティングを劇的に楽にする「Health Check & Troubleshooting」プラグインの使い方。
https://nelog.jp/health-check-and-troubleshooting-plugin

 

トラブルシューティングモードで、確認を行ってください。

トラブルシューティングモードにしただけで、全プラグイン無効化されると思います。
親テーマの有効化は、ご自分で操作する必要があります。

 

上記①②を順番に試しても、解消しない場合

編集画面で、当該ブロック追加時に、エラーが出ていないか、デベロッパーツールで確認。

デベロッパーツールを起動して、Consoleにエラーがないかを確認します。

デベロッパーツールは、Chromeであれば、PF12などで起動できます
(右クリック-「検証」、または、Chromeのメニューの「その他ツール」-「デベロッパーツール」でも起動できます)


   
わいひら reacted
返信引用
 zuss
(@zuss)
Eminent Member Registered
結合: 1年前
投稿: 20
Topic starter  

@mk2_mk2 

トラブルシューティングの方法を教えていただきありがとうございます。

無事に原因を突き止め、問題を解決することができました。

 

以下、経緯のまとめです。

ーーーーーーーーーーーー

②全プラグイン無効化&親テーマ有効化

1.「Health Check…有効化」→「親テーマ有効化」をしてみたところ、FAQブロックのスタイルが正常に表示されました。

2.「プラグインを1つずつ有効化」をしてみましたが、ここも問題なくFAQブロックのスタイルが正常に表示されました。

3.「子テーマ有効化」をしてみると問題が発生し、FAQブロックのスタイルが表示されなくなりました。

 

ということで、子テーマに原因があると見て「テーマ設定のバックアップ」→「テーマ設定のリセット」をしてみたところ、FAQブロックのスタイルが正常に表示されました。

そして「テーマ設定の復元」をしたところ、やはり正常に表示されなくなりました。
(なぜかサイトキーカラーの設定が元に戻らなくて焦りました)

 

Cocoon設定のどこかがおかしいと考えて見て回った結果、「エディター」→「スタイル表示」のチェックがなぜか外れていました。

チェックを付けたところ、正常に表示されるようになりました。

ーーーーーーーーーーーー

 

この度は問題の解決に尽力して下さりありがとうございました。


   
わいひら reacted
返信引用
chu-ya
(@chu-ya)
Famed Member Registered
結合: 2年前
投稿: 2474
 

投稿者:: @zuss

「テーマ設定のリセット」をしてみたところ、FAQブロックのスタイルが正常に表示されました。

そして「テーマ設定の復元」をしたところ、やはり正常に表示されなくなりました。

設定情報は、DBに情報が保存されます。
リセット時は問題なく、復元し問題発生となると、値が壊れているのか?と思います。
リッセットすると、Cocoon設定が初期化されるので、人手で再度設定すれば問題なく。

投稿者:: @zuss

「エディター」→「スタイル表示」のチェックがなぜか外れていました。

チェックを外すと、CSSが反映されないだけで、設定のスタイル自体は消えません。(図参照)


   
わいひら reacted
返信引用
共有:

問題の解決に至った場合には、トピック冒頭の「解決済み」をクリックしていただけますと幸いです。

また、有用な回答があった場合は返信右下にある「いいね!」もご活用ください。回答者の励みになります。

「いいね!」機能はフォーラム登録者のみが利用できる機能です。

CC BY-ND 2.1)準じていれば(リンクを貼っていただければ)転載も自由です。カスタマイズ記事を書く際にコード等をコピペ利用していただいて構いません。

フォーラムの使い方がよくわからない場合は、テストトピックで自由にテストしていただいて構いません。

最近の書き込みはこちら。

詳細なカスタマイズ依頼をするならこちら。

タイトルとURLをコピーしました