Cocoonフォーラム

書き込みの前に以下の3点をご確認ください。
  1. 1つのトピックにつき1つの質問を書き込んでください
  2. 不具合・カスタマイズ対象ページのURLを提示高速化を無効にしてください
  3. 該当部分のキャプチャ・環境情報とともに書き込んでいただけると助かります

何を書き込んだら良いか分からない場合は、以下のテンプレートをコピペしてご利用ください。

不具合・カスタマイズ対象ページのURL:

相談内容:

不具合の発生手順:

解決のために試したこと:

※文字だけでは正しく伝わらない可能性があるため、スクショ画像の添付もお願いします。
※高速化設定をしている場合は無効にしてください。
環境情報:

※↑こちらに「Cocoon設定 → テーマ情報」にある「環境情報」を貼り付けてください。

環境情報の取得方法はこちら。
https://wp-cocoon.com/theme-report/
高速化設定を無効にするにはこちら。
https://wp-cocoon.com/theme-trouble/

フォーラム利用ガイドリンク

  1. フォーラムガイドライン
  2. よくある質問と答え(FAQ)
  3. サポート対象外のケース
  4. 原因不明の不具合用トラブルシューティング
  5. トピックにHTMLを貼り付ける方法(推奨ツール:notepad.pw
  6. 真っ白画面でのエラーメッセージの確認方法
  7. ブラウザ環境チェックツール
  8. Cocoonカスタマイズ依頼

フォーラム質問後、問題等が解決した場合は結果を書き込んでいただけると幸いです。同様の問題で調べている方には、結果が一番気になる部分となります。

スキンのcss構文がAMPエラー
 
共有:
通知
すべてクリア

[解決済] スキンのcss構文がAMPエラー

16 投稿
3 ユーザー
15 Likes
324 表示
Nonon\'s
 Nonon\'s
(@Nonon\'s)
New Member
結合: 2年前
投稿: 4
Topic starter  

いつもお世話になっております、

Cocoonのスキン Hygieneを適用させていただいてますが、

AMPテストで スキンで設定された

entry-cardのカラーの記述で

background-color;〜

background:〜

の記述で、先に指定したbackground-color;は後にbackground;が書かれていることによって反映されず、

追加css内で指摘されている構文とカラーをカスタムしているのですが

SearchConsole側は元のスキンを読み込んで判定しているので追加cssで治していてもエラーが改善されません。

タグ「style amp-custom」の CSS 構文エラー

元のスキンの記述を改善したい場合はどのようにしたら良いでしょうか?


   
リフィトリー
(@leafytree)
Illustrious Member Moderator
結合: 4年前
投稿: 6845
 

前略、Nonon\'sさん

スキンの不具合だったら、わいひらさんが修正くださるかと思います。

ただ、修正する際に確認をすると思いますので、ご協力いただけるのでしたら、実際にエラーの出ているページのURLをご提示いただければ、おそらく助かるのではないかと推測します。


   
わいひら reacted
Nonon\'s
 Nonon\'s
(@Nonon\'s)
New Member
結合: 2年前
投稿: 4
Topic starter  

リフィトリー様

 

早速のお返事ありがとうございます。

リンクがこちらになります

https://jhbrablog.com/

こちらのエントリーカードに関する記述が構文エラーに引っかかってしまうようで、

次々と投稿ブログがAMPエラー判定とされてしまいます。

エラー箇所とされている部分が前述のbackgroundに関する部分となるのですが

恐らくそれがエラー原因かな?と考えております。

お手数をおかけしますが宜しくお願い致します(*^^*)

 


   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4675
 

Nonon\'sさん

すみません、今もAMPは有効でしょうか。

AMPページのHTMLソースではないようですが。


   
わいひら reacted
リフィトリー
(@leafytree)
Illustrious Member Moderator
結合: 4年前
投稿: 6845
 

Nonon\'s さん

なんか変ですね・・

例えば、以下のページだと、

 

 https://jhbrablog.com/peypey-ペイペイ決済トラブル【支払い受付の取消】で/?amp=1 
This post was modified 2年前 2回 by リフィトリー

   
わいひら reacted
リフィトリー
(@leafytree)
Illustrious Member Moderator
結合: 4年前
投稿: 6845
 

Nonon\'s さん

AMPプラグインか何かお使いでしょうか?

一応、環境情報を貼り付けていただいた方が良いかもしれません。

 

環境情報の取得方法はこちら。
https://wp-cocoon.com/theme-report/


   
わいひら reacted
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4675
 

Nonon\'sさん

トップページの通常ページ(非AMPページ)のエントリーカードのbackgroundは、スキンは負けてしまって、適用されていません。

子テーマでカスタマイズされたものが適用されています。


   
わいひら reacted
リフィトリー
(@leafytree)
Illustrious Member Moderator
結合: 4年前
投稿: 6845
 

Nonon\'s さん

そもそも、CocoonのAMP機能では、投稿ページと固定ページだけAMPページを生成し、他のページは、確かAMPページは生成しなかったような気がします。

 

なので、エントリーカードは、関係ないような気がします。

This post was modified 2年前 by リフィトリー

   
わいひら reacted
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4675
 

ちなみに、これってOKなんでしたっけ?
あまり詳しくないのですが。

 background: #c0c5c2 linear-gradient(225deg, #e9e4d4 10px, #a3a3a2);

 

すみません、何となくですが、大丈夫そうですね。

やはり、トップページがAMP化されていないように見えますので、はてなマークです。

あまりたくさん書いても。。。と思いますので、私は離脱します。


   
わいひら reacted
リフィトリー
(@leafytree)
Illustrious Member Moderator
結合: 4年前
投稿: 6845
 

Nonon\'s さん

CocoonのAMPページに関するマニュアルページは以下になります。

 

テーマをAMP対応する方法

https://wp-cocoon.com/amp/


   
わいひら reacted
リフィトリー
(@leafytree)
Illustrious Member Moderator
結合: 4年前
投稿: 6845
 

そもそも、トップページはAMPページは生成されない仕様のはずなのですが・・


   
リフィトリー
(@leafytree)
Illustrious Member Moderator
結合: 4年前
投稿: 6845
 

Nonon\'s さん

別の記事のAMPページを検証してみましたが、エラーは表示されませんでした。

どこに、どようにエラーが表示されたのか、お差支えのない範囲で、キャプチャ画像を貼り付けていただければと思います。

 

This post was modified 2年前 by リフィトリー

   
わいひら reacted
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4675
 

リフィトリーさん

少しだけ戻ってきました。

ローカル環境で試しました。

「AMP機能を有効化する」をONにしても、トップページはAMPページ化されていないことを確認しました。

自分のミスではないかと、投稿ページを確認しましたが、こちらはAMP化されていました。

 

リフィトリーさんの仰る通りかと思います。


   
わいひら reacted
Nonon\'s
 Nonon\'s
(@Nonon\'s)
New Member
結合: 2年前
投稿: 4
Topic starter  

お返事ありがとうございます、

Cocoon設定側ではAMPチェックは入っていましたが

AMPのプラグインは入れてませんでした

AMPテストをしたのが投稿リンクではなくサイトトップページのリンクを貼っていたので

そのせいですね( ˊᵕˋ ;)?凄く単純なことでずっと悩んでましたw 色々ご指導いただきありがとうございました(*^^*)


   
リフィトリー
(@leafytree)
Illustrious Member Moderator
結合: 4年前
投稿: 6845
 

Nonon\'s

別件ですが、サイトのSSL化が完了していないようです。

ロゴ画像辺りの画像のURLが、httpのアドレスのままになっているんじゃないかと思います。

This post was modified 2年前 by リフィトリー

   
わいひら reacted
Nonon\'s
 Nonon\'s
(@Nonon\'s)
New Member
結合: 2年前
投稿: 4
Topic starter  

アドバイスありがとうございます

サイトロゴ早速修正致しました(*^^*)

初心者なので色々と至らない点がありご指摘ほんとに勉強になります、色々と教えて下さり感謝致します。


   
共有:

問題の解決に至った場合には、トピック冒頭の「解決済み」をクリックしていただけますと幸いです。

また、有用な回答があった場合は返信右下にある「いいね!」もご活用ください。回答者の励みになります。

「いいね!」機能はフォーラム登録者のみが利用できる機能です。

CC BY-ND 2.1)準じていれば(リンクを貼っていただければ)転載も自由です。カスタマイズ記事を書く際にコード等をコピペ利用していただいて構いません。

フォーラムの使い方がよくわからない場合は、テストトピックで自由にテストしていただいて構いません。

最近の書き込みはこちら。

詳細なカスタマイズ依頼をするならこちら。

タイトルとURLをコピーしました