「メイド・イン・ヘブン」スキン適用中

Cocoonフォーラム

サイト内検索
書き込みの前に以下の3点をご確認ください。
  1. 1つのトピックにつき1つの質問を書き込んでください
  2. 不具合・カスタマイズ対象ページのURLを提示高速化を無効にしてください
  3. 該当部分のキャプチャ・環境情報とともに書き込んでいただけると助かります

何を書き込んだら良いか分からない場合は、以下のテンプレートをコピペしてご利用ください。

不具合・カスタマイズ対象ページのURL:

相談内容:

不具合の発生手順:

解決のために試したこと:

※文字だけでは正しく伝わらない可能性があるため、スクショ画像の添付もお願いします。
※高速化設定をしている場合は無効にしてください。
環境情報:

※↑こちらに「Cocoon設定 → テーマ情報」にある「環境情報」を貼り付けてください。

環境情報の取得方法はこちら。
https://wp-cocoon.com/theme-report/
高速化設定を無効にするにはこちら。
https://wp-cocoon.com/theme-trouble/

フォーラム利用ガイドリンク

  1. フォーラムガイドライン
  2. よくある質問と答え(FAQ)
  3. サポート対象外のケース
  4. 原因不明の不具合用トラブルシューティング
  5. トピックにHTMLを貼り付ける方法(推奨ツール:notepad.pw
  6. 真っ白画面でのエラーメッセージの確認方法
  7. ブラウザ環境チェックツール
  8. Cocoonカスタマイズ依頼

フォーラム質問後、問題等が解決した場合は結果を書き込んでいただけると幸いです。同様の問題で調べている方には、結果が一番気になる部分となります。

「ブロック追加ボタンが反応しない」の件
 
共有:
通知
すべてクリア

[解決済] 「ブロック追加ボタンが反応しない」の件

5 投稿
3 ユーザー
8 Likes
895 表示
はる
(@haruinoue)
Noble Member Moderator
結合: 4年前
投稿: 1066
Topic starter  

コメント欄で報告されて雑談スレッドでも話題になっていた以下の件についてです。

先ほどバージョン: 2.6.3.1に更新したのですが、1つバグを見つけたのでご報告します。

ブロックの追加ボタンが右端しか反応しない場合があります。
画面を録画しましたので、見ていただけたらわかると思います。
ご確認よろしくお願いします。

https://www.youtube.com/watch?v=Urx63PS4Yfo

普通に記事を書いていたら同様の症状になりました。

開発者ツールで原因を調べてみたところ、添付画像の通り<deepl-input-controller>という要素がクリック領域に被っていました。

以下のChrome拡張を使用していたため、拡張機能を削除すると問題は発生しなくなりました。
DeepL翻訳:読みながら、書きながら使える翻訳ツール

いつからこの症状が起こっていたかは分かりませんが、最新バージョン1.6.0が更新されたのが7月25日のようです。
Cocoonの更新時期と被っているので、Cocoonの更新によるものでなくDeepL翻訳が更新されたことで起こっているものかも知れません。


コメントの方も同じ原因かは分かりませんが、DeepL翻訳を使用しているようであれば停止してみると良いかも知れません。


   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 3年前
投稿: 6895
 

はるさんの仰る方法で、再現しました。

Chromeの拡張機能「DeepL翻訳」をインストールしました。

 
初期状態では、こんな感じで、拡張機能のボタンが、ブロック追加の「+」ボタンと被ります。
 
この拡張機能のボタンは、設定で「非表示」にできます。
 
しかし、「非表示」にしたからと言って、ボタンの要素がなくなる訳ではなく、ただ「非表示」になっているだけで、要素は残るようです。
(翻訳機能は無効になるのだと思いますけれど)
この被り方が、絶妙に「+」ボタンに掛かり、右端や上側がわずかに出るくらいですね。
(上画像の通り)
 
その結果、この事象が再現しました。

   
はる and わいひら reacted
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 3年前
投稿: 6895
 

ちなみに、この現象が起きるのは、Cocoonのみではありません。

WordPress公式テーマ「Twenty-Twenty-One」で確認しました。
同様に、拡張機能のボタンが絶妙に掛かります。

 
同様に、機能をオフにしても、要素は残ります。
 
 
その結果、同様の事象が発生します。
 
 
これらのことから、Cocoonの不具合ではなく、拡張機能の影響と言えると思います。
(「DeepL翻訳」をインストールしていれば・・・ですが)

   
わいひら reacted
わいひら
(@yhira)
Illustrious Member Admin
結合: 6年前
投稿: 16458
 

はるさん、ありがとうございます!
なるほど、通りで再現されないはずです。
僕の環境でも不具合を再現できました。

どうしても拡張を使いたい場合は、子テーマのstyle.cssに以下のように書くと完全に非表示になって不具合は起きなくなりますね。

deepl-input-controller {
  display: none;
}

   
はる reacted
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 3年前
投稿: 6895
 

ご本人からDeepL翻訳の拡張機能を使用とのコメントをいただきましたので、はるさんの想定通りだったようです。
https://wp-cocoon.com/2-6-3/#comment-17928

このトピックは「解決済」&「クローズ」にしちゃいますね。


   
わいひら and はる reacted
共有:

問題の解決に至った場合には、トピック冒頭の「解決済み」をクリックしていただけますと幸いです。

また、有用な回答があった場合は返信右下にある「いいね!」もご活用ください。回答者の励みになります。

「いいね!」機能はフォーラム登録者のみが利用できる機能です。

CC BY-ND 2.1)準じていれば(リンクを貼っていただければ)転載も自由です。カスタマイズ記事を書く際にコード等をコピペ利用していただいて構いません。

フォーラムの使い方がよくわからない場合は、テストトピックで自由にテストしていただいて構いません。

最近の書き込みはこちら。

詳細なカスタマイズ依頼をするならこちら。

タイトルとURLをコピーしました