Cocoonフォーラム

書き込みの前に以下の3点をご確認ください。
  1. 1つのトピックにつき1つの質問を書き込んでください
  2. 不具合・カスタマイズ対象ページのURLを提示高速化を無効にしてください
  3. 該当部分のキャプチャ・環境情報とともに書き込んでいただけると助かります

何を書き込んだら良いか分からない場合は、以下のテンプレートをコピペしてご利用ください。

不具合・カスタマイズ対象ページのURL:

相談内容:

不具合の発生手順:

解決のために試したこと:

※文字だけでは正しく伝わらない可能性があるため、スクショ画像の添付もお願いします。
※高速化設定をしている場合は無効にしてください。
環境情報:

※↑こちらに「Cocoon設定 → テーマ情報」にある「環境情報」を貼り付けてください。

環境情報の取得方法はこちら。
https://wp-cocoon.com/theme-report/
高速化設定を無効にするにはこちら。
https://wp-cocoon.com/theme-trouble/

フォーラム利用ガイドリンク

  1. フォーラムガイドライン
  2. よくある質問と答え(FAQ)
  3. サポート対象外のケース
  4. 原因不明の不具合用トラブルシューティング
  5. トピックにHTMLを貼り付ける方法(推奨ツール:notepad.pw
  6. 真っ白画面でのエラーメッセージの確認方法
  7. ブラウザ環境チェックツール
  8. Cocoonカスタマイズ依頼

フォーラム質問後、問題等が解決した場合は結果を書き込んでいただけると幸いです。同様の問題で調べている方には、結果が一番気になる部分となります。

フォーラムに関する案内
 
共有:
通知
すべてクリア

[固定] フォーラムに関する案内

221 投稿
6 ユーザー
77 Likes
4,280 表示
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 14137
Topic starter  

試しに、テスト投稿を削除してみたのですが大丈夫でした。
どうやら、直近の投稿のユーザーごと削除してしまうのがだめみたい…。
とりあえず今度からは、スパムユーザーは削除しないでブロックで対応しようと思います。


   
返信引用
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4416
 
投稿者:: @yhira

しかも、一旦フォーラムトップから非表示にされてしまったトピックは、タイトルをクリックしてもだめで「最初の投稿と返信」を開いてからクリックしないと、トピックも開かないっぽい…。

ええっ。
それはかなりの不具合ですね。

投稿者:: @yhira

フォーラムのダッシュボードからCacheも削除してみたんですがだめでした…。

無念です。

投稿者:: @yhira

直近の投稿のユーザーごと削除してしまうのがだめみたい…。

そうなんですね。
正直、スパムのユーザーは削除してしまいたいですよね。
どんどん増えちゃいますし。

しかし、最近のスパムは、過去の返信の一文をコピーするものが多いです。
何の意味があるのだろうと思ってしまいます。

宣伝効果もないでしょうし、迷惑行為なだけですよね。


   
返信引用
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 14137
Topic starter  

とりあえず、「テスト書き込み」→「テスト書き込み削除」でフォーラムトップの表示を復活させました。
これからは、不具合のでなさそうなユーザーブロックで対応してみようと思います。

投稿者:: @mk2_mk2

正直、スパムのユーザーは削除してしまいたいですよね。
どんどん増えちゃいますし。

そうなんですよ…。
毎回書き込まれると対応しきれなくなると思うので、削除していたのですが…。
以前はそれでも問題なかったんですけどね 🤣 

投稿者:: @mk2_mk2

しかし、最近のスパムは、過去の返信の一文をコピーするものが多いです。
何の意味があるのだろうと思ってしまいます。

マジでこれ意味不明です…。
URLがあるわけでもないし。

This post was modified 2か月前 by わいひら

   
返信引用
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4416
 
投稿者:: @yhira

とりあえず、「テスト書き込み」→「テスト書き込み削除」でフォーラムトップの表示を復活させました。

表示が戻りましたね。
良かったです。

それにしても、なかなか面倒ですね。
こういうところで作業が増えるのは、大変です。

お疲れ様です。


   
わいひら reacted
返信引用
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 14137
Topic starter  

とりあえず原因が分かって、復元方法もあってよかったです 😯 
いろいろ試してみていただいたり、ご協力いただきありがとうございます!
今日はトピックを立てた人がスパム者だったので、トピックをフォーラムトップに表示させる必要ないのでユーザー削除で対応しました。
既存のトピックに返信でスパムを書き込まれた場合は、返信の削除+ユーザーブロックで対応するよう気をつけたいです。

This post was modified 2か月前 by わいひら

   
mk2 reacted
返信引用
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4416
 
投稿者:: @yhira

今日はトピックを立てた人がスパム者だったので、トピックをフォーラムトップに表示させる必要ないのでユーザー削除で対応しました。

そうですね。
こういう輩は、削除してしまいましよう。

投稿者:: @yhira

既存のトピックに返信でスパムを書き込まれた場合は、返信の削除+ユーザーブロックで対応するよう気をつけたいです。

解決方法があって良かったです。
(本当は削除してしまいたいですけれど)

 

今は、ユーザー登録しないと書き込めないのに、それをしてまでスパムを書き込むというのも、なかなか凄いです。
その割には、まったく効果がない気がするんですけどねぇ。

こういう輩には言っても始まりませんけれど。
今後何か良い仕組みが、プラグインに導入されることを祈ります。


   
返信引用
Surlofia
(@surlofia)
Estimable Member Registered
結合: 3年前
投稿: 124
 

@mk2_mk2

サポート窓口に書き込めば?

https://wordpress.org/support/plugin/wpforo/

 


   
返信引用
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4416
 

Surlofiaさん

botでなく、手で書き込んでいるとしたら、有効な手がないというのが、現実なのかも・・・とは思います。

最近このフォーラムに書き込まれるスパムは、特にURLも含まれておらず、内容的には一見してスパムと分かりにくいものになっています。

要望するにしても、具体的な案がないと難しくないですかね。
(あくまでもそうなると良いなぁ・・・くらいの気持ちで書いたのですが)


   
返信引用
Surlofia
(@surlofia)
Estimable Member Registered
結合: 3年前
投稿: 124
 

@mk2_mk2 様

@yhira

以下の内容で、サポート掲示板に書き込んでも問題ないか、ご判断と許可をお願い致します。

 

投稿削除(もしくは承認投稿のユーザー削除)をするとトピックがフォーラムトップから非表示になってしまう。

管理者権限で、非表示になったトピックに書き込むと復活するみたいです。

フォーラムのダッシュボードからCacheも削除してみたんですがだめでした…。

どうやら、直近の投稿のユーザーごと削除してしまうのがだめみたい…。

スパムユーザーは削除しないでブロックで対応しようと思います。

 

Deleting a post (or deleting a user of an approved post) hides the topic from the top of the forum.

It seems to be restored when I write to the hidden topic with administrator privileges.

I also tried deleting Cache from the forum dashboard, but no luck...

Apparently, it is not possible to delete the most recent post by the user....

I will try to block spam users without deleting them.

 

書き込む場所

https://wordpress.org/support/plugin/wpforo/

Support » Plugin: wpForo Forum

 


   
返信引用
Surlofia
(@surlofia)
Estimable Member Registered
結合: 3年前
投稿: 124
 

@mk2_mk2

@yhira 様

 

Cocoon フォーラムのおふたりは、いろいろと試されたから聞いても良いと思います。

 

Getting lots of spam

https://wordpress.org/support/topic/getting-lots-of-spam/

という質問にも

https://wpforo.com/docs/wpforo-v2/settings/spam-protection/

をご覧ください。と回答されています。

 

2022年9月27日 20:32 の私の書き込みは、おふたりの検証結果のコピペですが、具体的に変えて欲しいことを書いてあるので、プラグイン作成者にとっては、レベルの高い質問と評価されそうです。

 

質問するのが嫌なら別ですが、遠慮は不要だと考えます。

プラグイン作成者が対応したくない場合、返事が無いだけです。

さみしくなりますけれど・・・

 

おふたりの技術力なら、胸を張って質問しても良い!

と考えます。

 

 


   
返信引用
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4416
 

Surlofiaさん

スマホからなもので、簡単に。

不具合報告ということですね。
勘違いしていました。


   
返信引用
Surlofia
(@surlofia)
Estimable Member Registered
結合: 3年前
投稿: 124
 

@mk2_mk2

そうです。

プラグインの作者に伝えれば、何か手を打ってくれそうです。

お二人の許可を得てから作者に質問したいです。

 


   
返信引用
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 14137
Topic starter  
投稿者:: @surlofia

以下の内容で、サポート掲示板に書き込んでも問題ないか、ご判断と許可をお願い致します。

書き込んでいただけるのであれば、僕としてはありがたいです。
ただ、今日試してみたところ、「スパム投稿を削除」→「ユーザーをブロック」でも同様の現象になってしまいました…。

一度こちらのトピックに「テスト」とでも書き込んでいただいてよろしいでしょうか。
https://wp-cocoon.com/community/postid/64656/
僕がその「テスト」投稿を削除してみて、投稿削除だけで不具合が再現されるか試してみたいです(「テスト」投稿を削除するだけです)。
※僕が自分で投稿して、その投稿を削除しても不具合が起きなくて…。

This post was modified 2か月前 2回 by わいひら

   
返信引用
Surlofia
(@surlofia)
Estimable Member Registered
結合: 3年前
投稿: 124
 

@yhira

ご指定のリンクにテスト書き込みしました。

プラグイン作成者への問い合わせ書き込みは、わいひらさんが書きたい内容の最新版をいただければ、わたしが英文に挑戦します。

では、次は22時30分頃に見に来ます。

 


   
返信引用
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 14137
Topic starter  

Surlofiaさんのテスト書き込みを削除してみました。
削除前がこの状態。


   
返信引用
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 14137
Topic starter  

削除後はこの状態で、Surlofiaさんの書き込み削除に関しては全く問題ありませんでした。
次にスパムの書き込みがあったら、いろいろ動作を確認しながら削除してみたいと思います。


   
返信引用
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 14137
Topic starter  
投稿者:: @surlofia

プラグイン作成者への問い合わせ書き込みは、わいひらさんが書きたい内容の最新版をいただければ、わたしが英文に挑戦します。

今回の確認では、詳しい不具合の発生条件はわかりませんでした。
なのでとりあえず、こちらの書き込みの不具合は確かなので、こちらの問い合わせ内容で書き込んでも問題ないように思います。
https://wp-cocoon.com/community/postid/64702/


   
返信引用
Surlofia
(@surlofia)
Estimable Member Registered
結合: 3年前
投稿: 124
 

@yhira

書き込みました。

Deleting a post hides the topic from the forum.

https://wordpress.org/support/topic/deleting-a-post-hides-the-topic-from-the-forum/

日本語訳

投稿削除(もしくは承認投稿のユーザー削除)をするとトピックがフォーラムトップから非表示になってしまう。

管理者権限で、非表示になったトピックに書き込むと復活するみたいです。

フォーラムのダッシュボードからCacheも削除してみたんですがだめでした…。

どうやら、直近の投稿のユーザーごと削除してしまうのがだめみたい…。

スパムユーザーは削除しないでブロックで対応しようと思います。

ただ、今日試してみたところ、「スパム投稿を削除」→「ユーザーをブロック」でも同様の現象になってしまいました…。

助けて欲しいページは、 https://wp-cocoon.com/community/chat/

 

ダメでもともと、なにか回答が来たらラッキーです。

 


   
わいひら reacted
返信引用
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4416
 

Surlofiaさん

お手数、お掛けします。

とりあえず、返信があるのを待ちましょう。
WordPress.orgのフォーラムも、wpForoのフォーラムも、どちらも機能しているように見えますから、おそらく何らかの返信はある気がします。

不具合がはっきりして、修正されることを期待したいです。


   
Surlofia reacted
返信引用
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 14137
Topic starter  

本日、スパムの書き込みがあったので投稿削除してみると、不具合が再現されました(ユーザー削除なし・ブロックなし)。

  • Surlofiaさんの投稿を削除→不具合発生せず
  • スパム投稿を削除→不具合発生

この二つの違いは、管理者やモデレーターによって「承認を解除」されているかどうかだと思います(削除対象の投稿が「承認待ち」状態かどうか)。

なので、不具合の発生条件は以下なのではないかと推測されます。

「承認を解除」されている(「承認待ち」状態)の投稿を削除するとフォーラムトップから該当トピックが表示されなくなる

もしくは

「承認を解除」されている(「承認待ち」状態)の投稿を保持しているユーザーを削除するとフォーラムトップから該当トピックが表示されなくなる

これだと思います。
前者は、こちらで同様の環境を作成して、動作確認したところ不具合が再現されました。

This post was modified 2か月前 2回 by わいひら

   
返信引用
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 14137
Topic starter  

なので「承認を解除」されて「承認待ち」のスパム投稿があれば、一旦「承認する」を押して書き込まれたスパム投稿をすべて削除し、その後ユーザーを削除するという手順が必要そうです。

前はユーザーを削除するだけでOKでしたが、不具合が出ないようにするには、以下のような手順にする必要があり、工程が増えて結構面倒かも…。

  1. 「承認する」を押す
  2. スパム投稿を削除する
  3. スパムユーザーに「承認待ち」の投稿がないか確認する
  4. ユーザーを削除する

   
返信引用
Surlofia
(@surlofia)
Estimable Member Registered
結合: 3年前
投稿: 124
 

@yhira

プラグイン作者からの回答が来ました。

この問題は、あなたが使用しているキャッシュプラグインに起因しています。このトピックを読み、できるだけ早くキャッシュプラグイン(補足: のキャッシュ対象)からフォーラムを除外するようにしてください。

https://wpforo.com/community/faq/wpforo-and-cache-plugins/

 

先ほどの2つのコメントについては、上記の確認結果とともに、プラグイン作者に送れたら幸いです。

 


   
返信引用
Surlofia
(@surlofia)
Estimable Member Registered
結合: 3年前
投稿: 124
 

@yhira

リンクページの翻訳です。

キャッシュプラグイン(補足: のキャッシュ対象)からwpForoフォーラムページを除外してください。

ほぼすべてのキャッシュプラグインには、キャッシュ処理からページを除外するオプションがあるはずです。キャッシュプラグインからフォーラムのトップページを除外してください。これは非常に重要なことです。

1.
wpForoはキャッシュシステムを内蔵しています。それはあなたのフォーラムのための非常によくキャッシュを行いますので、他のキャッシュプラグインを必要としません。

2.
なぜなら、wpForoはWordPressのCustom Post Typesをベースにしておらず、これらのプラグインは、何をキャッシュすべきか、何をキャッシュすべきでないかを全く理解していないからです。

3.
キャッシュプラグインは、フォーラムページの動的データをすべて削除します。これらのプラグインは、フォーラムページ全体をキャッシュし、常に同じコンテンツを表示します。あなたは、新しいトピックや投稿情報を見ることができなくなります. とフォーラムページ上の他のすべての情報は、ためキャッシュ/静的なフォーラムのページの、更新することはできません. あなたは常に古いと間違った情報が表示されます.

4.

キャッシュプラグインも、ユーザーのログイン/ログアウトの状態を殺す. ログインしてもフォーラムページは更新されず、メニューには[ログアウト]メニューの代わりに[ログイン]ボタンが表示されたままです。認証されたユーザーのためのボタンもすべて消えています。

www.DeepL.com/Translator(無料版)で翻訳しました。

 


   
返信引用
Surlofia
(@surlofia)
Estimable Member Registered
結合: 3年前
投稿: 124
 

@yhira

この調査結果を先方に伝えるために、

キャッシュプラグインを使用していない

とか

キャッシュプラグインを対象外にしても変化が無かった

とか

を書きたいです。

 


   
返信引用
Surlofia
(@surlofia)
Estimable Member Registered
結合: 3年前
投稿: 124
 

@yhira

 

たしか、プラグインの新バージョンから発生した不具合ですよね。

Ver. 2.0.9 から発生したと先方に伝えても良いですか?

それに、わいひらさんの書き込み

2022年9月29日 19:34

2022年9月29日 19:39

を足したいと思います。

 


   
返信引用
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 14137
Topic starter  
投稿者:: @surlofia

この問題は、あなたが使用しているキャッシュプラグインに起因しています。このトピックを読み、できるだけ早くキャッシュプラグイン(補足: のキャッシュ対象)からフォーラムを除外するようにしてください。

使用しているキャッシュプラグインを無効にして、こちらの不具合発生方法で試してみたのですが、やっぱり不具合は再現しました。
https://wp-cocoon.com/community/postid/64745/

キャッシュプラグインはwp fastest cacheを使用していて、wpForo2.0.xアップデート時に出た案内にしたがって除外対応は一度行なっております(添付画像)。
ただ、今回プラグインを無効にしても駄目だったので、この設定は今回関係ないと思います。


   
返信引用
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 14137
Topic starter  
投稿者:: @surlofia

たしか、プラグインの新バージョンから発生した不具合ですよね。

Ver. 2.0.9 から発生したと先方に伝えても良いですか?

wpForoのバージョンは何からだったかは、細かなバージョンに注視していたわけではないので詳しいことはわかりません。
ただ、v2.0.0以降なのは間違いないかと思います。


   
返信引用
Surlofia
(@surlofia)
Estimable Member Registered
結合: 3年前
投稿: 124
 

@yhira

回答ありがとうございます。

先方のサイトに書き込みました。

わいひら様のコメントを、ほぼ全部載せ致しました。

https://wordpress.org/support/topic/deleting-a-post-hides-the-topic-from-the-forum/#post-16055902


   
わいひら reacted
返信引用
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 14137
Topic starter  

お手数をおかけします。ありがとうございます。


   
返信引用
Surlofia
(@surlofia)
Estimable Member Registered
結合: 3年前
投稿: 124
 

@yhira

@mk2_mk2

プラグイン作者より、サポートフォーラムに移動して欲しいと指示されました。

https://wordpress.org/support/topic/deleting-a-post-hides-the-topic-from-the-forum/#post-16062019

という訳で、移動した書き込みへのリンクが下記です。
https://wpforo.com/community/general-forums-bug-reports/deleting-a-post-hides-the-topic-from-the-forum/

わいひら様から頂いたスクリーンショット画像を転用しています。
※ 事後報告で、すみません。
※ 「キャッシュプラグインを除外せよ!」が重要のようで、対応済みの証拠として必要でした。

[Closed] ⚠️ Heads-up: wpForo 2.0 has new cache excludes
https://wpforo.com/community/general-discussions/%e2%9a%a0%ef%b8%8f-heads-up-wpforo-2-0-has-new-cache-excludes/#post-69949

See Robert's updated FAQ thread for full details > wpForo and Cache Plugins
https://wpforo.com/community/faq/wpforo-and-cache-plugins/#post-37150

この画面では表示されていませんが、使用中の WordPress バージョンを入力する欄がありました。

ご使用中のバージョンを教えてください。

よろしくお願いいたします。

追伸

進展がありましたら、また書き込みます。

恐れ入りますが、気長に温かい目でお待ちいただければ幸いです。

サアロフィア

 

This post was modified 2か月前 by Surlofia

   
わいひら reacted
返信引用
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4416
 

Surlofiaさん

お手数お掛けします。

以下にwpForo側のフォーラムは、ログイン画面が表示されてしまい、まだ見れないみたいです。
(承認されないと見れないのかもですね)

投稿者:: @surlofia

という訳で、移動した書き込みへのリンクが下記です。
https://wpforo.com/community/general-forums-bug-reports/deleting-a-post-hides-the-topic-from-the-forum/

 

CocoonフォーラムのwpForoは、「Ver.2.0.9」みたいです。

 
 
投稿者:: @surlofia

進展がありましたら、また書き込みます。

恐れ入りますが、気長に温かい目でお待ちいただければ幸いです。

こうしてご協力いただけるだけで、ありがたいです。

相手のあることですし、仰る通り気長に待たせていただこうと思います。

今後ともよろしくお願い致します。


   
わいひら reacted
返信引用
Surlofia
(@surlofia)
Estimable Member Registered
結合: 3年前
投稿: 124
 

@mk2_mk2

ありがとうございます。

WordPress 本体のバージョンもお願いできますか?

わたしは、6.0.2 です。

このフォーラムのバージョンを調べる方法を知らなくて((;^_^A 汗)

 


   
返信引用
Surlofia
(@surlofia)
Estimable Member Registered
結合: 3年前
投稿: 124
 

@yhira 

@mk2_mk2 様

そう言えば、質問を書き込むためにアカウントを作りました。


可能性1

投稿をフォーラムのモデレーターが承認するまで、投稿者のみ閲覧可能のようです。

https://wpforo.com/community/general-forums-bug-reports/

ステータスが、「未承認」でした。2022/10/02 日 22:39 現在

承認後は、アカウントなしでも見れるかもしれません。

 

可能性2

投稿が承認されても、アカウントを作らないと読めない?

https://wpforo.com/sign-in/?redirect_to=https%3A%2F%2Fwpforo.com%2Fcommunity%2Fgeneral-forums-bug-reports%2Fdeleting-a-post-hides-the-topic-from-the-forum%2F

その場合は、
Create Account を左クリック(または、タッチ)して、
アカウント作成お願いします。

登録確認メール内のリンクを左クリック(または、タッチ)すると、
パスワードを設定出来ます。

 

明日の夜くらいは、承認されて、ご覧いただけることを祈ります。

内容としては、今までのコピペです。

※ 読む人が楽になるように、経過を省いて、少し編集しました。


   
わいひら reacted
返信引用
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4416
 

Surlofiaさん

遅くなり、すみません。
(自分の作業をしていたもので・・・。)

投稿者:: @surlofia

WordPress 本体のバージョンもお願いできますか?

「6.0.2」みたいです。
(フィードを確認しました。)

 

wpForo側のフォーラムが閲覧できないのは、おそらく未承認だからだと思います。
(他のトピックは閲覧できていますので。)

承認されれば、きっと閲覧できると思います。
こちらも気長に待ちます。


   
返信引用
Surlofia
(@surlofia)
Estimable Member Registered
結合: 3年前
投稿: 124
 

@mk2_mk2

回答ありがとうございました。


   
返信引用
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4416
 

wpForo側のフォーラムで承認されたみたいです。

投稿者:: @surlofia

という訳で、移動した書き込みへのリンクが下記です。
https://wpforo.com/community/general-forums-bug-reports/deleting-a-post-hides-the-topic-from-the-forum/

閲覧できます。


   
わいひら reacted
返信引用
Surlofia
(@surlofia)
Estimable Member Registered
結合: 3年前
投稿: 124
 

@mk2_mk2 様

@yhira 様

プラグイン作者からの回答が来ました。

キャッシュ プラグインを完全に無効にして、問題をもう一度テストしてください。
これがキャッシュ プラグインの問題ではないことを確認する必要があります。
場合によっては、フォーラム ページを除外するだけでは不十分な場合があるため、根本的な方法でテストする必要があります。

Please fully disable the cache plugin, deactivate it and test the issue again. We need to make sure this is not the cache plugin issue. Excluding the forum page may not be enough in some cases, so we need a radical way to test it.

https://wpforo.com/community/general-forums-bug-reports/deleting-a-post-hides-the-topic-from-the-forum/#post-73566

 

という訳で、検証お願いします。

「キャッシュ プラグイン 無効」

のつぎは、

「サーバー側のキャッシュ」を

無効にして欲しいと言われる気がします。

よろしくお願いします。

追伸

先方からの返信は、夜8時が多い気がします。

時差から言って、ヨーロッパかなあ?

 


   
わいひら reacted
返信引用
Surlofia
(@surlofia)
Estimable Member Registered
結合: 3年前
投稿: 124
 

https://sitereport.netcraft.com/?url=https://wpforo.com

Hosting country: France

フランスの会社かな?

 

 


   
わいひら reacted
返信引用
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4416
 

Surlofiaさん

うーん…。

wpForo側は、検証してくださらないみたいですね。
(認めたくない?)

私のローカル環境で、確認しました。
簡単に再現できます。

プラグインは、以下の2つのみです。
それ以外のプラグインは入っていません。
(もちろん、キャッシュ系のプラグインも入っていません)

  • wpForo 2.0.9
  • WP Multibyte Patch 2.9

 

日本語で書き込んで、確認・テストを行いましたので、あまり良くなかったかもしれないですが。

 

上記GIF動画に、一連の流れは表示されていますが、一応手順を説明します。

 


 
 
①メインカテゴリーという場所には、以下の4つのトピックが立っています。
  • テスト02
  • テスト03
  • テスト01
  • 雑談

 


 
②上記の「テスト02」を開きます

すると、以下の書き込みがあります

  • 書き込みテスト 00001
  • 書き込みテスト 00002
  • 書き込みテスト 00004
  • 書き込みテスト 00005

 


 

③「書き込みテスト 00005」を、「承認を解除」した後で、「削除」します

すると、以下が残ります

  • 書き込みテスト 00001
  • 書き込みテスト 00002
  • 書き込みテスト 00004

 


 

④その後、直上の階層「メインフォーラム」へ移動します

すると、以下のトピックが表示されています。

  • テスト02
  • テスト03
  • テスト01
  • 雑談
 

 
⑤フォーラムのホームへと戻ります
 
すると、「テスト02」のトピックが表示されていません。
 
 

 
とある書き込みを「承認を解除」後に、「削除」すると…。
 
フォーラムホームに戻ると、そのトピック自体が表示されなくなってしまう・・・ということですね。
まだ、書き込みが残っていたとしても。
 
 
こんなに簡単に再現できるのですが、おそらくテスト・確認などは、してくださっていないのだと思います。
(おそらく、手順をイマイチご理解いただいていないのかも・・・ですね。)
 
キャッシュは無関係ですね。

   
わいひら reacted
返信引用
Surlofia
(@surlofia)
Estimable Member Registered
結合: 3年前
投稿: 124
 

@mk2_mk2

@yhira

「キャッシュプラグインを無効にしても、変化なしです。」

という言葉を送って、どのような反応が返るかですね。

投稿者:: @mk2_mk2

wpForo側は、検証してくださらないみたいですね。
(認めたくない?)

Google様やエックスサーバー様でさえ、検証してくれませんからね。

サポート窓口は下請けなのか、エンジニアがいないのかが、ほとんどですが、

根競べのような我慢比べですね。

とにかく、サポート窓口様の、「あれして、これして」

に対して、

「あれしました、これしました」

という回答が必要ですね。

 

可能でしたら、英語表記での画像を頂けますか?

※わたしは、このプラグインを使ったことがないです。 PV数も少ないので使用予定もないです。

test topic #1

posting test #1

chat 雑談

投稿者:: @mk2_mk2

wpForo 2.0.9
WP Multibyte Patch 2.9

日本語で、書き込んだのであまり良くなかったかも…ですが。

これを先方に送れば、WP Multibyte Patch 2.9 が原因と言われるのでしょうか?

 


   
わいひら reacted
返信引用
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4416
 

Surlofiaさん

投稿者:: @surlofia

Google様やエックスサーバー様でさえ、検証してくれませんからね。

サポート窓口は下請けなのか、エンジニアがいないのかが、ほとんどですが、

根競べのような我慢比べですね。

はい、とても疲れます。

そういう意味では、このCocoonのフォーラムは凄いな・・・と思ってしまいます。

情報不足の無茶振りなご質問が多いですけど、推測して・環境まで作って、お答えになる方が多いですから。
(そこまでしても、何の返信もしてくれない方もいますが・・・。)

 

投稿者:: @surlofia

可能でしたら、英語表記での画像を頂けますか?

私も、ローカル環境で使ってみただけなんですけどね。

今日は自分の作業がこれからありますし・・・。
明日は通院予定ですし・・・。

明日遅い時間、もしくは、明後日であれば、やってみます。

WordPress本体の言語設定を、英語にするだけでできるものなのかどうか。
「承認を解除」等のボタンも英語の方が良いですよね。

 

(ストレスがたまると、ダークサイドに堕ちそうです😩)


   
わいひら reacted
返信引用
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 14137
Topic starter  

前回、キャッシュプラグインは無効にして検証しました。
ただ、サーバーキャッシュの解除については、僕に権限がありません。
けれどサーバキャッシュに関して言われた場合は、mk2さんが書かれた「サーバキャッシュもないローカル環境で試したけど不具合が出る」と言うしかないのかもしれません。

僕も明日、朝から通院です。
疲れたら、ちょっと明日休むかもしれません。

This post was modified 2か月前 by わいひら

   
mk2 reacted
返信引用
Surlofia
(@surlofia)
Estimable Member Registered
結合: 3年前
投稿: 124
 

@mk2_mk2

ご自分の作業を優先なさってください。

ダークサイドに堕ちそうなら休憩しましょう。

me too です。

わたしも休憩します。

 


   
返信引用
Surlofia
(@surlofia)
Estimable Member Registered
結合: 3年前
投稿: 124
 

@yhira

@mk2_mk2

御思案ありがとうございます。
以下で、書いておきます。

「前回、キャッシュプラグインは無効にして検証しました。

貴社での検証では再現しませんか?」

 


   
わいひら reacted
返信引用
Surlofia
(@surlofia)
Estimable Member Registered
結合: 3年前
投稿: 124
 

wpforo をインストールしましたが、トピックを追加を左クリックしても無反応。

ユーザー登録を使用としても無反応

初期設定を探しても、それらしく所が無くて・・・

テーマを2022にしているのがダメなのか?

また明日かんがえます。

 


   
返信引用
Surlofia
(@surlofia)
Estimable Member Registered
結合: 3年前
投稿: 124
 

回答きました。

https://wpforo.com/community/general-forums-bug-reports/deleting-a-post-hides-the-topic-from-the-forum/

あらゆる種類のキャッシュをパージする前に、キャッシュプラグインを無効にだけしてください。

無効にしたまま、2~3時間維持してください。 それから、ウェブサイトを確認してください。

Please, just disable the cache plugin, before disabling purge all kind of caches. Keep it disabled for a few hours and check the website.

ロベルトさんのタイムゾーン。 https://wpforo.com/participant/robert/

イタリア

 

追伸

わたしもダークサイドに落ちる前に、冷却します。

 


   
返信引用
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4416
 

Surlofiaさん

英語にしました。
一部日本語のままの箇所もありますが、ご容赦を。
(明日だと、もっとダークサイドに堕ちそうで)

先程の返信を、少し書き直します。

 

ローカル環境でのテストです。
サーバー環境ではありません。

なお、プラグインはwpForoのみです。
他のプラグインは使用しませんでした。
(もちろん、キャッシュ系プラグインもなしです)

 
上記GIF動画に、一連の流れは表示されていますが、一応手順を説明します。
 

 

①「Main Category」>「Main Forum」という場所には、以下の4つのトピックが立っています。

  • Topic 02
  • Topic 03
  • Topic 01
  • Idle Talk

 


 

②上記の「Topic 02」を開きます

すると、以下の書き込みがあります

  • Edit Test 00001
  • Edit Test 00002
  • Edit Test 00003
  • Edit Test 00004

 


 

③「Edit Test 00004」を、「承認を解除(Unapprove)」した後で、「削除(Delete)」します

すると、以下が残ります

  • Edit Test 00001
  • Edit Test 00002
  • Edit Test 00003

 


 

④その後、直上の階層「Main Forum」へ移動します

すると、以下のトピックが表示されています。

  • Topic 02
  • Topic 03
  • Topic 01
  • Idle Talk
 

 
⑤フォーラムのホームへと戻ります

すると、「Topic 02」が表示されていません。

 
 

 
プラグインは、「wpForo」のみ。
キャッシュ系プラグインは、もちろんなし
 
ローカル環境ですので、サーバー系のキャッシュもないです。
 
「ローカル環境で、あらゆるキャッシュ機能は使っていない状態でも再現する」ということを、強調しないとダメかもですね。
 
とりあえず、これで終了です。
 

   
わいひら reacted
返信引用
Surlofia
(@surlofia)
Estimable Member Registered
結合: 3年前
投稿: 124
 

@mk2_mk2

ありがとうございます。

さっそく、先方に送ります。

 

別件ですが、wp foro を使おうとしました。
しかし、トピックの追加さえ、できませんでした。

※ ユーザー登録は、なんとかできました。

どこかのタイミングで、お時間を割いて頂ければうれしいです。

 

掲示板のタイトル

Test for wpforo

https://natsu-mikan.com/wpforo/participants/

 

https://wpforo.com/community/faq/problems-with-user-registration-email/#post-40175

4. Install SMTP plugin. The new one is Post SMTP. Do a test email sending via Post SMTP. Check the logs of all sent emails. If you see the email is sent, then this is email receiver service issue, use other email address from other providers (gmail.com, yahoo.com, hotmail.com...) to register and test.

このプラグインをインストールすることで、ユーザー登録はできました。

 


   
返信引用
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4416
 

Surlofiaさん

私も、そんな詳しい訳ではないですが・・・。

Surlofiaさんの状態。

 
 
私のローカル環境。
 
 
 
Surlofiaさんは、まだ「カテゴリー」のみの状態な気がします。
 
「フォーラム」がないのではないか・・・という気はします。
確証はないのですけれど。
 
そして、すみません、そろそろ寝ます。
私も明日午前中から通院予定なもので。

   
わいひら reacted
返信引用
Surlofia
(@surlofia)
Estimable Member Registered
結合: 3年前
投稿: 124
 

@mk2_mk2

ありがとうございました。

先方に送りました。

この質問トピックは2ページ目に突入しました。

https://wpforo.com/community/general-forums-bug-reports/deleting-a-post-hides-the-topic-from-the-forum/

https://wpforo.com/community/general-forums-bug-reports/deleting-a-post-hides-the-topic-from-the-forum/paged/2/


   
わいひら reacted
返信引用
固定ページ 2 / 5
共有:

問題の解決に至った場合には、トピック冒頭の「解決済み」をクリックしていただけますと幸いです。

wpForoの解決済みリンク

また、有用な回答があった場合は「いいね!」もご活用ください。回答者の励みになります。

wpForoのいいねリンク

「いいね!」機能はフォーラム登録者のみが利用できる機能です。

CC BY-ND 2.1)準じていれば(リンクを貼っていただければ)転載も自由です。カスタマイズ記事を書く際にコード等をコピペ利用していただいて構いません。

フォーラムの使い方がよくわからない場合は、テストトピックで自由にテストしていただいて構いません。

最近の書き込みはこちら。

詳細なカスタマイズ依頼をするならこちら。

タイトルとURLをコピーしました