「メイド・イン・ヘブン」スキン適用中

Cocoonフォーラム

サイト内検索
書き込みの前に以下の3点をご確認ください。
  1. 1つのトピックにつき1つの質問を書き込んでください
  2. 不具合・カスタマイズ対象ページのURLを提示高速化を無効にしてください
  3. 該当部分のキャプチャ・環境情報とともに書き込んでいただけると助かります

何を書き込んだら良いか分からない場合は、以下のテンプレートをコピペしてご利用ください。

不具合・カスタマイズ対象ページのURL:

相談内容:

不具合の発生手順:

解決のために試したこと:

※文字だけでは正しく伝わらない可能性があるため、スクショ画像の添付もお願いします。
※高速化設定をしている場合は無効にしてください。
環境情報:

※↑こちらに「Cocoon設定 → テーマ情報」にある「環境情報」を貼り付けてください。

環境情報の取得方法はこちら。
https://wp-cocoon.com/theme-report/
高速化設定を無効にするにはこちら。
https://wp-cocoon.com/theme-trouble/

フォーラム利用ガイドリンク

  1. フォーラムガイドライン
  2. よくある質問と答え(FAQ)
  3. サポート対象外のケース
  4. 原因不明の不具合用トラブルシューティング
  5. トピックにHTMLを貼り付ける方法(推奨ツール:notepad.pw
  6. 真っ白画面でのエラーメッセージの確認方法
  7. ブラウザ環境チェックツール
  8. Cocoonカスタマイズ依頼

フォーラム質問後、問題等が解決した場合は結果を書き込んでいただけると幸いです。同様の問題で調べている方には、結果が一番気になる部分となります。

Cocoon 1.9.5のHighli...
 
共有:
通知
すべてクリア

[解決済] Cocoon 1.9.5のHighlight.js追加希望言語

7 投稿
3 ユーザー
4 Likes
1,660 表示
(@hiromi)
Estimable Member Registered
結合: 6年前
投稿: 81
Topic starter  

こんにちは。
現在Cocoon 1.9.4を利用させて頂いています。
さて、Cocoon 1.9.5のHighlight.jsで切り捨てられた言語のうち、もし可能ならば以下の言語を追加して頂きたいのですが。
awk
arduino
basic
dos
excel
fortran
fsharp
typescript
less
scss
asciidoc
vbnet
vbscript
よろしくお願いいたします。

でも、色んな人の要望を聞いていたら、結局は、殆ど全ての言語を追加する必要があるかもしれません。
ですので、例えばCocoonのオプション設定で、
〇良く使う言語のみの軽量版
〇全ての言語を含む完全版
みたいなラジオボタンが有れば良いかも知れません。


   
ろこ
(@lococo)
Prominent Member Registered
結合: 6年前
投稿: 830
 

私の使用言語のうち、今のところここには含まれていない言語を書かせていただきます。

  • Elixir
  • Erlang
  • Haskell
  • OCaml
  • Scala
  • Clojure
  • Lisp
  • TeX
  • Matlab
  • R
  • Go
  • Rust
  • Swift
  • Julia
  • Crystal
  • Kotlin

難しそうであればこちらでファイルを変更しますが、lib/utils.php#L550のURLだけ変更できるようにしていただけるとわざわざdequeueせずに済みそうです。

あと本トピックとは関係ないのですが、Cocoon設定ページにおける$_THEME_OPTIONSの修正が反映されるのはこの次のバージョン変更からということでよろしいでしょうか?


   
edit reacted
わいひら
(@yhira)
Illustrious Member Admin
結合: 6年前
投稿: 16440
 

いくつかはあるだろうと思っていましたが、ここまで、いろいろ使われているとは思っていませんでした。

例えばCocoonのオプション設定で、
〇良く使う言語のみの軽量版
〇全ての言語を含む完全版
みたいなラジオボタンが有れば良いかも知れません。

この機能を追加しておきました。

難しそうであればこちらでファイルを変更しますが、lib/utils.php#L550のURLだけ変更できるようにしていただけるとわざわざdequeueせずに済みそうです。

このフックも追加しておきました。
https://github.com/yhira/cocoon/blob/228c295b10e6d2e9eac71fe716f738c34f6c1e42/lib/utils.php#L556

あと本トピックとは関係ないのですが、Cocoon設定ページにおける$_THEME_OPTIONSの修正が反映されるのはこの次のバージョン変更からということでよろしいでしょうか?

はい。
更新情報に書き忘れていました ? 

------------------------------------------------
https://github.com/yhira/cocoon
最新ファイルをダウンロードする場合は、上記ページのダウンロードボタンからzipファイルをダウンロードしてください。

FTPでのアップデート方法はこちら。
https://wp-cocoon.com/ftp-update/
------------------------------------------------


   
(@hiromi)
Estimable Member Registered
結合: 6年前
投稿: 81
Topic starter  

わいひらさん、

素早い対応ありがとうございました。
さっそく最新版を入手してftpでUpdateしたところ、
「軽量版」と「全て」のラジオボタン選択が可能になりました。
「全て」を選択すると私が使っている言語に関しても今までと同じハイライト表示に出来ました。
ありがとうございました。

 

 

 


   
わいひら reacted
わいひら
(@yhira)
Illustrious Member Admin
結合: 6年前
投稿: 16440
 

ご確認ありがとうございます。
確か、以前のライブラリサイズは、500KB強くらいでした。
今回highlite.jsのアップデートで、さらに完全版の対応言語が増えたのか、完全版は700KB以上になっています(ちなみに軽量版は、50KB弱)。

さすがに重すぎるから、今回とりあえず軽量版にしたのですが、思っていた以上に軽量版以外の言語も需要があるのを知れて、機能化できてよかったです。


   
ろこ
(@lococo)
Prominent Member Registered
結合: 6年前
投稿: 830
 

確認しました。
フックの追加ありがとうございます。

あと本トピックとは関係ないのですが、Cocoon設定ページにおける$_THEME_OPTIONSの修正が反映されるのはこの次のバージョン変更からということでよろしいでしょうか?

はい。

分かりました。
次回のアップデートでよろしくお願いします。


   
edit and わいひら reacted
わいひら
(@yhira)
Illustrious Member Admin
結合: 6年前
投稿: 16440
 

ご確認ありがとうございます。

あ、よく読んだら。すいません。
次のバージョンからではなく、1.9.5から適用されています。
返信をしっかりと読んでませんでした。


   
共有:

問題の解決に至った場合には、トピック冒頭の「解決済み」をクリックしていただけますと幸いです。

また、有用な回答があった場合は返信右下にある「いいね!」もご活用ください。回答者の励みになります。

「いいね!」機能はフォーラム登録者のみが利用できる機能です。

CC BY-ND 2.1)準じていれば(リンクを貼っていただければ)転載も自由です。カスタマイズ記事を書く際にコード等をコピペ利用していただいて構いません。

フォーラムの使い方がよくわからない場合は、テストトピックで自由にテストしていただいて構いません。

最近の書き込みはこちら。

詳細なカスタマイズ依頼をするならこちら。

タイトルとURLをコピーしました