grayishスキン適用中

Cocoonフォーラム

サイト内検索
書き込みの前に以下の3点をご確認ください。
  1. 1つのトピックにつき1つの質問を書き込んでください
  2. 不具合・カスタマイズ対象ページのURLを提示高速化を無効にしてください
  3. 該当部分のキャプチャ・環境情報とともに書き込んでいただけると助かります

何を書き込んだら良いか分からない場合は、以下のテンプレートをコピペしてご利用ください。

不具合・カスタマイズ対象ページのURL:

相談内容:

不具合の発生手順:

解決のために試したこと:

※文字だけでは正しく伝わらない可能性があるため、スクショ画像の添付もお願いします。
※高速化設定をしている場合は無効にしてください。
環境情報:

※↑こちらに「Cocoon設定 → テーマ情報」にある「環境情報」を貼り付けてください。

環境情報の取得方法はこちら。
https://wp-cocoon.com/theme-report/
高速化設定を無効にするにはこちら。
https://wp-cocoon.com/theme-trouble/

フォーラム利用ガイドリンク

  1. フォーラムガイドライン
  2. よくある質問と答え(FAQ)
  3. サポート対象外のケース
  4. 原因不明の不具合用トラブルシューティング
  5. トピックにHTMLを貼り付ける方法(推奨ツール:notepad.pw
  6. 真っ白画面でのエラーメッセージの確認方法
  7. ブラウザ環境チェックツール
  8. Cocoonカスタマイズ依頼

フォーラム質問後、問題等が解決した場合は結果を書き込んでいただけると幸いです。同様の問題で調べている方には、結果が一番気になる部分となります。

テーマの自動更新エラーについて
 
共有:
通知
すべてクリア

[解決済] テーマの自動更新エラーについて

43 投稿
4 ユーザー
18 Likes
1,780 表示
(@treak)
Eminent Member Registered
結合: 12か月前
投稿: 20
Topic starter  

はじめまして!

Cocoonを気に入って数年使わせて頂いております。

親テーマと子テーマを利用し、子テーマを有効化して利用しております。

以前はテーマの更新をその都度行っておりましたが、1年ほど前にテーマの自動更新に設定しました。

しかし、この1年間1度もテーマが更新されませんでした。

現在、SiteGuardプラグインを使って更新の通知が送られるようにしたのですが、

テーマの更新エラーのメールが届くようになりました。

以下が、エラーの内容の一部です。

-------------------------------------------------

https://〇〇〇〇〇〇.co.jp にあるサイトでのテーマの更新に失敗しました。

サイトを確認してみてください。すべて問題なく動いている可能性があります。利用できる更新がある場合は更新をおすすめします。

以下のテーマの更新に失敗しました:
- Cocoon Child (バージョン1.1.0から2.5.7.5へ)

-------------------------------------------------

現在の親テーマのバージョンは2.4.2.4ですが、

このメールの内容を見ると、バージョンが1.1.0の子テーマに親テーマの更新をしようとしているみたいです。

SiteGuardプラグインが悪さをしている可能性があると思い、一度無効化してみましたが、

テーマの更新はされず、サイトヘルスステータスに同じようなエラーメッセージが表示されました。

解決策がありましたら、お知らせ頂けるとありがたいです。


   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 3年前
投稿: 6678
 

TREAKさん

お手数ですが、フォーラム上部のご案内にありますように、環境情報のご提示をお願いできますでしょうか。

書き込みの前に以下の3点をご確認ください。
  1. 1つのトピックにつき1つの質問を書き込んでください
  2. 不具合・カスタマイズ対象ページのURLを提示高速化を無効にしてください
  3. 該当部分のキャプチャ・環境情報とともに書き込んでいただけると助かります

環境情報の取得方法はこちら。
→  https://wp-cocoon.com/theme-report/

URL部分は削除していただいて構いません。


   
わいひら reacted
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 3年前
投稿: 6678
 

TREAKさん

投稿者:: @treak

現在の親テーマのバージョンは2.4.2.4です

上記であれば、私が懸念したことはなさそうな気はします。

以下の方法でアップデートできそうに思います。

Cocoonテーマファイルを手動でアップデートする方法
https://wp-cocoon.com/manual-update-of-cocoon-theme/

 

投稿者:: @treak

バージョンが1.1.0の子テーマに親テーマの更新をしようとしているみたいです。

これはさすがになさそうな気がしますが・・・。


   
わいひら reacted
(@treak)
Eminent Member Registered
結合: 12か月前
投稿: 20
Topic starter  

@mk2_mk2 さん

返信ありがとうございます。

以下が環境情報です。

----------------------------------------------
サイト名:
サイトURL:
ホームURL:
コンテンツURL:/wp-content
インクルードURL:/wp-includes/
テンプレートURL:/wp-content/themes/cocoon-master
スタイルシートURL:/wp-content/themes/cocoon-child-master
親テーマスタイル:/wp-content/themes/cocoon-master/style.css
子テーマスタイル:/wp-content/themes/cocoon-child-master/style.css
WordPressバージョン:6.1.1
PHPバージョン:8.0.17
ブラウザ:Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/110.0.0.0 Safari/537.36 Edg/110.0.1587.63
サーバーソフト:Apache
サーバープロトコル:HTTP/2.0
エンコーディング:gzip, deflate, br
言語:ja,en;q=0.9,en-GB;q=0.8,en-US;q=0.7
----------------------------------------------
テーマ名:Cocoon
バージョン:2.4.2.4
カテゴリ数:1
タグ数:0
ユーザー数:1
----------------------------------------------
子テーマ名:Cocoon Child
バージョン:1.1.0
style.cssサイズ:9767バイト
functions.phpサイズ:3294バイト
----------------------------------------------
Gutenberg:1
AMP:0
PWA:0
Font Awesome:5
Auto Post Thumbnail:0
Retina:1
ホームイメージ:
----------------------------------------------
ブラウザキャッシュ有効化:1
HTML縮小化:0
CSS縮小化:0
JavaScript縮小化:0
Lazy Load:0
WEBフォントLazy Load:0
----------------------------------------------
利用中のプラグイン:
Advanced Automatic Updates 1.0.2
Advanced Editor Tools (previously TinyMCE Advanced) 5.6.0
Akismet Anti-Spam 5.0.2
All-in-One WP Migration 7.72
EWWW Image Optimizer 6.9.3
Google XML Sitemaps 4.1.7
MetaSlider 3.29.0
MW WP Form 4.4.2
PHP Compatibility Checker 1.5.2
PS Auto Sitemap 1.1.9
Shortcodes Ultimate 5.12.8
SiteGuard WP Plugin 1.7.3
WP-Optimize - Clean, Compress, Cache 3.2.13
WP Carousel 2.5.4
WP Multibyte Patch 2.9
zipaddr-jp 1.36
----------------------------------------------


   
(@treak)
Eminent Member Registered
結合: 12か月前
投稿: 20
Topic starter  

@mk2_mk2 さん

お世話になります。

手動では問題なく更新できるのですが、自動更新できるようにしたくて、

色々と調べていますが、解決策がわかりません。

 

以下のテーマの更新に失敗しました:
- Cocoon Child (バージョン1.1.0から2.5.7.5へ)

 

このエラーメッセージは、なぜ子テーマの更新エラーとしてメールがくるのか、

普通なら、Cocoon(バージョン2.4.2.4から2.5.7.5へ)となるはずですよね?

 


   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 3年前
投稿: 6678
 

TREAKさん

ダッシュボードからの更新を含めて、何故かできない方がいらっしゃるんですよね、最近。

一旦、最新版にしてみると、改善するかもしれませんので、まずは手動で更新してみてください。

2.4.2.4はかなり古く、WordPress 6.1.1で使用するには支障があるはずです。特にブロックエディタ周りで。

(WordPress 6.1系の仕様変更に対応していない)

 

ちなみに、どこのサーバーが教えていただくことは可能でしょうか。

 

投稿者:: @treak

普通なら、Cocoon(バージョン2.4.2.4から2.5.7.5へ)となるはずですよね?

上記はSiteGuardの仕様を確認しないと分からないですね。

実際に子テーマの更新にはいかないと思います。

名前もフォルダも違うと思いますし。(そこはWordPressの仕様だと思いますし)

SiteGuardのメールの誤りではないかと、疑っています。

 


   
わいひら reacted
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 3年前
投稿: 6678
 

テーマのアップデート失敗のメールのバージョンが変なのは、以下のトピックでもありますね。

「Cocoon Childの更新に失敗しました」と表示される件に関して
https://wp-cocoon.com/community/postid/48231/

ただ、この時は、SiteGuardからのメールかどうかは分かってないです。


   
わいひら reacted
わいひら
(@yhira)
Illustrious Member Admin
結合: 6年前
投稿: 16125
 

投稿者:: @mk2_mk2

ダッシュボードからの更新を含めて、何故かできない方がいらっしゃるんですよね、最近。

これおそらくShield Securityプラグインのファイアウォールに引っかかっている可能性が高いっぽいんですよね。
https://ja.wordpress.org/plugins/wp-simple-firewall/
Shield Securityプラグインはフォーラムのスパムを減らすのに必要不可欠なプラグインなのでどうしたものかと…といった感じです。

@treak 

サイトURLの公開が難しいようでしたらサーバーのIPだけでもしていただいてよろしいでしょうか。
サーバーIPはこちらで調べると表示されます。
https://seocheki.net/
あとできれば使用しているサーバー名も教えてください。


   
(@treak)
Eminent Member Registered
結合: 12か月前
投稿: 20
Topic starter  

@mk2_mk2 さん

お世話になっております。

当方のサーバーはVALUE SERVERです。

手動更新して様子を見ようかと思います。

 


   
(@treak)
Eminent Member Registered
結合: 12か月前
投稿: 20
Topic starter  

わいひら さん

返信ありがとうございます。

当方のサーバーはVALUE SERVERです。

サーバーIPはこちらです。

s3.valueserver.jp 157.7.184.18

宜しくお願いします。


   
(@treak)
Eminent Member Registered
結合: 12か月前
投稿: 20
Topic starter  

わいひら さん

当方のサイトURLは以下です。

2つのサイト何れも自動更新エラーになります。

サーバーは同じです。

https://treasure-kogyo.co.jp&source=gmail&ust=1678904106391000&usg=AOvVaw1Vl_a-3Hcpwzcq6f7EKK6 W"> https://treasure-kogyo.co.jp

https://alice-care.co.jp

 

更新エラーのメールを再度確認したところ、

送信元はSiteGuardからではなくWordPressチームとなっておりました。

---------------------------------------------------------------------

 =?UTF-8?B?44Gu44OG44O844Oe44Gu5pu05paw44Gr5aSx5pWX44GX44G+44GX44Gf?=
Date: Mon, 13 Mar 2023 19:10:42 +0000
From: WordPress <wordpress@treasure-kogyo.co.jp>
Message-ID: <pl5wezPDYNAM3DWkwOhQqoaygE7pHnE2wfIyIo0lM@treasure-kogyo.co.jp>
X-Mailer: PHPMailer 6.6.5 (https://github.com/PHPMailer/PHPMailer&source=gmail&ust=1678904106391000&usg=AOvVaw1rc8N0TgWNqgxlvD_iv8V p"> https://github.com/PHPMailer/PHPMailer )
MIME-Version: 1.0
Status:  U
X-UIDL: http://1678734652.M339452P687919.s3.valueserver.jp&source=gmail&ust=1678904106391000&usg=AOvVaw0lZJk6CCpRExBrTyrx2Xb r">1678734652.M339452P687919.s3.valueserver.jp
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
X-Virus-Status: No
X-Virus-Checker-Version: clamassassin 1.2.4 with clamdscan / ClamAV 0.103.5/26839/Sun Mar 12 17:22:48 2023

https://treasure-kogyo.co.jp&source=gmail&ust=1678904106391000&usg=AOvVaw1Vl_a-3Hcpwzcq6f7EKK6 W"> https://treasure-kogyo.co.jp  にあるサイトでのテーマの更新に失敗しました。

サイトを確認してみてください。すべて問題なく動いている可能性があります。利用できる更新がある場合は更新をおすすめします。

以下のテーマの更新に失敗しました:
- Cocoon Child (バージョン1.1.0から2.5.7.5へ)

以下のプラグインを更新しました:
- WP-Optimize - クリーン、圧縮、キャッシュ (バージョン 3.2.12 から3.2.13へ) : https://wordpress.org/plugins/wp-optimize/&source=gmail&ust=1678904106391000&usg=AOvVaw0KfYrSnShfSS2gs4S5-4- s"> https://wordpress.org/plugins/wp-optimize/

サイトのテーマを管理するには、テーマページにアクセスしてください: https://treasure-kogyo.co.jp/wp-admin/themes.php&source=gmail&ust=1678904106391000&usg=AOvVaw1rR4ffcimPwha56i2yW3U E"> https://treasure-kogyo.co.jp/wp-admin/themes.php

問題が生じたり、サポートが必要な場合は、WordPress.org のサポートフォーラムのボランティアが助けになるでしょう。
https://ja.wordpress.org/support/forums/&source=gmail&ust=1678904106391000&usg=AOvVaw2mYT2gu5Mrn2Pn4CbMbKE E"> https://ja.wordpress.org/support/forums/

WordPress チーム

-------------------------------------------------------------------------------------
 
 
SiteGuardからの更新通知も届いてました。
-------------------------------------------------------------------------------------
=?UTF-8?Q?https://treasure-kogyo.co.jp?%3D&source=gmail&ust=1678904102902000&usg=AOvVaw3zCeMCmngBXeWIGmtx5cF g"> https://treasure-kogyo.co.jp?=
Date: Tue, 14 Mar 2023 07:11:46 +0000
From: WordPress <wordpress@treasure-kogyo.co.jp>
Message-ID: <xDfQwOU04dUyHvz3u3FsnTiyMmSWoMyzA6IZ8Y74G9I@treasure-kogyo.co.jp>
X-Mailer: PHPMailer 6.6.5 (https://github.com/PHPMailer/PHPMailer&source=gmail&ust=1678904102902000&usg=AOvVaw10ZLivC6230J4F4i-_MmY m"> https://github.com/PHPMailer/PHPMailer )
MIME-Version: 1.0
Status:  U
X-UIDL: http://1678777916.M180228P986936.s3.valueserver.jp&source=gmail&ust=1678904102902000&usg=AOvVaw2GfH4UK4CaD_G1oPBgPcJ l">1678777916.M180228P986936.s3.valueserver.jp
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
X-Virus-Status: No
X-Virus-Checker-Version: clamassassin 1.2.4 with clamdscan / ClamAV 0.103.5/26840/Mon Mar 13 16:22:58 2023

あなたのWordPressサイトで、実行可能な更新があります

Theme: Cocoon is out of date. Please update from version 2.4.2.4 to 2.5.7.5

次のページで、更新を行なって下さい。: https://treasure-kogyo.co.jp/wp-admin/update-core.php&source=gmail&ust=1678904102902000&usg=AOvVaw243AU6OQ1-fPK6PlRRZXN F"> https://treasure-kogyo.co.jp/wp-admin/update-core.php

--
SiteGuard WP Plugin

 
---------------------------------------------------------------------------------
 

   
わいひら
(@yhira)
Illustrious Member Admin
結合: 6年前
投稿: 16125
 

IPを調べたところブロック対象のIPにはなっていませんでした。
念のためIPをホワイトリストに登録してみたのですがもう一度行なってみてもアップデートできませんでしょうか。
うまくいかない場合は以下の手動アップデートもうまくいきませんでしょうか。
------------------------------------------------
WordPressでの手動アップデート方法はこちら
https://wp-cocoon.com/manual-update-of-cocoon-theme/
------------------------------------------------

This post was modified 12か月前 by わいひら

   
(@treak)
Eminent Member Registered
結合: 12か月前
投稿: 20
Topic starter  

わいひら さん

手動アップデートでは、以前から問題なく出来るのですが、

手間のかからないよう自動更新を有効化したものの、

エラーになってしまうので、原因と解決策を調べております。

動アップデートしましたので、現在のバージョンは2.5.7.11です。

何とか自動更新出来るようにしたいのですが、無理なのでしょうか?


   
わいひら
(@yhira)
Illustrious Member Admin
結合: 6年前
投稿: 16125
 

バリューサーバーのアップロード可能なファイル上限サイズってどのくらいなんでしょう?
これが原因かはわからないのですが調べても出てこなくて。

ただファイアウォールに遮断されていたわけではない以上、それ以外の原因はちょっと思いつかないです。


   
(@treak)
Eminent Member Registered
結合: 12か月前
投稿: 20
Topic starter  

やはり原因はわかりませんか!

因みに、ダッシュボードから手動アップデート後も自動更新エラーは出るものの、

エラー表示が変わりました。

 

----------------------------------------------------------------
https://treasure-kogyo.co.jp&source=gmail&ust=1679529437543000&usg=AOvVaw204ooQ5aACils5f_3NlCE f"> https://treasure-kogyo.co.jp  にあるサイトでのテーマの更新に失敗しました。

サイトを確認してみてください。すべて問題なく動いている可能性があります。利用できる更新がある場合は更新をおすすめします。

以下のテーマの更新に失敗しました:
- wp-cocoon-theme バージョン2.5.8
----------------------------------------------------------------

以前のエラーは、

以下のテーマの更新に失敗しました:

- Cocoon Child (バージョン1.1.0から2.5.7.5へ)

今回のエラーは、

以下のテーマの更新に失敗しました:

- wp-cocoon-theme バージョン2.5.8

PHPMailerで送信されているようですが、

PHP7からPHP8に変更してから、メールの件名も途中で途切れて送られてくるので、

PHP8に不具合がありそうな気がします。

PHPのバージョンを落として様子を見てみます。

 


   
(@treak)
Eminent Member Registered
結合: 12か月前
投稿: 20
Topic starter  

わいひら さん

PHP7.4に落としてみましたが、やはり更新エラーになります。

ただ、次のようなメッセージが表示されました。

------------------------------------------------------------------------------------------

現在お使いのバージョンは 2.5.7.11 です。2.5.8 に更新します。

3分前に期限切れになった自動更新。WP-Cron に問題がある可能性があります。

------------------------------------------------------------------------------------------

WP-Cron に問題がある可能性があるという事ですが、

これで何かわかりませんか?

 


   
わいひら
(@yhira)
Illustrious Member Admin
結合: 6年前
投稿: 16125
 

投稿者:: @treak

WP-Cron に問題がある可能性があります。

これで検索しても何も出てこないですね。

投稿者:: @treak

- Cocoon Child (バージョン1.1.0から2.5.7.5へ)

これもよく分からないんですよね。
子テーマがアップデートされることはないので(子テーマに自動アップデートは仕込んでいない)。

こちらに関してはどうなのでしょうか。

投稿者:: @yhira

バリューサーバーのアップロード可能なファイル上限サイズってどのくらいなんでしょう?


   
わいひら
(@yhira)
Illustrious Member Admin
結合: 6年前
投稿: 16125
 

投稿者:: @treak

----------------------------------------------------------------
https://treasure-kogyo.co.jp&source=gmail&ust=1679529437543000&usg=AOvVaw204ooQ5aACils5f_3NlCE f"> https://treasure-kogyo.co.jp  にあるサイトでのテーマの更新に失敗しました。

サイトを確認してみてください。すべて問題なく動いている可能性があります。利用できる更新がある場合は更新をおすすめします。

以下のテーマの更新に失敗しました:
- wp-cocoon-theme バージョン2.5.8
----------------------------------------------------------------

これが出ている画面のスクリーンショットもいただけますでしょうか。


   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 3年前
投稿: 6678
 

何かVALUE SERVERの制約に引っ掛かっているとか?

 
他にも制約事項はあるみたいですが、流石に実行時間が3分を超えることはなさそうな気はしますね。
 
バリューサーバーで使用できるCronジョブの最大設定数について
https://warashibe76.com/pc-memo/?p=549
 

   
わいひら reacted
(@treak)
Eminent Member Registered
結合: 12か月前
投稿: 20
Topic starter  

VALUE SERVER のスタンダードプラン契約ですので、

CRON数は最大99個となっていると思います。


   
(@treak)
Eminent Member Registered
結合: 12か月前
投稿: 20
Topic starter  

エラーメールのスクリーンショットです。

 

バリューサーバーのアップロード可能なファイル上限サイズはわかりません。


   
(@treak)
Eminent Member Registered
結合: 12か月前
投稿: 20
Topic starter  

スクリーンショットがアップ出来なかったので、以下がメール内容です。

 

---------------------------------------------------------------

 

=?UTF-8?B?44Gu44OG44O844Oe44Gu5pu05paw44Gr5aSx5pWX44GX44G+44GX44Gf?=
Date: Tue, 21 Mar 2023 06:43:46 +0000
From: WordPress <wordpress@treasure-kogyo.co.jp>
Message-ID: <p58AosjjTq06QqyM0VUF4jxn8PD7T049lVZuGirfqU@treasure-kogyo.co.jp>
X-Mailer: PHPMailer 6.6.5 (https://github.com/PHPMailer/PHPMailer&source=gmail&ust=1679529437543000&usg=AOvVaw0B_0-rSUBiBuAc5EnYUaP B"> https://github.com/PHPMailer/PHPMailer )
MIME-Version: 1.0
Status:  U
X-UIDL: http://1679381036.M608964P951481.s3.valueserver.jp&source=gmail&ust=1679529437543000&usg=AOvVaw3wXS9y6HZjiN6G9cxhxIL b">1679381036.M608964P951481.s3.valueserver.jp
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
X-Virus-Status: No
X-Virus-Checker-Version: clamassassin 1.2.4 with clamdscan / ClamAV 0.103.5/26849/Mon Mar 20 16:24:18 2023

https://treasure-kogyo.co.jp&source=gmail&ust=1679529437543000&usg=AOvVaw204ooQ5aACils5f_3NlCE f"> https://treasure-kogyo.co.jp  にあるサイトでのテーマの更新に失敗しました。

サイトを確認してみてください。すべて問題なく動いている可能性があります。利用できる更新がある場合は更新をおすすめします。

以下のテーマの更新に失敗しました:
- wp-cocoon-theme バージョン2.5.8

以下のプラグインを更新しました:
- Akismet Anti-Spam (アンチスパム) (バージョン 5.0.2 から5.1へ) : https://wordpress.org/plugins/akismet/&source=gmail&ust=1679529437543000&usg=AOvVaw3EtklKpnr0pz7qLYPJR0R d"> https://wordpress.org/plugins/akismet/
- MetaSlider (バージョン 3.29.0 から3.29.1へ) : https://wordpress.org/plugins/ml-slider/&source=gmail&ust=1679529437543000&usg=AOvVaw2SxwMbMu-VqQXQt3mIhH- o"> https://wordpress.org/plugins/ml-slider/

サイトのテーマを管理するには、テーマページにアクセスしてください: https://treasure-kogyo.co.jp/wp-admin/themes.php&source=gmail&ust=1679529437543000&usg=AOvVaw0nudsPHSOQBdwcwvrVlCN h"> https://treasure-kogyo.co.jp/wp-admin/themes.php

問題が生じたり、サポートが必要な場合は、WordPress.org のサポートフォーラムのボランティアが助けになるでしょう。
https://ja.wordpress.org/support/forums/&source=gmail&ust=1679529437543000&usg=AOvVaw2di5fIGeXDUKRlSRGolEX f"> https://ja.wordpress.org/support/forums/

WordPress チーム

 

   
(@treak)
Eminent Member Registered
結合: 12か月前
投稿: 20
Topic starter  

php.iniのアップロードに関する設定を調べたところ
以下の設定になっていました。

max_file_uploads 20
upload_max_filesize 2048M

 


   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 3年前
投稿: 6678
 

TREAKさん

いくつかお聞きしたいです。

手動更新と仰っているのは、以下で、これは問題ないということですよね。

 
 
添付いただいたメールを拝見すると、他のプラグインと同時に自動更新が掛かっているようです。
 
Cocoon単独で自動更新が掛かってエラーになっていることはありましたか?
(1年くらい自動更新できないとのことですから、Cocoon単独の場合もありそうですが)

   
わいひら reacted
(@treak)
Eminent Member Registered
結合: 12か月前
投稿: 20
Topic starter  

ダッシュボードの更新からだとCocoonテーマも問題なく更新できます。

自動更新設定してから、プラグインは自動更新でエラーになったことはありません。

Cocoonテーマだけが、毎回エラーになります。

Cocoon単独での自動更新もエラーになります。

一度も自動更新された事がありません。

 


   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 3年前
投稿: 6678
 

TREAKさん

そうですか、単独の自動更新もダメなんですね。

ちなみに、自動更新ができなかった辺りの時間帯で、エラーログ等、落ちていないでしょうか。


   
わいひら reacted
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 3年前
投稿: 6678
 

テーマの自動更新をしたことがなかったもので、やってみました。

すると、以下のような感じに。

 
この環境は、BASIC認証をかけてあります。
ログを確認したところ、wp-cron.phpが「401」で弾かれていました。
 
wp-cron.phpがBASIC認証を通過するようにすると、以下のように変化しました。
 
 
とりあえず、3時間待ってみようと思います。
 
 
添付いただいたメールに「wp-cron」の文字がありましたので、この辺の表示等あるかも知れないと思って書いてみました。
 
先の返信でも書かせていただきましたが、エラーログ等に何かないのか、調べていただくのが良さそうには思います。
cronの稼動が妨げられているのか、もしくは途中で実行が止まる等、あるのかもしれないですよね。

   
わいひら reacted
(@treak)
Eminent Member Registered
結合: 12か月前
投稿: 20
Topic starter  

MK2 さん

自動更新を試して頂いてありがとうございます。

表示内容は、当方と全く同じです。

自動更新の予定時間を過ぎてから確認すると、

「〇分前に期限切れになった自動更新。WP-Cron に問題がある可能性があります。」となり、

その後は、「〇時間に自動更新が予定されています。」と変わります。

あとは、その繰り返しです。

当方、wordpressの知識があまり無いので、エラーログの確認が出来ません。

 


   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 3年前
投稿: 6678
 

投稿者:: @treak

「〇分前に期限切れになった自動更新。WP-Cron に問題がある可能性があります。」となり、

これが「ダッシュボード」-「更新」のテーマのところに表示されるのですね。

この情報があると、伝わりやすかったと思います。

cronの問題の可能性が出てきていると思います。
(テーマではなく、WordPress側の可能性)

 

投稿者:: @treak

当方、wordpressの知識があまり無いので、エラーログの確認が出来ません。

すみません。
そう言われてしまうと、もう話が終わってしまいます。

TREAKさんの環境は、TREAKにしか調べることができないです。
外部の者からは確認ができません。

VALUE SERVERのヘルプみたいなものに記載がないかと探したのですが、今のところ見つかりませんので、どうすればログが閲覧できるのか等、私には分からないです。
(ログ等がない?契約者さんにしか見れないヘルプみたいなものがある?)

 

ちなみに、私の環境では、まだ自動更新ができていません。
現在、以下のような状態です。

 
特にメールは来ていないですが、cronが動かなかったのだと思います。
(更新に失敗したのではなく、そもそも動いていない)
 
その結果、11時間後にリトライという感じになったのだと思います。

WordPressのcronは、疑似cronみたいで、該当の時間に閲覧などがないと、動かないんですよね、確か。
私は、テスト環境で試したもので、特に閲覧等がありませんから、こういうことになっているんだと思います。
 
私の場合は、11時間後に閲覧等していないと動かないと思われます。
うーん、11時間後ですか厳しいかもしれないです。
 

   
わいひら reacted
(@treak)
Eminent Member Registered
結合: 12か月前
投稿: 20
Topic starter  

説明不足ですみませんでした。

それにしても、

WordPressのcronが、該当の時間に閲覧などがないと動かないとなると疑問が!

プラグインの自動更新もcronによって更新されるんですよね?

プラグインの自動更新は、その時間に閲覧がなくても動いて、

テーマの自動更新は動かないというのも変ですよね?

プラグインの更新とテーマの更新では、動くシステムが違うのでしょうか?

やはりcron自体に問題があるために起こる症状なのでしょうか?


   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 3年前
投稿: 6678
 

TREAKさん

cronが動かなかったのは、あくまでも私の環境での話です。

ただ、以下のような場合は、「期限切れ」とありますから、動いていないかもしれないです。

投稿者:: @treak

「〇分前に期限切れになった自動更新。WP-Cron に問題がある可能性があります。」となり、

何かcronに問題がある?

 

メールがきている件では動いていると思います。プラグインは更新されていますし。

ただし、何らかの原因で失敗していて、それがサーバーの制約等に抵触したのかなと、いくつか前にいただいた返信で思ったんですよね。


   
わいひら reacted
(@treak)
Eminent Member Registered
結合: 12か月前
投稿: 20
Topic starter  

更新通知のメールを確認したところ、

テーマ更新エラーのメールが届くのは、プラグインの更新があった時だけです。

テーマの自動更新は1日2回程されているようですが、エラーのメールは届いていません。

やはりcronが動いていないと思われます。


   
(@treak)
Eminent Member Registered
結合: 12か月前
投稿: 20
Topic starter  

WP-Cron Status Checkerプラグインをインストールして、
cronのログを見てみました。
以下、結果
--------------------------------------------------
Hook Name         Time (ms)   Result
delete_expired_transients     12.5 COMPLETED
elm_plugin_emailerrors_hook   0.6 COMPLETED
elm_plugin_checklogfilesize_hook 0.5 COMPLETED
wp_version_check         1,982.7 COMPLETED
wp_update_plugins         2.4 COMPLETED
wp_update_themes        2.0 COMPLETED
wp_scheduled_delete       3.5 COMPLETED
sm_ping_daily           6.1 COMPLETED
--------------------------------------------------

Error Log Monitorプラグインをインストールしました。

エラーログの表示なし

 

その他、試した結果

PHP5.6の場合、

プラグイン更新が無くてもテーマ更新エラーメールが届く

PHP7.0以降の場合

テーマ更新だけの場合はエラーメールが届かないが、

プラグイン更新があった時だけ、テーマ更新エラーメールが届く

 


   
(@treak)
Eminent Member Registered
結合: 12か月前
投稿: 20
Topic starter  

mk2さん

 

投稿者:: @mk2_mk2

メールがきている件では動いていると思います。プラグインは更新されていますし。

ただし、何らかの原因で失敗していて、それがサーバーの制約等に抵触したのかなと、いくつか前にいただいた返信で思ったんですよね。

VALUESERVERに問い合わせたところ、以下のような回答が来ました。

-------------------------------------------------------------------

日頃より弊社サービスをご愛顧くださり、ありがとうございます。
お問い合わせの件について案内させていただきます。

弊社担当部門にて確認いたしましたところ、
サーバー側でテーマの自動更新のみを制限しているようなことはないため、
プラグインの自動更新が実行されている場合、 WordPress側の問題である可能性が考えられます。
お手数ですが、WordPressの設定の見直しなどを実施していただければ幸いです。

その他ご不明な点がございましたら、お気軽にお問い合わせください。

-------------------------------------------------------------------

サーバー側には問題はなさそうです。

wordpress設定のどこかを変更すると解決する可能性はあるのでしょうか?


   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 3年前
投稿: 6678
 

TREAKさん

スマホからですので、短めに。

投稿者:: @treak

サーバー側でテーマの自動更新のみを制限しているようなことはない

これは文字通り、「テーマの自動更新のみを抑止はしていない」というかとかと思います。

どのサーバーもきっと同じです。(ある意味、定例の回答)

今のところ、cronが動かずにいるのではないかという推測の状況に変化は特にないと思います。

(おそらく自動更新の時間帯に、閲覧者等のアクセスが必要だと思いますが、それだけなのかどうか。プラグインは更新されているようですので)


話は逸れるかもしれないですが。

予約投稿が失敗した際には、その時間帯の後に閲覧があれば、未実行のものを拾って動かずプラグインがあるみたいです。

しかし、テーマの自動更新には、それがあるのかどうか。

テーマの自動更新は、元々1日2回動くようですから、そういうものは必要ないということで、ないのかもしれません。

申し訳ないですが、今はWordPress 6.2 関連の確認に注力しており、細かいことは調べたり確認したりは、しておりません。

(WordPress 6.2の方も細かいところまで確認する時間がとれていないもので)

おそらくテーマの問題ではなさそうという可能性は、高くなっていると思います。(可能性ですけれど)


   
(@akira)
Famed Member Registered
結合: 6年前
投稿: 1644
 

自動更新をしたことがなかったため、ローカル環境でやってみました。結果は、自動更新ができなかったです。

ただ、親テーマの functions.php の 52 行目 を…

'wp-cocoon-theme'

親テーマのディレクトリ名に変更したところ、自動更新ができました。

'cocoon-master'

ただ、Plugin Update Checker を使ったこともないため、この変更が理由で自動更新ができたのか疑問に思っています。

Plugin Update Checker の説明 には、このように書かれてはいます。

The third argument - i.e. the slug - is optional but recommended. In most cases, the slug should be the same as the name of your plugin directory. For example, if your plugin lives in /wp-content/plugins/my-plugin, set the slug to my-plugin. If the slug is omitted, the update checker will use the name of the main plugin file as the slug (e.g. my-cool-plugin.php → my-cool-plugin). This can lead to conflicts if your plugin has a generic file name like plugin.php.

Google 翻訳:3 番目の引数 (スラッグ) はオプションですが、使用することをお勧めします。ほとんどの場合、slug はプラグイン ディレクトリの名前と同じにする必要があります。たとえば、プラグインが /wp-content/plugins/my-plugin にある場合、スラッグを my-plugin に設定します。スラッグを省略した場合、更新チェッカーはメインのプラグイン ファイルの名前をスラッグとして使用します (例: my-cool-plugin.php → my-cool-plugin)。プラグインに plugin.php のような一般的なファイル名がある場合、これにより競合が発生する可能性があります。

わいひらさん、私が行った第 3 引数の変更は関係あるでしょうか?


   
TREAK and わいひら reacted
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 3年前
投稿: 6678
 

Akiraさんが試してくださった通りみたいです。

これで良いのか分かりませんが、私は以下のように試してみました。
(サーバーのテスト環境です)

 


事前にテーマは自動更新にしておきます。
(プラグインは、手動のままです)


実行前は、Cocoonと、プラグインの更新がそれぞれ1件ずつ、計2件ある状態でした。

 

「WP Control」というプラグインで、cronを強制的に実行できるみたいです。
 そこで、「wp_version_check」を実行してみました。
 

その結果、一見すると、更新できるものの件数が、1件減りました。
 

しかし、「ダッシュボード」-「更新」を開くと、また2件に戻ってしまいました。
 Cocoonも、更新できていませんでした。
 
 
何回か試してみましたが、同じ感じでした。
 

 
続いて、Akiraさんがご教示くださったように、親テーマのfunctions.phpの52行目を修正しました。
そして、上記の①~④の手順を再度、実施してみました。
 
すると、Cocoonは更新されていました。

   
TREAK and わいひら reacted
わいひら
(@yhira)
Illustrious Member Admin
結合: 6年前
投稿: 16125
 

Akiraさんありがとうございます!
Plugin Update Checkerのスラッグが何かしらに影響するなんて考えてみたこともなかったです。
古いアップデートチェッカーの値をそのまま使用していました。
確かに説明を読むとそのように書いてありますね。

mk2さんも詳しく検証していただいてありがとうございます!
スラッグを変更しておきました。
------------------------------------------------
https://github.com/xserver-inc/cocoon
開発中の最新ファイルをダウンロードする場合は、上記ページのダウンロードボタンからzipファイルをダウンロードしてください。

WordPressでの手動アップデート方法はこちら
https://wp-cocoon.com/manual-update-of-cocoon-theme/
------------------------------------------------


   
TREAK reacted
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 3年前
投稿: 6678
 

ご対応いただきありがとうございます。

そうは言え、現時点では試すことができないので・・・、確認はしておりません。
(最新バージョンなので)

サーバーのテスト環境で、functions.phpを修正した状態にはしてあります。
自然体で動いたものを確認しようかと思って。

ただ、しばらくは動かないのと、テスト環境なものでアクセスが・・・

 

TREAKさんは、自動更新が基本みたいですので、しばらくそれで運用していただいて、次のバージョンアップ時に検証いただいて、その後ご連絡いただく感じでしょうか。

(FTP等ご使用できるのであれば、親テーマのfunctions.phpのみをアップロードして確認するのも一案かもですが)

 


   
わいひら reacted
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 3年前
投稿: 6678
 

サーバーのテスト環境に、今回ご対応いただいたバージョンのfunctions.phpだけをアップロードしていました。

自然体で自動更新が掛かるのを待っていたのですが、先程実行され、Cocoonがアップデートされていました。


   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 3年前
投稿: 6678
 

テーマが自動更新されると、メールが来るんですね。


   
わいひら reacted
(@treak)
Eminent Member Registered
結合: 12か月前
投稿: 20
Topic starter  

Akira さん

的確な回答ありがとうございます。

親テーマのfunctions.phpの52行目を変更しただけで、

無事にテーマの自動更新が出来ました。

感謝です!!

 

わいひらさん、MK2さん、皆さん

色々と調べて対応して頂き、ありがとうございます。

 

更新のメールも届いています。

 

以下のプラグインを更新しました:
- Shortcodes Ultimate (バージョン 5.12.9 から5.12.11へ) : https://wordpress.org/plugins/shortcodes-ultimate/&source=gmail&ust=1680205592671000&usg=AOvVaw1u1eaVKU_2qliQO1AlFYj U"> https://wordpress.org/plugins/shortcodes-ultimate/

以下のテーマを更新しました:
- Cocoon (バージョン2.5.7.11から2.5.8.2へ)

 


   
わいひら reacted
わいひら
(@yhira)
Illustrious Member Admin
結合: 6年前
投稿: 16125
 

mk2さん、TREAKさんご確認いただきありがとうございます!
今回は僕は何もしてないです。
僕の頭の中ではPlugin Update Checkerが怪しいなんて発想は一ミリもなかったので^^;
全てAkiraさんのご指摘のおかげです。改めて感謝申し上げます。


   
共有:

問題の解決に至った場合には、トピック冒頭の「解決済み」をクリックしていただけますと幸いです。

また、有用な回答があった場合は返信右下にある「いいね!」もご活用ください。回答者の励みになります。

「いいね!」機能はフォーラム登録者のみが利用できる機能です。

CC BY-ND 2.1)準じていれば(リンクを貼っていただければ)転載も自由です。カスタマイズ記事を書く際にコード等をコピペ利用していただいて構いません。

フォーラムの使い方がよくわからない場合は、テストトピックで自由にテストしていただいて構いません。

最近の書き込みはこちら。

詳細なカスタマイズ依頼をするならこちら。

タイトルとURLをコピーしました