Cocoonフォーラム

書き込みの前に以下の3点をご確認ください。
  1. 1つのトピックにつき1つの質問を書き込んでください
  2. 不具合・カスタマイズ対象ページのURLを提示高速化を無効にしてください
  3. 該当部分のキャプチャ・環境情報とともに書き込んでいただけると助かります

何を書き込んだら良いか分からない場合は、以下のテンプレートをコピペしてご利用ください。

不具合・カスタマイズ対象ページのURL:

相談内容:

不具合の発生手順:

解決のために試したこと:

※文字だけでは正しく伝わらない可能性があるため、スクショ画像の添付もお願いします。
※高速化設定をしている場合は無効にしてください。
環境情報:

※↑こちらに「Cocoon設定 → テーマ情報」にある「環境情報」を貼り付けてください。

環境情報の取得方法はこちら。
https://wp-cocoon.com/theme-report/
高速化設定を無効にするにはこちら。
https://wp-cocoon.com/theme-trouble/

フォーラム利用ガイドリンク

  1. フォーラムガイドライン
  2. よくある質問と答え(FAQ)
  3. サポート対象外のケース
  4. 原因不明の不具合用トラブルシューティング
  5. トピックにHTMLを貼り付ける方法(推奨ツール:notepad.pw
  6. 真っ白画面でのエラーメッセージの確認方法
  7. ブラウザ環境チェックツール
  8. Cocoonカスタマイズ依頼

フォーラム質問後、問題等が解決した場合は結果を書き込んでいただけると幸いです。同様の問題で調べている方には、結果が一番気になる部分となります。

サイトトップに設定した固定ページのアイ...
 
共有:
通知
すべてクリア

[解決済] サイトトップに設定した固定ページのアイキャッチ(&SNS画像)が反映されない

23 投稿
3 ユーザー
5 Likes
461 表示
 lady
(@lady)
Active Member Registered
結合: 2年前
投稿: 11
Topic starter  

お世話になります。

対象のURLはコチラです。

https://garasya-precious-home.com/

 

本日、ようやく体裁が整ってきたのでブログサイトを公開しようとしたところ、サイトのフロントページとして作成した固定ページからツイッターシェアしようとすると、画像が表示されていないことが分かりました。Twitterなどで拡散する際にアイキャッチを表示させるにはどうしたら良いでしょうか?)

思い当たる話としては…

フロントページではアイキャッチを表示させたくなかったので、

ページ用の追加CSSに

.eye-catch {
display: none;
}

と書き込んでいます。(グーグルで調べて入れ込みました。)
いじっているのはココのみです。

これが原因でアイキャッチ画像がツイッターに反映されていないのかもしれないと思い、
SNS用画像も設定しましたが変化なし。

またこちらのフォーラムで何度か似たような質問が上がっていたので参考にし、

・All in One SEO のツイッターカードを停止
・All in One SEO のプラグイン自体を無効化

しましたが、相変わらず画像なしになってしまいます。

※もともとはツイッターにURLを添付すると、固定ページ内で使用していない画像がなぜかアイキャッチのように出てきていたのですが、All in One SEOのツイッター機能を停止したところ無関係の画像は消えて、現在はイメージなしの状態になっています。

みなさまの知恵を貸して頂けますと幸いです。

 

以下、環境情報になります。

----------------------------------------------
サイト名:積水ハウスで洋風な家を建てる
サイトURL: https://garasya-precious-home.com
ホームURL: https://garasya-precious-home.com
コンテンツURL:/wp-content
インクルードURL:/wp-includes/
テンプレートURL:/wp-content/themes/cocoon-master
スタイルシートURL:/wp-content/themes/cocoon-child-master
親テーマスタイル:/wp-content/themes/cocoon-master/style.css
子テーマスタイル:/wp-content/themes/cocoon-child-master/style.css
WordPressバージョン:5.7.2
PHPバージョン:7.4.16
ブラウザ:Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/90.0.4430.212 Safari/537.36
サーバーソフト:LiteSpeed
サーバープロトコル:HTTP/1.1
エンコーディング:gzip, deflate, br
言語:ja,en-US;q=0.9,en;q=0.8
----------------------------------------------
テーマ名:Cocoon
バージョン:2.2.9
カテゴリ数:15
タグ数:29
ユーザー数:1
----------------------------------------------
子テーマ名:Cocoon Child
バージョン:1.1.2
style.cssサイズ:918バイト
functions.phpサイズ:203バイト
----------------------------------------------
Gutenberg:1
AMP:0
PWA:0
Font Awesome:4
Auto Post Thumbnail:1
Retina:0
ホームイメージ:/wp-content/uploads/2021/05/cropped-cropped-ヘッダー.png
----------------------------------------------
ブラウザキャッシュ有効化:0
HTML縮小化:0
CSS縮小化:0
JavaScript縮小化:0
Lazy Load:0
WEBフォントLazy Load:0
----------------------------------------------
利用中のプラグイン:
Advanced Editor Tools (previously TinyMCE Advanced) 5.6.0
Akismet Anti-Spam 4.1.9
All in One SEO 4.1.1
BackWPup 3.8.0
Contact Form 7 5.4.1
Intuitive Custom Post Order 3.1.3
Invisible reCaptcha 1.2.3
Regenerate Thumbnails 3.1.5
Table of Contents Plus 2002
WordPress Popular Posts 5.3.2
WP Fastest Cache 0.9.1.8
WP Multibyte Patch 2.9
WP Social Bookmarking Light 2.0.7
----------------------------------------------

This topic was modified 2年前 by lady

   
(@yamachan11)
Reputable Member Registered
結合: 3年前
投稿: 303
 
 lady さん
おはようございます。
 
きっとキャッシュか何かの関係ではないでしょうか?
 
只今、該当ページを拝見したところ
 
異常はない様です。
 
 Topの画像も、SNSの画像も正常に表示されています。
 
一度、ブラウザのキャッシュをクリアされたら如何でしょうか?
 
This post was modified 2年前 by Yamachan11

   
わいひら reacted
 lady
(@lady)
Active Member Registered
結合: 2年前
投稿: 11
Topic starter  

ご回答ありがとうございます。今、キャッシュをクリアしてみたのですが…

ツイートしようとすると添付画像のようになってしまうんです。

初期段階に戻ってしまいました泣

ちなみに表示させたい画像は、サイトトップのロゴに似たもので…添付しましたが、こちらをアイキャッチやSNS用画像に設定しても反映されないのです。

This post was modified 2年前 2回 by lady

   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4733
 

ladyさん

ちょっと良く分からないところですが。。。

「WP Fastest Cache」が有効であれば、一旦無効化していただけますでしょうか。


   
 lady
(@lady)
Active Member Registered
結合: 2年前
投稿: 11
Topic starter  

今、WP Fastest Cacheを無効化いたしました!

ちなみにですが、cocoon設定の、アイキャッチの自動化にチェックが入っていたので先ほど取り消しました。

その上で、cocoonのキャッシュを全て削除しています。

しかし変化なしです。。

This post was modified 2年前 by lady

   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4733
 

ladyさん

変化なしですね。

WP Fastest Cache」を無効化する前と、ソースコードも同じでした。


   
 lady
(@lady)
Active Member Registered
結合: 2年前
投稿: 11
Topic starter  

ご確認ありがとうございます。

赤い枠で囲ってくださった部分、画像を更新してもそのまま変わらずで…

無知ながらに、「ヘッダー」と日本語が入っているのがいけないのかなと思い、

固定ページ内のアイキャッチ画像・SNS用画像のリンクを英語表記に編集したのですが反映されてないんです。。


   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4733
 

ladyさん

難しいですね。

可能性としては「All in One SEO」だと思うのですが、こちらもTwitterカードは停止になさったとのことですよね


   
 lady
(@lady)
Active Member Registered
結合: 2年前
投稿: 11
Topic starter  

現状オフになっているはずです。。

固定ページのアイキャッチを表示させない追加CSSがいけないのでしょうか…でもアイキャッチを表示させたくないので…。


   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4733
 

ladyさん

難しいですね。

CSSは関係ないと思います。
CSSで消しても、ソースから消える訳ではないので。


   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4733
 

もしかすると、Twitterbotが弾かれているのかと、robots.txtを確認しましたが、問題なさそうでした。

海外からのアクセスも確認してみましたが、おそらく問題ないです。

うーん、なんでしょうね。。。
基本中の基本を見逃しているのか。。。。

 

申し訳ないですが、一旦離脱します。


   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4733
 

ladyさん

投稿者:: @lady

固定ページ内のアイキャッチ画像・SNS用画像のリンクを英語表記に編集したのですが反映されてないんです。。

この部分ですが。

Cocoon設定 ⇒ OGP ⇒ ホームイメージも、同様に英数ファイル名のファイルに変更はなさっていますでしょうか。

 

といいつつ、ちょっと外出してしまいます。


   
 lady
(@lady)
Active Member Registered
結合: 2年前
投稿: 11
Topic starter  

ホームイメージを変更したところ、変わっておりました!

ものは試しに…と、アイキャッチを表示しない追加CSSを除いてみたら、サイトトップにももちろん表示されてしまいますがツイッターにはしっかり反映されていました。

これが原因なのでしょうか…。トップページには表示させないという理想は諦めるしかないですかね。。


   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4733
 

ladyさん

ソースでも変わりました。

CSSは関係ないと思うのですが。

該当固定ページのカスタムCSSに追加して、終わったら教えてください。
確認します。


   
 lady
(@lady)
Active Member Registered
結合: 2年前
投稿: 11
Topic starter  

今、また追加CSSを入れました。サイト上では表示されていません。

加えたCSSは

.eye-catch {
  display: none;
}
です

   
 lady
(@lady)
Active Member Registered
結合: 2年前
投稿: 11
Topic starter  

ツイートしようとしましたが、やはりダメになってます汗


   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4733
 

ladyさん

結果的にはすべて問題なしです。

 

トップページから、アイキャッチが消えました。
(見た目上は。)

 
 
カスタムCSSにアイキャッチを非表示にするコードも確認しました。
 
 
この状態で、Twitterカード用の画像もソースに出ています。
 
 
Twitterカード自体も問題なしです。

   
わいひら and lady reacted
 lady
(@lady)
Active Member Registered
結合: 2年前
投稿: 11
Topic starter  

ご確認ありがとうございます。

PCでツイッターに添付しようとしたところno imageになるのですが

スマホで拡散しようとしてみたら無事画像が表示されています!!

 

今改めてCard validatorにかけてみたら

何故かわかりませんがしっかり表示されるようになりました!!

さっきまでno imageだったのはなんなんだ…

理由はわからないですが表示されるようになっています!


   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4733
 

ladyさん

問題ないはずです。

Tweetしようとした段階では、分からないです。
Tweetしてみてください。

Twitterカード確認でも、問題ないです。


   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4733
 

ladyさん

Tweetしようとした段階では、ladyさんのブラウザにキャッシュが残っていることも考えられますから。

とりあえず、解決ですね。


   
 lady
(@lady)
Active Member Registered
結合: 2年前
投稿: 11
Topic starter  

いまやってみました。無事に反映されています!
何が功を奏したんでしょうか…でも良かったです。

知恵と時間を沢山いただき、ありがとうございます。

今回オフにしたプラグインは、今後も使用しないほうが良いですか?(WP Fastest Cacheなど)


   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4733
 

ladyさん

おそらく最後のホームイメージの変更が効いたと思います。
基本中の基本でした。。。

「WP Fastest Cache」については、有効にしてもかまいません。

Cocoonに限らず、ブログの設定に関する項目を変更する場合は、1度無効化するなり、「WP Fastest Cache」に関するキャッシュをクリアすることをお勧めします。

変更しても、ずっとページキャッシュが表示されてしまうんだと思います。

 

ただ、ページキャッシュに関するトラブルは多いです。
機能をご理解の上のご使用をお勧めします。

個人的には、万単位以上のPV/日がない限りは、本来の効果を発揮しないのかな…という気はします。
通常のレンタルサーバーをご利用の場合は。
(だからと言って、無意味ではないです。)


   
わいひら and lady reacted
 lady
(@lady)
Active Member Registered
結合: 2年前
投稿: 11
Topic starter  

丁寧な説明をいただき、ありがとうございます。

一度無効化することを忘れずにいきたいと思います。

万PVなんて夢のまた夢なので寝かせておきます…!トラブルも怖いです汗


   
共有:

問題の解決に至った場合には、トピック冒頭の「解決済み」をクリックしていただけますと幸いです。

また、有用な回答があった場合は返信右下にある「いいね!」もご活用ください。回答者の励みになります。

「いいね!」機能はフォーラム登録者のみが利用できる機能です。

CC BY-ND 2.1)準じていれば(リンクを貼っていただければ)転載も自由です。カスタマイズ記事を書く際にコード等をコピペ利用していただいて構いません。

フォーラムの使い方がよくわからない場合は、テストトピックで自由にテストしていただいて構いません。

最近の書き込みはこちら。

詳細なカスタマイズ依頼をするならこちら。

タイトルとURLをコピーしました