「メイド・イン・ヘブン」スキン適用中

Cocoonフォーラム

サイト内検索
書き込みの前に以下の3点をご確認ください。
  1. 1つのトピックにつき1つの質問を書き込んでください
  2. 不具合・カスタマイズ対象ページのURLを提示高速化を無効にしてください
  3. 該当部分のキャプチャ・環境情報とともに書き込んでいただけると助かります

何を書き込んだら良いか分からない場合は、以下のテンプレートをコピペしてご利用ください。

不具合・カスタマイズ対象ページのURL:

相談内容:

不具合の発生手順:

解決のために試したこと:

※文字だけでは正しく伝わらない可能性があるため、スクショ画像の添付もお願いします。
※高速化設定をしている場合は無効にしてください。
環境情報:

※↑こちらに「Cocoon設定 → テーマ情報」にある「環境情報」を貼り付けてください。

環境情報の取得方法はこちら。
https://wp-cocoon.com/theme-report/
高速化設定を無効にするにはこちら。
https://wp-cocoon.com/theme-trouble/

フォーラム利用ガイドリンク

  1. フォーラムガイドライン
  2. よくある質問と答え(FAQ)
  3. サポート対象外のケース
  4. 原因不明の不具合用トラブルシューティング
  5. トピックにHTMLを貼り付ける方法(推奨ツール:notepad.pw
  6. 真っ白画面でのエラーメッセージの確認方法
  7. ブラウザ環境チェックツール
  8. Cocoonカスタマイズ依頼

フォーラム質問後、問題等が解決した場合は結果を書き込んでいただけると幸いです。同様の問題で調べている方には、結果が一番気になる部分となります。

アイキャッチ画像項目が突然消えて困って...
 
共有:
通知
すべてクリア

アイキャッチ画像項目が突然消えて困っています。助けて下さい。

19 投稿
4 ユーザー
11 Reactions
295 表示
(@takashi)
Active Member Registered
結合: 1年前
投稿: 10
Topic starter  

不具合・カスタマイズ対象ページのURL https://everydaylife1.com

相談内容:投稿編集でアイキャッチ画像の項目が突然表示されなくなりました。アイキャッチの自動設定をしたら、サイト内の画像が貼り付けられ、チェックを外してもnoimageにも戻りません。

付随してか、Word Pressアプリにも連携できなくなりました。

不具合の発生手順:投稿編集でURLのパーマリンクを編集していました。cocoon設定の高速化もしたあたりで、プラグインのConverter for Mediaがちょうどバージョンアップしていたかと思います。

 

解決のために試したこと:プラグインの全無効化、cocoon削除と再インストール、Functions.phpファイルにadd theme support ('post-thumbnails');の追加、

cocoon設定の「全体」と「画像」のチェック項目投稿編集の表示オプションのチェック項目は確認しました。

 

文字だけでは正しく伝わらない可能性があるため、スクショ画像の添付もお願いします。


高速化設定をしている場合は無効にしてください。はい、無効にしました


環境情報:

----------------------------------------------

サイト名:新米夫婦の、子育て、節約、資産運用始めました。

サイトURL https://everydaylife1.com

ホームURL https://everydaylife1.com

コンテンツURL/wp-content

インクルードURL/wp-includes/

テンプレートURL/wp-content/themes/cocoon-master

スタイルシートURL/wp-content/themes/cocoon-child-master

親テーマスタイル:/wp-content/themes/cocoon-master/style.css

子テーマスタイル:/wp-content/themes/cocoon-child-master/style.css

スキン:/wp-content/themes/cocoon-master/skins/skin-tegakinote-blue-coral/style.css

WordPressバージョン:6.2.2

PHPバージョン:7.4.33

ブラウザ:Mozilla/5.0 (iPhone; CPU iPhone OS 16_4_1 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/16.4 Mobile/15E148 Safari/604.1

サーバーソフト:Apache

サーバープロトコル:HTTP/1.1

言語:ja

----------------------------------------------

テーマ名:Cocoon

バージョン:2.6.0.3

カテゴリー数:7

タグ数:0

ユーザー数:1

----------------------------------------------

子テーマ名:Cocoon Child

バージョン:   1.1.3

style.cssサイズ:1508バイト

functions.phpサイズ:203バイト

----------------------------------------------

Gutenberg1

AMP0

PWA0

Font Awesome5

Auto Post Thumbnail0

Retina1

ホームイメージ:/wp-content/themes/cocoon-master/screenshot.jpg

----------------------------------------------

ブラウザキャッシュ有効化:1

HTML縮小化:0

CSS縮小化:0

JavaScript縮小化:0

Lazy Load1

----------------------------------------------

利用中のプラグイン:

Akismet Anti-Spam 5.1

BackWPup 4.0.0

Broken Link Checker 2.1.0

Contact Form 7 5.7.6

Converter for Media 5.9.1

Media File Renamer: Rename Files (Manual, Auto & AI) 5.6.2

SiteGuard WP Plugin 1.7.5

WP Fastest Cache 1.1.5

WP Multibyte Patch 2.9

XML Sitemap & Google News 5.3.3

----------------------------------------------


   
引用
chu-ya
(@chu-ya)
Famed Member Registered
結合: 2年前
投稿: 2411
 

投稿者:: @takashi

投稿編集でアイキャッチ画像の項目が突然表示されなくなりました。アイキャッチの自動設定をしたら、サイト内の画像が貼り付けられ、チェックを外してもnoimageにも戻りません。

●Gutenbergエディターの「アイキャッチ画像を設定」パネル

「アイキャッチ画像」がオンになっていますか?

  1. 図①をクリック
  2. 図②「設定」をクリック
  3. 「パネル」をクリック

●画像
[Cocoon設定]→[画像]→アイキャッチの自動設定「アイキャッチ自動設定を有効にする」
 
オンの状態でページ編集を保存
書かれてるとおりページ内の先頭画像がアイキャッチ画像に設定(記事の情報として保存)されます。
この為、チェックをオフにしても、noimageには戻りません

   
わいひら reacted
返信引用
(@takashi)
Active Member Registered
結合: 1年前
投稿: 10
Topic starter  

コメントありがとうございます。

そのアイキャッチ画像項目も出てこない状態です。

とにかく、通常通りアイキャッチ画像を貼り付けれる状態に戻したいのですが、可能でしょうか?


   
返信引用
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 3年前
投稿: 7225
 

 

TAKASHIさん

ダメ元&念のためですが、2つほどお願いがあります。

投稿者:: @takashi

WP Fastest Cache 1.1.5

上記を無効化していただけますでしょうか。

キャッシュされた状態しか確認できず、現在もHTML等が縮小化されて見えるためです。
(今回は、管理画面内の事象ですので関係ないと思うのですが、念のためです)

 

以下の手順で、Cocoonの親テーマを手動でアップデートしていただけますでしょうか。
(同じバージョンでも、更新してみてください)

Cocoonテーマファイルを手動でアップデートする方法
https://wp-cocoon.com/manual-update-of-cocoon-theme/

 

以下の公式サイトからダウンロードした親テーマで構いません。

テーマのダウンロード
https://wp-cocoon.com/downloads/

ダメ元ですけれど。

 


上記でも改善されない場合、

  1. 親テーマを有効にしてみる
  2. WordPress公式テーマ(※)を有効にしてみる

 
上記1や2でも、同様の事象が発生するかご確認いただけますでしょうか。

※テーマ名が、英語の西暦のもの(「Twenty Twenty-One」など)

 


ちなみに別件ですが・・・。

コメント欄のSiteGuardの画像認証の画像が、何故か404になって表示されないようです。
他にも何か起きているのかもしれません。


   
わいひら reacted
返信引用
(@takashi)
Active Member Registered
結合: 1年前
投稿: 10
Topic starter  

mk2さん、コメントありがとうございます。

WP Fastest Cacheを無効化にして、Cocoonの親テーマを手動でアップデートしましたが、ダメでした。

その後、テーマをTwenty Twenty-Oneに変更してみましたが、それもダメでした。

指摘ありがとうございます。違う場所まで設定がおかしくなっているみたいですね。

ちなみに、私はブログを始めたばかりで、立ち上げは他の人のサイトを見て真似ただけなので、サイト設定をよくわかっていません。

特に中身をいじるような事はしていないのですが、原因はなんなのでしょうか?


   
返信引用
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 3年前
投稿: 7225
 

TAKASHIさん

投稿者:: @takashi

原因はなんなのでしょうか?

原因が分かるのであれば、既に皆さんご指摘くださっていると思います。(分かれば既に解決している)

今は原因が分からないため、可能性を絞り込んでいる感じです。

(SiteGuardの画像は、キャッシュプラグインが原因だったと思われます。設定変更したのに、キャッシュクリアされていないものと推測します)

 

今まで試した感じでは、プラグインやテーマではないのかもしれないです。

ダッシュボードから、WordPressの更新をしてみても、良いと思います。(同じバージョンだとしても)

他のことをしながら、スマホから書き込んでいるので、画像添付は難しいです。


   
わいひら reacted
返信引用
わいひら
(@yhira)
Illustrious Memberサイト Admin
結合: 6年前
投稿: 16663
 

こちらのトラブルシューティングプラグインをインストールしてトラブルシューティングモードにするとどうなりますか?
https://nelog.jp/health-check-and-troubleshooting-plugin


   
返信引用
(@takashi)
Active Member Registered
結合: 1年前
投稿: 10
Topic starter  

@mk2_mk2 

mk2さん、ありがとうございます。

そうですよね、分からないから皆さん協力して頂いているんですよね。

Word Pressを再インストールしてみましたが、ダメでした。

 


   
返信引用
(@takashi)
Active Member Registered
結合: 1年前
投稿: 10
Topic starter  

@yhira 

わいひらさん、ありがとうございます。

トラブルシューティングモードに出来たと思いますが、この後の設定はありますでしょうか?


   
返信引用
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 3年前
投稿: 7225
 

TAKASHIさん

WordPressを再インストールしてもダメですか・・・。

投稿者:: @takashi

トラブルシューティングモードに出来たと思いますが、この後の設定はありますでしょうか?

まずは、全プラグインの停止を試してみると良いと思います。
(もしかすると、既に全停止になっているかも)

その状況で、編集画面を開いて、今回の事象が発生しているのかをご確認いただければと。

それでも、ダメなら、プラグイン全停止に加えて、WordPress公式テーマに変更。
それで確認でしょうか。


   
わいひら reacted
返信引用
(@takashi)
Active Member Registered
結合: 1年前
投稿: 10
Topic starter  

mk2さん、ありがとうございます。

プラグインは停止になっており、Twenty Twenty-Oneに変更しましたが、ダメみたいです。協力ありがとうございます。


   
返信引用
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 3年前
投稿: 7225
 

TAKASHIさん

その状態で、設定パネルを開いても、アイキャッチはない状態でしょうか。
(設定パネルのアイキャッチは、1番最後に開きますので、少し時間をおくと良いかもしれません)


   
わいひら reacted
返信引用
(@takashi)
Active Member Registered
結合: 1年前
投稿: 10
Topic starter  

@mk2_mk2 

mk2さん、返答ありがとうございます。

変わらずアイキャッチはでませんね。


   
返信引用
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 3年前
投稿: 7225
 

TAKASHIさん

うーん、それで出ないとなると、厳しいですね。

iPhoneで操作なさっているかと思いますが、例えばAndroidだったり、PCの環境で、ご確認はできますでしょうか。


   
わいひら reacted
返信引用
(@takashi)
Active Member Registered
結合: 1年前
投稿: 10
Topic starter  

@mk2_mk2 

mk2さん、遅くまでありがとうございます。

すみません、iPhoneしか持っていなくて他で確認できない状況です。

   
返信引用
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 3年前
投稿: 7225
 

TAKASHIさん

そうですか。

では、iPhoneに他のブラウザをインストールして、ご確認いただくことはできますでしょうか。
(ChromeやEdgeなど)


   
わいひら and TAKASHI reacted
返信引用
(@takashi)
Active Member Registered
結合: 1年前
投稿: 10
Topic starter  

@mk2_mk2 

mk2さん!出来ました!!

Chromeで開いたらアイキャッチ画像の項目ありました!

諦めずにご協力いただきありがとうございます。本当に助かりました。

 


   
わいひら reacted
返信引用
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 3年前
投稿: 7225
 

TAKASHIさん

ありますか。

そうだとすると、Safariが何かをブロックしているかもしれないです。

WordPress側の問題ではなく、Safariの、設定なのか・拡張機能なのか、何かだと思います。

聞いたことはありませんが・・・。
広告ブロック的なものって、ありますか?
あれば無効化して確認してみても良いかもしれないです。


   
わいひら and TAKASHI reacted
返信引用
(@takashi)
Active Member Registered
結合: 1年前
投稿: 10
Topic starter  

@mk2_mk2 

mk2さん、ありがとうございます。

Safari側の原因なんてこともあるんですね。

わかりました。もう少し調べてみたいと思います!

 


   
返信引用
共有:

問題の解決に至った場合には、トピック冒頭の「解決済み」をクリックしていただけますと幸いです。

また、有用な回答があった場合は返信右下にある「いいね!」もご活用ください。回答者の励みになります。

「いいね!」機能はフォーラム登録者のみが利用できる機能です。

CC BY-ND 2.1)準じていれば(リンクを貼っていただければ)転載も自由です。カスタマイズ記事を書く際にコード等をコピペ利用していただいて構いません。

フォーラムの使い方がよくわからない場合は、テストトピックで自由にテストしていただいて構いません。

最近の書き込みはこちら。

詳細なカスタマイズ依頼をするならこちら。

タイトルとURLをコピーしました