Cocoonフォーラム

書き込みの前に以下の3点をご確認ください。
  1. 1つのトピックにつき1つの質問を書き込んでください
  2. 不具合・カスタマイズ対象ページのURLを提示高速化を無効にしてください
  3. 該当部分のキャプチャ・環境情報とともに書き込んでいただけると助かります

何を書き込んだら良いか分からない場合は、以下のテンプレートをコピペしてご利用ください。

不具合・カスタマイズ対象ページのURL:

相談内容:

不具合の発生手順:

解決のために試したこと:

※文字だけでは正しく伝わらない可能性があるため、スクショ画像の添付もお願いします。
※高速化設定をしている場合は無効にしてください。
環境情報:

※↑こちらに「Cocoon設定 → テーマ情報」にある「環境情報」を貼り付けてください。

環境情報の取得方法はこちら。
https://wp-cocoon.com/theme-report/
高速化設定を無効にするにはこちら。
https://wp-cocoon.com/theme-trouble/

フォーラム利用ガイドリンク

  1. フォーラムガイドライン
  2. よくある質問と答え(FAQ)
  3. サポート対象外のケース
  4. 原因不明の不具合用トラブルシューティング
  5. トピックにHTMLを貼り付ける方法(推奨ツール:notepad.pw
  6. 真っ白画面でのエラーメッセージの確認方法
  7. ブラウザ環境チェックツール
  8. Cocoonカスタマイズ依頼

フォーラム質問後、問題等が解決した場合は結果を書き込んでいただけると幸いです。同様の問題で調べている方には、結果が一番気になる部分となります。

アイキャッチ画像が自動反映されない件に...
 
共有:
通知
すべてクリア

[解決済] アイキャッチ画像が自動反映されない件について

17 投稿
4 ユーザー
26 Likes
120 表示
yoshiken
(@yoshiken)
Active Member Registered
結合: 2か月前
投稿: 4
Topic starter  

初めて投稿します。WPは始めたばかりでCOCOONには助けて頂いています。有難うございます。
COCOONの設定でアイキャッチ自動設定があることを最近しったのですが、有効にしても新規投稿の
アイキャッチ画像が設定されず困っており、アドバイス頂けたくよろしくお願いします。

投稿内容の画像や本文は、外部のWEBサイトからのコピペです。
コピペした画像はメディアライブラリにも反映されていないので、それが原因なのかもしれないのですが対応方法が分からずご質問した次第です。

■添付キャプチャ画像について
一番上の投稿が今回自動反映できていない投稿をリスト表示した際のキャプチャです。
他の投稿は手動で画像をアップロード・アイキャッチ画像の設定をしています。

どうぞよろしくお願いします。

----------------------------------------------
サイト名:Mickey31
サイトURL: https://mickey31.synology.me/wordpress
ホームURL: https://mickey31.synology.me/wordpress
コンテンツURL:/wp-content
インクルードURL:/wp-includes/
テンプレートURL:/wp-content/themes/cocoon-master
スタイルシートURL:/wp-content/themes/cocoon-child-master
親テーマスタイル:/wp-content/themes/cocoon-master/style.css
子テーマスタイル:/wp-content/themes/cocoon-child-master/style.css
サーバー:240f:34:cccc:1:b167:6f92:a2ab:3e09
WordPressバージョン:5.8.3
PHPバージョン:7.4.9
ブラウザ:Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/105.0.0.0 Safari/537.36
サーバーソフト:Apache/2.4.43 (Unix)
サーバープロトコル:HTTP/1.1
エンコーディング:gzip, deflate, br
言語:ja-JP,ja;q=0.9,en-US;q=0.8,en;q=0.7,id;q=0.6
----------------------------------------------
テーマ名:Cocoon
バージョン:2.4.9
カテゴリ数:6
タグ数:48
ユーザー数:2
----------------------------------------------
子テーマ名:Cocoon Child
バージョン:1.1.3
style.cssサイズ:2017バイト
functions.phpサイズ:4550バイト
----------------------------------------------
Gutenberg:0
AMP:0
PWA:0
Font Awesome:4
Auto Post Thumbnail:1
Retina:0
ホームイメージ:
----------------------------------------------
ブラウザキャッシュ有効化:0
HTML縮小化:0
CSS縮小化:0
JavaScript縮小化:0
Lazy Load:0
WEBフォントLazy Load:0
----------------------------------------------
利用中のプラグイン:
Admin Columns 4.4.5
Advanced Editor Tools (previously TinyMCE Advanced) 5.6.0
Better Search Replace 1.4.1
CMS Tree Page View 1.6.6
Content Views 2.4.0.7
Display Posts 3.0.2
Easy Footnotes 1.1.6
Elementor 3.7.7
Everest Tab Lite 2.0.5
Health Check & Troubleshooting 1.5.0
Hello Dolly 1.7.2
List Pages Shortcode 1.7.4
Nested Pages 3.2.0
Responsive Accordion And Collapse 2.3.6
Search Regex 3.0.6
Shortcodes Ultimate 5.12.0
Simple Tooltips 2.1.3
Table of Contents Plus 2106
TablePress 1.14
Tabs Responsive 2.3.2
WP Add Mime Types 3.0.3
WP RSS Aggregator 4.21.1
WP show more 1.0.7
WP Tabs 2.1.14
Yoast Duplicate Post 4.4
----------------------------------------------


   
トピックタグ
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4441
 

yoshikenさん

対象のページのURLをご提示いただけますと、助かります。

とりあえず、以下のページを閲覧しました。

月別アーカイブ
https://mickey31.synology.me/wordpress/2022/09/

投稿ページ
https://mickey31.synology.me/wordpress/2022-09-21%e3%80%80%e3%80%8c%e6%9d%b1%e6%80%a5%e7%b7%9a%e6%97%a5%e5%90%89%e9%a7%85%e3%81%abai%e3%82%ab%e3%83%95%e3%82%a7%e3%83%ad%e3%83%9c%e3%83%83%e3%83%88%e3%80%8croot-c%e3%80%8d%e3%82%92%e8%a8%ad/

 

上記投稿ページのアイキャッチには、外部サイトの画像が設定されているようです。

アイキャッチ画像のURL(直リンクになってしまうため、途中にスペースを入れてあります)
https ://prcdn.freetls.fastly.net/release_image/46923/46/46923-46-071d898d6a8de0d4fbf758c7e894ad2e-1200x700.jpg?format=jpeg&auto=webp&quality=85%2C75&width=1950&height=1350&fit=bounds

Cocoonの仕様がどうなのか・・・というのは、はっきりとお答えできないですが、外部サイトのものは一覧には反映されないのかもしれないです。

 

フォーラムの過去トピックに以下のようなものがありましたので、ご参考までに。

記事一覧のアイキャッチ画像のリンク先を外部のurlにしたい。
https://wp-cocoon.com/community/postid/40552/

 

投稿中の画像も、外部の画像のようですね。
通常は、自サイト内の画像を添付すると思うのですが・・・。


   
わいひら reacted
Akira
(@akira)
Noble Member Registered
結合: 5年前
投稿: 1179
 

その投稿ページの編集ページで「更新」するとどうなるでしょうか?

私の環境では、Cocoon 設定 > 画像タブで「アイキャッチ自動設定を有効にする」を有効後に、投稿ページを更新したら表示されました。

2022.09.21 「東急線日吉駅にAIカフェロボット「root C」を設置。9月21日より営業開始。」 と同じ画像を使いました。

This post was modified 2か月前 by Akira

   
chu-ya
(@chu-ya)
Noble Member Registered
結合: 8か月前
投稿: 623
 
投稿者:: @akira

私の環境では、Cocoon 設定 > 画像タブで「アイキャッチ自動設定を有効にする」を有効後に、投稿ページを更新したら表示されました。

この画像ですがメディアに登録された画像でなく外部URLの画像(メディアに存在しない)となっています。

●補足
アイキャッチ自動設定は、メディア登録されている画像を、投稿本文に貼り付けた際、一番目の画像がアイキャッチとなります。

 
Akiraさん
本当だ!gutenbergで外部URLを指定したら表示されました。申し訳ありません。
見たら外部URLからメディアに取り込まれる?!
言い訳笑、旧エディタでタグ入力しているので...
以下の一文で、単にHTMLをコピペしたので、ダメなのでは。
投稿内容の画像や本文は、外部のWEBサイトからのコピペです。

   
Akira
(@akira)
Noble Member Registered
結合: 5年前
投稿: 1179
 

@chu-ya さん

外部 URL で試しています。

auto_post_thumbnail_image() を確認すると、アクションフックで実行されています。

https://github.com/xserver-inc/cocoon/blob/master/lib/auto-post-thumbnail.php#L128-L138

そのため、「アイキャッチ自動設定を有効にする」を有効後に、記事を公開したり更新したりしないと本文の最初の画像がアイキャッチ画像にはならないと思います。ですので、更新を試していただきたいなと思いました。

This post was modified 2か月前 2回 by Akira

   
yoshiken
(@yoshiken)
Active Member Registered
結合: 2か月前
投稿: 4
Topic starter  

Akiraさん、Chu-ya
コメント有難うございました。
私も初めて認識したのですが、画像は外部URLになっていてそのためにうまく反映されないみたいですね。
Akirasさんのコメントにありました更新をした場合も試してみましたが、アイキャッチ画像には反映されましせんでした。

本来は別投稿で質問するべきかもしれないですが、外部サイトの画像・本文を投稿にコピペで使用する場合に外部URL参照にならない(=画像データもUPされる)ような方法やプラグインなどはあればご教示頂きたいです。
どうぞよろしくお願いします。


   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4441
 

ちなみに、私もAkiraさんの方法を試してみましたが、反映されませんでした。
(ローカル環境ですが)

でも、上手くいっている方もいらっしゃる訳ですから、何かが違うのだろうと思いつつ、原因は良く分からず・・・です。
(明日にでも、また試してみます)


   
chu-ya
(@chu-ya)
Noble Member Registered
結合: 8か月前
投稿: 623
 

図示したようにgutenbergエディターでできました。
URLから挿入すると、指定した画像が、メディアに登録され。

投稿者:: @yoshiken

外部サイトの画像・本文を投稿にコピペで使用する

上記の件ですが、転載にあたり、著作権違反に該当しませんか?


   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4441
 

できました。

ちょっとクセがあります。
長くなります。(4パターン試しました)

エディタは、ブロックエディタを使用しています。

親テーマにして、アイキャッチの設定は以下にしました。
(カスタマイズ等の影響を排除するため、親テーマにしました。)

 
 
そして、本文については、yoshikenさんのサイトからHTMLをコピーさせていただき、それを貼りつけました。
 

 
パターン①
 
HTMLを貼りつけましたので、「クラシック」ブロックです。
その結果、アイキャッチは設定されませんでした。
 
 
 

 
パターン②
 
「クラシック」ブロックなのが、良くないのかと考えました。
 
そして、本文の先頭に「画像」ブロックを設置しました。
「URLから挿入」を使用しましたが、URLについては、yoshikenさんのサイトのものを画像拡大して、そのURL欄全てを入力していました。
 
つまり、以下のようにパラメータが付いている状態です。(直リンクにならないよう、途中にスペースを挿入しています。)
 
https ://prcdn.freetls.fastly.net/release_image/46923/46/46923-46-071d898d6a8de0d4fbf758c7e894ad2e-1200x700.jpg?format=jpeg&auto=webp&quality=85%2C75&width=1950&height=1350&fit=bounds
 
 
しかし、結果は変わらず。
投稿にも、インデックスにも、アイキャッチは表示されませんでした。
 
 
 

パターン③

パターン②の「画像」ブロックのURLから、パラメータ部分を削除してみました。

つまり、以下のようなURLです。

https ://prcdn.freetls.fastly.net/release_image/46923/46/46923-46-071d898d6a8de0d4fbf758c7e894ad2e-1200x700.jpg

 

すると、アイキャッチ、インデックスに反映されました。

 
 

 
パターン④
 
バターン①の状態に戻しました。
 
つまり、yoshikenさんのサイトからHTMLをコピーさせていただいた状態で、「クラシック」ブロックを使用しています。
 
パターン①からの変更点は、本文の画像のURLから、パラメータ部分を削除するということです。
(.jpgの後ろの「?format=jpeg~」以降を削除)
 
すると、HTMLをコピーした「クラシック」ブロックのままでも、投稿・インデックスに反映されました。
 
 
本文中の画像(最初の画像)にパラメータがあると反映されないのかもしれないです。
(yoshikenさんのサイトと同様に、アイキャッチはあるけれど、display-noneの状態で、インデックスにサムネイルも出てこない)
 

   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4441
 

先の返信が長くなりましたので、ちょっとした疑問点をこちらに書いておこうと思います。

ただ、只今スマホなもので、確認ができなく、記憶が曖昧な部分もあります。

 

yoshikenさんのサイトも、投稿ページのアイキャッチは設定されていたと思います。

ただし、display-noneの状態で、投稿ページでは目に見える形では表示されていない状態。

この状態でも、本来インデックスカードには、アイキャッチのサムネイルが表示されるはずなのでは?

そこが疑問点です。(試すことができず、曖昧です)

yoshikenさんのサイトは、カードのサムネイルは「NO IMAGE」になってしまっています。

そこが問題なのかなという気がします。

外部URLの画像であっても、画像URLのパラメータ部分を削除すれば、反映されるようですし。

 

変なことを言っていたら、すみません。


   
yoshiken
(@yoshiken)
Active Member Registered
結合: 2か月前
投稿: 4
Topic starter  

@chu-ya さん
著作権についてのコメント有難うございます。
著作権については詳しく調べているわけではありませんが、私が作成しているWPは外部へ配信目的ではなく個人のメモ用のために作成しており、著作権の問題には該当しないと考えております。

配信用目的ではないので外部からアクセスできないようパスワードをかけていたのですが、皆さん普通にアクセスされているようなのでびっくりしているところです。^^;
多分どこかの設定が間違いか、そもそものアクセス権の概念を間違って理解していそうなのでそこは勉強します。
有難うございます。


   
yoshiken
(@yoshiken)
Active Member Registered
結合: 2か月前
投稿: 4
Topic starter  

@mk2_mk2 さん
色々試してくださり有難うございます。
私はクラシックエディタをつかっているのですが、ご指摘の通り「・・・・.jpeg」以降を削除すると無事にアイキャッチに設定されました! インデックスカードへの反映もでき、メディアライブラリへの画像データの反映もできています。

この方法で対応していこうと思います。
有難うございました。


   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4441
 

もっとシンプルに確認しようと試みました。
yoshikenさんのサイトのHTMLから、画像部分だけを取り出して、確認を行いました。

クラシックエディタで、確認を2パターン行いました。

ちなみに、Cocoon設定は以下です。

  • アイキャッチ表示アリ
  • アイキャッチ自動設定アリ
 
 

 
パターン①
 
画像URLに、パラメータが付いた状態。

(yoshikenさんのサイトと同じ状態)

クラシックエディタで、以下のように入力。
<p id="p-iframe-image-15802-2"><img src="https://prcdn.freetls.fastly.net/release_image/46923/46/46923-46-071d898d6a8de0d4fbf758c7e894ad2e-1200x700.jpg?format=jpeg&amp;auto=webp&amp;quality=85%2C75&amp;width=1950&amp;height=1350&amp;fit=bounds" alt="root C(ルートシー)"></p>
 
 
 
その結果、アイキャッチは設定はされているものの、非表示状態。
 
カードにも反映されませんでした。
 
 

 
パターン②
 
画像URLからパラメータ部分を削除します。
同じくクラシックエディタです。
 
<p id="p-iframe-image-15802-2"><img src="https://prcdn.freetls.fastly.net/release_image/46923/46/46923-46-071d898d6a8de0d4fbf758c7e894ad2e-1200x700.jpg" alt="root C(ルートシー)"></p>
 
 
 
すると、アイキャッチが表示されます。
 
カードにも反映されます。
 
 

 
今回の事象は、上記のようなことなのではないか・・・。
そんな気はします。
 
有識者の方々にもご確認いただければと思います。

   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4441
 

yoshikenさん

何回か確認して、私の返信のような結果になりました。

もしかすると、何かの不具合の可能性もあるのかもしれないです。
その辺りは、ちょっと私には分からないのですけど。
(あまり時間もなく、そこまで調べておりません、申し訳ないです)

確認した結果は書いておきましたので、詳しい方々がもう少しご確認してくださると思います。


   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4441
 

すみません、先程のクラシックエディタでの確認のところで、1点書き漏らしました。

以下の返信のことです。
https://wp-cocoon.com/community/postid/64640/

 

画像URLからパラメータ部分を削除した場合は、「新規投稿」-「公開」するだけで、アイキャッチ・カードのサムネイルは反映されました。

「公開」の後、「更新」する必要はありませんでした。


   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4441
 

上記のように書いたものの・・・。

外部URLの画像の添付はあまりないのかもしれないです。(遅くなるのではないかと)

画像URLにパラメータが付くこともあまりないのかもしれないです。

過去にお問い合わせがあったのは、Googleドライブに保存された画像の添付でしょうか。(パラメータありましたっけ?)


   
Akira
(@akira)
Noble Member Registered
結合: 5年前
投稿: 1179
 

申し訳ないです。パラメータを見逃していました。

外部 URL の画像の場合は、その画像を WordPress のメディアにアップロードします。パラメータを削除する処理は入っていないため、パラメータがあると正常なファイル名に変換できずメディアにアップロードできません。アップロードできないため、アイキャッチ画像にもサムネイル画像にも画像が表示されません。

例えば、以下のパラメータ付きの URL の場合は…

 https://i.ytimg.com/vi/CbH2F0kXgTY/maxresdefault.jpg ?format=jpeg

こんなファイル名が作られるため、メディアにアップロードできません。

maxresdefault.jpgformatjpeg
This post was modified 2か月前 2回 by Akira

   
共有:

問題の解決に至った場合には、トピック冒頭の「解決済み」をクリックしていただけますと幸いです。

wpForoの解決済みリンク

また、有用な回答があった場合は「いいね!」もご活用ください。回答者の励みになります。

wpForoのいいねリンク

「いいね!」機能はフォーラム登録者のみが利用できる機能です。

CC BY-ND 2.1)準じていれば(リンクを貼っていただければ)転載も自由です。カスタマイズ記事を書く際にコード等をコピペ利用していただいて構いません。

フォーラムの使い方がよくわからない場合は、テストトピックで自由にテストしていただいて構いません。

最近の書き込みはこちら。

詳細なカスタマイズ依頼をするならこちら。

タイトルとURLをコピーしました