Cocoonフォーラム

書き込みの前に以下の3点をご確認ください。
  1. 1つのトピックにつき1つの質問を書き込んでください
  2. 不具合・カスタマイズ対象ページのURLを提示高速化を無効にしてください
  3. 該当部分のキャプチャ・環境情報とともに書き込んでいただけると助かります

何を書き込んだら良いか分からない場合は、以下のテンプレートをコピペしてご利用ください。

不具合・カスタマイズ対象ページのURL:

相談内容:

不具合の発生手順:

解決のために試したこと:

※文字だけでは正しく伝わらない可能性があるため、スクショ画像の添付もお願いします。
※高速化設定をしている場合は無効にしてください。
環境情報:

※↑こちらに「Cocoon設定 → テーマ情報」にある「環境情報」を貼り付けてください。

環境情報の取得方法はこちら。
https://wp-cocoon.com/theme-report/
高速化設定を無効にするにはこちら。
https://wp-cocoon.com/theme-trouble/

フォーラム利用ガイドリンク

  1. フォーラムガイドライン
  2. よくある質問と答え(FAQ)
  3. サポート対象外のケース
  4. 原因不明の不具合用トラブルシューティング
  5. トピックにHTMLを貼り付ける方法(推奨ツール:notepad.pw
  6. 真っ白画面でのエラーメッセージの確認方法
  7. ブラウザ環境チェックツール
  8. Cocoonカスタマイズ依頼

フォーラム質問後、問題等が解決した場合は結果を書き込んでいただけると幸いです。同様の問題で調べている方には、結果が一番気になる部分となります。

AMPエラー 必須属性「src」がタグ...
 
共有:
通知
すべてクリア

[解決済] AMPエラー 必須属性「src」がタグ「amp-img」にありません。と指摘されています。

6 投稿
2 ユーザー
3 Likes
3,709 表示
bucho
(@bucho)
Trusted Member Registered
結合: 5年前
投稿: 83
Topic starter  

質問をお願い致します。

先日までは問題なかったのですが、少し前からAMPのエラーが急に出始めました。

自分では特段何もいじったり触ったりはしていません。

サーチコンソールでは必須属性「src」がタグ「amp-img」にありません。と指摘されています。

このような場合どのように対応したらよろしいでしょうか??

重大度が致命的となっているので早めに対応したいと思います。

よろしくお願い致します。

サイトはこちらです

https://bucho-diver.com/

 

 

 


   
bucho
(@bucho)
Trusted Member Registered
結合: 5年前
投稿: 83
Topic starter  

追記ですが、9月22日頃よりエラーが出始めていますが、確かテーマのアップデートをその頃にしたと思います。

関係なければ申し訳ありません。

よろしくお願い致します。


   
Akira
(@akira)
Noble Member Registered
結合: 5年前
投稿: 1212
 

Cocoon 設定 → AMP にある「AMPロゴ」が空になってはいないでしょうか。

もし、空の場合には、何かしらロゴを作成し設定されると、AMP エラーが解消すると思います。

また、この URL を設定されると、すぐに修正できます。

https://bucho-diver.com/wp-content/themes/cocoon-master/images/no-amp-logo.png

最初の h は全角で書いています。半角に修正後、「AMPロゴ」に記入します。

 


   
わいひら reacted
bucho
(@bucho)
Trusted Member Registered
結合: 5年前
投稿: 83
Topic starter  

Akira様

 

ご丁寧に説明いただきまして、ありがとうございます。

今みたところ、AMPロゴの箇所が空欄になったままでした。

そうしますと、Akira様のおっしゃるURLを添付の「AMPロゴ」の箇所にそのままコピペすればいいということでしょうか?

よろしくお願い致します。


   
Akira
(@akira)
Noble Member Registered
結合: 5年前
投稿: 1212
 

最初のh を半角の h に修正後、「AMPロゴ」にコピペをされると大丈夫です。

その URL は、親テーマに同梱の画像を呼び出すものです。

デフォルトでは、そのURL が「AMPロゴ」に設定されています。おそらく、クリアボタンをクリックされたことで、消えたのだと思います。

URL をコピペ後は、Cocoon 設定 → キャッシュ削除より、「AMPキャッシュの削除」を行います。

キャッシュ削除後に、AMP テストに合格すればエラーは解消しています。


   
わいひら reacted
bucho
(@bucho)
Trusted Member Registered
結合: 5年前
投稿: 83
Topic starter  

Akira様

 

ありがとうございます。

今やってみたので、当面はこれで様子を見てみたいと思います。

また、何かエラーが出るようであれば本フォーラムにご相談させて頂ければと思います。

お忙しいところ丁寧に教えて頂きましてありがとうございました。


   
わいひら reacted
共有:

問題の解決に至った場合には、トピック冒頭の「解決済み」をクリックしていただけますと幸いです。

また、有用な回答があった場合は返信右下にある「いいね!」もご活用ください。回答者の励みになります。

「いいね!」機能はフォーラム登録者のみが利用できる機能です。

CC BY-ND 2.1)準じていれば(リンクを貼っていただければ)転載も自由です。カスタマイズ記事を書く際にコード等をコピペ利用していただいて構いません。

フォーラムの使い方がよくわからない場合は、テストトピックで自由にテストしていただいて構いません。

最近の書き込みはこちら。

詳細なカスタマイズ依頼をするならこちら。

タイトルとURLをコピーしました