「メイド・イン・ヘブン」スキン適用中

Cocoonフォーラム

サイト内検索
書き込みの前に以下の3点をご確認ください。
  1. 1つのトピックにつき1つの質問を書き込んでください
  2. 不具合・カスタマイズ対象ページのURLを提示高速化を無効にしてください
  3. 該当部分のキャプチャ・環境情報とともに書き込んでいただけると助かります

何を書き込んだら良いか分からない場合は、以下のテンプレートをコピペしてご利用ください。

不具合・カスタマイズ対象ページのURL:

相談内容:

不具合の発生手順:

解決のために試したこと:

※文字だけでは正しく伝わらない可能性があるため、スクショ画像の添付もお願いします。
※高速化設定をしている場合は無効にしてください。
環境情報:

※↑こちらに「Cocoon設定 → テーマ情報」にある「環境情報」を貼り付けてください。

環境情報の取得方法はこちら。
https://wp-cocoon.com/theme-report/
高速化設定を無効にするにはこちら。
https://wp-cocoon.com/theme-trouble/

フォーラム利用ガイドリンク

  1. フォーラムガイドライン
  2. よくある質問と答え(FAQ)
  3. サポート対象外のケース
  4. 原因不明の不具合用トラブルシューティング
  5. トピックにHTMLを貼り付ける方法(推奨ツール:notepad.pw
  6. 真っ白画面でのエラーメッセージの確認方法
  7. ブラウザ環境チェックツール
  8. Cocoonカスタマイズ依頼

フォーラム質問後、問題等が解決した場合は結果を書き込んでいただけると幸いです。同様の問題で調べている方には、結果が一番気になる部分となります。

ディスクリプションが出力されない
 
共有:
通知
すべてクリア

[解決済] ディスクリプションが出力されない

16 投稿
4 ユーザー
15 Reactions
113 表示
(@koichi)
Eminent Member Registered
結合: 6年前
投稿: 18
Topic starter  

お世話になっております。

 

投稿記事のディスクリプションが、COCOON設定で「メタディスクリプションタグを出力する」にチェックが入っていても出力されないためご相談させていただきたいです。

 

投稿下部のSEO部分のメタディスクリプションに何も書き込まない場合→<meta name="description" content="">

 

投稿下部のSEO部分のメタディスクリプションに指定文書を書き込んだ場合→更新すると該当箇所が文字化けし、<meta name="description" content="">

 

の状態になります。

 

COCOON設定のタイトル部分でフロントページと投稿・固定ページのプレビューは正常ですが、カテゴリー・タグページ設定のメタディスクリプション部分だけ文字化けしています。

 

Health Check & TroubleshootingにてプラグインOFFのみ試しましたが、投稿時の文字化けと出力なしは改善されませんでした。

 

お手数ですがよろしくお願いします。

 

該当URL

https://www.iezo.net/forum/basketball-h/87284/

 

他投稿ページ幾つか試しましたがすべて同じ挙動でした。

 

環境情報

----------------------------------------------
テンプレートURL:/wp-content/themes/cocoon-master
スタイルシートURL:/wp-content/themes/cocoon-child-master
親テーマスタイル:/wp-content/themes/cocoon-master/style.css
子テーマスタイル:/wp-content/themes/cocoon-child-master/style.css
WordPressバージョン:6.5.3
PHPバージョン:8.1.22
ブラウザ:Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/124.0.0.0 Safari/537.36
サーバーソフト:Apache
サーバープロトコル:HTTP/1.1
言語:ja,en-US;q=0.9,en;q=0.8
----------------------------------------------
テーマ名:Cocoon
バージョン:2.7.3.5
カテゴリー数:26
タグ数:105
ユーザー数:1
----------------------------------------------
子テーマ名:Cocoon Child
バージョン:0.0.5
style.cssサイズ:7484 バイト
functions.phpサイズ:954 バイト
----------------------------------------------
Gutenberg:0
Font Awesome:4
Auto Post Thumbnail:1
Retina:0
ホームイメージ:/wp-content/uploads/2018/10/bukatsu.jpg
----------------------------------------------
ブラウザキャッシュ有効化:0
HTML縮小化:0
CSS縮小化:1
JavaScript縮小化:1
Lazy Load:1
----------------------------------------------
利用中のプラグイン:
Advanced Editor Tools 5.9.2
Cookie Notice & Compliance for GDPR / CCPA 2.4.16
EWWW Image Optimizer 7.6.0
Health Check & Troubleshooting 1.7.0
MW WP Form 5.1.0
Redirection 5.4.2
Shortcodes Ultimate 7.1.5
WP Multibyte Patch 2.9
XML Sitemap & Google News 5.4.9
----------------------------------------------

This topic was modified 2か月前 by わいひら

   
引用
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 3年前
投稿: 7225
 

koichiさん

ちなみに、どんなに文言を入力なさっているのでしょうか。

確かに、ディスクリプションは出てないですね。

 
構造化データが見づらいですので、フォーラム上部の案内の通り、高速化(縮小化)機能は無効化して欲しいです。
投稿者:: @koichi

CSS縮小化:1
JavaScript縮小化:1

書き込みの前に以下の3点をご確認ください。
  1. 1つのトピックにつき1つの質問を書き込んでください
  2. 不具合・カスタマイズ対象ページのURLを提示高速化を無効にしてください
  3. 該当部分のキャプチャ・環境情報とともに書き込んでいただけると助かります

 

ちなみに、私の環境(WordPress 6.5.3、Cocoon 2.7.3.6)では、問題なく出力されました。

 
 
投稿者:: @koichi

Health Check & TroubleshootingにてプラグインOFFのみ試しましたが、投稿時の文字化けと出力なしは改善されませんでした。

プラグインの全無効化はお試しになったみたいですね。

親テーマへの切り替えは、お試しになったのでしょうか。
まだでしたら、親テーマへの切り替えもお試しください。

上記のプラグインをご利用であれば、影響はログインユーザーのみです。
(閲覧者の方には影響はないです)


   
koichi and わいひら reacted
返信引用
(@koichi)
Eminent Member Registered
結合: 6年前
投稿: 18
Topic starter  

@mk2_mk2

ご返信ありがとうございます。

 

文言は「あいうえお」でも文字化けしていました。

 

テーマは、デフォルトに切り替えた場合、ディスクリプションが出力されなかったので記述しませんでした。

申し訳ありません。

 

過去の投稿等を見る限り、当サイト環境による理由が強そうですが、なにかきっかけがつかめればと思い投稿させていただきました。

 

何かヒントがいただければご教授いただきたいです。

 

お手数ですがよろしくお願いします。


   
返信引用
(@koichi)
Eminent Member Registered
結合: 6年前
投稿: 18
Topic starter  

@mk2_mk2

 

高速化に関しては、htmlだけ解除すればいいと勘違いしていました。

申し訳ありません。

 

cssとjavaも解除いたしました。

よろしくお願いします。


   
返信引用
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 3年前
投稿: 7225
 

koichiさん

親テーマにしてもダメでしたか。

正直ちょっと分からないというところです。

気になったのは、HTMLに多数エラーがあることです。
数が多くて、指摘しきれないです。(3桁あります)

例えば、投稿記事下のウィジットだと思いますが、以下のようにpタグ開始タグがないのに、終了タグが出てきます。

 
こういう感じのものがたくさんありますで、これらを解消すると変わるかどうかですね。
 
機械的にチェックできるようなツールなどで確認なさった方が良いと思います。
 
 
例えば、以下のようなツールもあります。
(他にもありますので、「HTMLチェックツール」等で検索してみてください)
 
HTML5バリデーター
https://rakko.tools/tools/58/
 
上記に、今回ご提示の投稿URLを入力すると、以下のように指摘くしてくれます。
(上に私が貼った場所と、同じ箇所です)
 
最後のpタグ閉じタグが赤くなっているかと思います。
 
同じように、これがたくさんあります。
(全部は収められません)
 
 
関係あるかどうかは分かりません。
ただ、HTMLの文法的にはまずいと思いますので、対応しておいた方が良いと思います。

   
koichi and わいひら reacted
返信引用
わいひら
(@yhira)
Illustrious Memberサイト Admin
結合: 6年前
投稿: 16663
 

添付画像のような投稿編集画面の「メタディスクリプション」に入力されているんですよね?
該当URLの記事にどのように入力されているか念のため、スクリーンショットを頂ければ幸いです。
※スクショを頂いても必ず原因がわかるかは分かりません。

This post was modified 2か月前 by わいひら

   
koichi reacted
返信引用
chu-ya
(@chu-ya)
Famed Member Registered
結合: 2年前
投稿: 2411
 

投稿者:: @koichi

functions.phpサイズ:954 バイト

何か、ご自身で以下のような、フック書いていませんか?
add_filter('ogp_card_description', function($description) {
});


   
わいひら and koichi reacted
返信引用
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 3年前
投稿: 7225
 

他のページもいくつか確認してみましたが。

OGP、Twitterカード、構造化データを含めて、出ていないですね。

Health Check & Troubleshooting」で親テーマにしても、出なかったようですね。
この際、このプラグインを使用せずに、親テーマに切り替えて確認してみても良いと思います。


   
わいひら and koichi reacted
返信引用
(@koichi)
Eminent Member Registered
結合: 6年前
投稿: 18
Topic starter  

@mk2_mk2

ご連絡ありがとうございます。

確認してみます。

ご指摘ありがとうございます。

 


   
返信引用
(@koichi)
Eminent Member Registered
結合: 6年前
投稿: 18
Topic starter  

@yhira

ご連絡ありがとうございます。

記載内容と更新後の状態を添付します。

よろしくお願いします。

 


   
返信引用
(@koichi)
Eminent Member Registered
結合: 6年前
投稿: 18
Topic starter  

@chu-ya

 

ご連絡ありがとうございます。

 

functions.phpの記載内容を添付します。

よろしくお願いします。

 

 


   
返信引用
(@koichi)
Eminent Member Registered
結合: 6年前
投稿: 18
Topic starter  

@mk2_mk2

ご連絡ありがとうございます。

親テーマに直接変更してみましたが、症状は変わりませんでした。

ありがとうございます。


   
返信引用
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 3年前
投稿: 7225
 

koichiさん

スマホからなもので、あまり書くことはできないのですけど。

投稿者:: @koichi

 

これだと思います。

データベースに保存された時に文字化けしている可能性が高そうに思います。

「wp_postmeta」テーブルの文字コードって、確認できますでしょうか。(他のテーブルも気にはなりますけど)

phpMyAdminで確認できると思います。(誤操作には注意を)

php.iniの文字コードも確認できればと思います。

 

【追記】

もしかして、メタディスクリプションの入力が、半角文字だけなら、上手くいったりしませんか。


   
わいひら and koichi reacted
返信引用
(@koichi)
Eminent Member Registered
結合: 6年前
投稿: 18
Topic starter  

@mk2_mk2

ご連絡ありがとうございます。

php.iniしか見れていないのですが、EUCになっていたのでご指摘いただいた通り、このあたりが関連していると思われます。

少し時間がかかりそうですが、全て確認し、utf8に変更したところで再度ご報告させていただければと思います。

よろしくお願いします。

 

@yhira 様 @chu-ya 様

 


   
返信引用
(@koichi)
Eminent Member Registered
結合: 6年前
投稿: 18
Topic starter  

@mk2_mk2 様

@yhira 様

@chu-ya 様

 

ご指摘いただいた通り、php.iniのdefault_charsetをutf-8に変更したら、文字化けもなくなりディスクリプションを入力しなくても、先頭部分から出力されるようになりました。

ただ現状はEUC-JPの状態に戻しています。(EUC-JPでつくられたhtmlのページが全て文字化けするため)

原因が分かったので今後修正していきたいと思います。

この度は、当サイトの構造とサーバー設定が原因だったにもかかわらず、ご丁寧にご指示いただきましてありがとうございました。

ご迷惑をおかけしました。

今後ともよろしくお願いいたします。

 


   
返信引用
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 3年前
投稿: 7225
 

koichiさん

投稿者:: @koichi

php.iniしか見れていないのですが、EUCになっていた

そうなんですね。
「wp-postmate」の方は、おそらくUTF-8になっていて、文字化けしたという感じでしょうか。

投稿者:: @koichi

ただ現状はEUC-JPの状態に戻しています。(EUC-JPでつくられたhtmlのページが全て文字化けするため)

そうですね。
変更すると、今度は既にEUCで保存されたものが、化けると思います。


   
koichi and わいひら reacted
返信引用
共有:

問題の解決に至った場合には、トピック冒頭の「解決済み」をクリックしていただけますと幸いです。

また、有用な回答があった場合は返信右下にある「いいね!」もご活用ください。回答者の励みになります。

「いいね!」機能はフォーラム登録者のみが利用できる機能です。

CC BY-ND 2.1)準じていれば(リンクを貼っていただければ)転載も自由です。カスタマイズ記事を書く際にコード等をコピペ利用していただいて構いません。

フォーラムの使い方がよくわからない場合は、テストトピックで自由にテストしていただいて構いません。

最近の書き込みはこちら。

詳細なカスタマイズ依頼をするならこちら。

タイトルとURLをコピーしました