Cocoonフォーラム

書き込みの前に以下の3点をご確認ください。
  1. 1つのトピックにつき1つの質問を書き込んでください
  2. 不具合・カスタマイズ対象ページのURLを提示高速化を無効にしてください
  3. 該当部分のキャプチャ・環境情報とともに書き込んでいただけると助かります

何を書き込んだら良いか分からない場合は、以下のテンプレートをコピペしてご利用ください。

不具合・カスタマイズ対象ページのURL:

相談内容:

不具合の発生手順:

解決のために試したこと:

※文字だけでは正しく伝わらない可能性があるため、スクショ画像の添付もお願いします。
※高速化設定をしている場合は無効にしてください。
環境情報:

※↑こちらに「Cocoon設定 → テーマ情報」にある「環境情報」を貼り付けてください。

環境情報の取得方法はこちら。
https://wp-cocoon.com/theme-report/
高速化設定を無効にするにはこちら。
https://wp-cocoon.com/theme-trouble/

フォーラム利用ガイドリンク

  1. フォーラムガイドライン
  2. よくある質問と答え(FAQ)
  3. サポート対象外のケース
  4. 原因不明の不具合用トラブルシューティング
  5. トピックにHTMLを貼り付ける方法(推奨ツール:notepad.pw
  6. 真っ白画面でのエラーメッセージの確認方法
  7. ブラウザ環境チェックツール
  8. Cocoonカスタマイズ依頼

フォーラム質問後、問題等が解決した場合は結果を書き込んでいただけると幸いです。同様の問題で調べている方には、結果が一番気になる部分となります。

プラグイン「Comment Image...
 
共有:
通知
すべてクリア

[解決済] プラグイン「Comment Image」有効化できない

6 投稿
3 ユーザー
7 Likes
235 表示
たむら船堀
(@lansap40)
Eminent Member Registered
結合: 2年前
投稿: 19
Topic starter  

お世話になっています。

コメントに画像を添付できるようにしたいと思い、プラグイン「Comment Image」をインストール、有効化しようとしたところ、「重大なエラーを引き起こしたため、プラグインを有効化できませんでした。Fatal error: Uncaught Error: Undefined constant "WPLANG" in /home/users/0/…」というメッセージが出て、有効化できませんでした。

原因は何なのでしょうか。Cocoonでは使えないということ? ご教示いただければ幸いです。どうぞ宜しくお願い申し上げます。

 

 

 


   
はる
(@haruinoue)
Noble Member Moderator
結合: 3年前
投稿: 957
 

以下の情報をいただいた方が原因究明がしやすいです。

・エラー内容の全文
→エラー内容を見ればどこでどんなエラーが出ているのか(WordPress本体なのかテーマなのかプラグインなのか)が分かります。

フルパスを公開するのが気になるのであれば、WordPressをインストールしているフォルダより上のパスは隠しても問題ありません。

・Cocoon以外のテーマでも有効化できないのか
→他テーマでも有効化できないのであればテーマが原因でない可能性が高まります。

プラグインの最終更新が1年以上前なので、プラグイン自体が現在のWordPressのバージョンに対応していないこともあると思います。


   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4892
 

投稿者:: @lansap40

Cocoonでは使えないということ?

「Cocoonでは」ではないですね。

WordPress公式テーマ「Twenty Twenty-One」でも、同様です。
(WordPress 6.1.1です。)

 

以下は、「Twenty Twenty-One」での確認結果です。

例えば、PHP.7.4.30では、以下のような表示が出ます。

 
 
エラーログを確認すると、以下のようなものがありました。
PHP Warning: Use of undefined constant WPLANG - assumed 'WPLANG' (this will throw an Error in a future version of PHP) in \wp-content\plugins\comment-image\plugin.php on line 256
未定義の定数があるみたいです。
 
PHP 8.0.22にしても、Warningが出ます。
PHP Warning: Undefined array key "page" in \wp-content\plugins\comment-image\plugin.php on line 17
 
以下のプラグインのページを見ると、もうメンテされていない可能性が高そうです。
最後に検証されたのは、WordPress 5.8.6のようです。
(上記のサポートフォーラムを見ても、運営されているようには見えないです)
 
 
 
テーマとの相性を確認する場合は、別テーマ、特にWordPress公式テーマに切替て、事前に検証いただけますと助かります。
 
ちなみに、私は有効化自体はできました。
プラグインが使用できるかは分かりませんけれど。
 
ただ、プラグインに問題があるのは間違いないと思います。

   
たむら船堀
(@lansap40)
Eminent Member Registered
結合: 2年前
投稿: 19
Topic starter  

ご丁寧に説明してくださり、ありがとうございます。よくわかりました。

諦めます。

 

 


   
わいひら reacted
たむら船堀
(@lansap40)
Eminent Member Registered
結合: 2年前
投稿: 19
Topic starter  

@haruinoue 

早々に回答ありがとうございました。使えないようなので諦めます。


   
わいひら reacted
たむら船堀
(@lansap40)
Eminent Member Registered
結合: 2年前
投稿: 19
Topic starter  

@mk2_mk2 

ご親切に詳しく教えてくださり、ありがとうございました。諦めます。


   
わいひら reacted
共有:

問題の解決に至った場合には、トピック冒頭の「解決済み」をクリックしていただけますと幸いです。

また、有用な回答があった場合は返信右下にある「いいね!」もご活用ください。回答者の励みになります。

「いいね!」機能はフォーラム登録者のみが利用できる機能です。

CC BY-ND 2.1)準じていれば(リンクを貼っていただければ)転載も自由です。カスタマイズ記事を書く際にコード等をコピペ利用していただいて構いません。

フォーラムの使い方がよくわからない場合は、テストトピックで自由にテストしていただいて構いません。

最近の書き込みはこちら。

詳細なカスタマイズ依頼をするならこちら。

タイトルとURLをコピーしました