Cocoonフォーラム

書き込みの前に以下の3点をご確認ください。
  1. 1つのトピックにつき1つの質問を書き込んでください
  2. 不具合・カスタマイズ対象ページのURLを提示高速化を無効にしてください
  3. 該当部分のキャプチャ・環境情報とともに書き込んでいただけると助かります

何を書き込んだら良いか分からない場合は、以下のテンプレートをコピペしてご利用ください。

不具合・カスタマイズ対象ページのURL:

相談内容:

不具合の発生手順:

解決のために試したこと:

※文字だけでは正しく伝わらない可能性があるため、スクショ画像の添付もお願いします。
※高速化設定をしている場合は無効にしてください。
環境情報:

※↑こちらに「Cocoon設定 → テーマ情報」にある「環境情報」を貼り付けてください。

環境情報の取得方法はこちら。
https://wp-cocoon.com/theme-report/
高速化設定を無効にするにはこちら。
https://wp-cocoon.com/theme-trouble/

フォーラム利用ガイドリンク

  1. フォーラムガイドライン
  2. よくある質問と答え(FAQ)
  3. サポート対象外のケース
  4. 原因不明の不具合用トラブルシューティング
  5. トピックにHTMLを貼り付ける方法(推奨ツール:notepad.pw
  6. 真っ白画面でのエラーメッセージの確認方法
  7. ブラウザ環境チェックツール
  8. Cocoonカスタマイズ依頼

フォーラム質問後、問題等が解決した場合は結果を書き込んでいただけると幸いです。同様の問題で調べている方には、結果が一番気になる部分となります。

jquery取得関数に関する質問
 
共有:
通知
すべてクリア

[解決済] jquery取得関数に関する質問

5 投稿
4 ユーザー
4 Likes
185 表示
ybm2233
(@ybm2233)
New Member Registered
結合: 3か月前
投稿: 2
Topic starter  

初めまして、わいひら様
ybm2233と申します。

会社のサイトにCocconを使わせて頂いております。ありがとうございます。
(わけあって最新ではないCocoon ver.2.4.2.4ですが)

しかし先日、そのサイトが社内のセキュリティチェックにひっかかってしまいました。
そこで、Cocoonのソースコード記載について質問がございます。

<コードの場所>
Cocoon: utils.php (lib/utils.php)
376行目 //jQueryコアURLの取得関数内のURL部分

<問題となった部分>
https://ajax.googleapis.com/ajax/libs/jquery/1.12.4/jquery.min.js?ver=1.12.4

<セキュリティチェックの検出理由>
脆弱なJavaScriptライブラリの使用 (jquery 1.12.4)

<質問>
コード内には上記URLがあるものの、コードをトレースすると、たどり着かないようにも見えます。
問題となった上記URLは使わなれないという認識であっておりますでしょうか。

以上、お忙しい所大変申し訳ございませんが、ご確認頂けますと幸いです。


   
トピックタグ
Akira
(@akira)
Noble Member Registered
結合: 5年前
投稿: 1179
 

私もちょっと気になっていたので口を挟みます。

問題となった上記URLは使わなれないという認識であっておりますでしょうか。

Cocoon 設定 > その他タブの「JavaScriptライブラリ設定」にある「jQuery」で「jQuery Core 3.6.0」を選択されていれば、1 系は使われません。

私が気になっているのが、jQuery の 1 系と 2 系の脆弱性です。1 系と 2 系を使っている場合は、Lighthouse でも以下のように指摘されます。

既知のセキュリティの脆弱性を含んだフロントエンドの JavaScript ライブラリが含まれています

「1 系じゃないと動かないプラグインがある」とか「よく分からない」との理由で 1 系や 2 系にされている方がいらっしゃるような気がします。

テーマとしては 3 系だけに対応するのがいいかもしれないなと以前思ったことがあります。または、1 系と 2 系のラジオボタン に「脆弱性が含まれています」との注意書きを追加するのがいいかもしれません。

This post was modified 3か月前 by Akira

   
わいひら and chu-ya reacted
chu-ya
(@chu-ya)
Noble Member Registered
結合: 8か月前
投稿: 624
 

jquery-core-js」でHTMLを検索すると、実際に使われているjQueryライブラリが分かります。
気になるなら確認してみては。

例:...libs/jquery/3.6.0/jquery.min.js?ver=3.3.1" id="jquery-core-js">


   
わいひら reacted
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 14165
 

以前どこかのトピックに書いて、どのトピックかは忘れたのですが、jQueryの選択機能と、jQuery Migrateはいずれ廃止します。
ただ、いずれと言っていると忘れたりずるずるとそのままいってしまうと思うので、2022年末日をもって廃止しようと思います(日にちは前後するかもしれませんが)。
機能の説明文にも、注意書きと廃止日を追記しておきました。


   
ybm2233
(@ybm2233)
New Member Registered
結合: 3か月前
投稿: 2
Topic starter  

Akiraさん、Cyu-yaさん、ご提案ご意見ありがとうございます。

わいひらさんご返信ならびにご対応くださりありがとうございます。

セキュリティ脆弱性チェックツールがソースを見てしまう場合は、1系の記述が削除されるまで、検出されると思いますが、選択していなければ、動作はしないという事が確認できたので、安心いたしました。

ありがとうございました。


   
わいひら reacted
共有:

問題の解決に至った場合には、トピック冒頭の「解決済み」をクリックしていただけますと幸いです。

wpForoの解決済みリンク

また、有用な回答があった場合は「いいね!」もご活用ください。回答者の励みになります。

wpForoのいいねリンク

「いいね!」機能はフォーラム登録者のみが利用できる機能です。

CC BY-ND 2.1)準じていれば(リンクを貼っていただければ)転載も自由です。カスタマイズ記事を書く際にコード等をコピペ利用していただいて構いません。

フォーラムの使い方がよくわからない場合は、テストトピックで自由にテストしていただいて構いません。

最近の書き込みはこちら。

詳細なカスタマイズ依頼をするならこちら。

タイトルとURLをコピーしました