Cocoonフォーラム

書き込みの前に以下の3点をご確認ください。
  1. 1つのトピックにつき1つの質問を書き込んでください
  2. 不具合・カスタマイズ対象ページのURLを提示高速化を無効にしてください
  3. 該当部分のキャプチャ・環境情報とともに書き込んでいただけると助かります

何を書き込んだら良いか分からない場合は、以下のテンプレートをコピペしてご利用ください。

不具合・カスタマイズ対象ページのURL:

相談内容:

不具合の発生手順:

解決のために試したこと:

※文字だけでは正しく伝わらない可能性があるため、スクショ画像の添付もお願いします。
※高速化設定をしている場合は無効にしてください。
環境情報:

※↑こちらに「Cocoon設定 → テーマ情報」にある「環境情報」を貼り付けてください。

環境情報の取得方法はこちら。
https://wp-cocoon.com/theme-report/
高速化設定を無効にするにはこちら。
https://wp-cocoon.com/theme-trouble/

フォーラム利用ガイドリンク

  1. フォーラムガイドライン
  2. よくある質問と答え(FAQ)
  3. サポート対象外のケース
  4. 原因不明の不具合用トラブルシューティング
  5. トピックにHTMLを貼り付ける方法(推奨ツール:notepad.pw
  6. 真っ白画面でのエラーメッセージの確認方法
  7. ブラウザ環境チェックツール
  8. Cocoonカスタマイズ依頼

フォーラム質問後、問題等が解決した場合は結果を書き込んでいただけると幸いです。同様の問題で調べている方には、結果が一番気になる部分となります。

もしもアフィリエイトの簡単リンクが表示...
 
共有:
通知
すべてクリア

[解決済] もしもアフィリエイトの簡単リンクが表示されない件について。

9 投稿
2 ユーザー
6 Likes
2,650 表示
ぽんこつーりすと
 ぽんこつーりすと
(@ぽんこつーりすと)
Active Member
結合: 2年前
投稿: 7
Topic starter  

こんにちは。

 

もしもアフィリエイトの『かんたんリンク』を使用したいのですが表示されません。

 

同じ質問を他の方がしていたので試したいと思っているのですが、高速化のところに「Javascriptをフッターで読み込む」というのを見つけることができません。

 

バージョンも先ほどアップデートしたのですが見つけることができないので他の場所に移動していたり、他に解決方法があれば教えていただきたいと思います。

 

よろしくお願いいたします。

 

----------------------------------------------
サイト名:ぽんこつーりすと
サイトURL: https://ponkotourist.com
ホームURL: https://ponkotourist.com
コンテンツURL:/wp-content
インクルードURL:/wp-includes/
テンプレートURL:/wp-content/themes/cocoon-master
スタイルシートURL:/wp-content/themes/cocoon-master
スキン:/wp-content/themes/cocoon-master/skins/bizarre-foods-pinkwine/style.css
WordPressバージョン:5.4.2
PHPバージョン:7.3.16
ブラウザ:Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_4) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/13.1 Safari/605.1.15
サーバーソフト:Apache
サーバープロトコル:HTTP/1.1
言語:ja-jp
----------------------------------------------
テーマ名:Cocoon
バージョン:2.1.8
カテゴリ数:16
タグ数:77
ユーザー数:1
----------------------------------------------
Gutenberg:1
AMP:0
PWA:0
Font Awesome:4
Auto Post Thumbnail:0
Retina:0
ホームイメージ:/wp-content/uploads/2020/06/25B5C13F-D171-40C0-8DBF-8D19DD8C6FB8-scaled.jpeg
----------------------------------------------
ブラウザキャッシュ有効化:0
HTML縮小化:0
CSS縮小化:0
JavaScript縮小化:0
Lazy Load:0
WEBフォントLazy Load:0
----------------------------------------------
利用中のプラグイン:
AddQuicktag 2.5.3
Akismet Anti-Spam 4.1.5
All in one Favicon 4.7
All In One SEO Pack 3.5.2
AmazonJS 0.10
Classic Editor 1.5
Contact Form 7 5.1.9
Customizer Search 1.1.3
Google XML Sitemaps 4.1.0
Image Widget 4.4.7
Penci Soledad Demo Importer 2.7
Quick Adsense 2.5
Really Simple SSL 3.3.3
Similar Posts 3.1.3
Smash Balloon Instagram Feed 2.4.3
Table of Contents Plus 2002
TinyMCE Advanced 5.4.0
TypeSquare Webfonts for エックスサーバー 1.2.1
Word Balloon 4.9.2
WordPress Popular Posts 5.1.0
WP Social Bookmarking Light 2.0.7
YellowPencil 7.3.1
----------------------------------------------


   
リフィトリー
(@leafytree)
Illustrious Member Moderator
結合: 4年前
投稿: 6845
 

前略、ぽんこつーりすと さん

私は普段は、ブロックエディターを使っていないので、どうかなと思ったのですが、ローカルのテストサイトで、カスタムHTMLブロックに貼り付けてみたら、ちゃんと表示されました。

 

あと、もしもから、コード取得する際に、一行にする、みたいなのがあったと思うので、それを使ってくみてください。

 

「Javascriptをフッターで読み込む」は、どうやら、廃止されたみたいですね。

 

あれ?クラッシックエディターをお使いですか?

 

クラッシックエディターの場合は、テキストの方に切り替えて、貼り付けると表示されるはずなんですけど・・


   
わいひら reacted
ぽんこつーりすと
 ぽんこつーりすと
(@ぽんこつーりすと)
Active Member
結合: 2年前
投稿: 7
Topic starter  

@leafytree

 

コメントありがとうございます。

 

クラシックエディターを使用しています。

他の方のブログを読ませていただいて、ビジュアルにこのように表示されていれば反映されるとのことでしたが、、プレビューを見てみると広告がつくべき場所に「リンク」とだけ表示されている状況です。


   
bikeman
 bikeman
(@bikeman)
Active Member
結合: 2年前
投稿: 17
 

@ぽんこつーりすと

 

AMP有効にするとそうなりますよ。

私も困ってAMPを無効にしました。


   
わいひら reacted
リフィトリー
(@leafytree)
Illustrious Member Moderator
結合: 4年前
投稿: 6845
 

なるほど、そうなんですね。

もともと、AMPを使っていないので、全く知りませんでした。


   
リフィトリー
(@leafytree)
Illustrious Member Moderator
結合: 4年前
投稿: 6845
 

テストサイトで、「AMPを有効化する」にチェックを入れてみたのですが、ブラウザのWebサイト表示では、ちゃんと表示されますね。

 

エディターのビジュアルモードで、表示されない、ということですかね?

 

それとも、ローカルのテストサイトでは、表示されてしまうのだろうか?


   
リフィトリー
(@leafytree)
Illustrious Member Moderator
結合: 4年前
投稿: 6845
 

かんたんリンクのコードは、JavaScriptなので、ビジュアルエディター上では、「リンク」としか表示されないと思い込んでいたのですが・・・

 

なにか思い違いをしていたのかもしれません。

 

ローカルのテストサイトでは、「AMPを有効にする」にチェックを入れても以下のように表示されてしまう・・

 


   
わいひら reacted
リフィトリー
(@leafytree)
Illustrious Member Moderator
結合: 4年前
投稿: 6845
 

私のテストサイトでも、エディター上では、「リンク」としか表示されていませんが、「変更をプレビュー」ボタンをクリックして、実際のサイトをプレビューすると、ちゃんと表示されています。

 


   
わいひら reacted
ぽんこつーりすと
 ぽんこつーりすと
(@ぽんこつーりすと)
Active Member
結合: 2年前
投稿: 7
Topic starter  

@leafytree

@bikeman

 

プレビューには表示されていないだけで、試しに公開してみたらちゃんと表示されていました。

 

今回は本当にありがとうございました。

 


   
共有:

問題の解決に至った場合には、トピック冒頭の「解決済み」をクリックしていただけますと幸いです。

wpForoの解決済みリンク

また、有用な回答があった場合は「いいね!」もご活用ください。回答者の励みになります。

wpForoのいいねリンク

「いいね!」機能はフォーラム登録者のみが利用できる機能です。

CC BY-ND 2.1)準じていれば(リンクを貼っていただければ)転載も自由です。カスタマイズ記事を書く際にコード等をコピペ利用していただいて構いません。

フォーラムの使い方がよくわからない場合は、テストトピックで自由にテストしていただいて構いません。

最近の書き込みはこちら。

詳細なカスタマイズ依頼をするならこちら。

タイトルとURLをコピーしました