Cocoonフォーラム

書き込みの前に以下の3点をご確認ください。
  1. 1つのトピックにつき1つの質問を書き込んでください
  2. 不具合・カスタマイズ対象ページのURLを提示高速化を無効にしてください
  3. 該当部分のキャプチャ・環境情報とともに書き込んでいただけると助かります

何を書き込んだら良いか分からない場合は、以下のテンプレートをコピペしてご利用ください。

不具合・カスタマイズ対象ページのURL:

相談内容:

不具合の発生手順:

解決のために試したこと:

※文字だけでは正しく伝わらない可能性があるため、スクショ画像の添付もお願いします。
※高速化設定をしている場合は無効にしてください。
環境情報:

※↑こちらに「Cocoon設定 → テーマ情報」にある「環境情報」を貼り付けてください。

環境情報の取得方法はこちら。
https://wp-cocoon.com/theme-report/
高速化設定を無効にするにはこちら。
https://wp-cocoon.com/theme-trouble/

フォーラム利用ガイドリンク

  1. フォーラムガイドライン
  2. よくある質問と答え(FAQ)
  3. サポート対象外のケース
  4. 原因不明の不具合用トラブルシューティング
  5. トピックにHTMLを貼り付ける方法(推奨ツール:notepad.pw
  6. 真っ白画面でのエラーメッセージの確認方法
  7. ブラウザ環境チェックツール
  8. Cocoonカスタマイズ依頼

フォーラム質問後、問題等が解決した場合は結果を書き込んでいただけると幸いです。同様の問題で調べている方には、結果が一番気になる部分となります。

「スペーサー」ブロックにmargin-...
 
共有:
通知
すべてクリア

[解決済] 「スペーサー」ブロックにmargin-bottom

7 投稿
2 ユーザー
1 Likes
662 表示
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4733
Topic starter  

Cocoon 2.3.3から、「スペーサー」ブロックに「margin-bottom: 1.8em」が適用されているようです。
(確認したところ、2.3.2.1ではありませんでした。)

ローカル環境でしか確認していませんが。
(本番はクラシックエディタなもので。)

「スペーサー」ブロックの用途から考えると、margin-bottomはない方が良い気がします。
ご確認いただけますでしょうか。

 

例として、2つの段落ブロックの間に「スペーサー」ブロックに30pxを指定してみました。

実際の表示。

 
HTMLソース。
 
デベロッパーツール。
 
「cocoon-style-inline-css」のものが当たっているようでした。

   
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 14349
 

ブロックエディター上はどのようになっていますか。
margin-bottomがないと添付画像のような表示になってしまい、これはこれで良くないのかなと思いました。


   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4733
Topic starter  

ブロックエディタ上は、以下のような感じです。

 
 
ただ、仰る通りmargin-bottomをなくしてしまうと、ちょっと難しい感じです。

   
わいひら reacted
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4733
Topic starter  

上の返信は、2.3.3です。

 

2.3.2.1は以下のような感じでした。


   
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 14349
 

エディターで、くっついているとやっぱり見た目は悪いですね。
これについては、仕様ということにしようかなと思います。
最近スペーサー関係のことは変更してなかったんですけどね ? 
何か影響のあるところを変更しちゃったのかな。


   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4733
Topic starter  
了解です。
 
 
投稿者:: @yhira

エディターで、くっついているとやっぱり見た目は悪いですね。

はい、そう思います。

そうでなくても、ブロック同士の間に新たにブロックを入れづらいのが、更に難しく。
(ブロック選んで、前・後に挿入…すればいいんですけど。)

違いと言えば…。

とりあえず、2.3.3で、「スペーサー」ブロックをデベロッパーツールで選択すると、トピックの最初に添付したセクレタのCSSが出てくるんですけど。

2.3.2.1では出てこない…くらいしか分からないです。
うーん…。


   
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 14349
 

とりあえず、こちらが正しい仕様ということでいきたいと思います。
ありがとうございます。


   
共有:

問題の解決に至った場合には、トピック冒頭の「解決済み」をクリックしていただけますと幸いです。

また、有用な回答があった場合は返信右下にある「いいね!」もご活用ください。回答者の励みになります。

「いいね!」機能はフォーラム登録者のみが利用できる機能です。

CC BY-ND 2.1)準じていれば(リンクを貼っていただければ)転載も自由です。カスタマイズ記事を書く際にコード等をコピペ利用していただいて構いません。

フォーラムの使い方がよくわからない場合は、テストトピックで自由にテストしていただいて構いません。

最近の書き込みはこちら。

詳細なカスタマイズ依頼をするならこちら。

タイトルとURLをコピーしました