Cocoonフォーラム

書き込みの前に以下の3点をご確認ください。
  1. 1つのトピックにつき1つの質問を書き込んでください
  2. 不具合・カスタマイズ対象ページのURLを提示高速化を無効にしてください
  3. 該当部分のキャプチャ・環境情報とともに書き込んでいただけると助かります

何を書き込んだら良いか分からない場合は、以下のテンプレートをコピペしてご利用ください。

不具合・カスタマイズ対象ページのURL:

相談内容:

不具合の発生手順:

解決のために試したこと:

※文字だけでは正しく伝わらない可能性があるため、スクショ画像の添付もお願いします。
※高速化設定をしている場合は無効にしてください。
環境情報:

※↑こちらに「Cocoon設定 → テーマ情報」にある「環境情報」を貼り付けてください。

環境情報の取得方法はこちら。
https://wp-cocoon.com/theme-report/
高速化設定を無効にするにはこちら。
https://wp-cocoon.com/theme-trouble/

フォーラム利用ガイドリンク

  1. フォーラムガイドライン
  2. よくある質問と答え(FAQ)
  3. サポート対象外のケース
  4. 原因不明の不具合用トラブルシューティング
  5. トピックにHTMLを貼り付ける方法(推奨ツール:notepad.pw
  6. 真っ白画面でのエラーメッセージの確認方法
  7. ブラウザ環境チェックツール
  8. Cocoonカスタマイズ依頼

フォーラム質問後、問題等が解決した場合は結果を書き込んでいただけると幸いです。同様の問題で調べている方には、結果が一番気になる部分となります。

V.2.5.0 「popular_li...
 
共有:
通知
すべてクリア

[解決済] V.2.5.0 「popular_list」のpost_type対応(get_access_ranking_records)

6 投稿
2 ユーザー
1 Likes
123 表示
loony
(@loony)
Eminent Member Registered
結合: 12か月前
投稿: 18
Topic starter  

わいひら様

「popular_list」のpost_type対応ありがとうございました。
 当方まだテストしていない状態ですが、ソースを見て気になった点を記載致します。

/cocoon-master/lib/page-access/access-func.php
[get_access_ranking_records]の引数に【.. $type = ET_DEFAULT, ..】と記載されいますが、この記載は修正の残りではないでしょうか?

まだ、ソース全体をみておりませんが、とりあえずご報告いたします。


   
トピックタグ
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 14137
 
投稿者:: @loony

/cocoon-master/lib/page-access/access-func.php
[get_access_ranking_records]の引数に【.. $type = ET_DEFAULT, ..】と記載されいますが、この記載は修正の残りではないでしょうか?

ちょっとこの記載だけではよくわかりませんでした。
上記のようになっていることでどういった問題点があるのでしょうか?

This post was modified 2か月前 by わいひら

   
loony
(@loony)
Eminent Member Registered
結合: 12か月前
投稿: 18
Topic starter  

わいひら様

返信ありがとうございます。

元々:$type = 'post'
現在:$type = ET_DEFAULT

となっております、ここで2つの疑問を感じたためお伺いした次第です。

1.ET_〇〇 は別用途のdefineではないでしょうか

2.定数を設定している点。
  設定はNullとすべきでは・・
  たまたま定数と同じ内容が存在した場合は・・

 

私の読み込み不足かもしれません。
その場合には4610のタワゴトと、ご容赦下さい。

 


   
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 14137
 

もともとpostオプションはカードの表示形式の設定項目です。
https://wp-cocoon.com/new_list/
なので「$type = 'post'」というのもあり得ない設定でした。
画像にもあるようにデフォルトだと「$type = 'default'」になるべきなのに。以前の方が問題ある記述でした。これは僕のコーディングミスです。
なので'default'が設定されるように定数であるET_DEFAULTを設定しています。

This post was modified 2か月前 2回 by わいひら

   
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 14137
 

今回のpost_typeオプションに関係のある引数はこちらになります。


   
loony
(@loony)
Eminent Member Registered
結合: 12か月前
投稿: 18
Topic starter  

わいひら様

ご回答ありがとうございます。

承知いたしました。

お騒がせしました。

今後ともよろしくお願いいたします

 


   
わいひら reacted
共有:

問題の解決に至った場合には、トピック冒頭の「解決済み」をクリックしていただけますと幸いです。

wpForoの解決済みリンク

また、有用な回答があった場合は「いいね!」もご活用ください。回答者の励みになります。

wpForoのいいねリンク

「いいね!」機能はフォーラム登録者のみが利用できる機能です。

CC BY-ND 2.1)準じていれば(リンクを貼っていただければ)転載も自由です。カスタマイズ記事を書く際にコード等をコピペ利用していただいて構いません。

フォーラムの使い方がよくわからない場合は、テストトピックで自由にテストしていただいて構いません。

最近の書き込みはこちら。

詳細なカスタマイズ依頼をするならこちら。

タイトルとURLをコピーしました