Cocoonフォーラム

書き込みの前に以下の3点をご確認ください。
  1. 1つのトピックにつき1つの質問を書き込んでください
  2. 不具合・カスタマイズ対象ページのURLを提示高速化を無効にしてください
  3. 該当部分のキャプチャ・環境情報とともに書き込んでいただけると助かります

何を書き込んだら良いか分からない場合は、以下のテンプレートをコピペしてご利用ください。

不具合・カスタマイズ対象ページのURL:

相談内容:

不具合の発生手順:

解決のために試したこと:

※文字だけでは正しく伝わらない可能性があるため、スクショ画像の添付もお願いします。
※高速化設定をしている場合は無効にしてください。
環境情報:

※↑こちらに「Cocoon設定 → テーマ情報」にある「環境情報」を貼り付けてください。

環境情報の取得方法はこちら。
https://wp-cocoon.com/theme-report/
高速化設定を無効にするにはこちら。
https://wp-cocoon.com/theme-trouble/

フォーラム利用ガイドリンク

  1. フォーラムガイドライン
  2. よくある質問と答え(FAQ)
  3. サポート対象外のケース
  4. 原因不明の不具合用トラブルシューティング
  5. トピックにHTMLを貼り付ける方法(推奨ツール:notepad.pw
  6. 真っ白画面でのエラーメッセージの確認方法
  7. ブラウザ環境チェックツール
  8. Cocoonカスタマイズ依頼

フォーラム質問後、問題等が解決した場合は結果を書き込んでいただけると幸いです。同様の問題で調べている方には、結果が一番気になる部分となります。

Cocoon設定用CSSの不具合(PH...
 
共有:
通知
すべてクリア

[解決済] Cocoon設定用CSSの不具合(PHP8)

9 投稿
2 ユーザー
3 Likes
1,806 表示
ろこ
(@lococo)
Prominent Member Registered
結合: 5年前
投稿: 830
Topic starter  

Cocoon設定用CSS

https://github.com/yhira/cocoon/blob/master/tmp/css-custom.php

での型の扱いが不適切な複数箇所で警告が出ており、添付画像のようにCSSが反映されません。

 

PHP8では警告の基準が引き上げられ、厳密でない箇所は今後のアップデート次第ではエラーになるようなので、適宜修正していく必要がありそうです。


   
わいひら reacted
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 14317
 

もしよろしければ、エラーメッセージを一行いただいてよろしいでしょうか。

あと、ろこさんは、ローカル環境は何を使用されていますでしょうか。
僕はローカル環境にLocal(旧Local by Flywheel)を使用しているのですが、PHPを8に変更するとphpinfoすら動作しなくて。
可能なら同じ環境にしてテストしてみます。


   
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 14317
 

探してみたら、XAMPP がPHP8に対応していたので、それで試してみます。


   
ろこ
(@lococo)
Prominent Member Registered
結合: 5年前
投稿: 830
Topic starter  

もしよろしければ、エラーメッセージを一行いただいてよろしいでしょうか。

add_action('get_header', function () {
  get_template_part('tmp/css-custom');
});

でエラーメッセージを表示させたところ、687行目703行目の文字列で計算している点が警告となっています。

Warning: A non-numeric value encountered

 

あと、ろこさんは、ローカル環境は何を使用されていますでしょうか。

普段の開発では基本的にwp-envを使用していますが、Cocoonの動作確認は内蔵されているテスト用コード等の関係からLocalで合わせています。

 

僕はローカル環境にLocal(旧Local by Flywheel)を使用しているのですが、PHPを8に変更するとphpinfoすら動作しなくて。

OSは何ですか?

PHPを動作するバージョンにしてからphpinfoを表示させて、PHPの動作環境がPHP8に対応しているか確認すると分かるのではないかと思います。


   
わいひら reacted
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 14317
 

警告メッセージありがとうございます。

OSはWindows8.1です。
もしかして、Localでバージョンを変更するだけではダメで、PHP8もインストールしないとダメなのかな。
後でやってみます。

とりあえず、XAMPP で動作を確認したので、不具合を修正してみました。
GitHubにアップしておきました。


   
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 14317
 

最新のWordPress5.6.2でもPHP8には対応していないんですね。
テーマ変更時に以下のようなエラーが出ました。

Fatal error: Uncaught ArgumentCountError: array_merge() does not accept unknown named parameters in wordpress\wp-includes\widgets.php:1261 Stack trace: #0 wordpress\wp-includes\widgets.php(1261):

GitHubのβ版にアップデートすることで、動作するようになりました。


   
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 14317
 
投稿者:: @yhira

もしかして、Localでバージョンを変更するだけではダメで、PHP8もインストールしないとダメなのかな。

XAMPPをインストールしたら、PHP8がインストールされるので、XAMPPを閉じて、LocalでPHPのバージョンを変更したら、動作しました。
LocalでPHP8にしたら、環境をインストールしてくれるわけではないんですね。


   
ろこ
(@lococo)
Prominent Member Registered
結合: 5年前
投稿: 830
Topic starter  

確認しました。

修正ありがとうございます。

 

最新のWordPress5.6.2でもPHP8には対応していないんですね。

WordPress5.6はPHP8のベータ互換としてリリースされたものであり、開発者がPHP8でWordPress本体をテストするためのバージョンです。

なので、本番環境で使用するにはまだしばらくは様子見といったところです。

 

LocalでPHP8にしたら、環境をインストールしてくれるわけではないんですね。

LocalではPHP8を選択すると、初回にPHP8はインストールされます。

ただし、PHP8の動作環境そのものをセットで揃えてくれるわけではないので、おそらくPHP用のコンパイラが古かったりだとか、PHP8の動作環境条件を満たせていなかったのが問題だったと考えられます。


   
わいひら reacted
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 14317
 

ご確認ありがとうございます。

そうなんですね。
Localは初回に全てがインストールされ環境を作ってくれるもので、PHP8も問題なくインストールされるものと思っていました。


   
共有:

問題の解決に至った場合には、トピック冒頭の「解決済み」をクリックしていただけますと幸いです。

また、有用な回答があった場合は返信右下にある「いいね!」もご活用ください。回答者の励みになります。

「いいね!」機能はフォーラム登録者のみが利用できる機能です。

CC BY-ND 2.1)準じていれば(リンクを貼っていただければ)転載も自由です。カスタマイズ記事を書く際にコード等をコピペ利用していただいて構いません。

フォーラムの使い方がよくわからない場合は、テストトピックで自由にテストしていただいて構いません。

最近の書き込みはこちら。

詳細なカスタマイズ依頼をするならこちら。

タイトルとURLをコピーしました