grayishスキン適用中

Cocoonフォーラム

サイト内検索
書き込みの前に以下の3点をご確認ください。
  1. 1つのトピックにつき1つの質問を書き込んでください
  2. 不具合・カスタマイズ対象ページのURLを提示高速化を無効にしてください
  3. 該当部分のキャプチャ・環境情報とともに書き込んでいただけると助かります

何を書き込んだら良いか分からない場合は、以下のテンプレートをコピペしてご利用ください。

不具合・カスタマイズ対象ページのURL:

相談内容:

不具合の発生手順:

解決のために試したこと:

※文字だけでは正しく伝わらない可能性があるため、スクショ画像の添付もお願いします。
※高速化設定をしている場合は無効にしてください。
環境情報:

※↑こちらに「Cocoon設定 → テーマ情報」にある「環境情報」を貼り付けてください。

環境情報の取得方法はこちら。
https://wp-cocoon.com/theme-report/
高速化設定を無効にするにはこちら。
https://wp-cocoon.com/theme-trouble/

フォーラム利用ガイドリンク

  1. フォーラムガイドライン
  2. よくある質問と答え(FAQ)
  3. サポート対象外のケース
  4. 原因不明の不具合用トラブルシューティング
  5. トピックにHTMLを貼り付ける方法(推奨ツール:notepad.pw
  6. 真っ白画面でのエラーメッセージの確認方法
  7. ブラウザ環境チェックツール
  8. Cocoonカスタマイズ依頼

フォーラム質問後、問題等が解決した場合は結果を書き込んでいただけると幸いです。同様の問題で調べている方には、結果が一番気になる部分となります。

Cocoonの更新をしたらFatal ...
 
共有:
通知
すべてクリア

[解決済] Cocoonの更新をしたらFatal errorが出て、ホームページにアクセスができなくなりました

7 投稿
3 ユーザー
2 Likes
4,521 表示
(@smaevo)
New Member Registered
結合: 4年前
投稿: 3
Topic starter  

お世話になります。

以前からCocoonを使わせてもらっているのですが、本日2.2.0.5 に更新したところ、
Fatal errorが出て、ホームページにアクセスができなくなりました。

WordPress管理画面にも入れません。

行ったのは、Cocoonの更新だけです。

サイトのアドレスは、 https://smaevo.com/ です。

試しに、下記のサブドメインのHPでもCocoonの更新を行ってみたところ、同じ症状になりました。
https://music.smaevo.com/

ブラウザでアクセスしたときに出るFatal errorの全文は、下記の通りです。

Fatal error: Uncaught Error: Call to undefined function register_block_style() in /home/smaevo/www/smaevo/wp-content/themes/cocoon-master/lib/block-editor-styles-paragraph.php:13 Stack trace: #0 /home/smaevo/www/smaevo/wp-content/themes/cocoon-master/lib/_imports.php(123): require_once() #1 /home/smaevo/www/smaevo/wp-content/themes/cocoon-master/lib/_defins.php(363): require_once('/home/smaevo/ww...') #2 /home/smaevo/www/smaevo/wp-content/themes/cocoon-master/functions.php(15): require_once('/home/smaevo/ww...') #3 /home/smaevo/www/smaevo/wp-settings.php(443): include('/home/smaevo/ww...') #4 /home/smaevo/www/smaevo/wp-config.php(93): require_once('/home/smaevo/ww...') #5 /home/smaevo/www/smaevo/wp-load.php(37): require_once('/home/smaevo/ww...') #6 /home/smaevo/www/smaevo/wp-blog-header.php(13): require_once('/home/smaevo/ww...') #7 /home/smaevo/www/smaevo/index.php(17): require('/home/smaevo/ww...') #8 {main} thrown in /home/smaevo/www/smaevo/wp-content/themes/cocoon-master/lib/block-editor-styles-paragraph.php on line 13

ネット調べてみても、何をすれば良いのかわからないので、解決策をご教示頂ければ幸いです。


   
わいひら
(@yhira)
Illustrious Member Admin
結合: 6年前
投稿: 16109
 

WordPressは5.3以上ですか?
https://developer.wordpress.org/reference/functions/register_block_style/


   
 Niki
(@Niki)
New Member
結合: 4年前
投稿: 2
 

お世話になります。

私もsmaevo様と同様の状態になってしまい困っております。
本日ブログテーマをCocoonに変更しようと親テーマ、子テーマをダウンロードの上WPで有効化したところ、同じような現象が起こってしまいました。PHPバージョンも7.3に変更してみましたが改修されません。
WP管理画面にも入れず、ただ白地画面に下記のエラーメッセージが表示されます。

Fatal error: Uncaught Error: Call to undefined function register_block_style() in /home/moegi/moegi1990.com/public_html/wp-content/themes/cocoon-master/lib/block-editor-styles-paragraph.php:13 Stack trace: #0 /home/moegi/moegi1990.com/public_html/wp-content/themes/cocoon-master/lib/_imports.php(123): require_once() #1 /home/moegi/moegi1990.com/public_html/wp-content/themes/cocoon-master/lib/_defins.php(363): require_once('/home/moegi/moe...') #2 /home/moegi/moegi1990.com/public_html/wp-content/themes/cocoon-master/functions.php(15): require_once('/home/moegi/moe...') #3 /home/moegi/moegi1990.com/public_html/wp-settings.php(443): include('/home/moegi/moe...') #4 /home/moegi/moegi1990.com/public_html/wp-config.php(93): require_once('/home/moegi/moe...') #5 /home/moegi/moegi1990.com/public_html/wp-load.php(37): require_once('/home/moegi/moe...') #6 /home/moegi/moegi1990.com/public_html/wp-login.php(12): require('/home/moegi/moe...') #7 {main} thrown in /home/moegi/moegi1990.com/public_html/wp-content/themes/cocoon-master/lib/block-editor-styles-paragraph.php on line 13

 

大変恐縮ですが、解決のアドバイスを頂ければ幸いです。
よろしくお願いいたします。


   
 Niki
(@Niki)
New Member
結合: 4年前
投稿: 2
 

@Niki 先ほど書き込んだ者です。

バックアップを復元させたのち、WPとPHPのヴァージョンアップをしたら正常に稼働しました。
お騒がせしまして申し訳ございませんでした。

取り急ぎお知らせいたします。


   
わいひら reacted
(@smaevo)
New Member Registered
結合: 4年前
投稿: 3
Topic starter  

version.phpを確認したところ、WPのヴァージョンは5.3以下(5.0.10 と 5.2.7)でした。

最新の5.4にアップデートできれば直るのでしょうか。

手動アップデートでできるか調べてみます。


   
(@smaevo)
New Member Registered
結合: 4年前
投稿: 3
Topic starter  

WPのヴァージョンを5.4にアップデートして、HPが開けるようになりました。

ありがとうございました。


   
わいひら reacted
わいひら
(@yhira)
Illustrious Member Admin
結合: 6年前
投稿: 16109
 

CocoonにはWordPress5.3以上が必要なので、ダウンロードページでも添付画像のように案内させていただいています。
というのもブロックエディターが標準化され、ブロックエディター用の関数を使用する必要があるからです。


   
共有:

問題の解決に至った場合には、トピック冒頭の「解決済み」をクリックしていただけますと幸いです。

また、有用な回答があった場合は返信右下にある「いいね!」もご活用ください。回答者の励みになります。

「いいね!」機能はフォーラム登録者のみが利用できる機能です。

CC BY-ND 2.1)準じていれば(リンクを貼っていただければ)転載も自由です。カスタマイズ記事を書く際にコード等をコピペ利用していただいて構いません。

フォーラムの使い方がよくわからない場合は、テストトピックで自由にテストしていただいて構いません。

最近の書き込みはこちら。

詳細なカスタマイズ依頼をするならこちら。

タイトルとURLをコピーしました