Cocoonフォーラム

書き込みの前に以下の3点をご確認ください。
  1. 1つのトピックにつき1つの質問を書き込んでください
  2. 不具合・カスタマイズ対象ページのURLを提示高速化を無効にしてください
  3. 該当部分のキャプチャ・環境情報とともに書き込んでいただけると助かります

何を書き込んだら良いか分からない場合は、以下のテンプレートをコピペしてご利用ください。

不具合・カスタマイズ対象ページのURL:

相談内容:

不具合の発生手順:

解決のために試したこと:

※文字だけでは正しく伝わらない可能性があるため、スクショ画像の添付もお願いします。
※高速化設定をしている場合は無効にしてください。
環境情報:

※↑こちらに「Cocoon設定 → テーマ情報」にある「環境情報」を貼り付けてください。

環境情報の取得方法はこちら。
https://wp-cocoon.com/theme-report/
高速化設定を無効にするにはこちら。
https://wp-cocoon.com/theme-trouble/

フォーラム利用ガイドリンク

  1. フォーラムガイドライン
  2. よくある質問と答え(FAQ)
  3. サポート対象外のケース
  4. 原因不明の不具合用トラブルシューティング
  5. トピックにHTMLを貼り付ける方法(推奨ツール:notepad.pw
  6. 真っ白画面でのエラーメッセージの確認方法
  7. ブラウザ環境チェックツール
  8. Cocoonカスタマイズ依頼

フォーラム質問後、問題等が解決した場合は結果を書き込んでいただけると幸いです。同様の問題で調べている方には、結果が一番気になる部分となります。

子テーマ インストール後の有効化時トラ...
 
共有:
通知
すべてクリア

[解決済] 子テーマ インストール後の有効化時トラブルについて

11 投稿
5 ユーザー
13 Likes
1,159 表示
marimo
 marimo
(@marimo)
New Member
結合: 2年前
投稿: 2
Topic starter  

お手数をおかけします。

Cocoonテーマを使用させていただこうと親・子ともにインストールし、子を有効化した瞬間に、

「Parse error: syntax error, unexpected ')' in /home/sakura0917/pub/wordpress/wp/wp-content/themes/cocoon-master/lib/settings.php on line 124

サイトに重大なエラーがありました。」

と表示されそれ以上進行出来なくなってしまいました。

一度アンインストールし、再度試みましたが同様でした。PHPは7.0以上となっています。

対策ご教示いただけますと幸いです。


   
引用
リフィトリー
(@leafytree)
Illustrious Member Moderator
結合: 4年前
投稿: 6845
 

前略、marimo さん

私は、エラーは詳しくないので、解決方法はよくわからないのですが、先ほど、ローカルのテストサイト環境にCocoonのバージョン:2.2.6.3をインストールしてみましたが、特にエラーは出ていません。

 

テスト環境のPHPのバージョンは、7.3.5 となっているようです。

 

わいひらさん、もしくは詳しい方が回答をくださるかと思いますので、少々お待ちください。

This post was modified 2年前 by リフィトリー

   
わいひら reacted
返信引用
はる
(@haruinoue)
Noble Member Moderator
結合: 2年前
投稿: 939
 

4日前の修正によるエラーのようです。

lib/settings.php122行目末尾の「,」が要らないのかな…?と思います。

GitHub上で報告している方もいるので、わいひらさんが対応してくださるの待ちで良いと思います。


   
返信引用
ジャム君
(@jamkun)
Estimable Member Registered
結合: 4年前
投稿: 158
 

PHP 7.2以下(7.2.34で確認)で問題発生、PHP 7.3以上(7.3.25で確認)で問題非発生でした。

 

すぐにでも修正しなければならないのであれば、はるさんがおっしゃっている

lib/settings.php122行目末尾の「,」が要らないのかな…?と思います。

「,」の削除でも修正可能です。

PHPのバージョンを上げてもいいですが、その他の不具合を引き起こす可能性もあるため、プラグインの対応状況には気をつけてください。


   
わいひら and はる reacted
返信引用
カワサキオート
 カワサキオート
(@カワサキオート)
Active Member
結合: 4年前
投稿: 11
 

ここからお邪魔させて頂きます。

私も同じようなエラーで悩んでいます。全くの無知ですのでご教授お願い申し上げます。

lib/settings.php122行目末尾の「,」が要らないのかな…?と思います』

→この画面はどこからどうやって開くのでしょうか~?これを試してみたいと思います。


   
わいひら reacted
返信引用
ぶーにょ
 ぶーにょ
(@ぶーにょ)
New Member
結合: 2年前
投稿: 1
 

同様の問題でビビりましたが…

 

XSERVERでPHPを7.4.13にアップグレードしたら、解決しました。

 

みなさんの知恵に感謝します。


   
わいひら reacted
返信引用
はる
(@haruinoue)
Noble Member Moderator
結合: 2年前
投稿: 939
 

→この画面はどこからどうやって開くのでしょうか~?これを試してみたいと思います。

ダウンロードした「cocoon-master」のフォルダの中に「lib」というフォルダがあり、その中に「settings.php」というファイルがあります。


   
わいひら reacted
返信引用
marimo
 marimo
(@marimo)
New Member
結合: 2年前
投稿: 2
Topic starter  

・settings.phpの「,」を修正しエラーがなくなりました。

・PHPをVerUPしても同様にエラーがなくなりました。

 

今回は始めたばかりでしたので、後者にてPHP7.4にし対応しました。

皆様ありがとうございました。

(同内容で他フォーラムも上がっていたようですので共有します。)


   
わいひら reacted
返信引用
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 14137
 

お手数をおかけしました。
当サイトのダウンロードファイルもアップしておきました。
どうやら自分の環境が、PHP7.4なのでエラーが出ない環境で、テストしたのでエラーが出ずエラーに気づいてなかったようです。


   
返信引用
カワサキオート
 カワサキオート
(@カワサキオート)
Active Member
結合: 4年前
投稿: 11
 

分かり易い解説、誠にありがとうございます。

しかしながらソフトかドライバが当PCに足りない様子で「settings.php」が開けませんでした。

そこでサーバーパネルにてPHPのバージョンアップをしましたところ正常になりました。

(正常になると「settings.php」は無くなり「settings」に変わっていました

お陰様で泣き顔が笑顔になりました!

無知な私へ御親切にご指南どうもありがとうございました。


   
わいひら reacted
返信引用
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 14137
 

array_push関数は、7.3で仕様変更があったんですね。
https://www.php.net/manual/ja/function.array-push.php


   
返信引用
共有:

問題の解決に至った場合には、トピック冒頭の「解決済み」をクリックしていただけますと幸いです。

wpForoの解決済みリンク

また、有用な回答があった場合は「いいね!」もご活用ください。回答者の励みになります。

wpForoのいいねリンク

「いいね!」機能はフォーラム登録者のみが利用できる機能です。

CC BY-ND 2.1)準じていれば(リンクを貼っていただければ)転載も自由です。カスタマイズ記事を書く際にコード等をコピペ利用していただいて構いません。

フォーラムの使い方がよくわからない場合は、テストトピックで自由にテストしていただいて構いません。

最近の書き込みはこちら。

詳細なカスタマイズ依頼をするならこちら。

タイトルとURLをコピーしました