Cocoonフォーラム

書き込みの前に以下の3点をご確認ください。
  1. 1つのトピックにつき1つの質問を書き込んでください
  2. 不具合・カスタマイズ対象ページのURLを提示高速化を無効にしてください
  3. 該当部分のキャプチャ・環境情報とともに書き込んでいただけると助かります

何を書き込んだら良いか分からない場合は、以下のテンプレートをコピペしてご利用ください。

不具合・カスタマイズ対象ページのURL:

相談内容:

不具合の発生手順:

解決のために試したこと:

※文字だけでは正しく伝わらない可能性があるため、スクショ画像の添付もお願いします。
※高速化設定をしている場合は無効にしてください。
環境情報:

※↑こちらに「Cocoon設定 → テーマ情報」にある「環境情報」を貼り付けてください。

環境情報の取得方法はこちら。
https://wp-cocoon.com/theme-report/
高速化設定を無効にするにはこちら。
https://wp-cocoon.com/theme-trouble/

フォーラム利用ガイドリンク

  1. フォーラムガイドライン
  2. よくある質問と答え(FAQ)
  3. サポート対象外のケース
  4. 原因不明の不具合用トラブルシューティング
  5. トピックにHTMLを貼り付ける方法(推奨ツール:notepad.pw
  6. 真っ白画面でのエラーメッセージの確認方法
  7. ブラウザ環境チェックツール
  8. Cocoonカスタマイズ依頼

フォーラム質問後、問題等が解決した場合は結果を書き込んでいただけると幸いです。同様の問題で調べている方には、結果が一番気になる部分となります。

先ほどCocoonテーマを更新後、管理...
 
共有:
通知
すべてクリア

[解決済] 先ほどCocoonテーマを更新後、管理画面とホームページにエラーが表示されアクセスできなくなりました

17 投稿
3 ユーザー
8 Likes
1,681 表示
yasuko
(@yasuko)
Active Member Registered
結合: 2年前
投稿: 11
Topic starter  

はじめまして。

どうぞよろしくお願い致します。

先ほどCocoonテーマを更新後、管理画面とホームページにエラーが表示され、管理画面にもアクセスできなくなりました。

似たようなご質問に対する回答を見たのですが、技術的なことがよく分からず、どのように対応したら好いかご教授いただけますでしょうか。

対象URL: https://chiba-ya.com/

WordPressのバージョン:管理画面に5.4.7に更新可能という表示があったように思います。

エラー:

Fatal error: Uncaught Error: Call to undefined function register_block_style() in /home/foodtokyo/chiba-ya.com/public_html/wp-content/themes/cocoon-master/functions.php:347 Stack trace: #0 /home/foodtokyo/chiba-ya.com/public_html/wp-includes/class-wp-hook.php(286): {closure}('') #1 /home/foodtokyo/chiba-ya.com/public_html/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array) #2 /home/foodtokyo/chiba-ya.com/public_html/wp-includes/plugin.php(465): WP_Hook->do_action(Array) #3 /home/foodtokyo/chiba-ya.com/public_html/wp-settings.php(525): do_action('init') #4 /home/foodtokyo/chiba-ya.com/public_html/wp-config.php(93): require_once('/home/foodtokyo...') #5 /home/foodtokyo/chiba-ya.com/public_html/wp-load.php(37): require_once('/home/foodtokyo...') #6 /home/foodtokyo/chiba-ya.com/public_html/wp-admin/admin.php(34): require_once('/home/foodtokyo...') #7 /home/foodtokyo/chiba-ya.com/public_html/wp-admin/index.php(10): require_once('/home/foodtokyo...') #8 {main} thrown in /home/foodtokyo/chiba-ya.com/public_html/wp-content/themes/cocoon-master/functions.php on line 347

サイトで技術的な問題が発生しています。サイト管理者のメールを確認して指示に従ってください。

 

よろしくお願い致します。


   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4666
 

yasukoさん

今スマホしか手元になく、調べたりはできないのですが。

  • WordPress
  • PHP

上記のバージョンは分かりますでしょうか。

また、FTPはお使いになれますでしょうか。

 

WordPressのバージョンは、管理者宛てに届いているメールで分かるかもしれません。


   
わいひら reacted
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4666
 

yasukoさん

お使いのテーマのフォルダ名を、適当なものに変更してください。

子テーマをお使いでしたら、子テーマのフォルダ名を「001cocoon-child-master」など、名前が変わればOKです。

後で戻せるように、分かり易い名前が良いです。

エックスサーバーをご利用のようですので、ファイルマネージャーが使えるはずです。

それで、ログインはできると思います。

 

メールが届いているはずですので、そのメールのリンクからリカバリーモードで入れるはずです。

その場合、上記対応は不要です。


   
yasuko
(@yasuko)
Active Member Registered
結合: 2年前
投稿: 11
Topic starter  

mk2さん

ありがとうございます。

Wordpressのバージョンですが、WordPressからメールが届き、5.2になっていました。

Cocoonは5.3以上ですよね><

PHPのバージョンは今すぐわからないのですが調べてみます。

FTPはWordpressを使い始めに使っただけでそれから使っていません。

私のPCが修理中でして手元になく、家族のパソコンを借りて作業しようと思っています。

どうぞよろしくお願い致します。

 

 

 

 


   
yasuko
(@yasuko)
Active Member Registered
結合: 2年前
投稿: 11
Topic starter  

mk2さん

リカバリーモードでログインができました!

下記実行して更新すればよろしいでしょうか。

WordPress 5.7.2 が利用可能です ! 今すぐ更新してください。

よろしくお願い致します。

This post was modified 2年前 by yasuko

   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4666
 

yasukoさん

まずは、WordPressをアップデートしてください。


   
わいひら reacted
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4666
 

yasukoさん

WordPressのアップデートが終わったら、別の端末(スマホなど)から、サイトの表示を確認してみてください。


   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4666
 

yasukoさん

PHPのバージョンも念のためご確認ください。

サーバー側から確認できるはずです。
PHP7.4系以外であれば、7.4系に変更してください。


   
yasuko
(@yasuko)
Active Member Registered
結合: 2年前
投稿: 11
Topic starter  

mk2さん

Wordpressは5.7.2にアップデートし、管理画面にもログインでき、ページも表示されました。

本当にありがとうございました。感謝申し上げます。


   
わいひら reacted
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4666
 

yasukoさん

PHPのバージョンもご確認いただけますか。


   
yasuko
(@yasuko)
Active Member Registered
結合: 2年前
投稿: 11
Topic starter  

mk2さん

サーバーパネルからPHPのバージョンをPHP7.3.25から「PHP7.4.13」に変更いたしました。

本当にありがとうございました。

 


   
わいひら reacted
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4666
 

yasukoさん

これで、ほぼ大丈夫だと思います。

今回のWordPressアップデートにより、プラグインも更新通知が来ているものがあると思います。
プラグインも最新のものにアップデートしておきましょう。 

ここ数ヶ月で、セキュリティ的にかなり危険な不具合のあるプラグインもいくつか発表されています。
最新版にすることで、問題なくなりますので、ぜひ。


   
わいひら reacted
yasuko
(@yasuko)
Active Member Registered
結合: 2年前
投稿: 11
Topic starter  

mk2さん

プラグインも更新しました。

アップデートや危険な不具合のあるプラグインもあることに留意し

今後対応していきます。

 


   
わいひら reacted
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4666
 

yasukoさん

WordPress本体にも重大なセキュリティの問題があることが、5月に発表されていました。

サーバーのファイルを外部から改ざん可能になってしまうという、大変危険なものでした。

過去すべてのWordPressのバージョンに、それは影響します。
対策されているのは、5.7.2のみです。

WordPress.org公式にも以下のようにあります。

積極的に保守されている5.7系統の最新版以外の以下のバージョンは、安全に使用することはできません。

 

そういう意味では、yasukoさんのサイトは大変危険な状態にありました。

今後ともご注意くださいませ。

何にせよ、解消して何よりです。
お疲れ様でした。


   
わいひら reacted
yasuko
(@yasuko)
Active Member Registered
結合: 2年前
投稿: 11
Topic starter  

mk2さん

大変危険な状態だったとは、びっくりです。

さる子さんから「もうすぐWordPress5.8のアップデートがありますが、すでに公開しているブログやウェブサイトをすぐ更新しないように気をつけてください。」とありましたので、すぐに更新しないようにします。(知らなかったらすぐにアップデートしてたかも(汗)

これを機に、こちらのフォーラムに参加して、情報を得たいと思います。

どうぞよろしくお願い致します。


   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 2年前
投稿: 4666
 

yasukoさん

WordPressは、WordPress本体・テーマ・プラグイン・PHPなど、可能な限りメンテナンスを続けていかなければ、運用ができないものです。

必ずしも最新のものが良いとは言えない場合もありますが、そこは自己判断の部分もあります。

常に動向は伺っておいた方が良いと思います。

 

プラグインのセキュリティの問題が日本で発表になった頃には…。

既に、自分のサイトはその手の攻撃を最低でも数件は受けています、大抵。
そのプラグインを入れていませんでしたから、被害はないですけど。

そういうものだと思っておいた方が良いです。

 

WordPress 5.8については、先程さる子さんがお書きになった通りですね。

他にも。。。

リフィトリーさん。
https://wp-cocoon.com/community/postid/53312/

そして、私も。
https://wp-cocoon.com/community/postid/53315/

書かせていただいています。

リリース直後は不安定なことも考えられますので、注意が必要です。


   
わいひら reacted
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 14315
 

とりあえず最新版v2.3.3.2でWordPress5.8の動作確認をしてみましたが、大きな問題はなさそうに見えました。
とはいえ、WordPressのアップデートでは何が起こるかはちょっとわからないので、今から怖いです。


   
共有:

問題の解決に至った場合には、トピック冒頭の「解決済み」をクリックしていただけますと幸いです。

また、有用な回答があった場合は返信右下にある「いいね!」もご活用ください。回答者の励みになります。

「いいね!」機能はフォーラム登録者のみが利用できる機能です。

CC BY-ND 2.1)準じていれば(リンクを貼っていただければ)転載も自由です。カスタマイズ記事を書く際にコード等をコピペ利用していただいて構いません。

フォーラムの使い方がよくわからない場合は、テストトピックで自由にテストしていただいて構いません。

最近の書き込みはこちら。

詳細なカスタマイズ依頼をするならこちら。

タイトルとURLをコピーしました