grayishスキン適用中

Cocoonフォーラム

サイト内検索
書き込みの前に以下の3点をご確認ください。
  1. 1つのトピックにつき1つの質問を書き込んでください
  2. 不具合・カスタマイズ対象ページのURLを提示高速化を無効にしてください
  3. 該当部分のキャプチャ・環境情報とともに書き込んでいただけると助かります

何を書き込んだら良いか分からない場合は、以下のテンプレートをコピペしてご利用ください。

不具合・カスタマイズ対象ページのURL:

相談内容:

不具合の発生手順:

解決のために試したこと:

※文字だけでは正しく伝わらない可能性があるため、スクショ画像の添付もお願いします。
※高速化設定をしている場合は無効にしてください。
環境情報:

※↑こちらに「Cocoon設定 → テーマ情報」にある「環境情報」を貼り付けてください。

環境情報の取得方法はこちら。
https://wp-cocoon.com/theme-report/
高速化設定を無効にするにはこちら。
https://wp-cocoon.com/theme-trouble/

フォーラム利用ガイドリンク

  1. フォーラムガイドライン
  2. よくある質問と答え(FAQ)
  3. サポート対象外のケース
  4. 原因不明の不具合用トラブルシューティング
  5. トピックにHTMLを貼り付ける方法(推奨ツール:notepad.pw
  6. 真っ白画面でのエラーメッセージの確認方法
  7. ブラウザ環境チェックツール
  8. Cocoonカスタマイズ依頼

フォーラム質問後、問題等が解決した場合は結果を書き込んでいただけると幸いです。同様の問題で調べている方には、結果が一番気になる部分となります。

ブロックエディターにおけるアイコンフォ...
 
共有:
通知
すべてクリア

[解決済] ブロックエディターにおけるアイコンフォントの不具合

7 投稿
2 ユーザー
14 Likes
1,219 表示
ろこ
(@lococo)
Prominent Member Registered
結合: 6年前
投稿: 830
Topic starter  

ブロックエディターでアイコンフォント(Font Awesome 4・5)の一部ファイルが読み込めていないようです。

ざっと確認した限りではwoff2ファイルしか読み込まれておらず、非対応ブラウザでは表示されないアイコンがあります。

 

読み込み時のURLが異なるディレクトリで404になっているので、テーマディレクトリの取得に誤りがあるとかだと思います。


   
iwamoto, stmap and pnp reacted
わいひら
(@yhira)
Illustrious Member Admin
結合: 6年前
投稿: 16122
 

ご連絡ありがとうございます。
お手数ですがよろしければ、どのブロックとかわかりますでしょうか。
アイコンリストとか、アイコンボックスとかを見てみたのですが、表示されていたので。


   
ろこ
(@lococo)
Prominent Member Registered
結合: 6年前
投稿: 830
Topic starter  

すべてのブロックを確認したわけではありませんが、添付画像の通りです。

woff2だけはテーマディレクトリと存在しないディレクトリの2種類を重複して読み込んでいるようです。

 

woff2に対応しているブラウザでは表示されますが、存在するwoff2を読み込むまでにタイムラグがあり、一部のアイコンが表示されるまでに一瞬の間があります。


   
iwamoto, stmap and pnp reacted
ろこ
(@lococo)
Prominent Member Registered
結合: 6年前
投稿: 830
Topic starter  

一応、アイコンの表示も添付しておきます。

 

アイコンフォントのファイル読み込みは非同期だと思うので、該当のフォントを初回に表示するのに合わせて読み込みを行います。

他にFont Awesomeのアイコンが表示されていない状態で初めて表示させるとき、読み込みの重複や存在しないファイルの読み込みなどによってGIFのようにタイムラグが発生する場合が出てきているようです。

 

フォーマットツールボタン選択表示されない不具合修正あたりが気になりますが、検証はしていません。


   
iwamoto, stmap and pnp reacted
わいひら
(@yhira)
Illustrious Member Admin
結合: 6年前
投稿: 16122
 

ありがとうございます。
僕の環境では、ラグもなく表示されるので、全く気づきませんでした。
検証して見たところ、以前からそのようになっていたようです。
原因としては、ブロックエディターで@fortawesome/react-fontawesomeで呼び出しているのに、PHPからも重複して呼び出しているからっぽかったので、ブロックエディターだけPHPで呼び出さないようにしてみました。


   
pnp reacted
ろこ
(@lococo)
Prominent Member Registered
結合: 6年前
投稿: 830
Topic starter  

修正ありがとうございます。

今のところ問題はないようです。

 

私の通常の環境でも特に問題は感じられなかったのですが、スキンユーザーから問い合わせがあったので調べたところ、woff2以外の404エラーが原因だと分かったので報告した次第です。


   
iwamoto, stmap, わいひら and 1 people reacted
わいひら
(@yhira)
Illustrious Member Admin
結合: 6年前
投稿: 16122
 

ご確認いただきありがとうございます。


   
共有:

問題の解決に至った場合には、トピック冒頭の「解決済み」をクリックしていただけますと幸いです。

また、有用な回答があった場合は返信右下にある「いいね!」もご活用ください。回答者の励みになります。

「いいね!」機能はフォーラム登録者のみが利用できる機能です。

CC BY-ND 2.1)準じていれば(リンクを貼っていただければ)転載も自由です。カスタマイズ記事を書く際にコード等をコピペ利用していただいて構いません。

フォーラムの使い方がよくわからない場合は、テストトピックで自由にテストしていただいて構いません。

最近の書き込みはこちら。

詳細なカスタマイズ依頼をするならこちら。

タイトルとURLをコピーしました