「メイド・イン・ヘブン」スキン適用中

Cocoonフォーラム

サイト内検索
書き込みの前に以下の3点をご確認ください。
  1. 1つのトピックにつき1つの質問を書き込んでください
  2. 不具合・カスタマイズ対象ページのURLを提示高速化を無効にしてください
  3. 該当部分のキャプチャ・環境情報とともに書き込んでいただけると助かります

何を書き込んだら良いか分からない場合は、以下のテンプレートをコピペしてご利用ください。

不具合・カスタマイズ対象ページのURL:

相談内容:

不具合の発生手順:

解決のために試したこと:

※文字だけでは正しく伝わらない可能性があるため、スクショ画像の添付もお願いします。
※高速化設定をしている場合は無効にしてください。
環境情報:

※↑こちらに「Cocoon設定 → テーマ情報」にある「環境情報」を貼り付けてください。

環境情報の取得方法はこちら。
https://wp-cocoon.com/theme-report/
高速化設定を無効にするにはこちら。
https://wp-cocoon.com/theme-trouble/

フォーラム利用ガイドリンク

  1. フォーラムガイドライン
  2. よくある質問と答え(FAQ)
  3. サポート対象外のケース
  4. 原因不明の不具合用トラブルシューティング
  5. トピックにHTMLを貼り付ける方法(推奨ツール:notepad.pw
  6. 真っ白画面でのエラーメッセージの確認方法
  7. ブラウザ環境チェックツール
  8. Cocoonカスタマイズ依頼

フォーラム質問後、問題等が解決した場合は結果を書き込んでいただけると幸いです。同様の問題で調べている方には、結果が一番気になる部分となります。

タグ「style amp-custom...
 
共有:
通知
すべてクリア

[解決済] タグ「style amp-custom」の CSS 構文エラーです。について

8 投稿
2 ユーザー
1 Likes
2,722 表示
(@老眼ライダー)
Active Member
結合: 4年前
投稿: 5
Topic starter  

いつも参考にさせて頂いております。

ありがとうございます。

 

4日程前から、

タグ「style amp-custom」の CSS 構文エラー - 修飾ルールの前にスタイルシートの末尾があります。

に悩まされており、上記エラーが156ページにまで膨らんでしまっています。

AMP Validatorでは、

必須タグ「html!doctype」がないか、正しくありません。

とありますが、どこをどうしていいのか分かりません。

AMPエラーの画像も添付します。

よろしくお願いいたします。

該当サイトのひとつ  https://runthin.net/costco-soft-serve-ice-cream-sundae?amp=1

 

----------------------------------------------
サイト名:自転車でサッカーの応援に行こう!
サイトURL: https://runthin.net
ホームURL: https://runthin.net
コンテンツURL:/wp-content
インクルードURL:/wp-includes/
テンプレートURL:/wp-content/themes/cocoon-master
スタイルシートURL:/wp-content/themes/cocoon-child-master
子テーマスタイル:/wp-content/themes/cocoon-child-master/style.css
スキン:/wp-content/themes/cocoon-master/skins/skin-colors-blue/style.css
WordPressバージョン:5.4.2
PHPバージョン:7.3.17
ブラウザ:Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/83.0.4103.97 Safari/537.36
サーバーソフト:Apache
サーバープロトコル:HTTP/1.1
エンコーディング:gzip, deflate, br
言語:ja,en-US;q=0.9,en;q=0.8
----------------------------------------------
テーマ名:Cocoon
バージョン:2.1.8
カテゴリ数:101
タグ数:211
ユーザー数:1
----------------------------------------------
子テーマ名:Cocoon Child
バージョン:1.1.0
style.cssサイズ:2163バイト
functions.phpサイズ:203バイト
----------------------------------------------
Gutenberg:1
AMP:1
PWA:0
Font Awesome:4
Auto Post Thumbnail:0
Retina:1
ホームイメージ:/wp-content/uploads/2019/11/29ECCE85-ECCB-46D0-ADAE-80406D9A10EE.png
----------------------------------------------
ブラウザキャッシュ有効化:1
HTML縮小化:0
CSS縮小化:1
JavaScript縮小化:1
Lazy Load:1
WEBフォントLazy Load:1
----------------------------------------------
利用中のプラグイン:
Akismet Anti-Spam 4.1.6
Aurora Heatmap 1.4.4
BackWPup 3.7.1
Category Order and Taxonomy Terms Order 1.5.7.2
Contact Form 7 5.1.9
Duplicate Post 3.2.4
EWWW Image Optimizer 5.4.1
Google XML Sitemaps 4.1.0
Imsanity 2.6.0
Simple 301 Redirects 1.07
SiteGuard WP Plugin 1.5.0
TablePress 1.11
TablePress Extension: Responsive Tables 1.7
Widget Logic 5.10.4
WP Fastest Cache 0.9.0.7
WP Multibyte Patch 2.8.4
WP User Avatar 2.2.6
----------------------------------------------

 


   
引用
わいひら
(@yhira)
Illustrious Member Admin
結合: 6年前
投稿: 16440
 

一旦子テーマの内容を全てバックアップしておきます。
https://runthin.net/wp-content/themes/cocoon-child-master/style.css
その後、子テーマのCSSを全て削除し以下でチェックをするとエラーが出ますか?
https://validator.ampproject.org/#url=https%3A%2F%2Frunthin.net%2Fcostco-soft-serve-ice-cream-sundae%3Famp%3D1
チェックをする前は、Cocoon設定のキャッシュ削除からAMPのキャッシュを削除する必要があります。


   
返信引用
(@老眼ライダー)
Active Member
結合: 4年前
投稿: 5
Topic starter  

わいひら様

ご連絡ありがとうございます。

 

子テーマのCSSを全削除→AMPキャッシュ削除→チェックしましたが、同様のエラーが出たままです。

CSSの一部削除等、数パターン試しましたがダメでした。

 

よろしくお願いいたします。

 


   
返信引用
わいひら
(@yhira)
Illustrious Member Admin
結合: 6年前
投稿: 16440
 

子テーマのCSSを削除した状態で状態を見せていただくことは可能でしょうか。
https://runthin.net/wp-content/themes/cocoon-child-master/style.css


   
返信引用
(@老眼ライダー)
Active Member
結合: 4年前
投稿: 5
Topic starter  

この状態でAMPキャッシュ削除しましたが宜しいでしょうか。

ご確認お願いします。


   
返信引用
(@老眼ライダー)
Active Member
結合: 4年前
投稿: 5
Topic starter  

しばらく経ってから再度確認したところ、エラーが解消されました。

他のページも解消されて来ていますので、もう少し様子みてみます。

今まで全く問題なかったので、

どのCSSが影響していたのか少しずつ追加・検証してみます。


   
わいひら reacted
返信引用
わいひら
(@yhira)
Illustrious Member Admin
結合: 6年前
投稿: 16440
 

確かに現在は問題なさそうですね。
CSS構文エラーが出ていたので、何かしらCSSの記述に問題があったのかもしれません。


   
返信引用
(@老眼ライダー)
Active Member
結合: 4年前
投稿: 5
Topic starter  

わいひら様

ご確認ありがとうございます。

進展ありましたら、再度連絡させて頂きます。

対応して頂き、ありがとうございました。


   
返信引用
共有:

問題の解決に至った場合には、トピック冒頭の「解決済み」をクリックしていただけますと幸いです。

また、有用な回答があった場合は返信右下にある「いいね!」もご活用ください。回答者の励みになります。

「いいね!」機能はフォーラム登録者のみが利用できる機能です。

CC BY-ND 2.1)準じていれば(リンクを貼っていただければ)転載も自由です。カスタマイズ記事を書く際にコード等をコピペ利用していただいて構いません。

フォーラムの使い方がよくわからない場合は、テストトピックで自由にテストしていただいて構いません。

最近の書き込みはこちら。

詳細なカスタマイズ依頼をするならこちら。

タイトルとURLをコピーしました