現在デフォルトスキンとして「Season (Autumn)」を適用中。

エラーメッセージが出てテーマが表示されない | 不具合報告 | Cocoon フォーラム

書き込みの前に以下の3点をご確認ください。
  1. 1つのトピックにつき1つの質問を書き込んでください
  2. 不具合・カスタマイズ対象ページのURLを提示してください
  3. 該当部分のキャプチャ・環境情報とともに書き込んでいただけると助かります

フォーラム利用ガイドリンク

  1. フォーラムガイドライン
  2. よくある質問と答え(FAQ)
  3. サポート対象外のケース
  4. 原因不明の不具合用トラブルシューティング
  5. トピックにHTMLを貼り付ける方法(推奨ツール:notepad.pw
  6. 真っ白画面でのエラーメッセージの確認方法 
  7. ブラウザ環境チェックツール

フォーラムの内容は、CCライセンス(CC BY-ND 2.1)準じていれば(リンクを貼っていただければ)転載も自由です。カスタマイズ記事を書く際にコード等をコピペ利用していただいて構いません。

フォーラムの使い方がよくわからない場合は、テストトピックで自由にテストしていただいて構いません。

詳細なカスタマイズ依頼をするならこちら。

フォーラムのTwitterアカウント(@CocoonForum)はこちら

スポンサーリンク
エラーメッセージが出てテーマが表示され...
 
Share:

[解決済] エラーメッセージが出てテーマが表示されない  


Saaya K
(@suberidai)
New Memberサイト
参加: 2年 前
投稿: 3
2018年3月20日 18:30  

初めまして。

Parse error: syntax error, unexpected T_CONST in /home/users/2/(中略)/themes/cocoon-master/lib/page-settings/code-funcs.php on line 27

と言うエラーが出て、プレビューができません。
ちなみに、以前Simplicity2の使用を試みた際にも、同様のエラーが出て挫折しています。

相性の悪いプラグインはチェックして停止したのですが、考えられる原因は何がありますでしょうか…。お判りでしたら教えていただければ幸いです。よろしくお願いいたします。


わいひら
(@yhira)
メンバーサイト Admin
参加: 2年 前
投稿: 6440
わいひら - Facebookわいひら - Twitter
2018年3月20日 18:55  

はじめまして。
PHPのバージョンは幾つでしょうか?

できればPHP7を、少なくともPHP5.6以上を利用する必要があります。


Saaya K
(@suberidai)
New Memberサイト
参加: 2年 前
投稿: 3
2018年3月20日 19:09  

ロリポップを使用しています。
>ver.5.6(モジュール版/CGI版)
>ver.7.1(CGI版)

となっているのですが、
>ver.5.6(モジュール版/CGI版)
こちらが適用されてしまっているのでしょうか。


わいひら
(@yhira)
メンバーサイト Admin
参加: 2年 前
投稿: 6440
わいひら - Facebookわいひら - Twitter
2018年3月20日 19:39  

以下の設定方法でうまくいかなかったでしょうか。
PHP設定 / サーバー・プログラム / マニュアル - レンタルサーバーならロリポップ!
https://lolipop.jp/manual/user/php-setting/

ただ、PHPのバージョンが関係ない書き方に変更したものを、以下にアップしました。
https://wp-cocoon.com/wp-content/uploads/dlm_uploads/2018/02/cocoon-master-0.2.4.zip

よろしければ、試してみていただければ幸いです。


Saaya K
(@suberidai)
New Memberサイト
参加: 2年 前
投稿: 3
2018年3月21日 01:30  

PHPの設定画面があったのですね…確認不足でした、申し訳ありません。
設定が7より前になっていたので、変更したところ無事に表示されるようになりました。
お忙しいところ親切にご回答くださりありがとうございました。活用させていただきます。


わいひら
(@yhira)
メンバーサイト Admin
参加: 2年 前
投稿: 6440
わいひら - Facebookわいひら - Twitter
2018年3月21日 18:57  

ご報告ありがとうございます。

やはりPHPのバージョンでそういったエラーが出るという確認ができました。


Share:
スポンサーリンク
わいひらをフォローする
おすすめサーバ

性能も兼ね備えながら安くブログ運営を開始したいのであればここ1択。

◎LiteSpeedを用いた高速サーバー(完全SSD)
◎http/2・QUIC(高速化プロトコル)に対応
◎東京・大阪でリージョン選択が可能
◎プランのアップ・ダウングレードが自由自在
◎同サービス内でドメイン管理が可能
◎転送量が多い
◎毎日無料バックアップ(14日分)
◎復元ポイントを指定して復旧可能(無料)
◎アダルト・出会い系サイト可
◎ドメインとサーバー代のチャージ払いが可能
○サーバ引っ越しオプションあり(有料)
サービス運営期間:1年1ヶ月

1年以上の契約をする場合は、クーポンコード入力でさらに10%割引(※2019/12/31まで)。

クーポンコード:PK4JK4RJ

クーポンの使用方法はこちら

プラン変更で負荷対策が行えるので、ブログ向きのレンタルサーバーです。

◎LiteSpeedを用いた高速サーバー(完全SSD)
◎http/2・QUIC(高速化プロトコル)に対応
◎プランのアップ・ダウングレードが自由自在
◎転送量が多い
◎毎日無料バックアップ(14日分)
◎復元ポイントを指定して復旧可能(無料)
◎アダルト・出会い系サイト可
○サーバ引っ越しオプションあり(有料)
○サーバー料金をチャージ払いが可能
サービス運営期間:3年

安定感抜群のサーバーです。あまり急激なアクセス変動がないアフィリエイトサイトに向いています。

◎nginxを用いた高速サーバー(完全SSD)
◎老舗サーバーなので安定感抜群
◎ディスク容量が多い
◎転送量が多い
◎同サービス内でドメイン管理が可能
○http/2(高速化プロトコル)に対応
○毎日無料バックアップ(14日分)
△DBは7日分だけ無料復旧可能(ファイルは有料)
×プラン変更でCPUのスペックアップができない
×プラン変更しても即時反映されない
×アダルト・出会い系サイト不可
サービス運営期間:16年

とにかく速い。サイトに表示スピードを求めるならココ。

◎nginxを用いた高速サーバー(完全SSD)
◎プランのアップ・ダウングレードが自由自在
◎ディスク容量が多い
◎転送量が多い
○http/2(高速化プロトコル)に対応
○毎日無料バックアップ(14日分)
○DB復旧は無料(ファイルは有料)
○サーバ引っ越しツールあり
○サーバー料金をチャージ払いが可能
△新しいサービスなので運営櫪がまだ短い
サービス運営期間:11ヶ月

格安な値段で始められる高機能サーバーです。
性能も備えつつ最安ならここ。
サイトを続けるうちにアクセスが増えれば、プランのアップグレートで対応可能です。

◎LiteSpeedを用いた高速サーバー(完全SSD)
◎激安プランが用意してある
◎値段あたりのスペックが高い(コスパ良し)
◎サーバ引っ越しオプションあり(無料)
◎アダルト・出会い系サイト可
○http/2(高速化プロトコル)に対応
△プランのアップは可能だがダウンは不可
△毎日自動バックアップ(1日分)
△前日のバックアップからのみ復元できる(無料)
サービス運営期間:3年

Cocoon
  
動作中

ログイン または 登録 してください

タイトルとURLをコピーしました