Cocoonフォーラム

書き込みの前に以下の3点をご確認ください。
  1. 1つのトピックにつき1つの質問を書き込んでください
  2. 不具合・カスタマイズ対象ページのURLを提示高速化を無効にしてください
  3. 該当部分のキャプチャ・環境情報とともに書き込んでいただけると助かります

何を書き込んだら良いか分からない場合は、以下のテンプレートをコピペしてご利用ください。

不具合・カスタマイズ対象ページのURL:

相談内容:

不具合の発生手順:

解決のために試したこと:

※文字だけでは正しく伝わらない可能性があるため、スクショ画像の添付もお願いします。
※高速化設定をしている場合は無効にしてください。
環境情報:

※↑こちらに「Cocoon設定 → テーマ情報」にある「環境情報」を貼り付けてください。

環境情報の取得方法はこちら。
https://wp-cocoon.com/theme-report/
高速化設定を無効にするにはこちら。
https://wp-cocoon.com/theme-trouble/

フォーラム利用ガイドリンク

  1. フォーラムガイドライン
  2. よくある質問と答え(FAQ)
  3. サポート対象外のケース
  4. 原因不明の不具合用トラブルシューティング
  5. トピックにHTMLを貼り付ける方法(推奨ツール:notepad.pw
  6. 真っ白画面でのエラーメッセージの確認方法
  7. ブラウザ環境チェックツール
  8. Cocoonカスタマイズ依頼

フォーラム質問後、問題等が解決した場合は結果を書き込んでいただけると幸いです。同様の問題で調べている方には、結果が一番気になる部分となります。

Webサイトのログイン画面に入れなくな...
 
共有:
通知
すべてクリア

Webサイトのログイン画面に入れなくなりました

6 投稿
2 ユーザー
3 Likes
1,107 表示
みたらい
 みたらい
(@みたらい)
Eminent Member
結合: 4年前
投稿: 47
Topic starter  

いつもお世話になっております。
このたび、WordPressで作ったサイトに関して移管を行いました。
1.ドメイン会社の変更(エックスドメインからバリュードメインへ変更しました)
2.サーバーアカウントの変更(Aというサーバーアカウントから、Bという別のサーバーアカウントに移しました)

その際、下記の手順を踏みました。
①サーバーAから、FTPソフトでサイトのデータを保管
②ドメインを削除
③FTPソフトでサーバーBにデータをアップロード

結果、添付画像のようにエラーが出ました。
特にデータの書き換えもしていないので、原因がわかりません。

大変お手数ですが、ご教授頂けますと幸いです.....?


   
引用
namipho
(@namipho)
New Member Registered
結合: 3年前
投稿: 3
 

ドメイン会社変更?ってのがよくわからないのですが、レンタルwebサーバの会社が変わったということでよろしいでしょうか?これによりレンタルwebサーバとドメイン管理の両方をバリュードメインに移動したという認識で以下に説明を。(ドメインを管理している会社を変えるだけで起きるエラーとは思えないため)

エラーメッセージを見る限り、レンタルwebサーバを移動したことでサーバ上のPHPプログラム参照位置が変わった可能性があります。(サーバ管理会社によりその辺の環境が変わることはあります)

まずPHPがインストされているディレクトリ位置とPHPの対応Verを確認(状況によってはサーバの対応Verを変更する必要あり)し、エラーにあるようにwp-settings-phpの33行目のinclude_Pathの情報を書き換えてからwp-setting.phpをFTPでアップしてください。(変更保存時の文字コードに注意すること)


   
わいひら reacted
返信引用
みたらい
 みたらい
(@みたらい)
Eminent Member
結合: 4年前
投稿: 47
Topic starter  

namipho様

ありがとうございます!
ドメインのurlはそのまま、ドメインの管理会社を変更した状態です。
エックスドメインからバリュードメインに変更しました。

その後、エックスサーバーの中で
サーバーAからサーバーBに変更しました。
つまり、サーバー会社に変更はなく、エックスサーバーの中で別のアカウントに移した状態です。
(アカウント名phi1111からアカウント名phi1112に変更するイメージです。

ややこしくて恐縮です......。


   
返信引用
namipho
(@namipho)
New Member Registered
結合: 3年前
投稿: 3
 

エックスサーバの中でプラン変更しましたか?

とりあえずドメイン変更は関係ないですね。サーバ移動ということで。

 

こちらもエックスサーバでwordpressを運用してるため、こちらのwp-setting.phpも見たのですが、33行目は/wp-include/version.phpを参照してました。

ここから、version.phpの中身もチェックしたのですが、include_path変数に当たるものは見つからず。$required_php_version(=5.6.20になっていた)はあったものの、現在サーバーパネルでPHP verは「7.36.16(推奨)」に切り替えてあります。

どうやら、ここの変数は最低動作ラインの変数っぽい(?)ので変更する必要はない模様。

 

とりあえず、wp-setting.phpとversion.phpでinclude_path変数があるかどうかを確認してください。存在する場合は、サーバーパネルで選択されているPHP verと同じもののパスを入力してください。

(サーバパネルで選択されているPHP verが低いものが選択されている場合は7.3以上にしておいたほうがよいと思われます)

↓はPHPのパス一覧です。

https://www.xserver.ne.jp/manual/man_program_soft.php


   
わいひら reacted
返信引用
namipho
(@namipho)
New Member Registered
結合: 3年前
投稿: 3
 

もしかすると、/wp-include/version.php自体が新しいサーバ上にアップロードできてない。

という可能性があります。

もしくはファイル名が何か間違ってるとか。全角半角など注意して見てください。


   
わいひら reacted
返信引用
みたらい
 みたらい
(@みたらい)
Eminent Member
結合: 4年前
投稿: 47
Topic starter  

丁寧に教えて頂き、嬉しい限りです。
本当にありがとうございます....!

教えていただいた通りにやってみます。


   
返信引用
共有:

問題の解決に至った場合には、トピック冒頭の「解決済み」をクリックしていただけますと幸いです。

また、有用な回答があった場合は返信右下にある「いいね!」もご活用ください。回答者の励みになります。

「いいね!」機能はフォーラム登録者のみが利用できる機能です。

CC BY-ND 2.1)準じていれば(リンクを貼っていただければ)転載も自由です。カスタマイズ記事を書く際にコード等をコピペ利用していただいて構いません。

フォーラムの使い方がよくわからない場合は、テストトピックで自由にテストしていただいて構いません。

最近の書き込みはこちら。

詳細なカスタマイズ依頼をするならこちら。

タイトルとURLをコピーしました