「メイド・イン・ヘブン」スキン適用中

Cocoonフォーラム

サイト内検索
書き込みの前に以下の3点をご確認ください。
  1. 1つのトピックにつき1つの質問を書き込んでください
  2. 不具合・カスタマイズ対象ページのURLを提示高速化を無効にしてください
  3. 該当部分のキャプチャ・環境情報とともに書き込んでいただけると助かります

何を書き込んだら良いか分からない場合は、以下のテンプレートをコピペしてご利用ください。

不具合・カスタマイズ対象ページのURL:

相談内容:

不具合の発生手順:

解決のために試したこと:

※文字だけでは正しく伝わらない可能性があるため、スクショ画像の添付もお願いします。
※高速化設定をしている場合は無効にしてください。
環境情報:

※↑こちらに「Cocoon設定 → テーマ情報」にある「環境情報」を貼り付けてください。

環境情報の取得方法はこちら。
https://wp-cocoon.com/theme-report/
高速化設定を無効にするにはこちら。
https://wp-cocoon.com/theme-trouble/

フォーラム利用ガイドリンク

  1. フォーラムガイドライン
  2. よくある質問と答え(FAQ)
  3. サポート対象外のケース
  4. 原因不明の不具合用トラブルシューティング
  5. トピックにHTMLを貼り付ける方法(推奨ツール:notepad.pw
  6. 真っ白画面でのエラーメッセージの確認方法
  7. ブラウザ環境チェックツール
  8. Cocoonカスタマイズ依頼

フォーラム質問後、問題等が解決した場合は結果を書き込んでいただけると幸いです。同様の問題で調べている方には、結果が一番気になる部分となります。

simplicityからの移行でサーバ...
 
共有:
通知
すべてクリア

simplicityからの移行でサーバ負荷が大きくなりました

4 投稿
2 ユーザー
1 Reactions
1,577 表示
(@tarayuki)
Active Member Registered
結合: 4年前
投稿: 6
Topic starter  

わいひらさま

お世話になっております。

Simplicityからcocoonへ移行をしたのですが、サーバのCPU負荷が2倍強となりました。

下記の設定のように、サーバの負荷を考え、ランキング作成やアクセス集計はおこなわず、ウィジェットでも人気の記事などは利用しないようにしています。

またキャッシュについては当方は別のCDNを利用しており、基本的にサイトへの接続は数時間単位での接続にしているのですが、1時間の数回程度、大きなCPUの利用が発生しています。

お聞きしたいのは、サーバの負荷を下げるための設定があれば教えてください。

下記設定のようにランキングやアクセス集計は行っていない(と思われる)、定期的にデータを収集したりしているものはあるのでしょうか?またその際に、wp-cron.phpを利用していますか?

よろしくお願いいたします。

※サイト名等は控えさせていただきます。申し訳ありません。

----------------------------------------------
サイト名:*
サイトURL:
*
ホームURL:*
コンテンツURL:/wp-content
インクルードURL:/wp-includes/
テンプレートURL:/wp-content/themes/cocoon-master
スタイルシートURL:/wp-content/themes/cocoon-child-master
子テーマスタイル:/wp-content/themes/cocoon-child-master/style.css
WordPressバージョン:5.4.1
PHPバージョン:7.2.27
ブラウザ:Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/81.0.4044.138 Safari/537.36
サーバーソフト:Apache
サーバープロトコル:HTTP/1.1
言語:ja,en-US;q=0.9,en;q=0.8
----------------------------------------------
テーマ名:Cocoon
バージョン:2.1.4.1
カテゴリ数:159
タグ数:7718
ユーザー数:2
----------------------------------------------
子テーマ名:Cocoon Child
バージョン:1.1.0
style.cssサイズ:18283バイト
functions.phpサイズ:23694バイト
----------------------------------------------
Gutenberg:1
AMP:1
PWA:0
Font Awesome:5
Auto Post Thumbnail:0
Retina:1
ホームイメージ:/wp-content/uploads/2019/12/
.png
----------------------------------------------
ブラウザキャッシュ有効化:0
HTML縮小化:1
CSS縮小化:1
JavaScript縮小化:1
Lazy Load:1
WEBフォントLazy Load:1
----------------------------------------------
利用中のプラグイン:
Akismet Anti-Spam 4.1.5
Category Order and Taxonomy Terms Order 1.5.7.2
Classic Editor 1.5
Contact Form 7 5.1.7
Disable REST API 1.5
Duplicate Post 3.2.4
Editor Extender 0.2.1
EWWW Image Optimizer 5.3.1
Google XML Sitemaps 4.1.0
KB Robots.txt 1.0.1
Link Library 6.4.7
PHP Code Widget 2.3
Post Snippets 3.0.21
PS Auto Sitemap 1.1.9
PuSHPress 0.1.9
TinyMCE Advanced 5.4.0
WP-RSSImport 4.6.1
WP Category Permalink 3.4.0
WP Multibyte Patch 2.8.4
----------------------------------------------

 


   
引用
わいひら
(@yhira)
Illustrious Memberサイト Admin
結合: 6年前
投稿: 16663
 

申し訳ないですが、個々の環境動作についてまではわからないです。
少なくとも、サーバーにログインして設定をみないことには何とも言えないです。
サーバー負荷に関しては、ページキャッシュプラグインなどを利用するしかないかと思います。


   
返信引用
(@tarayuki)
Active Member Registered
結合: 4年前
投稿: 6
Topic starter  

wordpressの変更はしておらず、simplicityからcocoonへテーマを変更して負荷が増えたので、テーマの方のアクセス集計やランキングなどで集計処理が走っているのかと思ったのですが、違いましたか。

どうもありがとうございました。

This post was modified 4年前 by tarayuki

   
わいひら reacted
返信引用
わいひら
(@yhira)
Illustrious Memberサイト Admin
結合: 6年前
投稿: 16663
 

アクセス集計やランキングで、そこまで影響あるかは負荷状態を見てみないとちょっと分からないかもしれません。
ただ、ランキングとかはキャッシュ処理がしてあるので、そこまで影響もないと思うんですけど。
もちろん全く負荷がないわけではないので、全く関係ないとまではいえないんですけど。
いずれにせよ、機能を無効にしているのであれば、それら機能の影響はほぼなくなると言っていいと思います。

当サイトは、アクセス集計やランキングを使用していますが、大した負荷もかかっていないようです。
負荷の問題は、サーバーのスペックにも関わってくるので、総合的な判断が必要になるのかもしれません。


   
返信引用
共有:

問題の解決に至った場合には、トピック冒頭の「解決済み」をクリックしていただけますと幸いです。

また、有用な回答があった場合は返信右下にある「いいね!」もご活用ください。回答者の励みになります。

「いいね!」機能はフォーラム登録者のみが利用できる機能です。

CC BY-ND 2.1)準じていれば(リンクを貼っていただければ)転載も自由です。カスタマイズ記事を書く際にコード等をコピペ利用していただいて構いません。

フォーラムの使い方がよくわからない場合は、テストトピックで自由にテストしていただいて構いません。

最近の書き込みはこちら。

詳細なカスタマイズ依頼をするならこちら。

タイトルとURLをコピーしました