Cocoonフォーラム

書き込みの前に以下の3点をご確認ください。
  1. 1つのトピックにつき1つの質問を書き込んでください
  2. 不具合・カスタマイズ対象ページのURLを提示高速化を無効にしてください
  3. 該当部分のキャプチャ・環境情報とともに書き込んでいただけると助かります

何を書き込んだら良いか分からない場合は、以下のテンプレートをコピペしてご利用ください。

不具合・カスタマイズ対象ページのURL:

相談内容:

不具合の発生手順:

解決のために試したこと:

※文字だけでは正しく伝わらない可能性があるため、スクショ画像の添付もお願いします。
※高速化設定をしている場合は無効にしてください。
環境情報:

※↑こちらに「Cocoon設定 → テーマ情報」にある「環境情報」を貼り付けてください。

環境情報の取得方法はこちら。
https://wp-cocoon.com/theme-report/
高速化設定を無効にするにはこちら。
https://wp-cocoon.com/theme-trouble/

フォーラム利用ガイドリンク

  1. フォーラムガイドライン
  2. よくある質問と答え(FAQ)
  3. サポート対象外のケース
  4. 原因不明の不具合用トラブルシューティング
  5. トピックにHTMLを貼り付ける方法(推奨ツール:notepad.pw
  6. 真っ白画面でのエラーメッセージの確認方法
  7. ブラウザ環境チェックツール
  8. Cocoonカスタマイズ依頼

フォーラム質問後、問題等が解決した場合は結果を書き込んでいただけると幸いです。同様の問題で調べている方には、結果が一番気になる部分となります。

共有:
通知
すべてクリア

[解決済] スキンが反映されない

18 投稿
3 ユーザー
7 Likes
6,905 表示
ちう
 ちう
(@ちう)
Active Member
結合: 3年前
投稿: 10
Topic starter  

スキン設定のプレビューも真っ白で、実際設定してみても反映されません。

プラグインを全て停止しても変わらなかったので、プラグインが問題ではなさそうです。

キャッシュの削除も行いましたが、効果なしでした。

Wordpressやプラグインやcocoonのバージョンも全て新しいはずなので、よくわかりません。

スキンはサムライブルー(無印)を選択しています。

過去の質問にスキンのCSSを子テーマ内のCSSに張り付けたという方がいらっしゃったので真似しようかと思ったのですが、お恥ずかしいことにいくら調べてもやり方が分かりませんでした...

以下環境情報です。

----------------------------------------------
サイト名:迷える子羊たちの放牧場
サイトURL: https://ymu39.info
ホームURL: http://ymu39.info
コンテンツURL: https://ymu39.info/wp-content
インクルードURL: https://ymu39.info/wp-includes/
テンプレートURL: https://ymu39.info/wp-content/themes/cocoon-master
スタイルシートURL: https://ymu39.info/wp-content/themes/cocoon-master
スキン:/wp-content/themes/cocoon-master/skins/skin-samuraiblue-muji/style.css
Wordpressバージョン:5.2.2
PHPバージョン:7.1.30
ブラウザ:Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/75.0.3770.100 Safari/537.36
サーバーソフト:Apache
サーバープロトコル:HTTP/2.0
エンコーディング:gzip, deflate, br
言語:ja,en-US;q=0.9,en;q=0.8
----------------------------------------------
テーマ名:Cocoon
バージョン:1.8.9.1
カテゴリ数:15
タグ数:5
ユーザー数:1
----------------------------------------------
Gutenberg:1
AMP:0
PWA:0
Auto Post Thumbnail:0
ホームイメージ:
----------------------------------------------
ブラウザキャッシュ有効化:0
HTML縮小化:0
CSS縮小化:0
JavaScript縮小化:0
Lazy Load:0
WEBフォントLazy Load:0
JavaScript(フッター):1
----------------------------------------------
利用中のプラグイン:
.html after URL 1.0
AddQuicktag 2.5.3
All In One SEO Pack 3.1.1
brBrbr 4.1
Category Order and Taxonomy Terms Order 1.5.7
Dagon Design Sitemap Generator 3.17
Google Analyticator 6.5.4
Google Analytics Dashboard for WP (GADWP) 5.3.8
Google XML Sitemaps 4.1.0
Hot Linked Image Cacher 1.16
No Self Pings 1.1.2
Regenerate Thumbnails 3.1.1
Similar Posts 3.1.1
WordPress Ping Optimizer 2.35.1.0.0
WP-DBManager 2.79.2
WP-PostViews 1.76.1
WP Multibyte Patch 2.8.2
WPtouch Mobile Plugin 4.3.37
----------------------------------------------


   
かうたっく
(@kautakku)
Famed Member Moderator
結合: 5年前
投稿: 4764
 

スキン設定のプレビューも真っ白で、実際設定してみても反映されません。

PC上で ctrlキー Shiftキー Jキー を同時クリックしてデベロッパーツール画面上にエラーはでてませんか?

もう1つ。以下方法でエラーを確認して、エラー画面とエラーをアップしてください。

https://nelog.jp/edump-wordpress-error-check

 

どちらも問題ない場合。ウィジェットが問題になる場合もあったりしますが、ウィジェットには何も入れてませんか?

とりあえずこの範囲だけ案内っと。

 

過去の質問にスキンのCSSを子テーマ内のCSSに張り付けたという方がいらっしゃったので真似しようかと思ったのですが、お恥ずかしいことにいくら調べてもやり方が分かりませんでした...

skinsフォルダ内にある該当skinフォルダをPC上で作ったskinsフォルダに入れて、子テーマフォルダ内にアップロード。

Cocoon設定のスキンタブで子テーマ内のスキンとしてアップした該当skinを選択して有効化。ザックリですが。その前に画面が表示されないので、これもザックリした案内だけ。


   
わいひら reacted
ちう
 ちう
(@ちう)
Active Member
結合: 3年前
投稿: 10
Topic starter  

ctrlキー、Shiftキー、Jキー、を同時クリックしたところ、いろいろエラーが出てきましたがよくわかりません...

url先のedumpですが、なぜか新規登録ができませんでした。メアド2つ使いましたが、どちらにも確認のメールが届きません。迷惑メールにもなかったです。
もしかしたら時間おけば来るかもしれないので、とりあえず様子見です。

 


   
ちう
 ちう
(@ちう)
Active Member
結合: 3年前
投稿: 10
Topic starter  

スクショの続きです


   
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 14165
 

とりあえず、サイトのURLスキームにそれぞれ違いがあります。

サイトURL: https://ymu39.info
ホームURL: http://ymu39.info

WordPressの一般設定のURL設定でこの部分は統一しておいた方もいるかもしれません(※今回の原因かはわかりませんけどまずはここから修正した方が良いかと思います)。


   
かうたっく
(@kautakku)
Famed Member Moderator
結合: 5年前
投稿: 4764
 

ctrlキー、Shiftキー、Jキー、を同時クリックしたところ、いろいろエラーが出てきましたがよくわかりません...

わいひらさんが言ってる事をやれば、エラーもスッキリしそうですね^^

 

あとカスタマイズを行ってないなら、プラグインの影響が大きいかも。

なのでプラグインの停止で表示される事もあるかもしれないです。

ついでに、不要なプラグインは削除したり、停止を行うのが良いと思います。

 

url先のedumpですが、なぜか新規登録ができませんでした。メアド2つ使いましたが、どちらにも確認のメールが届きません。迷惑メールにもなかったです。

https://www.coreserver.jp/support/faq/php-error.php

エラーコードを表示できる状態にサーバー側で操作して、エラーコードが表示されるかご確認いただけますか。

エラーコードのコピペがおわれば、速攻元に戻せばOKです。

※プラグイン停止で表示されたら、この工程はいらないかも。


   
ちう
 ちう
(@ちう)
Active Member
結合: 3年前
投稿: 10
Topic starter  

一般設定のWordPress アドレス (URL)とサイトアドレス (URL)を確認しましたが、どちらもhttp:の形でした。
環境情報に載ってるサイトURL: https://ymu39.info  とはどこで編集できるのでしょうか。

 

かうたっくさんのURL先についてですが、.user.iniを設置しコマンドを記載してエラー表示が出る設定にするとありますが、設置場所について

設置場所は、呼び出すphpファイルを設置しているディレクトリ・フォルダ内になります。

とあるのですが、説明が理解できません...

お手数おかけしてすみません。


   
かうたっく
(@kautakku)
Famed Member Moderator
結合: 5年前
投稿: 4764
 

一般設定のWordPress アドレス (URL)とサイトアドレス (URL)を確認しましたが、どちらもhttp:の形でした。

サーバー側でSSL対応をおこなわれたか、すでにもう行われていると思うんですけど。ちがってますか?

※アクセスできるので対応済みだと思うけど、どういうことかな?と思いまして。

h ttps://ymu39.info/wp-content/uploads/2019/07/b212d34d51d39cc8144c33b5e71630b5_s.jpg


   
わいひら reacted
かうたっく
(@kautakku)
Famed Member Moderator
結合: 5年前
投稿: 4764
 

.user.iniを設置しコマンドを記載してエラー表示が出る設定にするとありますが、設置場所について

設置場所は、呼び出すphpファイルを設置しているディレクトリ・フォルダ内になります。

FTPソフトを使ってymu39.infoにWordPressを置くためのフォルダを開いた場所にありませんか。もしくは開いた場所のフォルダ内などにあると思われます。

ただそのサーバーの状況がよく分からないのが前提です。


   
わいひら reacted
かうたっく
(@kautakku)
Famed Member Moderator
結合: 5年前
投稿: 4764
 

それ以前にプラグインの停止は試しましたか?それで表示されませんか??

※プラグインを停止した結果が書いてないので。

ちうさんにとって、プラグイン停止が一番カンタンな方法だと思います。


   
わいひら reacted
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 14165
 
  • サイトURL(site_url())=Wordpressアドレス
  • ホームURL(home_url())=サイトアドレス

のはずなのに、なぜこのように出力されるのだろう…。

https://www.deep-blog.jp/engineer/archives/13101/
※この関数と設定面の関係が最高にややこしいけどWordPress自体がそういう仕様です。

 

確かに1度全てのプラグインの停止を試してみて欲しいです。


   
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 14165
 

環境情報で以下のように出るなら、

サイトURL: https://ymu39.info
ホームURL: http://ymu39.info

以下の「Wordpressアドレス」のところはhttpsスキームになると思うんですけど、ならないのはなぜなんだろう…。


   
かうたっく
(@kautakku)
Famed Member Moderator
結合: 5年前
投稿: 4764
 

Cocoon設定からSSL設定を行ったんだと思うんですけど。

タイミング的には

  1. スキンを有効化
  2. SSL設定(Cocoon設定より)
  3. その後記事を書いて画像をアップ

その順序で行った可能性が高そう。って事しか分からないです ? ? ? 

 

理由を書くのを忘れました。

Mixed Content: The page at 'h ttps://ymu39.info/17/.html' was loaded over HTTPS, but requested an insecure stylesheet 'h ttp://ymu39.info/wp-content/themes/cocoon-master/skins/skin-samuraiblue-muji/style.css?ver=5.2.2'. This request has been blocked; the content must be served over HTTPS.

そして上述済みの画像のパスがSSL対応済み。

h ttps://ymu39.info/wp-content/uploads/2019/07/b212d34d51d39cc8144c33b5e71630b5_s.jpg

そんな感じで。CocoonSSL対応とか関係してないですかね。

This post was modified 3年前 2回 by かうたっく

   
ちう
 ちう
(@ちう)
Active Member
結合: 3年前
投稿: 10
Topic starter  

プラグインの停止についてですが、一番最初の投稿で書いた通り全て停止しましたが変わりありませんでした。

CocoonでもSSL設定しましたが、記事を投稿したのはCocoonを設定する前です。

SSL設定をオフにしたのですが、丁度のタイミングでプライバシーエラーが起こってしまったのでまた後で返信します。


   
かうたっく
(@kautakku)
Famed Member Moderator
結合: 5年前
投稿: 4764
 

CocoonでもSSL設定しましたが、記事を投稿したのはCocoonを設定する前です。

SSL設定をオフにしたのですが、丁度のタイミングでプライバシーエラーが起こってしまったのでまた後で返信します。

  1. 記事投稿
  2. CocoonのSSL設定をON
  3. SSL設定をOFF
  4. プライバシーエラー

2のSSL設定をON前に1の記事投稿をした際、画像をアップロードしていれば、既にhttpsのアドレスになってるはずない。と思ったんですが、CocoonサイドでURLの書き換えってか置換がおこなわれた可能性も。

h ttps://ymu39.info/wp-content/uploads/2019/07/b212d34d51d39cc8144c33b5e71630b5_s.jpg

 

SSL設定をオフにしたのですが、丁度のタイミングでプライバシーエラーが起こってしまった

https://bibabosi-rizumu.com/wordpress-ssl-https/#toc4

上記見出し『ライバシーが保護されない。とブラウザで表示され、アクセスできない』にある画像のようなことですか?

 

って事は、その際サーバー上でSSL化をするよう手順を踏んだ。って事で間違いないですか??

  • サーバー上でSSL設定をおこなったか。その手順を踏んだかどうか、それを知りたいです。

 


   
わいひら reacted
ちう
 ちう
(@ちう)
Active Member
結合: 3年前
投稿: 10
Topic starter  

はい、記事を投稿する前にサーバー側で無料SSLの設定をしていました。

そしてCocoonのSSLを有効にした後に、かうたっくさんからSSLの設定が影響してるかもという指摘を頂いたので、
CocoonのSSL設定を解除した後サーバー側でも無料SSLを解除したところエラーが起きました。エラーの種類はurl先にもある赤い注意マークのものです。


   
ちう
 ちう
(@ちう)
Active Member
結合: 3年前
投稿: 10
Topic starter  

すみません、先ほど解決しました!!

原因はサーバー側で無料SSL設定したのにもかかわらずWordpress側の一般設定にて
WordPress アドレス (URL)とサイトアドレス (URL)をhttpからhttpsに設定し直していなかったからでした...

サーバー側だけで設定すれば他はいじらなくてもいいと思っていたので完全に私の凡ミスです...

迷惑かけてすみません、本当にありがとうございました!!


   
わいひら reacted
かうたっく
(@kautakku)
Famed Member Moderator
結合: 5年前
投稿: 4764
 

原因はサーバー側で無料SSL設定したのにもかかわらずWordpress側の一般設定にて
WordPress アドレス (URL)とサイトアドレス (URL)をhttpからhttpsに設定し直していなかったからでした...

サーバー側のSSL設定を行ってないうえで、WPアドレス・サイトアドレスを変更したら、さらにエラーが出るので、サーバーのSSL設定を行っているかどうかを知りたかった感じです。

 

サーバーのSSH設定をおこなっているのであれば、それらのアドレスを変更すればOKです。

スキンのプレビューが表示されたようで何よりです。お疲れさまでした!


   
わいひら reacted
共有:

問題の解決に至った場合には、トピック冒頭の「解決済み」をクリックしていただけますと幸いです。

wpForoの解決済みリンク

また、有用な回答があった場合は「いいね!」もご活用ください。回答者の励みになります。

wpForoのいいねリンク

「いいね!」機能はフォーラム登録者のみが利用できる機能です。

CC BY-ND 2.1)準じていれば(リンクを貼っていただければ)転載も自由です。カスタマイズ記事を書く際にコード等をコピペ利用していただいて構いません。

フォーラムの使い方がよくわからない場合は、テストトピックで自由にテストしていただいて構いません。

最近の書き込みはこちら。

詳細なカスタマイズ依頼をするならこちら。

タイトルとURLをコピーしました