「メイド・イン・ヘブン」スキン適用中

Cocoonフォーラム

サイト内検索
書き込みの前に以下の3点をご確認ください。
  1. 1つのトピックにつき1つの質問を書き込んでください
  2. 不具合・カスタマイズ対象ページのURLを提示高速化を無効にしてください
  3. 該当部分のキャプチャ・環境情報とともに書き込んでいただけると助かります

何を書き込んだら良いか分からない場合は、以下のテンプレートをコピペしてご利用ください。

不具合・カスタマイズ対象ページのURL:

相談内容:

不具合の発生手順:

解決のために試したこと:

※文字だけでは正しく伝わらない可能性があるため、スクショ画像の添付もお願いします。
※高速化設定をしている場合は無効にしてください。
環境情報:

※↑こちらに「Cocoon設定 → テーマ情報」にある「環境情報」を貼り付けてください。

環境情報の取得方法はこちら。
https://wp-cocoon.com/theme-report/
高速化設定を無効にするにはこちら。
https://wp-cocoon.com/theme-trouble/

フォーラム利用ガイドリンク

  1. フォーラムガイドライン
  2. よくある質問と答え(FAQ)
  3. サポート対象外のケース
  4. 原因不明の不具合用トラブルシューティング
  5. トピックにHTMLを貼り付ける方法(推奨ツール:notepad.pw
  6. 真っ白画面でのエラーメッセージの確認方法
  7. ブラウザ環境チェックツール
  8. Cocoonカスタマイズ依頼

フォーラム質問後、問題等が解決した場合は結果を書き込んでいただけると幸いです。同様の問題で調べている方には、結果が一番気になる部分となります。

カラーパレットでの設定値の扱い方による...
 
共有:
通知
すべてクリア

[解決済] カラーパレットでの設定値の扱い方による不具合

61 投稿
2 ユーザー
34 Likes
6,777 表示
わいひら
(@yhira)
Illustrious Member Admin
結合: 6年前
投稿: 16456
 

実装したテーマのブランチはこちら。
https://github.com/yhira/cocoon/tree/deprecated-blocks


   
ろこ
(@lococo)
Prominent Member Registered
結合: 6年前
投稿: 830
Topic starter  

確認しました。

確認した範囲での修正点としては、修正版の方でマイクロテキストブロックの配置がエディタ上に反映されていない(エディタ上でのスタイルを調整)くらいかと思います。


   
わいひら
(@yhira)
Illustrious Member Admin
結合: 6年前
投稿: 16456
 

ご確認ありがとうございます。
そこはチェック漏れしてました。
以下で修正しておきました。
https://github.com/yhira/cocoon/tree/deprecated-blocks


   
ろこ
(@lococo)
Prominent Member Registered
結合: 6年前
投稿: 830
Topic starter  

確認しました。
修正ありがとうございます。

  • 各ブロックの修正版への移行
  • カラーパレットに関わるフック等でのカスタマイズ
  • 修正版の各ブロックでのカラー設定値

についてはざっと確認を行っていますが、今のところその他の問題箇所は見当たりません。


   
わいひら
(@yhira)
Illustrious Member Admin
結合: 6年前
投稿: 16456
 

いろいろなご確認をいただき感謝申し上げます。
ロコさんのアドバイスがなければ、にっちもさっちもいかなかったと思います。

一応、新たな不具合があった場合用にしばらくトピックは空けておこうと思います。


   
ろこ
(@lococo)
Prominent Member Registered
結合: 6年前
投稿: 830
Topic starter  

10月前半頃に作成したコンテンツ内にて、アイコンリストブロックのボーダー色がmigrateで引き継げていないことに今気づきました。
設定していたのは全てカラーパレットの黒色です。

11月前半~自動アップデートで作成したコンテンツ内の同ブロックは引き継げているので、可能性として考えられるのは初期のカラーパレット修正版が含まれていた自動アップデート(1.9.9.5~1.9.9.6あたり?)になるのではないかと。
その期間に自動アップデートを行った場合、作成されたブロックの一部カラー設定が引き継げない場合があるかもしれません。


   
わいひら
(@yhira)
Illustrious Member Admin
結合: 6年前
投稿: 16456
 

ご連絡ありがとうございます。
不具合を確認いたしました。1.9.9.5~1.9.9.6あたりでは、以下のようなカラーコード設定にしていたようですね;


   
わいひら
(@yhira)
Illustrious Member Admin
結合: 6年前
投稿: 16456
 

最新版は、3桁でなくて6桁にしていました。
これが原因で不具合が起こったっぽいですね。


   
わいひら
(@yhira)
Illustrious Member Admin
結合: 6年前
投稿: 16456
 

ブロック用のコードを書き換えて、対応されるように修正してみました。
https://github.com/yhira/Cocoon-Blocks-embed/commit/1d4d944964b4616746e30c16b7091a5566efc02c

この修正はGitHubの最新版にも適用しておきました。
https://github.com/yhira/cocoon


   
ろこ
(@lococo)
Prominent Member Registered
結合: 6年前
投稿: 830
Topic starter  

該当箇所は既にmigrateされてしまっているので、直接の原因を確認することはできませんが、問題点とそれに対する修正は確認しました。
ありがとうございます。


   
わいひら reacted
わいひら
(@yhira)
Illustrious Member Admin
結合: 6年前
投稿: 16456
 

コードを確認していただいてありがとうございます。


   
固定ページ 2 / 2
共有:

問題の解決に至った場合には、トピック冒頭の「解決済み」をクリックしていただけますと幸いです。

また、有用な回答があった場合は返信右下にある「いいね!」もご活用ください。回答者の励みになります。

「いいね!」機能はフォーラム登録者のみが利用できる機能です。

CC BY-ND 2.1)準じていれば(リンクを貼っていただければ)転載も自由です。カスタマイズ記事を書く際にコード等をコピペ利用していただいて構いません。

フォーラムの使い方がよくわからない場合は、テストトピックで自由にテストしていただいて構いません。

最近の書き込みはこちら。

詳細なカスタマイズ依頼をするならこちら。

タイトルとURLをコピーしました