「メイド・イン・ヘブン」スキン適用中

Cocoonフォーラム

サイト内検索
書き込みの前に以下の3点をご確認ください。
  1. 1つのトピックにつき1つの質問を書き込んでください
  2. 不具合・カスタマイズ対象ページのURLを提示高速化を無効にしてください
  3. 該当部分のキャプチャ・環境情報とともに書き込んでいただけると助かります

何を書き込んだら良いか分からない場合は、以下のテンプレートをコピペしてご利用ください。

不具合・カスタマイズ対象ページのURL:

相談内容:

不具合の発生手順:

解決のために試したこと:

※文字だけでは正しく伝わらない可能性があるため、スクショ画像の添付もお願いします。
※高速化設定をしている場合は無効にしてください。
環境情報:

※↑こちらに「Cocoon設定 → テーマ情報」にある「環境情報」を貼り付けてください。

環境情報の取得方法はこちら。
https://wp-cocoon.com/theme-report/
高速化設定を無効にするにはこちら。
https://wp-cocoon.com/theme-trouble/

フォーラム利用ガイドリンク

  1. フォーラムガイドライン
  2. よくある質問と答え(FAQ)
  3. サポート対象外のケース
  4. 原因不明の不具合用トラブルシューティング
  5. トピックにHTMLを貼り付ける方法(推奨ツール:notepad.pw
  6. 真っ白画面でのエラーメッセージの確認方法
  7. ブラウザ環境チェックツール
  8. Cocoonカスタマイズ依頼

フォーラム質問後、問題等が解決した場合は結果を書き込んでいただけると幸いです。同様の問題で調べている方には、結果が一番気になる部分となります。

WordPress5.6とCocoon...
 
共有:
通知
すべてクリア

[解決済] WordPress5.6とCocoon2.2.5.1

7 投稿
3 ユーザー
2 Likes
1,385 表示
(@ひなき)
New Member
結合: 3年前
投稿: 3
Topic starter  

はじめまして。

いつもアップデートありがとうございます。

タイトルの通り、2つの組み合わせだと投稿の編集画面がなかなか表示されず、1分近くかかるようになってしまいました。

そして、表示されてからちょっと経つとブラウザが落ちてしまいます。

試しに、Cocoonを前の2.2.4.5に戻してみると、編集画面が崩れてはしまいますが、すぐに表示されるようになり、ブラウザが落ちることもなくなります。

ブラウザはchromeを使ってます。


   
ろこ
(@lococo)
Prominent Member Registered
結合: 6年前
投稿: 830
 

ブラウザが落ちるのは投稿を新規追加したときも同様でしょうか?

WordPress5.6の不具合修正でDOM操作を遅延させていることから、レンダリングが完了してページが表示されるまでに以前よりもほんの少しだけ遅れるというのはあると思います。

時間がかかりすぎたり、ブラウザが落ちるのは、この遅延によるタイミングの差に問題があるのかどうか、実際に同じ症状が起こってみないとちょっとよく分かりません。


   
わいひら reacted
わいひら
(@yhira)
Illustrious Member Admin
結合: 6年前
投稿: 16435
 

僕の環境のChromeで、同様の状態にして試してみたのですが、添付GIFのようなタイミングでは表示されます。
スーパーリロード(Ctrl+F5)等を行っても同様でしょうか。


   
(@ひなき)
New Member
結合: 3年前
投稿: 3
Topic starter  

記事を新規追加したときは普通に表示されました。

表示が遅かった編集画面でスーパーリロードというのをやってみましたが改善されません。

表示される瞬間はGIFにして頂いた感じなのですが、その表示までに30秒以上かかってしまいます。


   
わいひら
(@yhira)
Illustrious Member Admin
結合: 6年前
投稿: 16435
 

その投稿の、コンテンツ量はどのくらいでしょうか。

よろしければこちらの環境でも試してみるので、時間がかかるコンテンツのソースコードを、以下の方法でいただいてよろしいでしょうか。
https://wp-cocoon.com/notepad-pw/
※上記はクラシックエディターの例ですが、ブロックエディターのソースコードです。


   
(@ひなき)
New Member
結合: 3年前
投稿: 3
Topic starter  

解決しました。

Cocoonに入ってないスキンを使用していたのでスキンが問題かと思い問い合わせたところ、カスタムHTMLブロックを多用しているのが問題だと教えてもらいました。

別の書き方に変えたら以前のように表示されました。

お手数おかけしました。


   
わいひら reacted
わいひら
(@yhira)
Illustrious Member Admin
結合: 6年前
投稿: 16435
 

カスタムHTMLについては、今後何とかならないか検討してみます。


   
共有:

問題の解決に至った場合には、トピック冒頭の「解決済み」をクリックしていただけますと幸いです。

また、有用な回答があった場合は返信右下にある「いいね!」もご活用ください。回答者の励みになります。

「いいね!」機能はフォーラム登録者のみが利用できる機能です。

CC BY-ND 2.1)準じていれば(リンクを貼っていただければ)転載も自由です。カスタマイズ記事を書く際にコード等をコピペ利用していただいて構いません。

フォーラムの使い方がよくわからない場合は、テストトピックで自由にテストしていただいて構いません。

最近の書き込みはこちら。

詳細なカスタマイズ依頼をするならこちら。

タイトルとURLをコピーしました