「メイド・イン・ヘブン」スキン適用中

Cocoonフォーラム

サイト内検索
書き込みの前に以下の3点をご確認ください。
  1. 1つのトピックにつき1つの質問を書き込んでください
  2. 不具合・カスタマイズ対象ページのURLを提示高速化を無効にしてください
  3. 該当部分のキャプチャ・環境情報とともに書き込んでいただけると助かります

何を書き込んだら良いか分からない場合は、以下のテンプレートをコピペしてご利用ください。

不具合・カスタマイズ対象ページのURL:

相談内容:

不具合の発生手順:

解決のために試したこと:

※文字だけでは正しく伝わらない可能性があるため、スクショ画像の添付もお願いします。
※高速化設定をしている場合は無効にしてください。
環境情報:

※↑こちらに「Cocoon設定 → テーマ情報」にある「環境情報」を貼り付けてください。

環境情報の取得方法はこちら。
https://wp-cocoon.com/theme-report/
高速化設定を無効にするにはこちら。
https://wp-cocoon.com/theme-trouble/

フォーラム利用ガイドリンク

  1. フォーラムガイドライン
  2. よくある質問と答え(FAQ)
  3. サポート対象外のケース
  4. 原因不明の不具合用トラブルシューティング
  5. トピックにHTMLを貼り付ける方法(推奨ツール:notepad.pw
  6. 真っ白画面でのエラーメッセージの確認方法
  7. ブラウザ環境チェックツール
  8. Cocoonカスタマイズ依頼

フォーラム質問後、問題等が解決した場合は結果を書き込んでいただけると幸いです。同様の問題で調べている方には、結果が一番気になる部分となります。

SSL化したのですが、一部のページが保...
 
共有:
通知
すべてクリア

[解決済] SSL化したのですが、一部のページが保護された通信にならない

9 投稿
4 ユーザー
13 Likes
4,910 表示
(@komennta)
Eminent Member Registered
結合: 6年前
投稿: 26
Topic starter  

このたびブログをSSL化したのですが、一部のページが保護された通信にならない状態なので相談に乗っていただきたいです。

トップページ、カテゴリーなどのページは「保護された通信」と表示されるのですが、それ以外の個別投稿ページに移ると「通信が保護されていない」と表示されてしまいます。

↓トップページ

https://enjoy-yugioh.com/

↓個別投稿

https://enjoy-yugioh.com/crawler-deck/

Firefoxのブラウザーのコンソールで確認したところ、以下のような要素が邪魔をしているようです。

 

安全なページ上で (安全でない) 混在表示コンテンツ “ ” を読み込んでいます

 

しかし、ページを見てもこのようなjpg画像が見当たらず、どこに使用されている画像なのかも分かりません。

どのようにすれば問題を解決できるでしょうか。

初歩的な質問かもしれませんが、解答お待ちしております。


   
かうたっく
(@kautakku)
Famed Member Moderator
結合: 6年前
投稿: 4764
 

https://gyazo.com/1495e9d4895362d618cdce054e248e45

上記の部分

<p>安全なページ上で (安全でない) 混在表示コンテンツ “ <a class="wpforo-auto-embeded-link" href="http://enjoy-yugioh.com/wp-content/uploads/2018/04/fabikon.jpg" target="_blank" rel="nofollow"><img alt="" class="wpforo-auto-embeded-image" src="http://enjoy-yugioh.com/wp-content/uploads/2018/04/fabikon.jpg"></a> ” を読み込んでいます</p>

今年4月にアップロードされた画像fabikon.jpgみたいですね。

head内になにか:または、どこかで指定されてるのかもしれませんが、確認できてません。他に原因が分かるまで、ご返信は大丈夫です。


   
keybou
(@keybou)
Trusted Member Registered
結合: 6年前
投稿: 60
 

komennta さん初めまして。

該当するかどうかは分かりませんが、僕も以前同じような経験をした事がありましたのでもしも参考になればと思いまして・・・

↓トップページ

https://enjoy-yugioh.com/

↓個別投稿

https://enjoy-yugioh.com/crawler-deck/

上記、両方のページを比較しまして

モンスターカード(17枚)
クローラー・レセプター×3
クローラー・デンドライト×3
クローラー・グリア×3
クローラー・スパイン
クローラー・アクソン ×2
粘糸壊獣クモグス×2
増殖するG×2
星遺物-『星杯』

 上記の部分が、個別ページには存在し、トップページには存在していません。

そこで例えば、クローラー・レセプター×3のリンクが、http://amzn.to/2lSWEQe』 となっています。

ですので、http://amzn.to/2lSWEQe』https://amzn.to/2lSWEQe』に書き換えてみてはいかがでしょうか? 他にも同様の形で該当する部分がありますので同様にhttphttpsに書き換えるという事でどうでしょうか。。。

もしも違っていたらごめんなさい。


   
keybou
(@keybou)
Trusted Member Registered
結合: 6年前
投稿: 60
 

あと例えば

https://enjoy-yugioh.com/10minute/  こちらのページでは、ソーシャルボタンのリンク先が、非SSL ( http://~) になっているので、これも要因と考えられます。

画像を2枚送ります。その画像の最上部の、amazon 等のソーシャルボタンのリンクが該当します。


   
keybou
(@keybou)
Trusted Member Registered
結合: 6年前
投稿: 60
 

2枚目の画像です。


   
 pixt
(@pixt)
New Member Registered
結合: 6年前
投稿: 1
 

komennta さん初めまして。こちらの掲示板でも初めて書き込みさせていただきます。

私も同様の症状が出ていました。

ソースを確認すると <!-- publisher設定 -->の中に
/wp-content/themes/cocoon-master/screenshot.jpg
がhttpのままになっていました。cocoonのテーマの画像です。

Cocoon 設定>>>OGP>>>ホームイメージを自分でアップロードした画像に変更したところ解決しました。


   
komennta reacted
(@komennta)
Eminent Member Registered
結合: 6年前
投稿: 26
Topic starter  

keybouさんご丁寧な解答感謝します。

どうやらpixtさんのおっしゃる通り、OGP設定の欄の画像がhttpのままなのが原因だったようです。

しかしアマゾンのリンクが「http」のままだと都合が悪くなりそうな気もするので、一応変更しておきます。

ありがとうございましたm(_ _)m


   
わいひら reacted
(@komennta)
Eminent Member Registered
結合: 6年前
投稿: 26
Topic starter  

かうたっくさんご回答感謝します。

pixtさんのアドバイスで無事に解決できたことをご報告いたします。


   
わいひら reacted
(@komennta)
Eminent Member Registered
結合: 6年前
投稿: 26
Topic starter  

pixtさんはじめまして。

アドバイス通りOGP設定で画像を変更したところ、無事に全ページが「安全な接続」と表示されるようになりました!

非常に助かりました。感謝しますm(_ _)m


   
pixt and わいひら reacted
共有:

問題の解決に至った場合には、トピック冒頭の「解決済み」をクリックしていただけますと幸いです。

また、有用な回答があった場合は返信右下にある「いいね!」もご活用ください。回答者の励みになります。

「いいね!」機能はフォーラム登録者のみが利用できる機能です。

CC BY-ND 2.1)準じていれば(リンクを貼っていただければ)転載も自由です。カスタマイズ記事を書く際にコード等をコピペ利用していただいて構いません。

フォーラムの使い方がよくわからない場合は、テストトピックで自由にテストしていただいて構いません。

最近の書き込みはこちら。

詳細なカスタマイズ依頼をするならこちら。

タイトルとURLをコピーしました