「メイド・イン・ヘブン」スキン適用中

Cocoonフォーラム

サイト内検索
書き込みの前に以下の3点をご確認ください。
  1. 1つのトピックにつき1つの質問を書き込んでください
  2. 不具合・カスタマイズ対象ページのURLを提示高速化を無効にしてください
  3. 該当部分のキャプチャ・環境情報とともに書き込んでいただけると助かります

何を書き込んだら良いか分からない場合は、以下のテンプレートをコピペしてご利用ください。

不具合・カスタマイズ対象ページのURL:

相談内容:

不具合の発生手順:

解決のために試したこと:

※文字だけでは正しく伝わらない可能性があるため、スクショ画像の添付もお願いします。
※高速化設定をしている場合は無効にしてください。
環境情報:

※↑こちらに「Cocoon設定 → テーマ情報」にある「環境情報」を貼り付けてください。

環境情報の取得方法はこちら。
https://wp-cocoon.com/theme-report/
高速化設定を無効にするにはこちら。
https://wp-cocoon.com/theme-trouble/

フォーラム利用ガイドリンク

  1. フォーラムガイドライン
  2. よくある質問と答え(FAQ)
  3. サポート対象外のケース
  4. 原因不明の不具合用トラブルシューティング
  5. トピックにHTMLを貼り付ける方法(推奨ツール:notepad.pw
  6. 真っ白画面でのエラーメッセージの確認方法
  7. ブラウザ環境チェックツール
  8. Cocoonカスタマイズ依頼

フォーラム質問後、問題等が解決した場合は結果を書き込んでいただけると幸いです。同様の問題で調べている方には、結果が一番気になる部分となります。

編集画面の見出し表示が崩れてしまう
 
共有:
通知
すべてクリア

[解決済] 編集画面の見出し表示が崩れてしまう

11 投稿
3 ユーザー
10 Reactions
2,995 表示
(@tomocom)
Active Member Registered
結合: 3年前
投稿: 5
Topic starter  

編集画面において、h2とh3の見出しだけ
かなり左側によるという現象がおきています。
※今朝まではh1見出しと同じような位置に表示されていました。
※実際の投稿画面では、特に問題なく表示されておりました。

直前で見出しのカスタマイズ等は行っておらず、

・リセット
・リロード
・キャッシュ削除
・プラグイン無効化
・コードエディタへの切り替え

等、トラブルシューティングに乗っているものは試しましたが
解決にいたりませんでした。

こちらの表示がおかしくなる前、
バリューコマースのLinkswitchの設定をいれたところ
表示が崩れがおこったため、すぐに設定を外したのですが元に戻りませんでした。

こちらの設定をしたことが、なにか関係しているでしょうか。

 

基本的なところで申し訳ありませんが、どなたかご教授いただけると助かります。
よろしくお願いいたします。

----------------------------------------------
サイト名:うち活のススメ
サイトURL: https://tomocominfo.com
ホームURL: https://tomocominfo.com
コンテンツURL:/wp-content
インクルードURL:/wp-includes/
テンプレートURL:/wp-content/themes/cocoon-master
スタイルシートURL:/wp-content/themes/cocoon-child-master
親テーマスタイル:/wp-content/themes/cocoon-master/style.css
子テーマスタイル:/wp-content/themes/cocoon-child-master/style.css
WordPressバージョン:5.7.1
PHPバージョン:7.4.13
ブラウザ:Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/90.0.4430.93 Safari/537.36
サーバーソフト:Apache
サーバープロトコル:HTTP/1.1
言語:ja,en-US;q=0.9,en;q=0.8
----------------------------------------------
テーマ名:Cocoon
バージョン:2.2.8.8
カテゴリ数:27
タグ数:8
ユーザー数:1
----------------------------------------------
子テーマ名:Cocoon Child
バージョン:1.1.0
style.cssサイズ:12830バイト
functions.phpサイズ:203バイト
----------------------------------------------
Gutenberg:1
AMP:0
PWA:0
Font Awesome:4
Auto Post Thumbnail:0
Retina:0
ホームイメージ:/wp-content/themes/cocoon-master/screenshot.jpg
----------------------------------------------
ブラウザキャッシュ有効化:0
HTML縮小化:0
CSS縮小化:0
JavaScript縮小化:0
Lazy Load:0
WEBフォントLazy Load:0
----------------------------------------------
利用中のプラグイン:
AddQuicktag 2.5.3
Advanced Editor Tools (previously TinyMCE Advanced) 5.6.0
Broken Link Checker 1.11.15
Category Order and Taxonomy Terms Order 1.5.7.5
EWWW Image Optimizer 6.1.2
Google XML Sitemaps 4.1.1
Jetpack by WordPress.com 9.3.1
Kattene 1.4
----------------------------------------------


   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 3年前
投稿: 7201
 

tomocomさん

あまり調べていなくて恐縮なのですが。

エディタ画面のことですので、なかなか外部からは分からないところでもあります。

子テーマに、以下のようにマイナスmarginでお書きになっているようですので、その影響は考えられないでしょうか。
(左右共にマイナスmargin。)

.article h2 {
    background-color: #e589a2;
    padding: .75em 1em;
    color: #fff;
    margin: 4em -16px 2em;
    font-size: 1.4em;
    line-height: 1.4;
}

.article h3 {
    margin: 3em -8px 2em;
    padding: 0 .5em .5em;
    font-size: 1.3em;
    position: relative;
    line-height: 1.4;
    border: 0;
}

 

もしくは、エディタスタイルが上手く反映されていないのかもとも思いますが、まずは上記をお試しいただければと。


   
(@tomocom)
Active Member Registered
結合: 3年前
投稿: 5
Topic starter  

mk2様

早々にアドバイス、ありがとうございます!!

ご指摘いただいたマイナスmarginを修正してみたのですが
残念ながら、特に修正されませんでした。

エディタスタイルの反映も調べていろいろ試しているのですが
やはり崩れたままでした。

他にもなにかお気づきの点ありましたら、ご指摘いただけると助かりますmm
(自分でも引き続きいろいろ試してみます)

拾っていただき、ありがとうございます!!


   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 3年前
投稿: 7201
 

tomocomさん

改善されず、残念です。
以前、同様のお問い合わせがあり、それで解消したことあったと思うのですが、今のところ、過去のトピックが見つかりません。

 

他の可能性というところでは、プラグイン「Advanced Editor Tools (previously TinyMCE Advanced)」の影響です。

ブロックエディタ使用時には、トラブルが多い印象です。
一旦、無効化していただけますでしょうか。

無効化後に、エディタ画面を開いて、ブラウザのリロードをしてみてください。

 

それでも解消しない場合ですが。

上記プラグインを無効化したままで、Cocoon設定の「まとめて変更を保存」を押してみてください。
Cocoonの設定は、何も変更しなくて大丈夫です。

その後、エディタ画面を開いて、ブラウザのリロードを行ってみてください。


   
tomocom reacted
(@tomocom)
Active Member Registered
結合: 3年前
投稿: 5
Topic starter  

mk2

何度もほんとに助かります!

ご教授いただいた方法どちらも試してみましたが、改善されませんでした。。
(うーん、原因がわからないです)

 

視認性は悪くなりますが、編集できないことはないので
しばらくいろいろ試しながらやってみます。

 

度々のアドバイス、ありがとうございます!!!


   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 3年前
投稿: 7201
 

tomocomさん

ちなみにですが、私のローカル環境での確認結果です。

子テーマには、何もCSSを書いていない状態だと、以下のような感じでした。

 
 
この状態で、エディタ画面を開いたままで、私の最初の返信に貼り付けたh2とh3のCSSを丸々子テーマに追加しました。
 
追加後に、ブラウザのリロードをすると、以下のようになりました。
 
 
この後に、エディタ画面を開いたままで、子テーマのCSSを削除しました。
そして、ブラウザのリロードすると、元の表示に戻りました。
 
やはり、CSSが原因のような気はします。

   
tomocom reacted
(@tomocom)
Active Member Registered
結合: 3年前
投稿: 5
Topic starter  

mk2

おおおおお。確かに、CSSの該当のコードを削除したところ
左によるというのはなくなりました!!

CSSいじっていないので謎が残りますが
無事解決できて、大変助かりました!!

なんどもご確認いただき、本当にありがとうございました!!


   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 3年前
投稿: 7201
 

tomocomさん

その後も、少しローカル環境で試してみました。

そもそもマージンを指定すると、何だか変な感じですね。

最初の返信に貼り付けた、マイナスmarginを解消してみると(「-」だけを削除した状態)、
以下のようになりました。

 
正しく、marginが反映された状態に見えます。
 
しかし、この状態で、何も変更しないでブラウザのウィンドウを最大化すると、以下のようになります。
 
marginは反映されてはいるのですが。。。
(マイナスmarginではなくなっています、一応。。。)
 
基準が、エディタ画面の端になっているように見受けられますね、この感じだと。
marginを指定すると、コンテンツの表示の場所ではなく、エディタ画面の端からのmarginになってしまうようです。
 
(CSSが当たっていない見出しは、なにを基準に位置を決めているのでしょう。)
 
エディタ画面だけのことですが。
これが、何の不具合なのかは、ちょっと分かりませんけど。

   
tomocom and わいひら reacted
わいひら
(@yhira)
Illustrious Memberサイト Admin
結合: 6年前
投稿: 16644
 

新しいブロックエディターは、基本的にコンテンツ直下はmargin-left: auto;とmargin-right: auto;があたるようになっています。
これに対してマージンの左右が指定されてしまうと、その分ずれてしまうという現象が起きるんだと思います。

なぜ最近の、ブロックエディターでmargin-left: auto;とmargin-right: auto;になっているかというと、フルサイト編集(Full Site Editing)機能に対応させるためなのかなと思っています。

設定次第で画面幅いっぱいにコンテンツを作れるようにしているのかなと。
新しいWordPressについては、詳しくは追っていないのであっているかわかりませんが。


   
mk2
(@mk2_mk2)
Illustrious Member Moderator
結合: 3年前
投稿: 7201
 

わいひらさん

ありがとうございます。

確かにautoがあたっていました。
WordPressの公式テーマなどを使っても少し違和感を感じた時があったのですが、納得です。

対処方法はありますから、なんとかなりそうです。

エディタ画面のことですから、気にしないか。

もしくは、ウィンドウ幅を狭める、フルスクリーンモードの解除、右上の設定(歯車のアイコン)でメニューを出してさらに幅を狭める、などで実際のコンテンツ幅に近づければ、違和感なくなると思います。

エディタ画面の同様の問い合わせはそこそこあるように思いますので、覚えておこうと思います。

ありがとうございました。


   
わいひら and tomocom reacted
(@tomocom)
Active Member Registered
結合: 3年前
投稿: 5
Topic starter  

お二方とも、ありがとうございます!

なるほど、だから設定をいれていたh2とh3だけ表示がおかしくなってしまったんですね。
大変勉強になりました!

いただいた内容をもとに、修正をさせていただきます。
ありがとうございました。


   
わいひら reacted
共有:

問題の解決に至った場合には、トピック冒頭の「解決済み」をクリックしていただけますと幸いです。

また、有用な回答があった場合は返信右下にある「いいね!」もご活用ください。回答者の励みになります。

「いいね!」機能はフォーラム登録者のみが利用できる機能です。

CC BY-ND 2.1)準じていれば(リンクを貼っていただければ)転載も自由です。カスタマイズ記事を書く際にコード等をコピペ利用していただいて構いません。

フォーラムの使い方がよくわからない場合は、テストトピックで自由にテストしていただいて構いません。

最近の書き込みはこちら。

詳細なカスタマイズ依頼をするならこちら。

タイトルとURLをコピーしました