Cocoonフォーラム

書き込みの前に以下の3点をご確認ください。
  1. 1つのトピックにつき1つの質問を書き込んでください
  2. 不具合・カスタマイズ対象ページのURLを提示高速化を無効にしてください
  3. 該当部分のキャプチャ・環境情報とともに書き込んでいただけると助かります

何を書き込んだら良いか分からない場合は、以下のテンプレートをコピペしてご利用ください。

不具合・カスタマイズ対象ページのURL:

相談内容:

不具合の発生手順:

解決のために試したこと:

※文字だけでは正しく伝わらない可能性があるため、スクショ画像の添付もお願いします。
※高速化設定をしている場合は無効にしてください。
環境情報:

※↑こちらに「Cocoon設定 → テーマ情報」にある「環境情報」を貼り付けてください。

環境情報の取得方法はこちら。
https://wp-cocoon.com/theme-report/
高速化設定を無効にするにはこちら。
https://wp-cocoon.com/theme-trouble/

フォーラム利用ガイドリンク

  1. フォーラムガイドライン
  2. よくある質問と答え(FAQ)
  3. サポート対象外のケース
  4. 原因不明の不具合用トラブルシューティング
  5. トピックにHTMLを貼り付ける方法(推奨ツール:notepad.pw
  6. 真っ白画面でのエラーメッセージの確認方法
  7. ブラウザ環境チェックツール
  8. Cocoonカスタマイズ依頼

フォーラム質問後、問題等が解決した場合は結果を書き込んでいただけると幸いです。同様の問題で調べている方には、結果が一番気になる部分となります。

先のトピックと同じく 解析不能な構造化...
 
共有:
通知
すべてクリア

[解決済] 先のトピックと同じく 解析不能な構造化データエラーの件で

76 投稿
4 ユーザー
20 Likes
5,813 表示
なお
 なお
(@なお)
Trusted Member
結合: 4年前
投稿: 79
Topic starter  

テーマを更新したら、サイトが消えてしまいました泣


   
なお
 なお
(@なお)
Trusted Member
結合: 4年前
投稿: 79
Topic starter  

添付されていませんでしたので、追申です。

https://tarot-kazuki.com/


   
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 14154
 

以下の方法で、エラーメッセージを取得しキャプチャと、エラーメッセージテキストを貼り付けていただけますか。
https://nelog.jp/edump-wordpress-error-check
※伏字にする必要がある場合は伏字変換していただければと思います。


   
かうたっく
(@kautakku)
Famed Member Moderator
結合: 5年前
投稿: 4764
 

ロリポップにログインして、エラーコードを表示して内容をコピペしてください。

ってかそこにプラグイン名が表示されていれば、ロリポップFTPからそのプラグイン名を変更すれば表示されますが、何が原因かはエラーコードを見ないとわからないです。

あとサイトが表示されてないだけで、消えてないので大丈夫ですよ


   
わいひら reacted
なお
 なお
(@なお)
Trusted Member
結合: 4年前
投稿: 79
Topic starter  

https://tarot-kazuki.com/wp-admin/ に入ることができません。

ロリポップを添付 「エラーページ変更」 ←ここをクリックしました。

2枚目は「変更」をクリックしていいのでしょうか。

 


   
なお
 なお
(@なお)
Trusted Member
結合: 4年前
投稿: 79
Topic starter  

エラーページ 1枚目です。先に添付できていませんでした。

エラーがあるよ、と。


   
なお
 なお
(@なお)
Trusted Member
結合: 4年前
投稿: 79
Topic starter  

エラーページ変更って、関係ないですね。勘違いです。

エラーコードの件、ロリポップに問い合わせてみます。

ありがとうございます。


   
かうたっく
(@kautakku)
Famed Member Moderator
結合: 5年前
投稿: 4764
 

ちがってるかも。エラー画面の表示なので。

https://bibabosi-rizumu.com/blog-error-return/

目次1.1:レンタルサーバーのPHP設定の変更:php.ini

上記で表示されれば、そのコードをチェック。

エラーコードがツラツラと表示されなければ、以下も必要かもです。

目次2:デバックモードでエラー表示

そのページにだいたい書いてるかも。なので、問い合わせるより、ページをチェックしてみるのが早いかもです。


   
わいひら reacted
なお
 なお
(@なお)
Trusted Member
結合: 4年前
投稿: 79
Topic starter  

おはようございます。

error_reporting

10個ほどでてきました。しかし、コピーできない。

キャプチャもできない。

1個づつ「php.iniを設定する」のでしょうか?


   
かうたっく
(@kautakku)
Famed Member Moderator
結合: 5年前
投稿: 4764
 

https://tarot-kazuki.com/

https://gyazo.com/685302b204700024b81cbb0df6a2950e

記事内に書いてる通りなんですが。上記をONに。それで表示されたと思います。

現状は以下の通りなので、こちらも確認できないので何もできないです。

このページは動作していません

arot-kazuki.com では現在このリクエストを処理できません。

HTTP ERROR 500

詳細はリンクしたページ内にも書いてるんですが。

 

追記

https://bibabosi-rizumu.com/blog-error-return/

説明は以下リンク先に、初心者向けで書いてるのですが。どこをどのように見たのかがちょっと分からなくって戸惑ってます ? ? ? 

  1. サーバーで上記設定をon
  2. siteにアクセス
  3. エラーコードをコピペ

エラーコードが表示されていなければ、bibabosi-rizumu.com/blog-error-return/ に書いてる通りPHPファイルをロリポップFTPからでも編集すればOK!

って言う手順です。


   
わいひら reacted
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 14154
 

エラーメッセージを取得できないようであれば、一旦以下に書かれている「過去バージョンに戻す方法」の方法でFTPを用いて古いバージョンに戻した方が良いかもしれません。
https://wp-cocoon.com/downloads/

ただ、エラーメッセージを取得できるのであれば、取得していただいた方が原因がわかるかもしれません。


   
なお
 なお
(@なお)
Trusted Member
結合: 4年前
投稿: 79
Topic starter  

かうたっくさん、ありがとうございます。

ファイルを開いてdefine(‘WP_DEBUG’,を検索してください。

検索しましたが、ありませんでした。0/0 でした。

わいひらさん、ありがとうございます。

親テーマのダウンロードで

「必ずPHP7以上でご利用ください。」と書かれていますが、

5.4ですので、無理かと。

今回のエラーは、多分、PHPバージョンが古い(5.4)から

ではないかと。

以前にも、かうたっくさんから指摘されていたのですが、

ロリポップの説明で「PHPバージョンの変更によりサイト表示やプログラム利用に影響が出る可能性があります。
下記注意事項を必ずご確認の上、PHPバージョンの変更を行ってください。」とありましたので、失敗がこわくて後回しにしていました。

 


   
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 14154
 

「必ずPHP7以上でご利用ください。」と書かれていますが、

5.4ですので、無理かと。

いや、PHPのバージョンを上げてください。

現在逆に、利用に悪影響が出ているかと思うんですけど。
いまどき、PHP5.4でないと利用できないプログラムは逆にダメだと思います。
古いPHPは、セキュリティー的にも問題があるかもしれないので。


   
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 14154
 

推奨環境で利用していないものは、エラーが出ても仕方ないかと思います。
https://wp-cocoon.com/downloads/
PHP5.4では存在しない関数とかも使っていると思うので。


   
かうたっく
(@kautakku)
Famed Member Moderator
結合: 5年前
投稿: 4764
 

ファイルを開いてdefine(‘WP_DEBUG’,を検索してください。

検索しましたが、ありませんでした。0/0 でした。

その場合は、以下を追記すれば良いですよ。

define(‘WP_DEBUG’, true);

書く場所もどこかに書いてたと思います。※前提は以下

レンタルサーバーのPHP設定の変更:php.ini

ロリポップやheteml、エックスサーバーなどでは、php.iniで表示・非表示が行えます。※ロリポップの初期設定では、デフォルトでエラーコードを表示させている(2015年2月時点)

PHP設定のphp.iniで設定変更が出来るならエラーコードを表示させる設定をオンにします。

  • display_errorsをonに変更・保存

https://bibabosi-rizumu.com/blog-error-return/

これでサイトにアクセスすれば500エラーの画面ではなく、エラーコードは表示されますよ。


   
わいひら reacted
かうたっく
(@kautakku)
Famed Member Moderator
結合: 5年前
投稿: 4764
 

わいひらさんと重複するので書き込もうと思った事をやめたんですが。

かんたんに言えば

PHPバージョンの変更を行ってください。」とありましたので、失敗がこわくて後回し

それを行わなかったのでエラーが出ているのも現実で。


   
かうたっく
(@kautakku)
Famed Member Moderator
結合: 5年前
投稿: 4764
 

プラグインの影響の事をおしゃってたのかと思いますが、どんなプラグインかも不明ですし、聞いても実際試さないと何とも言えません。

追記:私は時間的余裕もない為ためさないです❦

 

最悪プラグインにもエラーが出たら、該当プラグインをFTPでリネームして強制的に外すのがデフォルト対応だったりします。

500エラーから元どおり復活させるには、エラーの対処・また対処…と、していくしかないと思いますよ❦

追記

復元できるバックアップをとっておくのがベストですよ。

※復元作業を行いたい場合、バックアップがなければ検索する手間がかかると思う➡バックアップがあれば、まだ時間的にも早いので。


   
わいひら reacted
なお
 なお
(@なお)
Trusted Member
結合: 4年前
投稿: 79
Topic starter  

わいひらさん、かうたっくさん、いろいろご提案ありがとうございました。

ロリポップから回答がきましたので説明通りに行い、

とりあえず、サイトが見られる状態になっております。

ここから、PHPバージョンを上げて、うまくできれば、

再度Cocoonのテーマにしてみようと思います。

下記はロリポップからの内容をピックアップしたものです。

~~~~~~~~~~~~~~~

テーマが影響しているようでございます。

 ■該当のテーマファイル
  b/wp-content/themes/cocoon-master/

このような場合、テーマ名を変更し無効化すると、
管理画面へはログインできるようになりますので、その後
改めて異なるテーマを設定いただくことでサイト表示が行えるかと存じます。

なお、ご利用いただいているテーマに関しましては
ロリポップ!では詳しいご案内を行うことが出来ません。

そのため、引き続き該当のテーマの利用を希望される場合には
テーマの提供元にて、エラーの原因についてお問合せいただき、
ご対応いただきますようお願いいたします。

~~~~~~~~~~~~~~~~~~

 


   
さくら
(@komachi)
Trusted Member Registered
結合: 5年前
投稿: 59
 

なおさん

参考までに、バックアップはプラグインにあるし、ロリポップでは有料サービスにあるので、そういうのを活用してもいいかもです。

わたしは All-in-One WP Migrationというプラグインを使ってバックアップを取っています。(が、わたし自身はバックアップを復元したことがないので、実際にどんな感じかまではわからないのですが。)

他にもバックアップのプラグインはあるので、検索してみて使いやすそうなプラグインを選んでみてください。

わたし自身は、PHPのバージョンをあげたり、wordpressのバージョンをあげる前は必ずバックアップを取るようにしています。

それと、初心者だと不安な気持ちはわかるので、PHPのバージョンやwordpressのバージョンをあげるときは少し待って、Cocoonフォーラムに何か書き込みが出るかどうか?を見てからだと少し安心できるかもです。

ちなみに、PHP7にすると速度が速くなると評判ですよ~。


   
わいひら reacted
なお
 なお
(@なお)
Trusted Member
結合: 4年前
投稿: 79
Topic starter  

さくらさん、おはようございます。

ご親切にいろいろ教えてくださりありがとうございます。

一応バックアップはとっていますが、というか、今回の件でいろいろ気付きがありました。

この際、ロリポップの有料サービスを利用しようかと考えていたところです。

それと、初心者だと不安な気持ちはわかるので、PHPのバージョンやwordpressのバージョンをあげるときは少し待って、Cocoonフォーラムに何か書き込みが出るかどうか?を見てからだと少し安心できるかもです。

はい、そうします! ありがとうございました。


   
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 14154
 

PHPのバージョン変更は、サーバー上で変更してエラーが出たとしても、サーバーの設定を戻せば元に戻るので、あまりそこまで身構える必要もないかと思います。


   
なお
 なお
(@なお)
Trusted Member
結合: 4年前
投稿: 79
Topic starter  

わいひらさん、いろいろお手数をお掛けしていました。

サーバーの設定を戻せば元に戻るので、あまりそこまで身構える必要もないかと思います。

そうなんですね!

復元も簡単そうなロリポップの有料バックアップを申し込みましたので

明日にでも、PHP7.1に変更してみようと思います。

本サイトの方は、エックスサーバーでPHP7.1.18になっていますので

Cocoonの更新を行っても大丈夫かな?と。

いろいろ勉強になりました。すぐ忘れますが(苦笑)

 


   
かうたっく
(@kautakku)
Famed Member Moderator
結合: 5年前
投稿: 4764
 

https://lolipop.jp/manual/user/php-setting/

今ローカルを作らなくても、ステージング環境があるんですね。今の本番環境を触らず確認はできるみたいですね。

 

あと、PHPのバージョンが古いので、更新が止まったままのプラグインの影響でエラーが出る可能性があるかもしれませんね。

ちなみに5.4には戻れないと思います。でもそれなりの(PHPバージョンの設定のプルダウンさせて表示される)バージョンに戻れると思いますけど


   
わいひら reacted
かうたっく
(@kautakku)
Famed Member Moderator
結合: 5年前
投稿: 4764
 

https://gyazo.com/e5299089f2d9e03c72fc9865860f69be

今一通りチェックして再度、見てみるとロリポップの上記リンク先の画像に書いてる感じです。

色々面倒だとおもうので、ステージング環境でためしてくださいね❦


   
わいひら reacted
なお
 なお
(@なお)
Trusted Member
結合: 4年前
投稿: 79
Topic starter  

わいひらさん、かうたっくさん、さくらさん

PHP7.1に、難なく無事に変更できました。

ありがとうございました ? 


   
わいひら reacted
かうたっく
(@kautakku)
Famed Member Moderator
結合: 5年前
投稿: 4764
 

案ずるより…でしたね❦

良かった良かった^^ ? ? ? 

全て完了で良かったんですかね?
であれば、お疲れさまでした!


   
わいひら reacted
固定ページ 2 / 2
共有:

問題の解決に至った場合には、トピック冒頭の「解決済み」をクリックしていただけますと幸いです。

wpForoの解決済みリンク

また、有用な回答があった場合は「いいね!」もご活用ください。回答者の励みになります。

wpForoのいいねリンク

「いいね!」機能はフォーラム登録者のみが利用できる機能です。

CC BY-ND 2.1)準じていれば(リンクを貼っていただければ)転載も自由です。カスタマイズ記事を書く際にコード等をコピペ利用していただいて構いません。

フォーラムの使い方がよくわからない場合は、テストトピックで自由にテストしていただいて構いません。

最近の書き込みはこちら。

詳細なカスタマイズ依頼をするならこちら。

タイトルとURLをコピーしました