「メイド・イン・ヘブン」スキン適用中

Cocoonフォーラム

サイト内検索
書き込みの前に以下の3点をご確認ください。
  1. 1つのトピックにつき1つの質問を書き込んでください
  2. 不具合・カスタマイズ対象ページのURLを提示高速化を無効にしてください
  3. 該当部分のキャプチャ・環境情報とともに書き込んでいただけると助かります

何を書き込んだら良いか分からない場合は、以下のテンプレートをコピペしてご利用ください。

不具合・カスタマイズ対象ページのURL:

相談内容:

不具合の発生手順:

解決のために試したこと:

※文字だけでは正しく伝わらない可能性があるため、スクショ画像の添付もお願いします。
※高速化設定をしている場合は無効にしてください。
環境情報:

※↑こちらに「Cocoon設定 → テーマ情報」にある「環境情報」を貼り付けてください。

環境情報の取得方法はこちら。
https://wp-cocoon.com/theme-report/
高速化設定を無効にするにはこちら。
https://wp-cocoon.com/theme-trouble/

フォーラム利用ガイドリンク

  1. フォーラムガイドライン
  2. よくある質問と答え(FAQ)
  3. サポート対象外のケース
  4. 原因不明の不具合用トラブルシューティング
  5. トピックにHTMLを貼り付ける方法(推奨ツール:notepad.pw
  6. 真っ白画面でのエラーメッセージの確認方法
  7. ブラウザ環境チェックツール
  8. Cocoonカスタマイズ依頼

フォーラム質問後、問題等が解決した場合は結果を書き込んでいただけると幸いです。同様の問題で調べている方には、結果が一番気になる部分となります。

リンクアイコンが表示されない
 
共有:
通知
すべてクリア

[解決済] リンクアイコンが表示されない

12 投稿
3 ユーザー
1 Likes
7,613 表示
(@azuki)
Eminent Member Registered
結合: 6年前
投稿: 37
Topic starter  

こんにちは。ワードプレス超初心者で、全く見当違いの内容かもしれません。何卒ご容赦ください。

https://wp-cocoon.com/link-settings/

こちらにある通り、リンクの開き方やアイコンの付加を設定致しました。

記事を投稿したところリンク自体(内部リンクです)はできたのですが、アイコンが表示されません。

同様のプラグインがあると競合してしまうかもしれないとのことですので、すべてのプラグインを停止してみましたが、リンクアイコンは表示されませんでした。

不具合が起きているページは:

https://gambaru-life.com/wp-admin/post.php?post=123&action=edit

上から6行目の「重症な場合は~」という部分です。

 

当方の情報は次の通りです:

サイト名:元気に老いるために今日も頑張ってます
サイトURL: https://gambaru-life.com
ホームURL: https://gambaru-life.com
Wordpressバージョン:4.9.4
PHPバージョン:7.0.18
ブラウザ:Mozilla/5.0 (Windows NT 10.0; WOW64; Trident/7.0; rv:11.0) like Gecko
サーバーソフト:Apache
サーバープロトコル:HTTP/1.1
言語:ja-JP
----------------------------------------------
テーマ名:Cocoon
バージョン:0.4.1

----------------------------------------------
子テーマ名:Cocoon Child
バージョン:0.0.2
----------------------------------------------
利用中のプラグイン:
Akismet Anti-Spam 4.0.3
BackWPup 3.4.4
Category Order and Taxonomy Terms Order 1.5.3.2
Edit Author Slug 1.5.2
Google XML Sitemaps 4.0.9
Imagify 1.7
Jetpack by WordPress.com 6.0
Regenerate Thumbnails 3.0.2
Simple 301 Redirects 1.07
WebSub/PubSubHubbub 2.2.1
Wordfence Security 7.1.1
WP Multibyte Patch 2.8.1

お忙しいところご迷惑をおかけして申し訳ありませんが、どうぞよろしくお願い申し上げます。


   
引用
(@azuki)
Eminent Member Registered
結合: 6年前
投稿: 37
Topic starter  

投稿者のazukiです。追伸です。

すみません、編集用のURLを載せてしまいました。

当該URLは:

https://gambaru-life.com/exercise/

です。

ありがとうございます。よろしくお願い致します。

 


   
返信引用
(@yuzakasota)
Eminent Member Registered
結合: 6年前
投稿: 44
 

@azuki さん、こんにちは。

ブログ拝見しました。

https://gambaru-life.com/exercise/

そして、内部リンクアイコンの件ですが、下記記事の設定画面と同じ様に設定をすると「内部リンク設定」の「アイコン表示」にはチェックが入っていません。

https://wp-cocoon.com/link-settings/

もしかして、この「アイコン表示」のチェックマークを外したままにしていませんか?

ここにチェックを入れると内部リンクの場合にもリンクアイコンが表示されます。
ぜひ確認してみてください。


   
返信引用
(@azuki)
Eminent Member Registered
結合: 6年前
投稿: 37
Topic starter  

@yuzakasota様

ご親切に返信をどうもありがとうございます。

あいにくですが、「内部リンク設定」の「アイコン表示」には、ちゃんとチェックが入っているのです。

念のため、一度チェックを外して、改めてチェックを入れて保存して・・・ということも試してみたのですが、やはりアイコンは表示されません。

どうしたものか・・・

いずれにせよ、どうもありがとうございました!

 

 

 


   
返信引用
(@azuki)
Eminent Member Registered
結合: 6年前
投稿: 37
Topic starter  

元の投稿者azukiです。

試しに記事に外部リンクをつけてみたところ、アイコンマークは正常に表示されました。

外部リンク、内部リンクとも、全く同じに設定してあります。

内部リンクだけ、アイコンマークが表示されません。

よろしくお願い致します。

 

 


   
返信引用
わいひら
(@yhira)
Illustrious Member Admin
結合: 6年前
投稿: 16435
 

僕のテスト環境で試してみたのですが、内部リンクだけの設定でもアイコンフォントは表示されました。
内部リンク設定が反映されないのは、アイコフォントだけでしょうか?その他の設定は反映されていますか?

またできれば、内部リンク・外部リンクの設定画面のキャプチャ画像をアップしていただけると助かります。
アップローダーが必要な場合は、以下に案内があります。
https://wp-cocoon.com/read-me-for-using-fourm/


   
返信引用
(@azuki)
Eminent Member Registered
結合: 6年前
投稿: 37
Topic starter  

わいひら様

設定画面の画像を添付します。

外部リンクの設定画面です。

azuki

 


   
返信引用
(@azuki)
Eminent Member Registered
結合: 6年前
投稿: 37
Topic starter  

わいひら様

内部リンクの設定画面です。

お忙しいところ申し訳ございませんが、よろしくお願い申し上げます。

azuki


   
返信引用
(@yuzakasota)
Eminent Member Registered
結合: 6年前
投稿: 44
 

@azuki さん、 @yhira さん、お疲れ様です。

現象が再現できました。

下記のタグで確認してもらえますか?

<a href="https://wp-cocoon.com/">テストです</a>

<a href="https://wp-cocoon.com/">テスト<strong>です</strong></a>

たぶん、上だとリンクアイコンが表示されますが、下だと表示されないと思います。

@azuki さんの記事でリンク文字列をさらに「強調」文字にしているところ

<strong>骨盤底筋運動(ケーゲル体操)</strong>

ここを解除して、リンクアイコンが表示されるか確認してもらえますか?
私の環境では、この「storong」タグが入っていると、内部、外部ともにリンクアイコンが表示されないようです。


   
わいひら reacted
返信引用
(@azuki)
Eminent Member Registered
結合: 6年前
投稿: 37
Topic starter  

わいひら様

>内部リンク設定が反映されないのは、アイコフォントだけでしょうか?その他の設定は反映されていますか?

こちらについてお返事するのを忘れてしまいました。

内部リンクについて、リンク自体がなされているのは確認しています。「新しいタブで開く」というのも、反映されています。その他の細かい設定(フォロータイプ、追加rel属性)については、専門的すぎて、私にはまだ意味が分かりません。

ご面倒をおかけしますが、よろしくお願い申し上げます。

azuki

 

 


   
返信引用
(@azuki)
Eminent Member Registered
結合: 6年前
投稿: 37
Topic starter  

@yuzakasotaさま

ご親切にどうもありがとうございます!!

おっしゃる通り、太文字を解除してリンクをつけ直したら、アイコンが表示されました!!! 助かりました!!!

私ごときのために貴重な時間を割いて下さり、解決して下さって、本当にありがとうございます!!!

これからはリンクをつける時は、太文字を使わないようにします。

@yuzakasotaさま、わいひら様、本当にどうもありがとうございました!!

初心者で知らないことばかりです。今後ともどうぞよろしくお願い申し上げます。

azuki


   
返信引用
わいひら
(@yhira)
Illustrious Member Admin
結合: 6年前
投稿: 16435
 

以前は、アンカーテキストにタグや含まれていると、適用されない仕様になっていたようですね。
先程別の要望を実装している最中に、図らずともそれに気づいて改善されていると思うので、アップロードしておきます。
https://github.com/yhira/cocoon/archive/master.zip


   
返信引用
共有:

問題の解決に至った場合には、トピック冒頭の「解決済み」をクリックしていただけますと幸いです。

また、有用な回答があった場合は返信右下にある「いいね!」もご活用ください。回答者の励みになります。

「いいね!」機能はフォーラム登録者のみが利用できる機能です。

CC BY-ND 2.1)準じていれば(リンクを貼っていただければ)転載も自由です。カスタマイズ記事を書く際にコード等をコピペ利用していただいて構いません。

フォーラムの使い方がよくわからない場合は、テストトピックで自由にテストしていただいて構いません。

最近の書き込みはこちら。

詳細なカスタマイズ依頼をするならこちら。

タイトルとURLをコピーしました