「メイド・イン・ヘブン」スキン適用中

Cocoonフォーラム

サイト内検索
書き込みの前に以下の3点をご確認ください。
  1. 1つのトピックにつき1つの質問を書き込んでください
  2. 不具合・カスタマイズ対象ページのURLを提示高速化を無効にしてください
  3. 該当部分のキャプチャ・環境情報とともに書き込んでいただけると助かります

何を書き込んだら良いか分からない場合は、以下のテンプレートをコピペしてご利用ください。

不具合・カスタマイズ対象ページのURL:

相談内容:

不具合の発生手順:

解決のために試したこと:

※文字だけでは正しく伝わらない可能性があるため、スクショ画像の添付もお願いします。
※高速化設定をしている場合は無効にしてください。
環境情報:

※↑こちらに「Cocoon設定 → テーマ情報」にある「環境情報」を貼り付けてください。

環境情報の取得方法はこちら。
https://wp-cocoon.com/theme-report/
高速化設定を無効にするにはこちら。
https://wp-cocoon.com/theme-trouble/

フォーラム利用ガイドリンク

  1. フォーラムガイドライン
  2. よくある質問と答え(FAQ)
  3. サポート対象外のケース
  4. 原因不明の不具合用トラブルシューティング
  5. トピックにHTMLを貼り付ける方法(推奨ツール:notepad.pw
  6. 真っ白画面でのエラーメッセージの確認方法
  7. ブラウザ環境チェックツール
  8. Cocoonカスタマイズ依頼

フォーラム質問後、問題等が解決した場合は結果を書き込んでいただけると幸いです。同様の問題で調べている方には、結果が一番気になる部分となります。

タグ検索ができなくなりました
 
共有:
通知
すべてクリア

タグ検索ができなくなりました

10 投稿
3 ユーザー
6 Likes
733 表示
(@manami2020)
New Member Registered
結合: 3年前
投稿: 3
Topic starter  

サイトを作り始めて1ヶ月の初心者です。

 

タグ検索を行うと検索結果画面に「404 NOT FOUND」が表示されます。

https://ukiyoe.licensebiz.tokyo/topics/hiroshige

投稿のテスト段階ではタグ検索の機能は有効でしたが、サイト内の表示変更や投稿内容の編集などを行っていましたら、タグ検索機能が使えなくなりました。

キャッシュのクリア、投稿やページの更新を行いましたが、改善しません。

また、投稿と登録したタグをすべて削除し、新規登録後に確認しましたが「404 NOT FOUND」が表示されます。

 

ネットで解決策を調べてみましたが見つかりませんでした。

対応策を教えていただけると助かります。よろしくお願いいたします。

 

サイト名:浮世絵ストックフォト
サイトURL: https://ukiyoe.licensebiz.tokyo
ホームURL: http://ukiyoe.licensebiz.tokyo
コンテンツURL: https://ukiyoe.licensebiz.tokyo/wp-content
インクルードURL: https://ukiyoe.licensebiz.tokyo/wp-includes/
テンプレートURL: https://ukiyoe.licensebiz.tokyo/wp-content/themes/cocoon-master
スタイルシートURL: https://ukiyoe.licensebiz.tokyo/wp-content/themes/cocoon-master
親テーマスタイル: https://ukiyoe.licensebiz.tokyo/wp-content/themes/cocoon-master/style.css
WordPressバージョン:5.6
PHPバージョン:7.4.6
ブラウザ:Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/88.0.4324.104 Safari/537.36
サーバーソフト:Apache
サーバープロトコル:HTTP/1.1
エンコーディング:gzip, deflate, br
言語:ja,en-US;q=0.9,en;q=0.8
----------------------------------------------
テーマ名:Cocoon
バージョン:2.2.6.6
カテゴリ数:14
タグ数:37
ユーザー数:1
----------------------------------------------
Gutenberg:1
AMP:0
PWA:0
Font Awesome:4
Auto Post Thumbnail:1
Retina:0
ホームイメージ:
----------------------------------------------
ブラウザキャッシュ有効化:0
HTML縮小化:0
CSS縮小化:0
JavaScript縮小化:0
Lazy Load:0
WEBフォントLazy Load:0
----------------------------------------------
利用中のプラグイン:
Cache Clear for お名前.com 1.0.0
Contact Form 7 5.3.2
----------------------------------------------


   
引用
リフィトリー
(@leafytree)
Illustrious Member Moderator
結合: 5年前
投稿: 6845
 

前略、manami2020 さん

確かに、私の環境でもタグクラウドのタグをクリックすると404ページが表示されるようです。

 

タグクラウドとの関連性は、私にはよくわかりませんが、「ホームURL」が「http」のままになっているようです。

サイトのSSL化が完了していないような気がします。

 

私も、わいひらさんの以下の記事を読んで、SSL化をした記憶があるのですが、あまり詳しくはないです。

 

WordPressをhttpからhttpsにSSL化した全手順まとめ(エックスサーバー環境)

 


   
返信引用
リフィトリー
(@leafytree)
Illustrious Member Moderator
結合: 5年前
投稿: 6845
 

manami2020 さん

最近、パーマリンクの設定を変更したりしませんでしたか?

This post was modified 3年前 by リフィトリー

   
返信引用
ろこ
(@lococo)
Prominent Member Registered
結合: 6年前
投稿: 830
 

カテゴリーベースとタグベースが同じ文字列になっているのが原因と思われます。

リライトルールにより、URLに'topics'が付く場合はカテゴリーページを参照していると判定され、存在しているタグページが開けない状態です。

カテゴリーベースとタグベースを分ける必要があります。


   
返信引用
リフィトリー
(@leafytree)
Illustrious Member Moderator
結合: 5年前
投稿: 6845
 

manami2020 さん

記事を書く度にパーマリンクを半角ローマ字で設定するのは、面倒ですが、アクセス解析などで、どの記事が閲覧されているのかがわかるので、数字ベースよりオススメです。

 

ただ、パーマリンクは、基本的に変更しない方が良いようなので、最初が肝心かと思います。

 

ネットで、「WordPress パーマリンクおすすめ」等で検索すると、いろいろな記事がヒットするかと思います。

 

例えば、以下のような記事とか・・

 

【WordPressのパーマリンクの変更方法とおすすめ設定】

 

私は、カテゴリーベース、タグベースは、空欄の方がわかりやすいような気がします。(後でアクセス解析時などでも、自分自身も わかりやすいです。)

 

私は、先に添付した画像のようにしてしまっていますが、いろいろ調べてみてください。

This post was modified 3年前 2回 by リフィトリー

   
わいひら reacted
返信引用
リフィトリー
(@leafytree)
Illustrious Member Moderator
結合: 5年前
投稿: 6845
 

manami2020 さん

あと、子テーマをお使いになられていないようなので、子テーマを導入されることをオススメします。

 

親テーマ、子テーマの関係については、以下の過去のトピックが参考になるかと思います。

 

[解決済] 親テーマと子テーマについてです。

 

子テーマの導入は、テーマ作者様も強く推奨されています。

 

Cocoonテーマをインストールする方法


   
manami2020 reacted
返信引用
リフィトリー
(@leafytree)
Illustrious Member Moderator
結合: 5年前
投稿: 6845
 

manami2020 さん

お見受けしたところ、個人ブログではないようですので、パーマリンクについては、運営に合った設定をすれば良いのかもしれません。


   
返信引用
(@manami2020)
New Member Registered
結合: 3年前
投稿: 3
Topic starter  

@lococo 様

 

解決しました。

ありがとうございました。


   
返信引用
(@manami2020)
New Member Registered
結合: 3年前
投稿: 3
Topic starter  

@leafytree 様

 

子テーマの使い方、理解しておりませんでした。

先日アップデートした際、設定していた画面の表示が元に戻っていました。

これが理由だったのですね。

参考にさせていただきます。

ありがとうございました。


   
返信引用
リフィトリー
(@leafytree)
Illustrious Member Moderator
結合: 5年前
投稿: 6845
 

@manami2020 さん

WP Multibyte Patch というプラグインはどうも必要みたいです。

 

WordPress5から無くなったWP Multibyte Patchは必須なので手動インストールしましょう


   
返信引用
共有:

問題の解決に至った場合には、トピック冒頭の「解決済み」をクリックしていただけますと幸いです。

また、有用な回答があった場合は返信右下にある「いいね!」もご活用ください。回答者の励みになります。

「いいね!」機能はフォーラム登録者のみが利用できる機能です。

CC BY-ND 2.1)準じていれば(リンクを貼っていただければ)転載も自由です。カスタマイズ記事を書く際にコード等をコピペ利用していただいて構いません。

フォーラムの使い方がよくわからない場合は、テストトピックで自由にテストしていただいて構いません。

最近の書き込みはこちら。

詳細なカスタマイズ依頼をするならこちら。

タイトルとURLをコピーしました