Cocoonフォーラム

書き込みの前に以下の3点をご確認ください。
  1. 1つのトピックにつき1つの質問を書き込んでください
  2. 不具合・カスタマイズ対象ページのURLを提示高速化を無効にしてください
  3. 該当部分のキャプチャ・環境情報とともに書き込んでいただけると助かります

何を書き込んだら良いか分からない場合は、以下のテンプレートをコピペしてご利用ください。

不具合・カスタマイズ対象ページのURL:

相談内容:

不具合の発生手順:

解決のために試したこと:

※文字だけでは正しく伝わらない可能性があるため、スクショ画像の添付もお願いします。
※高速化設定をしている場合は無効にしてください。
環境情報:

※↑こちらに「Cocoon設定 → テーマ情報」にある「環境情報」を貼り付けてください。

環境情報の取得方法はこちら。
https://wp-cocoon.com/theme-report/
高速化設定を無効にするにはこちら。
https://wp-cocoon.com/theme-trouble/

フォーラム利用ガイドリンク

  1. フォーラムガイドライン
  2. よくある質問と答え(FAQ)
  3. サポート対象外のケース
  4. 原因不明の不具合用トラブルシューティング
  5. トピックにHTMLを貼り付ける方法(推奨ツール:notepad.pw
  6. 真っ白画面でのエラーメッセージの確認方法
  7. ブラウザ環境チェックツール
  8. Cocoonカスタマイズ依頼

フォーラム質問後、問題等が解決した場合は結果を書き込んでいただけると幸いです。同様の問題で調べている方には、結果が一番気になる部分となります。

「アーカイブに出力しない」設定可能ペー...
 
共有:
通知
すべてクリア

[解決済] 「アーカイブに出力しない」設定可能ページ数を無制限にして欲しい。

8 投稿
3 ユーザー
2 Likes
676 表示
kojika
(@kojika)
Active Member Registered
結合: 1年前
投稿: 5
Topic starter  

いつもテンプレートを活用させていただいています。
なかでも、「アーカイブに出力しない」機能は、
古い記事はサイトに表示させず、検索には引っかかるため、大変重宝しています。

この機能ですが、一定数投稿に適応すると機能しなくなりました。
以前設定した記事を削除・下書きにすると新しく設定したページは機能しましたので、
上限があるのではと推測しております。

私のサイトでは、設定170記事あたりで、非表示にできなかったり、以前設定したページが表示されてしまうようになりました。

試しに以下テストサイトを作成したところ、状態が再現いたしました。。

検証手順は以下です。

1.1~220記事 「アーカイブに出力しない」を設定し公開 > 全て非表示(OK)
2.A1~A220記事&B1~B220記事 通常の設定で公開 > 全て表示、先の1~220は非表示(OK)
3.D1~D3記事 「アーカイブに出力しない」を設定し公開 > D1~D3表示されてしまう(NG)先の1~220は非表示(OK)

不具合か要望かわからないのですが、制限を解除していただけると大変ありがたいです。

お手数をおかけいたしますが、ご検討のほどよろしくお願いいたします。
(検証サイトですので、必要でしたらログイン情報お渡しできます。)

----------------------------------------------
サイト名:アーカイブに出力しない
サイトURL: http://office-r.tokyo/Archive1
ホームURL: http://office-r.tokyo/Archive1
コンテンツURL:/wp-content
インクルードURL:/wp-includes/
テンプレートURL:/wp-content/themes/cocoon-master
スタイルシートURL:/wp-content/themes/cocoon-child-master
親テーマスタイル:/wp-content/themes/cocoon-master/style.css
子テーマスタイル:/wp-content/themes/cocoon-child-master/style.css
WordPressバージョン:5.8.1
PHPバージョン:7.4.24
ブラウザ:Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/94.0.4606.81 Safari/537.36
サーバーソフト:LiteSpeed
サーバープロトコル:HTTP/1.1
エンコーディング:gzip, deflate
言語:ja,en-US;q=0.9,en;q=0.8
----------------------------------------------
テーマ名:Cocoon
バージョン:2.3.7
カテゴリ数:1
タグ数:0
ユーザー数:1
----------------------------------------------
子テーマ名:Cocoon Child
バージョン:1.1.3
style.cssサイズ:845バイト
functions.phpサイズ:203バイト
----------------------------------------------
Gutenberg:0
AMP:0
PWA:0
Font Awesome:4
Auto Post Thumbnail:1
Retina:0
ホームイメージ:
----------------------------------------------
ブラウザキャッシュ有効化:1
HTML縮小化:0
CSS縮小化:0
JavaScript縮小化:0
Lazy Load:0
WEBフォントLazy Load:0
----------------------------------------------
利用中のプラグイン:
----------------------------------------------


   
わいひら
(@yhira)
Illustrious Member Admin
結合: 5年前
投稿: 14137
 

特にそういった制限は設けていません。
もしかしたらあまりにもメインクエリ等ににpost__not_inを設けるとSQLが膨大になってしまうので、何かしらの制限があるのかもしれません。


   
kojika
(@kojika)
Active Member Registered
結合: 1年前
投稿: 5
Topic starter  

ご回答ありがとうございます。
そうすると古い記事から削除していくしかなさそうですね。

残念ですが、運用で対応していきます。

よろしくお願いいたします。


   
Akira
(@akira)
Noble Member Registered
結合: 5年前
投稿: 1179
 

Stack Overflow に全く同じ質問がありました。

Max Array Length post__not_in Parameter in Wp_Query

「php.ini を変更してみたら?」との回答があります。

また、別の回答でも php.ini を変更する下記リンクを紹介しています。

Increasing the maximum post size

いくつか変更し検証する必要はあると思いますが、お試しになる価値はあるかもしれません。


   
kojika
(@kojika)
Active Member Registered
結合: 1年前
投稿: 5
Topic starter  

Akiraさん

ご教示ありがとうございます。大変参考になりました。

いただいた情報をもとに、下記のように値を変更してみましたが、改善しませんでした。

まず、php.ini の値について他のサイトを物色したところ
比較的近いと思われる事象の記事を見つけました。

https://insource-mkd.co.jp/staff-blog/16076.html

これをもとに、関連がありそうな値を増加させました。
post_max_size=200M
enable_post_data_reading=10
error_reporting=22527
max_input_vars=6000
post_max_size=200M

また下記サイトに.htaccessも変更が必要と書かれていたので

https://qiita.com/k2hrm/items/937b8573ab06484b7ec6

確認してみると以下の記述がファイルの最下部にきさいされていたので、
反映されているように思います。

# BEGIN CUSTOM PHP SETTINGS
php_value post_max_size 200M
php_value enable_post_data_reading 10
php_value error_reporting 22527
php_value max_input_vars 6000
php_value post_max_size 200M
# END CUSTOM PHP SETTINGS

私は開発スキルもなく、エラーの確認やその他設定があるかもわからず
手探りではこの辺りまでが限界かと思います。

大変不躾で恐縮ですが、お力をお借りして有償で調査いただくことはお願いできませんでしょうか。

「アーカイブに出力しない」機能は他テンプレートにはない、
私にとって大変有意義な機能です。

制限なく使用できれば大変ありがたいです。


   
kojika
(@kojika)
Active Member Registered
結合: 1年前
投稿: 5
Topic starter  

すみません。
上の値記載は、最初に設定したものでした。
php_value post_max_size 200Mが重複していることに気づき再設定しています。

enable_post_data_reading=10
error_reporting=22527
max_input_vars=6000
post_max_size=200M

失礼しました。

ちなみに上記が見当違いなのかもよくわかっておりません。


   
Akira
(@akira)
Noble Member Registered
結合: 5年前
投稿: 1179
 

申し訳ありません。返事が遅れました。

考えてみたのですが、根本的な解決のためにはループ処理を変更するのがいいように思えます。

「アーカイブに出力しない」機能は、言い換えれば例外の設定です。例外が 170 以上あっては、それは例外とは言えないと思います。「アーカイブに出力しない」機能が、「古い記事はサイトに表示しない」とのご希望に合っていないように思えます。

また、php.ini の変更で解決したとしても、除外する記事の数が今より増えた時に再発する可能性があります。

有料でも差し支えない場合は、Cocoonカスタマイズを依頼するならば是非こちらに【Cocoon対応されている方々】にご相談されてはいかがでしょうか。

尚、ループ処理を変更すれば、このようなことができます。

① 表示件数を絞る

例)全部で 1000 記事ある場合、表示するのは 400 件。残りの 600 件は古い記事として表示しない。

② 任意の日付以降の記事のみ表示

例)2018 年 1 月 1 日以降の記事のみ表示。2017 年 12 月 31 日以前は古い記事として表示しない。

例)現在からの相対的な日付以降の記事のみ表示。例えば、現在から 2 年以内(1 年でも 3 年でも 1 ヶ月でも可能)の記事のみを表示できる。


   
わいひら reacted
kojika
(@kojika)
Active Member Registered
結合: 1年前
投稿: 5
Topic starter  

なるほど、皆さんのコメントから何となくイメージしていましたが
「例外処理が沢山になったらもはや例外ではない」

と言うことですね。

カスタマイズ検討してみます。

ありがとうございました。

 


   
わいひら reacted
共有:

問題の解決に至った場合には、トピック冒頭の「解決済み」をクリックしていただけますと幸いです。

wpForoの解決済みリンク

また、有用な回答があった場合は「いいね!」もご活用ください。回答者の励みになります。

wpForoのいいねリンク

「いいね!」機能はフォーラム登録者のみが利用できる機能です。

CC BY-ND 2.1)準じていれば(リンクを貼っていただければ)転載も自由です。カスタマイズ記事を書く際にコード等をコピペ利用していただいて構いません。

フォーラムの使い方がよくわからない場合は、テストトピックで自由にテストしていただいて構いません。

最近の書き込みはこちら。

詳細なカスタマイズ依頼をするならこちら。

タイトルとURLをコピーしました