Cocoonフォーラム

書き込みの前に以下の3点をご確認ください。
  1. 1つのトピックにつき1つの質問を書き込んでください
  2. 不具合・カスタマイズ対象ページのURLを提示高速化を無効にしてください
  3. 該当部分のキャプチャ・環境情報とともに書き込んでいただけると助かります

何を書き込んだら良いか分からない場合は、以下のテンプレートをコピペしてご利用ください。

不具合・カスタマイズ対象ページのURL:

相談内容:

不具合の発生手順:

解決のために試したこと:

※文字だけでは正しく伝わらない可能性があるため、スクショ画像の添付もお願いします。
※高速化設定をしている場合は無効にしてください。
環境情報:

※↑こちらに「Cocoon設定 → テーマ情報」にある「環境情報」を貼り付けてください。

環境情報の取得方法はこちら。
https://wp-cocoon.com/theme-report/
高速化設定を無効にするにはこちら。
https://wp-cocoon.com/theme-trouble/

フォーラム利用ガイドリンク

  1. フォーラムガイドライン
  2. よくある質問と答え(FAQ)
  3. サポート対象外のケース
  4. 原因不明の不具合用トラブルシューティング
  5. トピックにHTMLを貼り付ける方法(推奨ツール:notepad.pw
  6. 真っ白画面でのエラーメッセージの確認方法
  7. ブラウザ環境チェックツール
  8. Cocoonカスタマイズ依頼

フォーラム質問後、問題等が解決した場合は結果を書き込んでいただけると幸いです。同様の問題で調べている方には、結果が一番気になる部分となります。

モバイル版グローバルメニューが出現した...
 
共有:
通知
すべてクリア

モバイル版グローバルメニューが出現したりしなかったり…不具合?

7 投稿
4 ユーザー
6 Likes
752 表示
kana
 kana
(@kana)
New Member
結合: 2年前
投稿: 3
Topic starter  

モバイル版のヘッダーのグローバルメニュー(メニューを押すとスライドで出てくるカテゴリ一覧)が、出現したりしなかったりします。

設定した当初は問題なく表示されていたのに、気付いたらヘッダー、フッター療法表示されていませんでした。

何度もチャレンジしたところ、フッターは問題なく表示はされるようになったのですが、ヘッダーが出現する時と、「×」の表示のみ出現する時があります。

その際、ブログを更新すると出現する事があります。

不具合なのか、こちらのプラグインなどの設定の問題なのかわからないので、あとから入れたプラグインを消したりしましたが、かわりがありません。

 

---------------------------------------------
サイト名:アトピーブログ
サイトURL: https://kanachin-atopi.com
ホームURL: https://kanachin-atopi.com
コンテンツURL:/wp-content
インクルードURL:/wp-includes/
テンプレートURL:/wp-content/themes/cocoon-master
スタイルシートURL:/wp-content/themes/cocoon-child-master
親テーマスタイル:/wp-content/themes/cocoon-master/style.css
子テーマスタイル:/wp-content/themes/cocoon-child-master/style.css
スキン:/wp-content/themes/cocoon-child-master/skins/skin-template/style.css
WordPressバージョン:5.5.3
PHPバージョン:7.2.29
ブラウザ:Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:84.0) Gecko/20100101 Firefox/84.0
サーバーソフト:Apache
サーバープロトコル:HTTP/1.1
言語:ja,en-US;q=0.7,en;q=0.3
----------------------------------------------
テーマ名:Cocoon
バージョン:2.2.3.2
カテゴリ数:12
タグ数:3
ユーザー数:2
----------------------------------------------
子テーマ名:Cocoon Child
バージョン:0.0.5
style.cssサイズ:6406バイト
functions.phpサイズ:169バイト
----------------------------------------------
Gutenberg:1
AMP:0
PWA:0
Font Awesome:4
Auto Post Thumbnail:0
Retina:0
ホームイメージ:/wp-content/uploads/2020/01/0CD2D520-91E9-43FF-B762-18D661101941.jpg
----------------------------------------------
ブラウザキャッシュ有効化:1
HTML縮小化:0
CSS縮小化:0
JavaScript縮小化:0
Lazy Load:0
WEBフォントLazy Load:0
----------------------------------------------
利用中のプラグイン:
AddQuicktag 2.5.3
Akismet Anti-Spam 4.1.6
All In One SEO Pack 3.7.0
Autoptimize 2.8.1
Broken Link Checker 1.11.15
Category Order and Taxonomy Terms Order 1.5.7.4
Classic Editor 1.6
Contact Form 7 5.3.2
EWWW Image Optimizer 5.8.2
Google XML Sitemaps 4.1.1
Jetpack by WordPress.com 9.2.1
Lazy Loader 7.1.0
LIQUID SPEECH BALLOON 1.1.4
Post Type Switcher 3.2.0
Search Regex 2.4.1
Simple Custom CSS and JS 3.34.1
TinyMCE Advanced 5.4.0
Uji Countdown 2.1.2
Uji Countdown Pro 2.1
----------------------------------------------


   
引用
mofumofu
(@mofumofu)
Trusted Member Registered
結合: 2年前
投稿: 73
 

@kanaさん

スクロールするとメニュー部分のHTMLに

style="z-index: 3; transform: translateY(0px);"

が挿入されていますね。

これがcocoonの仕様なのかプラグインの仕様なのかはわかりませんが、これが原因だと思います。

cocoonが原因の場合は詳しい方がコメントしてくださるかと思いますが、プラグインが原因の可能性もありますので、プラグインを1つずつ無効化して挙動が変わるか確認してみると原因が分かるかもしれません。


   
わいひら reacted
返信引用
リフィトリー
(@leafytree)
Illustrious Member Moderator
結合: 4年前
投稿: 6845
 

前略、kana さん

私もデベロッパーツールで、サイトを見てみましたが、原因はよくわかりませんでした。

 

とりあず、要らないプラグインを停止するか、削除しましょう。

 

・Autoptimize 2.8.1(Cocoonの場合は高速化設定を使えばいいので不要です。)

・Lazy Loader 7.1.0(WordPress5.5からは、Lazy Load機能が標準で備わったので不要です。)

 

サイトが上手く表示されない原因としては、以下のようなことが考えられます。

 

1. プラグインそのものや、テーマとプラグインの相性が悪いなどのプラグイン関連の問題

2. ご自身でのカスタマイズが影響している場合

3. テーマの不具合

 

フォーラムを見ていると、3である場合も無くはないですが、1と2の場合の方が多いように感じます。

 

プラグインを全て停止しても、症状が改善しない場合は、ご自身のカスタマイズされた部分をバックアップしたうえで、一旦、外してみるなどの方法が考えられます。

 

もし、スキンのテンプレートでカスタマイズされていらっしゃるとしたら、スキンを「なし」にしてみて、確認してみるのも確認事項のひとつかもしれません。

 

This post was modified 2年前 2回 by リフィトリー

   
わいひら reacted
返信引用
kana
 kana
(@kana)
New Member
結合: 2年前
投稿: 3
Topic starter  

mofumofuさん

リフィトリーさん ありがとうございます。

Autoptimize 2.8.1

Lazy Loader 7.1.0を消したところおそらくですが治ったようです。

このプラグインが必要だと言われるままに入れていたので、必要ない事もわかり助かりました!

ありがとうございました!


   
わいひら reacted
返信引用
リフィトリー
(@leafytree)
Illustrious Member Moderator
結合: 4年前
投稿: 6845
 

kana さん

私の環境(Windows10 Firefox 開発ツールエニュミレータ)では、まだ症状が改善されていないようです。

 

一応、ブラウザのキャッシュは削除してみたのですが、変わらずです。

 

もう少し様子を見た方がいいのかもしれません。

 


   
返信引用
ろこ
(@lococo)
Prominent Member Registered
結合: 5年前
投稿: 830
 

バージョン:2.2.3.2

Cocoonのバージョンが古く、当時の不具合をそのままにしているからです。

Cocoon親テーマをアップデートしてください。


   
返信引用
リフィトリー
(@leafytree)
Illustrious Member Moderator
結合: 4年前
投稿: 6845
 

kana さん

PHPのバージョンもレンタルサーバーの推奨バージョンにした方が良いかもしれません。


   
わいひら reacted
返信引用
共有:

問題の解決に至った場合には、トピック冒頭の「解決済み」をクリックしていただけますと幸いです。

wpForoの解決済みリンク

また、有用な回答があった場合は「いいね!」もご活用ください。回答者の励みになります。

wpForoのいいねリンク

「いいね!」機能はフォーラム登録者のみが利用できる機能です。

CC BY-ND 2.1)準じていれば(リンクを貼っていただければ)転載も自由です。カスタマイズ記事を書く際にコード等をコピペ利用していただいて構いません。

フォーラムの使い方がよくわからない場合は、テストトピックで自由にテストしていただいて構いません。

最近の書き込みはこちら。

詳細なカスタマイズ依頼をするならこちら。

タイトルとURLをコピーしました