「メイド・イン・ヘブン」スキン適用中

Cocoonフォーラム

サイト内検索
書き込みの前に以下の3点をご確認ください。
  1. 1つのトピックにつき1つの質問を書き込んでください
  2. 不具合・カスタマイズ対象ページのURLを提示高速化を無効にしてください
  3. 該当部分のキャプチャ・環境情報とともに書き込んでいただけると助かります

何を書き込んだら良いか分からない場合は、以下のテンプレートをコピペしてご利用ください。

不具合・カスタマイズ対象ページのURL:

相談内容:

不具合の発生手順:

解決のために試したこと:

※文字だけでは正しく伝わらない可能性があるため、スクショ画像の添付もお願いします。
※高速化設定をしている場合は無効にしてください。
環境情報:

※↑こちらに「Cocoon設定 → テーマ情報」にある「環境情報」を貼り付けてください。

環境情報の取得方法はこちら。
https://wp-cocoon.com/theme-report/
高速化設定を無効にするにはこちら。
https://wp-cocoon.com/theme-trouble/

フォーラム利用ガイドリンク

  1. フォーラムガイドライン
  2. よくある質問と答え(FAQ)
  3. サポート対象外のケース
  4. 原因不明の不具合用トラブルシューティング
  5. トピックにHTMLを貼り付ける方法(推奨ツール:notepad.pw
  6. 真っ白画面でのエラーメッセージの確認方法
  7. ブラウザ環境チェックツール
  8. Cocoonカスタマイズ依頼

フォーラム質問後、問題等が解決した場合は結果を書き込んでいただけると幸いです。同様の問題で調べている方には、結果が一番気になる部分となります。

画像がすべて非表示になってしまう
 
共有:
通知
すべてクリア

[解決済] 画像がすべて非表示になってしまう

7 投稿
2 ユーザー
4 Reactions
1,606 表示
(@Kenya)
Active Member
結合: 5年前
投稿: 15
Topic starter  

cocoonで非表示設定をしているのにトップページにアドセンス広告が表示されてしまい困っていたところ以下を発見しました。

https://wp-cocoon.com/community/customs/%E5%BA%83%E5%91%8A%E3%81%8C%E8%A1%A8%E7%A4%BA%E3%81%95%E3%82%8C%E3%81%A6%E3%81%97%E3%81%BE%E3%81%86/

原因がわかり、ほっとして、cocoon設定ーアクセス解析・認証から「ヘッド用コード」を確認したところ、アドセンス申請時のコードが残っていたので削除しました。おかげさまでトップページでのアドセンス広告は消えました。

ところが、ブログ内の画像(記事内で貼り付けた画像やブログカード内のサムネイル画像など)が全て表示されなくなってしまいました。

恐らく「ヘッド用コード」内にアドセンス申請用コード以外にも何か定義をしていて、うっかり全て削除してしまったために不具合が発生したのだと思います。

解決方法のヒント等、どんな情報でも良いので何かおわかりになれば教えていただけますと幸甚です。

----------------------------------------------
サイト名:ロサンゼルスMBA生活とその後 2019~
サイトURL: https://takekura.tokyo
ホームURL: https://takekura.tokyo
コンテンツURL:/wp-content
インクルードURL:/wp-includes/
テンプレートURL:/wp-content/themes/cocoon-master
スタイルシートURL:/wp-content/themes/cocoon-child-master
子テーマスタイル:/wp-content/themes/cocoon-child-master/style.css
スキン:/wp-content/themes/cocoon-master/skins/skin-colors-blue/style.css
Wordpressバージョン:5.2.2
PHPバージョン:7.1.5
ブラウザ:Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/75.0.3770.100 Safari/537.36
サーバーソフト:Apache
サーバープロトコル:HTTP/1.1
エンコーディング:gzip, deflate, br
言語:ja-JP,ja;q=0.9,en-US;q=0.8,en;q=0.7
----------------------------------------------
テーマ名:Cocoon
バージョン:1.8.4.4
カテゴリ数:30
タグ数:3
ユーザー数:1
----------------------------------------------
子テーマ名:Cocoon Child
バージョン:0.0.5
----------------------------------------------
Gutenberg:1
AMP:1
PWA:0
Auto Post Thumbnail:0
ホームイメージ:/wp-content/uploads/2019/01/vw-camper-336606_640.jpg
----------------------------------------------
ブラウザキャッシュ有効化:1
HTML縮小化:0
CSS縮小化:0
JavaScript縮小化:0
Lazy Load:1
WEBフォントLazy Load:1
JavaScript(フッター):1
----------------------------------------------
利用中のプラグイン:
Category Order and Taxonomy Terms Order 1.5.7
Imsanity 2.4.2
WP Random Post Thumbnails 2.5.0
----------------------------------------------

 


   
(@Kenya)
Active Member
結合: 5年前
投稿: 15
Topic starter  

追記です。

  • WPの編集画面から見ると、問題なく貼り付けている画像は表示されています。
  • プラグイン(WP Random Post Thumbnails)で表示しているトップページのアイキャッチ画像のみ、正しく表示されています。

   
(@Kenya)
Active Member
結合: 5年前
投稿: 15
Topic starter  

自己レスですが、解決しました。

色々とウェブで関連情報を調べていたところ、Lazy Load設定が関連していそうと思い、cocoon設定>高速化の「Lazy Loadを有効にする」チェックをオフにしたところ、問題なく表示されるようになりました。

取り急ぎご報告まで。


   
わいひら reacted
(@Kenya)
Active Member
結合: 5年前
投稿: 15
Topic starter  

まだ不具合がありました。

モバイル端末で表示するときにアイコン文字(Font Awesome)がバツ表示されてしまいます。

例えば下段に表示されるメニューやブログ記事に表示される投稿日時の時計アイコン等です。


   
かうたっく
(@kautakku)
Famed Member Moderator
結合: 6年前
投稿: 4764
 

まだ不具合がありました。

モバイル端末で表示するときにアイコン文字(Font Awesome)がバツ表示されてしまいます。

1トピックに1つの内容を書き込んで頂けると助かります❦

  • 『画像がすべて非表示になってしまう』
  • 『モバイル端末で表示するときにアイコン文字(Font Awesome)がバツ表示される』➡こっちは画像と質問内容が異なりますよね。

一応

Cocoon設定・アクセス解析・認証タブあたりで、FontAwesomeのバージョン5を読み込んでるからだと思います。

<script

defer="" src="https://use.fontawesome.com/releases/v5.7.2/js/all.js" integrity="sha384-0pzryjIRos8mFBWMzSSZApWtPl/5++eIfzYmTgBBmXYdhvxPc+XcFEk+zJwDgWbP" crossorigin="anonymous"><

/script>

削除してもまだ表示されないようであれば、ロリポップのコンテンツキャッシュを削除してみるのも良いかもです。

またプラグインがFontAwesomeのバージョン5を読み込んでいても表示されないと思います。

解決しない場合は、新規トピックを立ててくださいね。


   
わいひら reacted
(@Kenya)
Active Member
結合: 5年前
投稿: 15
Topic starter  

かうたっくさん、コメントありがとうございます。

先ほどcocoon設定>高速化>アイコンフォントの非同期読み込みを有効にする、をオフにしてみたところ表示されるようになりました。

何かのタイミングで高速化オプションがネガティブな動きをしていたようです。

ご覧頂いた皆様、ありがとうございます。本件はクローズでお願い致します。


   
わいひら reacted
かうたっく
(@kautakku)
Famed Member Moderator
結合: 6年前
投稿: 4764
 

先ほどcocoon設定>高速化>アイコンフォントの非同期読み込みを有効にする、をオフにしてみたところ表示されるようになりました。

そうなんですね!?!?

プラグインで『FontAwesomeのバージョン5』を読み込んでても表示されない状態だった記憶もあるんですが、色々更新が行われたのか?

それが原因でなくなった可能性が大きいのかも????

どっちにしても、書き込みされなくても自己解決でしたね^^

何のトピックかわかんないけど ? ?

良かったです? ? ? 


   
わいひら reacted
共有:

問題の解決に至った場合には、トピック冒頭の「解決済み」をクリックしていただけますと幸いです。

また、有用な回答があった場合は返信右下にある「いいね!」もご活用ください。回答者の励みになります。

「いいね!」機能はフォーラム登録者のみが利用できる機能です。

CC BY-ND 2.1)準じていれば(リンクを貼っていただければ)転載も自由です。カスタマイズ記事を書く際にコード等をコピペ利用していただいて構いません。

フォーラムの使い方がよくわからない場合は、テストトピックで自由にテストしていただいて構いません。

最近の書き込みはこちら。

詳細なカスタマイズ依頼をするならこちら。

タイトルとURLをコピーしました